Jump to content

PetterK

Members
  • Content count

    110
  • Joined

  • Last visited

  • Days Won

    1

PetterK last won the day on October 19 2009

PetterK had the most liked content!

1 Follower

About PetterK

  • Birthday 05/15/1966

Profile Information

  1. PetterK

    Where is the Install-button?

    I simply ask where the "attachment-point" is? If it indeed is "wherever" inside the code, I think v3 is just an upgraded version and will soon be just as messed up as 2.1 and 2.2 is today... For me that's bad news - it might suit you well, though.
  2. ...I thought there would be an install-feature in v3, where Add-Ons written by the wonderful community out there could be installed without manually injecting them into the existing code... Maybe I have misunderstood absolutely everything, but to me osCommerce v3 seems more like a "renovated car" than a new release, it's got new tires, new wiring and a fancy paint-job - it's maybe even a lot faster and maybe it's looking a lot better, but is it still a 2003-model? Please tell me I've just not found it yet, please tell me that the way contributions had to be applied in the past is history, please show me where the install-button in admin is.
  3. Anyone translating to norwegian? PM me so we can join forces - no need for a lot of people doing the same work... There you go; it was way to early...
  4. PetterK

    osC reCaptcha

    My store is running a (fine-tuned to my needs) version of Loaded v.5 (based on osc snapshot 16th Febrauary 2003 (MS1 Releases). As message_stack.php does not exist in Loaded v.5 I descided to try to drop it in includes/classes and it worked right out of the box with the contact_us.php from v2.2 RC2. Id: contact_us.php 1739 2007-12-20 00:52:16Z hpdl Id: message_stack.php 1740 2007-12-20 14:57:13Z hpdl Apart from that I just modifyed my application_top.php by adding this at the end: // initialize the message stack for output messages require(DIR_WS_CLASSES . 'message_stack.php'); $messageStack = new messageStack; ?>
  5. PetterK

    osC reCaptcha

    I upgraded the contact_us.php, added message_stack.php to includes/classes and edited my application_top.php :rolleyes: It works now, but it seems that some typing-errors slip through; anyone else noted this?
  6. PetterK

    osC reCaptcha

    Nice contrib, thanks! I'm trying to implement it on a "sligtly" older (but otherwise fully working) version of osC. This line in contact_us.php is completely missing: $messageStack->add('contact', ENTRY_EMAIL_ADDRESS_CHECK_ERROR); ...and the result is that the e-mail address is rendered not valid. To be hones I'm not sure if it is possible to implement at all, but if someone can see how/where to insert reCaptcha-code in this segment it would be much appreiciated: require('includes/application_top.php'); $enquiry = $HTTP_POST_VARS['enquiry']; $name = $HTTP_POST_VARS['name']; $email = $HTTP_POST_VARS['email']; $enquiry = ''; $name = ''; $email = ''; require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_CONTACT_US); $error = false; if (isset($HTTP_GET_VARS['action']) && ($HTTP_GET_VARS['action'] == 'send')) { if (tep_validate_email(trim($HTTP_POST_VARS['email']))) { tep_mail(STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS, EMAIL_SUBJECT, 'Sent from IP: ' . $REMOTE_ADDR . "\n\n" . $HTTP_POST_VARS['enquiry'], $HTTP_POST_VARS['name'], $HTTP_POST_VARS['email']); tep_redirect(tep_href_link(FILENAME_CONTACT_US, 'action=success', 'NONSSL')); } else { $error = true; } } $breadcrumb->add(NAVBAR_TITLE, tep_href_link(FILENAME_CONTACT_US));
  7. PetterK

    Multiple Order Status Change Emails

    Not exactly, but I found another solution that does the job for me.
  8. PetterK

    Multiple Order Status Change Emails

    Nice contrib, works fine on my MS1 teststore - thanks! When I alter the status to Sent I usually post a tracking-number for the shipment, so I need to merge some info from the standard comment-field with the predefined text. Anyone got a suggestion for this? :-"
  9. I'm glad you got it working, but that's not helping me much is it.... I need someone to tell me exactly which files to use - the contrib is really messed up now as someone posted a COD-version + recently someone dropped a Norgespakke-version under the same contribution - please note that Posten does not offer COD on Servicepakker, and Norgespakke is a totally different shipping solution from Posten. No disrespect for the authors of these modules, but they both got nothing to do with Posten Servicepakke... >_<
  10. Well, for one it does not generate accurate shipping-costs for me.. So. if anyone else got it working, my guess is that something is not configured right in my store - either my zones (Norwegian zones contrib) or product-weights or something else. :'( I've tried it also on a vanilla install on my local test-server, but to no avail. I've been in touch with several others that have given up on this one as they too can't get it working. This package could REALLY need a repack <_< ...I just wish someone could take the time to upload a complete version with instructions included on how/what... :-"
  11. Could someone please put together a working package with detailed instructions on how to install/configure this module? I've been trying on and off for more than a year now, but either I'm stupid :huh: or the darn thing doesn't work... :-" So - if anyone could take the time to upload an updated version containing all relevant files + some instructions that would be much appreiciated. :thumbsup:
  12. Thanks Steve, I'll give it a go on my testing server :thumbsup:
  13. Just wondering if anyone tried it with MS1? Where the instructions say: 2. Replace the line (120): <p><?php echo stripslashes($product_info['products_description']); ?></p> My code goes like this: <p><?php echo stripslashes($product_info_values['products_description']); ?></p>
  14. >_< Jason, it would be great if you could upload a working archive... <EDIT> Got several Diagnostic messages in WinRAR, but I got it opened finally - disregard this post... </EDIT
  15. PetterK

    Faster Page Loads

    Seems both .html-files (config_cache_install) in v1.30 are for ms2... :(
×