Jump to content

Olimess

Members
  • Content count

    26
  • Joined

  • Last visited

  1. Olimess

    Authorize.net AIM - Success page problem

    Check the authorizenet_aim.php file at line 921. It likely has spaces after the '?>'. Remove the spaces so that the file ends with ?> Upload the saved file and you should be good to go after that. Also, the payment module may have installed properly the first time you received the error message but your system may have not verified this. As a result you might see the install button for this payment module but nothing happens when you press it. Restore your backup DB and try again and it should work.
  2. Hi everyone, I'm not sure if this has been discussed in this thread before but I sure wasn't able to find anything. The Option Type Feature is amazing! Great contribution. It has definitely allowed me to add far more options to my products in a far more user friendly way but I think it could be taken a step further. Is there some way of being able to provide conditional options to users? For example a products options for Sun Glasses might be: Colour: Red, Blue, Orange, Black (in a drop down list) Lens Type: Semi-Clear, Blue Tint, Black Tint (in a drop down list) Custom Arm Text: (text field) Let's say if the user selects "Black" for the Colour ... is it possible to hide "Blue Tint" as an option for Lens Type? Has anyone done anything like this with this contribution? I'll eagerly be waiting for a response! Thanks, Olimess
  3. Olimess

    New UPS XML Shipping Module available

    Hi all. JanZ ... I just received your PM as I logged in. I went through the code today and added/changed the following with regards to Negotiated Rates for UPS XML. I'm sure you did the same on your end as well. I'll post below for other users but by the sounds of it you are going to be extending this further into the contribution to have it defined in the admin etc. I was thinking of doing the same but no sense in having us both work at the same thing. Anyways, for all those who need Negotiated Rates from the UPS XML, you can do the following ... At about line 654 add the following in between the Shipper and Address tag ... " <Shipper>\n". " <ShipperNumber>YOURACCOUNTNUMBER</ShipperNumber>\n". " <Address>\n". I found that the next line was not really necessary, although the programming information for UPS XML said it was necessary. At about line 717, just before the closing Shipment tag, add .. " <RateInformation>\n". " <NegotiatedRatesIndicator/>\n". " </RateInformation>\n". Finally, change the following line at somewhere around 875 or so ... //$totalCharge = $ratedShipments[$i]->getValueByPath("/TotalCharges/MonetaryValue"); to ... $totalCharge = $ratedShipments[$i]->getValueByPath("/NegotiatedRates/NetSummaryCharges/GrandTotal/MonetaryValue"); That's it! This can be done in a much smoother way if added properly to the contribution .... via admin etc. As I said above, I believe JanZ is working on this now so we'll wait and see his fine work. For now, this is the quick and dirty method. JanZ, let me know if I can be of any assistance .... although I doubt you'll need it. Olimess
  4. Olimess

    New UPS XML Shipping Module available

    The file name that I have is RSS-WW-XML.pdf and the document title/volume is: UPS OnLine Tools Rates and Service Selection XML Programming Information Volume 6, Number 3 Revision Date: July 15, 2006 I did a search in the contribution as well and didn't find any mention of negotiated. However, you'd figure that if all the that is needed is the Shipper account number to be sent and varified in order for the negotiated rates to be returned .. it couldn't be that hard to do could it? I can send you my version of the UPS XML Programming document if you like. Cheers, Olimess
  5. Olimess

    New UPS XML Shipping Module available

    Thanks for the info JanZ. I figured as much. Took a look at the code myself after the last post and came to the same conclusion as you. Just to take this issue a little further, here is what the UPS OnLineTools Rates and Service Selection XML Programming Information document had to say about Negotiated Rates. A little further down in the document we encounter ... The starting to shed some light on this thing. Again, further down we find ... Now we see why I have been getting the "wrong" rates. I haven't yet checked to see if the UPS XML contribution offers Negotiated Rates ability (although I seriously doubt it) but I will check none the less. Too bad I couldn't add attachments to my post otherwise I would gladly provide the UPS OnLineTools Rates and Service Selection XML Programming Information document for all those who cared to take a look. I'll be back shortly with my findings. Thanks for your time all, Chao
  6. Olimess

    New UPS XML Shipping Module available

    Hi everyone. Great contribution ... major problem. First of all, let me inform you that I am a Canadian shop owner so UPS XML is being used from a Canadian origin ... although I don't believe that will make any difference at all to my issue. I've searched for similar issues through out this thread but have been unable to locate any. I've also contact UPS on this issue but have not yet received a response. Anyways .... on to my issue ... I have installed the UPS XML with very little trouble. Everything works perfectly, until I decided to put it to some real life testing. I created several accounts of "mock" customers from different locations across the U.S., Canada and internationally. I placed orders using these mock customers to see what shipping cost I would be quoted for each location. At first glance all appeared to be fine. It wasn't until I compared these rates with those issued through our UPS Connect software. The quotes are WAY off between the two. It then occured to me, we receive discounted rates from UPS due to the volume that we ship. So perhaps the UPS XML is not taking this into account. The question becomes ... are UPS XML files standard amongst all users, basically containing the same rate information for all or are the UPS XML files generated against user account? In either case, how would someone in my position go about fixing/modifying the contribution to obtain our correct rates. I could stand the rates being off by a few cents but not by $5 or more! All help/suggestions/info is greatly appreciated. Hopefully JanZ is reading this since he seems to be the man when it comes to this! Thanks, Olimess
  7. Olimess

    New UPS XML Shipping Module available

    Ok JanZ. Read link you provided and tracked down the problem. For anyone else having this issue, you need to add: // Canada Origin 'Canada Origin' => array( '01' => MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_01, //BOF add next line '02' => MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_02, //EOF Add line above '07' => MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_07, '08' => MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_08, '11' => MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_11, '12' => MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_12, '13' => MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_13, '14' => MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_14, '54' => MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_54, '65' => MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_65 ), To the UPSXML.php file (under includes/modules/shipping/) in and around line 158. Olimess
  8. Olimess

    New UPS XML Shipping Module available

    Oppps ... sorry JanZ. I guess we were both writing our replies at the same time. Sorry. What should the language file include? you accidentally re-copied code from shipping file. Thanks, Olimess
  9. Olimess

    New UPS XML Shipping Module available

    Just an update on the problem I've been experiencing above .... I tried figuring out what value was being returned to the shop by the Rate and Service XML. As some of you may know, the value that is returned to the shop is numeric and therefore a Human-readable Service Code lookup table is used to return the a specific options proper name. I've created a new name to see if I could narrow down which numeric value was responsible for the "Phantom" option. define('MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_XX', 'Phantom UPS Option'); // Canada Origin 'Canada Origin' => array( '01' => MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_01, '02' => MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_XX, '07' => MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_07, '08' => MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_08, '11' => MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_11, '12' => MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_12, '13' => MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_13, '14' => MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_14, '54' => MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_54, '65' => MODULE_SHIPPING_UPSXML_SERVICE_CODE_CANADA_ORIGIN_65 ), I was able to attach a name to the phantom option when I captured value '2'. Not sure what this was intended to be but I guess it must be a new option available for Canadian Orders from Canadian origin. The checkout process seems to work fine when it has a name attached to it. Anyone know what this option is supposed to be? I will see if I can contact UPS and ask them about this as well. Thanks, Olimess
  10. Olimess

    New UPS XML Shipping Module available

    Greetings all, I've recently installed this great contribution and have had no major issues or problems until now. Our store is located in Ontario Canada. So specific options such as origin and currency reflects this in the UPS XML Shipping Admin setttings. Here's the problem. When I test this shipping module against an international order, it seems to work fine ... only offering what is available. Same thing with US orders. But when I test the module against Canadian orders, it adds an additional option. This option is not displayed with a name or date. The only thing that shows up is the radio button and price. This option falls somewhere in between Standard and Express ... costs more than standard but less than express. If I select this option continue through the checkout process, the confirmation page will display that the Standard option was actually selected (even though the phantom was). It seems to default back to the cheaper option. If I disable any option that shows up as cheaper through the admin ... it actually will display this phantom option as being selected on the confirmation page by listing the price and nothing else (no option name). Similarily, when I disable all options from the admin (so that no UPS option is displayed) this phantom option is still selectable as a shipping option and is still displayed in the confirmation page is being selected. Has anyone run into this before? Any idea what this is and why it is desiplaying? How to correct this? Any suggestions, informationa and advice would be greatly appreciated. Thanks for a great contribution, Olimess
  11. Hi everyone. I'm not sure how often this Support thread is looked at but I'm hoping often! Anyways, I'm here for the same reason many of you have come here. To find a viable solution that integrates flash into osCommerce ... specifically a Flash Menu system. I was VERY excited to find Chris' contribution. I thought that this was what I had been looking for! I downloaded and installed the contributon .... only to have it not work?!? Obviously it must since many of you have gotten it to work. First, I did a completely new of the latest osCommerce release (as of today oscommerce-2.2ms2-051113). Then I installed the very simply Sessions ID into Flash contribution. Finally I tested it and ... nothing. Not much more to say. When I press one of the buttons, it always loads the index page. I noticed that the link URL that appears on the bottom left corner of IE states .... http://www.mywebsite.com/osc/shopping_cart.php?OSCsid= for a brief moment but never actually loads anything other than the index page. So here's my challenge. I am very interested in this. If anyone out there can lead me in the right direction, I will be happy to post a full and complete solution with full custom flash navigation and all. I'll stick with it from beginning to end. I will not stop until we can post a solution for ALL to see ... we all know how tough its been to find anything related to this through Google. Have a go all. Thanks.
  12. Thanks for the help .... unfortunately I'm still having problems using your approach. Seems wierd but if I to use more than one line inside the IF statement ... it won't work. I'm still trying to work through this to see if I can come up with another solution to this problem. If anyone else has any thoughts ... please read my original post about three post up or so. THanks everyone.
  13. Hi Everyone. This should be a fairly easy mod for those of you who are inclined to this sort of thing. I used to think I was ... but I can't for the life of me figure out how to make this "SIMPLE" mod for QTPro work. This is something I thought I would just want to do for my own purposes but the more I think about it, it might be something that the contributors to this contribution might want to add for future updates to QTPro. Here's the LOW down. :sweating: I have installed QTPro on my osCommerce shop. Everything is working perfectly! I wanted to be able to change one thing .... just one thing ... one ... simple ... thing ... I thought anyways... I'm using the Multiple Drop Down menu and enabled the "Display Out of Stock Message Line". As you probably know, the message line displays a generic message ... something like, "The combination of options you have selected is currently out of stock. Please select another combination." This message appears when the user selects an out of stock option combination. My idea, was to change this line to read something like, "combination of options you have selected is currently out of stock. Please click here for information on how to order ..." Blah Blah Blah. I won't get into specifics but I basically needed to add a link to this message. So I set off on my journey to insert the link. First, I traced back the "out of stock" message to the define TEXT_OUT_OF_STOCK_MESSAGE located in includes/laguages/english/product_info.php. I changed this message and added some HTML to it thinking this would do the trick. No go! I then trace the TEXT_OUT_OF_STOCK_MESSAGE usage to includes/classes/pad_multiple_dropdowns.php. I noticed that this was used in two areas in this document ... one for the message error box (the red error message that appears on the page) and one for the popup alert box if the user tried to continue placing the order regardless of the first message. I figured I would define a new "out of stock" message just for the alert box so that I could redefine the original TEXT_OUT_OF_STOCK_MESSAGE for my purposes. I tried slaying the @#$%er (excuse my #$%@) a few times but kept coming up short. I then noticed that the message could only display text because the output line on 156 of pad_multiple_dropdowns.php was using the DOM "document.createTextNode" and javascript to append to the message ... like this: $out.=" span.appendChild(document.createTextNode(\"".TEXT_OUT_OF_STOCK_MESSAGE."\"));\n"; I won't get into detail explaining what the above line means ... because I already know and I'm sure the person that can figure this out for me would already know as well but basically "span" was previously defined as the message box section and we are appending to this with our TEXT_OUT_OF_STOCK_MESSAGE using the text node (element). ... I though I wasn't going to get into detail!?! Anyways, I've tried several approaches of inserting a link into this node ... which I guess is impossible and so I tried several ways of insert some text and a link into the messagebox itself. So alas, I'm left with this challenge. Can anyone help me to figure out how I can modify the "out of stock" message to include a link?!? Please don't let this post be waisted wit and humor. (I'm a mind reader too you know ... "What wit and humor?", you say.) Seriously ... any help would be GREATLY, GREATLY appreciated! Looking forward to the responses Olimess
  14. Olimess

    OSC-Affiliate

    Hi everyone, Still working through the problem listed above. I just had a "VERY" simple question though. COnsidering that I'm not at all familiar with osc Affiliate ... I'm just alittle confused as to how the banners and links category works in an affiliate account. I've installed updates on the standard osc Affiliate off of the oscommerce contributions ... as I'm sure everyone has who uses this. Anyways, here's what I'm alittle confused about ... So in admin, I go to generate an affiliate banner. Now an affiliate can either select one of four options when logged in to their account. - WebSite Banners - Build Product Link - Product Banners - Text Links So now ... text link is a simple text version of the link I created. Product banner provides both the full banner code and text link to the banner I created. Build a product link is where the affiliate can generate their own links. But what is website banner for? Hmmmm ... it is confusing to me but then again I might be off. Can anyone enlighten this poor sap. I know there should be a reasonable explanation for this but .... who knows, maybe my thing isn't working right. Thanks all! Chao I should add that nothing shows up on the website banner page for me no matter how many banners I create.
  15. Olimess

    OSC-Affiliate

    I have installed osc Affiliate v2.03 onto my osc site. I can see that the sale is in fact made and is recorded to the affiliate_sales table. It just seems to stop working when it tries to retrieve this information and post it to the affiliate payment page through admin. Obviously, no info being posted means no payments being billed. I'll continue to work through this and see if I can find out exactly why this is happening. I'll post me results here. Of course, if any one else has any ideas on how to fix this ... PLEASE let me know. Thanks for your responses all! Chao
×