Jump to content

day2

Members
  • Content count

    79
  • Joined

  • Last visited

Everything posted by day2

  1. Hi, I know there are 2 shipping cost estimator but the approach is all after added into the cart. Is there a Shipping Cost Estimater before Add into Cart? Where customer just need to enter the state & country to estimate the shipping cost, before they decide to buy or not to buy?? Of Course the shipping option is at configured in Admin, the weight is as determined in product admin..etc. Thank you.
  2. I just installed this old individual by zone modules and i need this but there isn't any latest version on it. http://addons.oscommerce.com/info/1333 I encounter this problem in admin categories page, where it display the error massage in side the product page: Warning: Invalid argument supplied for foreach() in /home/xxx/public_html/store/includes/functions/indvshipzones.php on line 58 where the code in the "includes/functions/indvshipzones.php" are: function Display($product_id) { $return = "<table class='main'><tr>"; $nZones = count(GetAllZones()); $i = 1; foreach(GetAllZones() as $key=>$value) { $finLigne = ""; if ($i==$nZones) { // Cherche la fin de tableau $modulo = $i%3; // Nombre de cellules vides restantes for ($x=0; $x<=$modulo; $x++) { $finLigne .= "<td></td><td></td>"; } } elseif ($i%3 == 0 && $i<$nZones) $finLigne .= "</tr><tr>"; elseif ($i%3 == 0) $finLigne .= "</tr>"; $zone_code = $key; $zone_name = $value; $price = number_format(GetPrice($product_id, $zone_code),2); $priceInput = tep_draw_input_field($zone_code, $price); $return .= "<td>".$zone_name ."</td><td>". $priceInput."</td>".$finLigne; $i++; } $return .= "</table>"; return $return; } When i ignore this, go straight to preview product and update, this error ocurred: Warning: Invalid argument supplied for foreach() in /home/xxx/public_html/store/admin/categories.php on line 329 Warning: Cannot modify header information - headers already sent by (output started at /home/xxx/public_html/store/admin/categories.php:329) in /home/xxx/public_html/store/admin/includes/functions/general.php on line 22 where the code in admin/categories.php are: foreach(GetAllZones() as $key=>$value) { if(isset($HTTP_POST_VARS[$key])) { SetPrices((int)$products_id, $key, $HTTP_POST_VARS[$value]); } } Appreciate for ppl who have installed this add on to give a hand. Thank you.
  3. day2

    Free Shipping by categories

    Forgive me for my silliness, i didn't config it properly. Issue resolved.
  4. Hi, I am experimenting with the building Credit Card modules, hoping to install further add on i.e. the the encription, deleting the credit card details, ccv2 etc to make it more secured. However, my first problem is after entering the credit card details during payment and check out succesfully, this cc info doesn't go to admin nor database nor email. May i know where can i obtain the credit card info that the customer entered?? I know this modules is not mean for production, i am just experimental and try i to make it happen at my end. Thank you.
  5. day2

    "Dynamenu" for osCommerce

    I still got no clue where is the '1' come from, basically i just uploaded the file given. Does anyone use this mod and encounter the same problem??
  6. day2

    "Dynamenu" for osCommerce

    Dear all, I faced a minor problem but can't figure out what has gone wrong. I want the Dynamenu to be horizontall, hence, i edit the configuration in dm_categories.php for: $menu_type = 0; But when i set: // Set to false to display the menu output only. Set to true to display in // a regular box. The former is useful for better integrating the menu with your layout. $show_dmcats_as_box = false; It will always appear a numerik '1' below the menu bar. What is that?? Where does it come from?? How to get rid of it?? :angry:
  7. Hi Guys, Sorry for opening a new page but apparently the Osplayer contribution thread is no longer under support, hence has to ask for public helps; I installed the osPlayer in a same server, same domain but diff folder, both works, in the way mp3 was called out, the player displayed, either pop up player or display in the page. My problem is, 1 player can play the mp3 (same file, same size) This product can play Another one failed to play: This one cannot play-the mp3 is identified and located successfully as displayed in the playlist Any Idea what has determine a file can play or can't play? In fact, i installed a few mp3 player before, some can play some can't, some can't at first but can after, and i can't figure out what is the reason causing that. You sharing is very much appreciated. Thank you.
  8. Thanks for the advice, i got it solved, it is the global register issue. :angry: Haha, what a pain..
  9. day2

    OSPLAYER

    Got it resolve by creating a php.ini instead of .htaccess file. register_globals = On safe_mode = Off memory_limit = 128M upload_max_filesize = 50M max_execution_time = 300 max_input_time = 600 Folder created, mp3 uploaded, player appeared according with the track shown. The only problem is it doesn't stream hence can't played . :'( The funny part is i have installed 2 player in the same domain but diff directory, one can play but the another can't/ ><
  10. day2

    OSPLAYER

    Dear Gurus, I am running with the latest version of Os commerce, installing the OsPlayer, having the same problem, i.e., can't create the folder although the access right was set to 777. in the default .htaccess file, it read like this: # php_value session.use_trans_sid 0 # php_value register_globals 1 When i remove the # and made it to: # php_value session.use_trans_sid 0 php_value register_globals 1 I have a page error: 500 Server Error A misconfiguration on the server caused a hiccup. Check the server logs, fix the problem, then try again. URL: http://mmo.net.my/store/admin/categories.p...ted_box=catalog How would i able to fix this problem?? Thanks
  11. OK now, i have installed a brand new store for testing purpose, copied all the old and new files from the downloaded zip file to the said testing store and run the sql. But the results still the same!! This is my setup of sort order in order total under admin's module setting: Points Redeemptions 4 Shipping 2 Sub-Total 1 Tax 3 Total 5 Take a look of the payment and order confirmation page, the point is still fail to be redeemed >< Can somebody give me some clue?? What has gone wrong??
  12. I have set my sorting of Order Total Modules in Admin to: Point Redemption: 2 Shipping: 3 Sub Total: 1 Payment Type Surcharge: 5 Tax: 4 Total: 6 Where i want the point can only redeem against product price only. Do i set it right??
  13. Just have rechecked all the editing, can't find anything goes wrong, in fact i am using ExamDiff software to compare line by line, hardly miss out any editing; I also examine ssnb new instruction file as well, haven't notice anything wrong. Can someone show me their working store with this modules?? I just want to take a look how does it look it at the payment page.. May i know which code determine and the calculation of net price after minus the reward point?? Any idea which file was wrongly edited??? Thanks
  14. Hi Guys, Just get it installed. So excited. But i have one big problem need your advise. When i am checking out, at Payment Information, i clicked to use maximum point and enter the referrer email. But when go to next page, i.e. confirmation, no Money Value reduction noted. And when i clicked back to "Payment Information", the Tick for utilizing point and referrer email has gone!! Any clue what has gone wrong?? This is a wonderful add on, i so keen to get it done. Thanks in advance.
  15. day2

    Supplier Admin Area Contribution

    Findings: Apparently the supplier ID in the admin are referring to Group ID in the supplier table. No 1, i donno what this group ID for No 2, it can't be altered. I changed it in the admin page to 1, when saved it and reopen, it will still reflect as 0. Even if i edit the group ID in database to "1", the admin page will show one. But once you reopen to edit and save it, it will automatically change back to 0. Problem!! i tried to insert a new supplier, it will still reflect as 0 for both suppliers. :angry:
  16. day2

    Supplier Admin Area Contribution

    still Trying, I realised in my OSC Admin-under supplier, i have a supplier category box where i can't scroll down and seem failed to do selection: In the database, suppliers_products_groups, it is empty although i have hightlighted the selected category in the admin page as above: Will this caused the failure of redirection?? Also, my supplier configure.php is as follows, hope anyone can point it out the diff with yours: define('HTTP_SERVER', 'http://www.mmo.net.my'); // eg, http://localhost or - https://localhost should not be NULL for productive servers define('HTTP_CATALOG_SERVER', 'http://www.mmo.net.my/'); define('HTTPS_CATALOG_SERVER', ''); define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module define('DIR_FS_DOCUMENT_ROOT', '/home/mmonetmy/public_html/store'); // where your pages are located on the server. if $DOCUMENT_ROOT doesnt suit you, replace with your local path. (eg, /usr/local/apache/htdocs) define('DIR_WS_S_ADMIN', '/supplier/'); define('DIR_WS_ADMIN', '/admin/'); define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN); define('DIR_FS_S_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_S_ADMIN); // define our Catalog path / or /catalog/ define('DIR_WS_CATALOG', 'http://www.mmo.net.my/store'); define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . '/'); define('DIR_WS_IMAGES', DIR_WS_CATALOG . DIR_WS_ADMIN . 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . '/images/'); define('DIR_WS_INCLUDES', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN . 'includes/'); define('DIR_WS_SUPPLIER_INCLUDES', DIR_FS_DOCUMENT_ROOT . DIR_WS_S_ADMIN . 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . '/includes/languages/'); define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/'); define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/'); define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
  17. day2

    Supplier Admin Area Contribution

    I read the respective php files, realise there is a code in every page: $osCAdminID = $_REQUEST['osCAdminID']; In my Administrator Table, i m the only admin exist. Would this be the problem that caused the redirection failed??
  18. day2

    Supplier Admin Area Contribution

    Hi, I just installed the supplier admin using the latest version on OSc 2.2 and need some help here; http://www.mydomain.com/store/supplier/supplier_area.php At the log in page, i entered the user and password and was accepted, but it doesn't redirect me to the next page, where the log in page stay still. Any idea what has gone wrong?? Thanks in advance.
  19. day2

    Country-State Selector

    Hi Steve, It is all sort out via editing the general.php, you are the life saver~~ Great Contribution!! :lol:
  20. day2

    Country-State Selector

    Correction~~is Zone_Code was displayed instead of Zone_Name.. How to Make Zone_Name displayed with Zone_id in the Address Book table, just like how does Country_Name displayed as Country_id is available in the Address Book table?? Which file determine the $state and $country in the Address_format table?? Thanks
  21. day2

    Country-State Selector

    Bingo!! It is the Address Format that caused the hidden state. :rolleyes: But i still got the problem, as the database only have zone_id and no Entry State, the address end up only display the Zone ID Code instead of state name in full, how do i display the state name instead of the zone id?? <_<
  22. day2

    Country-State Selector

    I just made compare using examDiff software between the downloaded zip files to my following edited files to ensure the changes are appropriate. Nothing seem to be goes wrong: * catalog/address_book_process.php * catalog/create_account.php * catalog/checkout_payment_address.php * catalog/checkout_shipping_address.php * catalog/includes/form_check.js.php * catalog/includes/modules/address_book_details.php * catalog/includes/modules/checkout_new_address.php * catalog/admin/customers.php * catalog/admin/includes/functions/html_output.php The entry_State column in the address_book table apparently is irrelevant as i ve made manual input in the field also didn't make it turn up. I just want to know which script in which files query the state info to appear ?? Thanks.
  23. day2

    Country-State Selector

    I am installing version1.5.5, uploaded on 2/6/08 with bug fixed. Thanks
  24. day2

    Country-State Selector

    On Top of that, i go to phpmyAdmin to view my database, and realised the entry state is empty but entry zone id is recorded, not sure is this caused the unshown:
  25. day2

    Country-State Selector

    Hi Guys, I need some help here: the drop down selector work fine with every files, my only problem is i can't see the state selected reflected in the output files" INPUT OUTPUT I need some clue to figure out what have i done wrong.. I am installing the OSC 2.2 Release Candidate 2a, i.e. the latest version. Thanks in advance.
×