Jump to content

mustafa

Members
  • Content count

    19
  • Joined

  • Last visited

Profile Information

  • Real Name
    Stefano
  1. mustafa

    Google Analytics module

    i have the same "problem" redrum has (had? :)). it looks like both of us have final_price in our orders_products table with no tax included. so, i (we?) can't pick up some other value from db to have detailed prices for single products. two possible solutions: 1) keep things as they are. we'll see prices without tax included in e-commerce reports in google analytics 2) try to add tax to product price 'on the fly' in includes/modules/analytics/analytics.php before we pass this value to google. but, in this case, we may want to get it 'rounded' as store does for users. if somebody found out how to do this, i (and maybe not only me) will appreciate it, of course in the meantime, i'll try to figure it out, though i can be everything except a good programmer :D
  2. mustafa

    RSS News

    about charset problem, html entities is the solution :)
  3. mustafa

    Country-State Selector

    i ship only to my country, and i simply removed all other countries from database :)
  4. mustafa

    Country-State Selector

    stevel, great job again (i love your login a la amazon contrib). i would simply suggest one thing, and then you can tell me what do you think about it. (if i didn't make mistakes :D ), when i select one country, i see in the zone field the first one of the list. is it possible to display as default item a "select please" instead of the first zone of that country? let me know. thank for your effort p.s. aside: i posted on my blog about kitty angels, as a thank you for these contributions. bye
  5. mustafa

    [contribution] Star Product

    i got fixed this problem. easier than i thought :-" in star_product.php i added the bold </table> <td align="right" height="20"><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, "products_id=" . $star_products["products_id"]). '">' . tep_image(DIR_WS_LANGUAGES . $language . '/images/buttons/more_info.gif') . '</a>' . tep_draw_separator('pixel_trans.gif', '10', '10') . '<a href="' . tep_href_link(FILENAME_DEFAULT, tep_get_all_get_params(array('action')) . 'action=buy_now&products_id=' . $star_products['products_id']) . '">' . tep_image_button('button_buy_now.gif', IMAGE_BUTTON_IN_CART) . '</a></td> </tr> </table>'); $star_products_output = array_slice($star_products, sizeof($star_products)-1); incredible how i missed that thing for a long time :o
  6. mustafa

    [contribution] Star Product

    to fix euro symbol, simply use € entity. i still have problems with tables... since i was afraid i made a mess somewhere in index.php, i just tried with a new fresh copy of index.php. so, this is the part of code: <?php } else { // default page ?> <td width="100%" valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="0"> <tr> <td><table border="0" width="100%" cellspacing="0" cellpadding="0"> <tr> <td class="pageHeading"><?php echo HEADING_TITLE; ?></td> <td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . 'table_background_default.gif', HEADING_TITLE, HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td> </tr> </table></td> </tr> <tr> <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td> </tr> <tr> <td><table border="0" width="100%" cellspacing="0" cellpadding="0"> <tr> <td class="main"><?php echo tep_customer_greeting(); ?></td> </tr> <tr> <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td> </tr> <tr> <td class="main"><?php echo TEXT_MAIN; ?></td> </tr> <tr> <td><?php include(DIR_WS_MODULES . FILENAME_STAR_PRODUCT); ?></td> </tr> <tr> <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td> </tr> <tr> <td><?php include(DIR_WS_MODULES . FILENAME_NEW_PRODUCTS); ?></td> </tr> <?php include(DIR_WS_MODULES . FILENAME_UPCOMING_PRODUCTS); ?> </table></td> </tr> </table></td> <?php } ?> but now it's worse than before, since i can see with my eyes there are problems with tables looking at the page... (right column doesn't begin on top...). and this is the interesting part on the validation page: any hint?
  7. mustafa

    [contribution] Star Product

    i can set one page up. actually, i deeply changed my osc, and star product contrib as well, to display 4 products in the homepage. i can set up a new installation of osc with only this contrib (i already did it and checked it still had that problem, and i removed it), if needed. but if you don't have validation problem with your page on http://validator.w3.org/ , surely it's just a problem of mine. bye Stefano http://www.diarizing.com
  8. mustafa

    [contribution] Star Product

    Hi, i like your contribution very much, but i'm having problems with table. when i try to validate html code with w3c validator, it says "end tag for "TABLE" omitted". actually, i'm not sure it depends on your contribution cause i modified a lot my osc. i'd just like to know if it works fine for you, and if you can get it validate as well. (i'm installing a new copy of osc to check it as well, but 4 eyes see better than 2 :) ).
×