Jump to content

teksigns

Members
  • Content count

    117
  • Joined

  • Last visited

1 Follower

Profile Information

  1. awesum !!!!!!!!!!!!!!! we now have working select boxes with the mod i posted earlier ..... you will see the correction soon thanks to compugeek2003 for getting this working . thank you
  2. has nothing to do with random invoice number . i uninstalled that mod still when restored my admin it does not restore the order to cart..... guess ill go back to old version till someone fixes this
  3. does not work at all now if the customer restores orders its ok and items get added to cart ok..... however if i do it from the admin only the product count and no discription or quanitys get put back in the cart.... "Cart: 1 Items $0.00" im using the mod that changed the order ids to random i dont know if maybe this is affecting your mod of not . just thought id say . maybe you know whats going on
  4. case ($products_options_name['products_options_type'] == PRODUCTS_OPTIONS_TYPE_CHECKBOX): //CLR 2003-03-18 Add logic for checkboxes $products_attribs_query = tep_db_query("select distinct patrib.options_values_id, patrib.options_values_price, patrib.price_prefix from " . TABLE_PRODUCTS_ATTRIBUTES . " patrib where patrib.products_id='" . (int)$HTTP_GET_VARS['products_id'] . "' and patrib.options_id = '" . $products_options_name['products_options_id'] . "'"); $products_attribs_array = tep_db_fetch_array($products_attribs_query); echo '<tr><td class="main" valign="top">' . $products_options_name['products_options_name'] . ': </td><td class="main">'; $products_options = tep_db_query("select pov.products_options_values_id, pov.products_options_values_name, pa.options_values_price, pa.price_prefix from " . TABLE_PRODUCTS_ATTRIBUTES . " pa, " . TABLE_PRODUCTS_OPTIONS_VALUES . " pov where pa.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pa.options_id = '" . $products_options_name['products_options_id'] . "' and pa.options_values_id = pov.products_options_values_id and pov.language_id = '" . $languages_id . "'"); echo '<tr><td class="main"><br><b>' . $products_options_name_values['products_options_name'] . ':</b></td><td> </td></tr>' . "n"; while ($products_options_values = tep_db_fetch_array($products_options)) { //$linked_attrib = tep_linked_attributes($products_options_values['0'],$HTTP_GET_VARS['products_id']); $name_checkbox = 'id[' . $products_options_name['products_options_id'] . ']'; $value_checkbox = $products_options_values['products_options_values_id']; if (strchr($products_options_values['price_prefix'],'s')) { $special_class = 'productSpecialPrice'; } else { $special_class = 'main'; } echo '<tr><td class="' . $special_class . '"> ' . $products_options_values['products_options_values_name']; if (($products_options_values['options_values_price'] != '0') && (!strchr($products_options_values['price_prefix'],'i'))) { echo ' (' . tep_prefix_view($products_options_values['price_prefix']) . ' '. $currencies->display_price($products_options_values['options_values_price'], tep_get_tax_rate($product_info['products_tax_class_id'])) .') '; } echo '</td><td>' . tep_draw_checkbox_field($name_checkbox, $value_checkbox) . '</td></tr>' . "n"; } break; this is how i had mine displaying more than one checkbox however it would not add more than one of them to the cart. if you know how to fix that problem let me know i have 62 mods on my shopping cart and its becomming a real pain to add contributions.
  5. yes i had this all working except the same thing back on march 19th . http://forums.oscommerce.com/viewtopic.php...er=asc&start=20 i was asking how to fix this and noone ever replyed.
  6. i just inserted them and all is ok
  7. i get the following when i goto tools then blacklist i have imported the sql but it does not have those columns. whats the missing sql query
  8. i have figured out how to completly hide any boxes that the user is not approved for . in your admin/includes/column_left.php you should set it up with a statement like this arround every require statement making sure to change the file name to match. if (CanShowBox('yourfilename.php')){ // your require statement here } here is a short example of a file : if (CanShowBox('configuration.php')){ require(DIR_WS_BOXES . 'configuration.php'); } if (CanShowBox('administrators.php')){ require(DIR_WS_BOXES . 'administrators.php'); } if (CanShowBox('catalog.php')){ require(DIR_WS_BOXES . 'catalog.php'); } with this in place the boxes that the admin does not have access to will not show up . hope this helps someone .
  9. fixed.... used new one that came out tonight .
  10. i have this installed however i could not get it to allow me to add users without changing every $password to $password1 in the file admin/administrators.php for some reason it was picking up something else long string as $password and it would never match $confpwd. with that problem solved i was now able to add a different user. i added myself with full access and 1 user with access to only one section . i clicked logoff then tried my login it keeps going back to login . tried about 5 times . closed browser and reopened then loged in ok . everytime i have this same login problem for some reason . having to click logoff and close browser before i can login again . other problem : i tried login as the test user with only one page access. it lets me in ok . but if i click a page that i dont have access to then it sends me back to login and then i can no longer access the page that i do have access to eather. what is going on ? i have feb 2.2 pr release
  11. teksigns

    [Contribution] Wishlist v1.2 - Extended

    im missing a image for the wishlist table_background_wishlist.gif where is it at?
  12. does anyone know how to put together a sql statement in php to do what im trying to do ?
  13. fixed the html showing up in the top . i changed this from the file spg_blacklist_admin.php change: if ( (is_object($sInfo)) && ($admin_quer['customers_id'] == $sInfo->customers_id) ) { echo ' <tr class="dataTableRowSelected" onmouseover="this.style.cursor='hand'" '">' . "n"; } else { echo ' <tr class="dataTableRow" onmouseover="this.className='dataTableRowOver';this.style.cursor='hand'" onmouseout="this.className='dataTableRow'" '">' . "n"; } replace with this : if ( (is_object($sInfo)) && ($admin_quer['customers_id'] == $sInfo->customers_id) ) { echo ' <tr class="dataTableRowSelected" onmouseover="this.style.cursor='hand'">' . "n"; } else { echo ' <tr class="dataTableRow" onmouseover="this.className='dataTableRowOver';this.style.cursor='hand'" onmouseout="this.className='dataTableRow'">' . "n"; } still when i click the green icon to activate i get the sql error above . also i have noticed if i click the action icon at the end of the customer line it takes me to a screen with lots of undefined text. where are these defines supposed to be .
  14. i get this at the top of the page when i click customer admin <tr class="dataTableRowSelected" onmouseover="this.style.cursor='hand'" '"> <tr class="dataTableRow" onmouseover="this.className='dataTableRowOver';this.style.cursor='hand'" onmouseout="this.className='dataTableRow'" '"> <tr class="dataTableRow" onmouseover="this.className='dataTableRowOver';this.style.cursor='hand'" onmouseout="this.className='dataTableRow'" '"> <tr class="dataTableRow" onmouseover="this.className='dataTableRowOver';this.style.cursor='hand'" onmouseout="this.className='dataTableRow'" '"> <tr class="dataTableRow" onmouseover="this.className='dataTableRowOver';this.style.cursor='hand'" onmouseout="this.className='dataTableRow'" '"> <tr class="dataTableRow" onmouseover="this.className='dataTableRowOver';this.style.cursor='hand'" onmouseout="this.className='dataTableRow'" '"> <tr class="dataTableRow" onmouseover="this.className='dataTableRowOver';this.style.cursor='hand'" onmouseout="this.className='dataTableRow'" '"> i also get this when clicking the little green icon to activate the listed customer in a blacklist i guess 1146 - Table 'catalog.table_spg_customers' doesn't exist update TABLE_SPG_CUSTOMERS set customers_blacklist = '1' where customers_id = '2' i customer does exist looking at it . i click the green icon to activate and thats what i get . how do we fix?
  15. i have the folling code in my includes/functions/general.php file // BOF Enable - Disable Categories Contribution-------------------------------------- function tep_set_categories_status($categories_id, $status) { if ($status == '1') { return tep_db_query("update " . TABLE_CATEGORIES . " set categories_status = '1' where categories_id = '" . $categories_id . "'"); } elseif ($status == '0') { return tep_db_query("update " . TABLE_CATEGORIES . " set categories_status = '0' where categories_id = '" . $categories_id . "'"); } else { return -1; } } // EOF Enable - Disable Categories Contribution-------------------------------------- im adding another product status to my products i have all of that part working already . however i would like to change the above code to update the product status of every product in the directory thats set to disabled to product status 2. how can i do this . im sure its just a simple mysql statement but im having trouble figuring this out . i only want the product status set to 2 in the disabled directory if the current product status is not equal to "0" help !
×