Jump to content

bjraybould

Members
  • Content count

    64
  • Joined

  • Last visited

Posts posted by bjraybould


  1. Authorizenet has a recuring payment program that might fit your needs. Just make the purchaser affirmatively agree with a check box that they are agreeing to recurring payments over a set period of time and you should be all set.

     

    Drop me a line if you have further questions.

     

    Do you what files and the specific changes I need to make in order be able to use Authorize.net's Automated Recurring Billing ARB system?

     

    I am using contribution number 2184, by Matt Williams (Authorize.Net Consolidated 1.7 with Curl Fix, 1.7b.)

     

    Thank You!

     

    (From Authorize.net website: ARB enables you to create ?subscriptions? for recurring billings. Simply enter the customer?s payment information, billing amount, and a specific billing interval and duration. ARB automatically generates the subsequent recurring transactions for you)


  2. The two most recent Authorize.net modules seem to be:

     

    1. Authorize.net Consolidated v1.8

    Link to contribution

    Updated July 26, 2005

     

    2. Authorize.net Consolidated v1.7 with Curl fix.

    Link to contribution

    Updated January 18, 2005

     

    Then there is the one that came with OSC 2.2 MS2

     

    Is there one that is more widely used?  What do #1 or #2 offer that the one packaged with OSC doesn't?

     

    Thanks!

     

     

    This is what I am using successfully:

    Updated: Contribution number 2184, by Matt Williams

    Authorizenet Consolidated v1.7b.zip

    Authorize.Net Consolidated 1.7 with Curl Fix, 1.7b

     

    I also made this change in authorizenet.php after reading a topic in this forum forum topic

    //commented out following line

    // $response_vars = explode(',', $response[0]);

    //added following line

    $response_vars = $response;


  3. Is there a modification to the Step-By-Step Manual Order Entry or the Attitude Simple Manual Order Entry contribution to work with the downloads controller?

     

    At the moment, when you create an order, as far as I can make out, nothing gets added to the orders_products_download table.

     

    I've searched the forums but cannot find anything about this question.

     

    thanks for any input on this.

    Barry


  4. If you enter in 2004, then click "recalculate", then enter in a different profit margin, then "recalculate", it should remember that you're looking at 2004, not 2005 or 2003 or any other year.

     

    -jared

     

    Thanks Jared for your reply.

    As I understand it, if you leave the order tracking section and then return, you have to re-enter your new profit margin as it does not remember the last profit margin you entered? Is that how it is supposed to work?

    Barry


  5. Could you help clarify this fix please. It looks very useful. I've added the fix after line 357 of orders_tracking.php and now have the following code. Each time I click the orders_tracking in the admin panel though it forgets the year and gross profit rate. Am I missing something? Also I'm not sure I understand the context of "if a year has been entered as part of the URL" What URL are we talking about here?

    thank you for working on this excellent contribution

    Barry

     

        $jan = get_month("01", $year);

        $current_month = get_month($mo, $year);

    // if a year has been entered as part of the URL, use that year instead

      if (isset($HTTP_GET_VARS['year']) && $HTTP_GET_VARS['year'] != '') $year=$HTTP_GET_VARS['year'];

        else $year = date('Y'); #current year

     

     

     

    Just another hack to this excellent contrib. I found it disturbing that I had to enter a year each time I wanted to play with the Gross Profit Rate in order_tracking.php. Extending line 357 a little makes this more comfortable:

    // if a year has been entered as part of the URL, use that year instead
       if (isset($HTTP_GET_VARS['year']) && $HTTP_GET_VARS['year'] != '') $year=$HTTP_GET_VARS['year'];
         else $year = date('Y'); #current year

     

    Best,

    Ted


  6. I've tracked down the problem to this contribution:

     

    http://www.oscommerce.com/community/contributions,2784

     

    It is some problem in the latest post - 18 Feb 2005 - More Control to costumers.php

     

    The 17 Feb 2005 - Error Update contribution works fine, but the manual instructions in the 18 Feb post cause the error. It must be my misunderstanding of the instructions. This is a very useful update to the contribution (you can sort the customers by first name, last name, date account created etc) except that for some reason it causes an error in the search function (at least the way I interpreted the instructions).

     

    If anyone has installed this contribution successfully could you please post the new customers.php file on the contribution page: http://www.oscommerce.com/community/contributions,2784

     

    thanks!


  7. I am using 4.0.20 ... should not make a difference. The only thing I can think of is that you have some invisible character in that statement. Try typing the code on new lines below the existing ones and then deleting the existing. Only a guess, but it looks the same as mine.

     

    Thanks for the idea Lane, I tried that, but still no luck.

     

    Thank you for your helpful suggestions. I think I've run into a roadblock here.

    best regards

    Barry


  8. Thank you lane, I appreciate your reply. This has me baffled? Perhaps you are using a different version of MySQL. My server is running MySQL 4.0.22.

    regards

    Barry

     

    This is my code. It looks identical to yours.

    <?php

        $search = '';

        if (isset($HTTP_GET_VARS['search']) && tep_not_null($HTTP_GET_VARS['search'])) {

          $keywords = tep_db_input(tep_db_prepare_input($HTTP_GET_VARS['search']));

          $search = "where c.customers_lastname like '%" . $keywords . "%' or c.customers_firstname like '%" . $keywords . "%' or c.customers_email_address like '%" . $keywords . "%'";

        }

     

    This is my customers table. It should be pretty standard.

        Field    Type  Attributes  Null  Default  Extra  Action

      customers_id  int(11)    No      auto_increment  Change  Drop  Primary  Index  Unique  Fulltext

      customers_gender  char(1)    No        Change  Drop  Primary  Index  Unique  Fulltext

      customers_firstname  varchar(32)    No        Change  Drop  Primary  Index  Unique  Fulltext

      customers_lastname  varchar(32)    No        Change  Drop  Primary  Index  Unique  Fulltext

      customers_dob  datetime    No  0000-00-00 00:00:00      Change  Drop  Primary  Index  Unique  Fulltext

      customers_email_address  varchar(96)    No        Change  Drop  Primary  Index  Unique  Fulltext

      customers_default_address_id  int(11)    No  0      Change  Drop  Primary  Index  Unique  Fulltext

      customers_telephone  varchar(32)    No        Change  Drop  Primary  Index  Unique  Fulltext

      customers_fax  varchar(32)    Yes  NULL      Change  Drop  Primary  Index  Unique  Fulltext

      customers_password  varchar(40)    No        Change  Drop  Primary  Index  Unique  Fulltext

      customers_newsletter


  9. If you go to Admin Customers, and type anything in the Search box, you get the error message. For example

     

    /admin/customers.php?search=gfgf

     

    Customers    Search:

    1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'where c.customers_lastname like '%gfgf%' or c.customers_firstna

     

    select count(*) as total from customers c, address_book a, customers_info ci where c.customers_id = a.customers_id and c.customers_default_address_id = a.address_book_id and c.customers_id = ci.customers_info_id where c.customers_lastname like '%gfgf%' or c.customers_firstname like '%gfgf%' or c.customers_email_address like '%gfgf%'

     

    [TEP STOP]


  10. since installing this contribution (which is great other than this problem) whenever i search for a customer name i get

     

    where NAME = the name searched for.

     

    Hi,

    I'm having the same problem. I understand the problem is in customers.php?search=xxxxx and is nothing to do with the recover cart.

     

    Did anyone ever find a fix for this problem? I've searched the forums but cannot find the fix for this specific MySQL error.

     

    thanks anyone.

    Barry


  11. Problem

    When a customer sets the currency to something other than US Dollars in the Currency box selector, Authorize.net does not process the transaction and returns an error response code 3, response reason code 39:

     

    The supplied currency code is either invalid, not supported, not allowed for this merchant or doesn?t have an exchange rate.

     

    Question

    How do you let customer's see the prices of products in their own currency without getting this error message?

     

    Any help would be greatly appreciated

    Barry :D

     

    Contribution version

    Contribution number 2184, by Matt Williams

    Authorizenet Consolidated v1.7b.zip

    Authorize.Net Consolidated 1.7 with Curl Fix, 1.7b


  12. Payment Module: Authorize.net

     

    Problem:

    Where there is a problem with a credit card transaction, an error gets displayed beneath the navigation bar in white text on a red background. The problem is that the error message is truncated so you cannot read the reason for the problem. (see the following example.)

     

    There was an error processing your credit card (39): The supplied currency code is either invalid

     

    The problem is with this section of the code

      else if($x_response_code == '3') {
    	 tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'error_message=' . urlencode('There was an error processing your credit card ') . urlencode('(') . urlencode("$x_response_reason_code") . urlencode('): ') . urlencode("$x_response_reason_text"), 'SSL', true, false));

    Questions:

    1.Does anyone know how to prevent the truncation of the error message?

    2.Can anyone help me with how to send an email address to the store owner with the details of the error. (I'm not a programmer).?

     

    Thanks in advance for any help :D

     

    Contribution details

    Contribution number 2184, by Matt Williams

    Authorizenet Consolidated v1.7b.zip

    Authorize.Net Consolidated 1.7 with Curl Fix, 1.7b


  13. I'm getting some strange results in the daily sales summary for today. For example I get the following output, when in fact there have been no sales today. (fyi The yesterday totals are accurate.)

     

     

    Today 02-24 6 (0) * $154.60 $25.77

     

    I am running version 2.5

     

    thanks for any input on this

    Barry


  14. Hello,

    I installed the User Tracking contribution, and everything works great except that the Originating URL is empty in all of the sessions.

     

    The only thing I was not clear about in the installation instructions was this section:

     

     add to catalog/includes/application_top.php   Look for: 
      tep_session_start();
         add after:
         // user_tracking modifications 
       if (!$referer_url) { 
        $referer_url = $HTTP_SERVER_VARS['HTTP_REFERER']; 
            if ($referer_url) { 
                tep_session_register('referer_url'); 
            } 
        } This last bit allows us to track the originating URL (where the user came to your site from).

     

    I found 3 instances of tep_session_start(); in the file, and so added the requisite code after each of the 3 instances.

     

    Any ideas why I am not seeing the originating URL anyone?


  15. I just installed the latest version of Paypal IPN and everything works like a charm except that customers are not getting a download link when they are supposed to. I've read through this thread and found a couple replies and tried them but still not working. Any help would be greatly appreciated since I can't keep going into the orders download table and adding the data by hand.

     

    oh yes, the problem is, the orders_products_download table is not being updated with information needed to create the link if that helps

     

    I had the same problem and could not get it fixed. I eventually went back to version 1.0 of Paypal and that worked okay with the download controller. However I was losing half the orders due to Paypal thinking there was nothing in people's shopping carts when there actually was something in them. For some people it worked great, others had a lot of trouble. I think there must be a conflict with some contribution I installed previously. Anyway I finally gave up and ended up not using PayPal and using an authorize.net gateway instead. I'd suggest tracking your customer's for a while using the who's online feature and seeing if people are getting stuck in your system using paypal.


  16. Hi John,

    Thanks for the suggestion. I have double checked the installation several times now but still cannot figure it out. It seems there is an install button for the module, but when you install it, fill out the fields in the various boxes, and then click update, there is still an install button next to the module, when there should be an edit, remove button.

     

    The installation is not complicated, it just involves copying these files:

    /catalog/includes/modules/authorizenet_direct.php

    /catalog/includes/modules/payment/authorizenet.php

    /catalog/admin/modules.php

    these are the only files in the contribution that I think would affect the admin panel.

     

    any ideas?

     

    Barry

     

    double check the contribution instructions, usually something is not in the right spot code wise.


  17. I now have the following contribution installed, but still have the same problem (cannot save credit card types in admin panel, and no credit card types displayed in checkout_payment.php screen).

     

    I am now using:

    Original: Contribution number 2278, by Austin Renfroe

    2278 Authorizenet Consolidated v17_1_2.zip

    Authorize.net Consolidated v1.7

     

    note: there was no change to the catalog/admin/modules.php from contribution 2278 to contribution 2184, so what might be causing the problem in the admin panel?

     

    Any ideas anyone?


  18. thanks Wolfgang, I'll give that a try.

    Barry

     

    Barry,

     

    Sorry about my delay.

     

    I used the original contribution. Had to do this again about a month ago after my web site provider had done some 'Genius' upgrades that caused all kinds of problems.

     

    I trusted that they had tested all their new contributions.

     

    Anyway, I re installed the orginal contrib. #2278 again and it still works.

     

    Good Luck

    Wolfgang


  19. Thanks Wolfgang for replying and helping out. This has been bugging me for days.

     

    I just wanted to clarify your posting. Which is the contribution that fixed your problem: the original contribution number 2278 by Austin Renfroe, or the updated contribution number 2184 by Matt Williams?

     

    The version I am having problems with is the updated contribution 2184.

     

    Barry

     

    Original: Contribution number 2278, by Austin Renfroe

    2278 Authorizenet Consolidated v17_1_2.zip

    Authorize.net Consolidated v1.7

     

    Updated: Contribution number 2184, by Matt Williams

    Authorizenet Consolidated v1.7b.zip

    Authorize.Net Consolidated 1.7 with Curl Fix, 1.7b

     

     

     

     

    I had all these problems and never was able to process any transactions until I installed the basic contribution by Austin Renfroe. Follow his instructons an it will work perfect.

     

    Here is is original one

     

    http://www.oscommerce.com/community/contri...h,authorize.net

    and here is an updated version

     

    http://www.oscommerce.com/community/contri...h,authorize.net

    Good Luck

    Wolfgang


  20. Hello,

    Does anyone know how to fix this problem with the Authorize.net Payment Module in the admin panel? I have run into the same problem.

    Any help would be greatly appreciated.

    Barry

     

    Summary of the problem:

    1. After you install the Authorize.net Payment Module , the button next to the module still says install. It should say Remove, Edit

     

    2. When you click Install, check the credit card check boxes, and then Update, all the credit card check boxes are not stored (next time you install the module, they are all unchecked).


  21. could you explain what you mean by "the payments page" please and where you find it?

    thanks

    Barry

     

    Problem is now solved. On the off chance someone else out there has encountered something like this the problem for us was:

     

    We're not using the payment page, so the payment selection was not being set...

    We've now got a url parameter of payment=paypal_ipn and that seems to have cleared up the mess.

     

    So nevermind... :-"

×