Jump to content

Yuck

Members
  • Content count

    171
  • Joined

  • Last visited

Posts posted by Yuck


  1. Hi,

     

    The site is www.mysite.com

     

    Heres the .htaccess, I've got the site passworded at the moment so theres some other stuff in there.

     

    AuthUserFile /home/fhlinux152/p/mysite.com/user/htdocs/.htpasswd
    AuthName "protected access"
    AuthType Basic
    require valid-user
    Options +FollowSymLinks
    RewriteEngine On 
    RewriteBase /
    
    RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
    RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}

     

    Hopefully this helps.

    Thanks.


  2. Hi,

    Just installed Ultimate SEO URLs - 2.1d by yesudo to OSC rc2. Server is php5.

     

    I now cannot access either the main site or the admin. Error is the same for both

     

     

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

     

    Is there a better version for OSC RC2?

    Any help would be much appreciated.

    Thanks.


  3. If you want to do drop over style installs, most are not compatible with RC2.

     

    But with manual install most are compatible and can be used with RC2.

     

     

    Hi,

    I'll not be installing any cosmetic contributions, especially templates. I can make the changes I need, which are fairly basic but effective, using the stylesheet and by some minor editing.

    It's more important to me to make sure the search engines like the site, cosmetics can be fiddled with afterwards.

    So with the current releases I wonder which SEO contribs "sit" best together?

     

    Thanks

     

    edit:Just noticed the last link in your sig, some interesting reading, thanks.


  4. Hi,

    It's been a while since I last used OSc, it's changed for the better :thumbsup:

    I've got a new vanilla install and the first thing I want to do is make sure the search engines find me and like me!

    What would you guys suggest to be the current best compatible contributions to achieve this with v2.2 RC2?

     

    Thanks all.


  5. Hi, Just installed ver1.05 this contrib and it seems to be working nicely. I would like the info box to show "online" and "offline" status. The images to do this appear to be there in /live_support/images, but are not used. Instead an image from catalog/images is used. Am I missing something? Do I need to configure status somewhere?

    Thanks.


  6. Hi, I have just started adding inventory and noticed that my Product Name field appears to be missing. I have HTC & SEO URLS installed and I "think" this may be something to do with HTC. Basically on the product description page there is no field for me to enter the product name, heres what I get: http://www.zenadsl2129.zen.co.uk/OSC/NewProduct.jpg .

    On my Admin/Categories/Products page the products appear, but with no name as I'm not able to enter one. Here's what it looks like: http://www.zenadsl2129.zen.co.uk/OSC/ProductName.jpg .

     

    When viewing a product in the store the model number appears at the top, but above that there is obviously no product name.

     

    I hope it's ok to post the image links, seemed the best way to describe what's happening.

    Any help in finding the elusive Product Name field would be very much appreciated. If I can get this sorted I'll be back in business. If you need any of my code please let me know. Thanks.


  7. Hi, I'm a little confused with the install instructions so thought best to ask before making a mess of stuff. The file checkout_success.php requires some changes, most done. There is a block of code to add

    paste this block of code BEFORE the $breadcrumb
    My question is which $breadcrumb? The one just edited? ie:
    $breadcrumb->add($NAVBAR_TITLE_2);

    or the one above it? ie:

    $breadcrumb->add(NAVBAR_TITLE_1);

     

    Any guidance much appreciated, Thanks.


  8. Hi, I thought all was well but I've just noticed this error message in the config screen in admin. Any help fixing this would be appreciated, thanks.

     

    Warning: call_user_func(tep_reset_cache_data_seo_urls): First argument is expected to be a valid callback in /data01/hcdvd/public_html/mysite.com/catalog/admin/includes/functions/general.php on line 1199

  9. OK I found it :)

    Now I've got to figure out how to change it :/

    It's in the update to the sql database, featured_products_english.sql file.

     

    create table featured (
     featured_id int(11) not null auto_increment,
     products_id int(11) default '0' not null ,
     featured_date_added datetime ,
     featured_last_modified datetime ,
     expires_date datetime ,
     date_status_change datetime ,
     status int(1) default '1' ,
     PRIMARY KEY (featured_id)
    );
    
    INSERT INTO configuration_group (configuration_group_id, configuration_group_title, configuration_group_description, sort_order, visible) values ('39','Featured', 'Featured Products Display', '339', '1'
    );
    
    INSERT into configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added) values ('Display Featured Products', 'FEATURED_PRODUCTS_DISPLAY', 'true', 'Set to true or false in order to display featured.', '39', '1', now(), now()
    );
    
    INSERT into configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added) values ('Maximum Display of Featured', 'MAX_DISPLAY_FEATURED_PRODUCTS', '6', 'This is the maximum amount of items to display on the front page.', '39', '2', now(), now()
    );

     

    So my question now is how do I change that 6 to a 9 in a database that has that value? I've got phpmyadmin, but a really simple step by step explanation would be much appreciated. I'll be backing up before touching this.

    I should add I've poked around in the databse looking for that "6" but can't find it, or anything that refers to a 'MAX_DISPLAY_FEATURED_PRODUCTS' value.

    Thanks in advance.


  10. Just going through the install.

    So far changed the sql, changed all the files in catalog, and done the changes to stylesheet.css.

    Up to that point everything seemed to be going ok. Just made the changes to index.php and now I'm getting this error....

    Parse error: parse error, unexpected $ in /home/fhlinux195/b/bazanjo.com/user/htdocs/index.php on line 356

     

    The last line of code in the index file is line 355, so this has me a little confused :)

    This error is showing on the main page and category pages. My all product page and individual product description pages seem to be fine. I will post the whole file if that helps.

     

    Anyone got any ideas?

    Thanks.


  11. It is normal to have the osCsid appended on first click when visiting the store.  However, from the second and subsequent clicks it should be pulled from the cookie (except if browser cookies are disabled).

     

    Change these settings:

    Prevent Spider Sessions True 

    Recreate Session True

     

    I would change the Recreate Session since you have not prevented the session_id's from being indexed.  This will help eliminate the passing of mass SID's :)

     

    Bobby

     

    Thanks very much, I now have much shorter urls, much appreciated :thumbsup:


  12. A while ago I asked if is was normal to have stuff like this at the end of urls?

    &osCsid=a5d997d087dfc4807d85c942d4f2eedb

    I have this contrib running in cName mode as my hosting doesn't seem to like rewrite. I have installed exactly to the instructions and my store is in the root.

     

    I get that in my browser, not google stuff that I don't yet fully understand. Can someone please let me know if that should be there in my browser for categories and products? If not, is there a setting that I may have messed up?

    Thanks in advance.

     

     

    /edit

    Do any of these settings need changing for example?

     

    Session Directory /tmp

    Force Cookie Use False

    Check SSL Session ID False

    Check User Agent False

    Check IP Address False

    Prevent Spider Sessions False

    Recreate Session False


  13. Bobby,

    I am still seeing this:?osCsid=a17d56eee79210ab67cd7367dd893358 

    in all my page rankings.  I have done everything you recommended and have spend a LONG time comparing your contrib to others I have installed and stock OSC files, I am no expect at this but these all seem to be completely unrelated with your contrib yet I still am having this trouble.

    I downloaded and installed v1.4 - do you suggest I upgrade?

     

    S

     

    I seem to have a similar problem to sincraft, for example....

     

    http://www.mysite.com/product_info.php?pName=under-siege&osCsid=be1b88e9e8d736e331b3444f4646b09c

     

    I can live with it being unsightly, but will this effect the way the contrib works?

    I'm using cname as my hosting didn't seem to want to work with rewrite, it couldn't find my product pages :/

    Thanks for a very useful contrib btw :thumbsup:

×