nicklestud

Members
  • Content count

    23
  • Joined

  • Last visited

Community Reputation

0 Neutral

About nicklestud

  • Birthday 08/14/1969

Profile Information

  • Real Name
    Nicholas
  • Gender
    Male
  • Location
    Seattle
  1. Just to confirm - USPS API was shut down briefly on April 23rd. For my site (Host in California) it is now up and running. All the same settings I have been using for a few years are not changed.
  2. I notice that there has been other posts elsewhere about this issue - but with no answers. Anyone? The only thing I can find is that it may be something to do with the browser. I dont get the broken images in Firefox, but I do in Chrome and IE. Still at a loss...
  3. Same problem with my site. I notice that the final page displayd to my customer "You successfully made an order" has broken images and a white background color. The URL is: https://secure.authorize.net/gateway/transact.dll The URL of a broken image is: https://secure.authorize.net/gateway/images/table_background_man_on_board.gif Anyone have a solution?
  4. Just to backup the quick fix to get USPS First Class International up and running, anywhere in the includes/modules/shipping/usps.php file where it says 'First-Class Mail International' should be changed to 'First Class Mail International Package' Make sure the dash is taken out of the word: First Class. The difference between Letter, Large Enveloped (Flats), and Packages is the following: A letter is just paper correspondence in a small envelope. It only goes up to 3 ounces. A Large Envelope is like a letter where it needs to be flat, like paper, but can be put into a large envelope. Like a 9x11 manila envelope. There should be no lumps or unevenness in the Envelope - needs to be flat and uniform - but can be up to 4 lbs. A Package is anything up to 4 lbs. Including a box or a lumpy envelope. I use Package for all purposes of shipping due to the nature of our products (they are lumpy.) It is totally confusing to offer three types, and if I could get my hands on the guy whom decides these things at USPS, Id give him a wedgie like no other. More on Int. First Class here: http://www.usps.com/prices/first-class-mai...onal-prices.htm If you need all three, you may think of installing the latest contribution to this module. But the quick fix above should get your international customers Int. First Class choice again. I hope this helps.
  5. I put the code shown below into the includes/modules/shipping/dhlairborne.php somewhere around line 273. Pretty simple fix. Basically I had to change the information from 'GB' into "UK'. I tested it out for address from Scotland all the way to N Ireland and it works. Here is the old code: function _setDestination($street_address, $city, $state, $postal, $country) { global $order; $postal = str_replace(' ', '', $postal); $state_query = tep_db_query("select zone_code from " . TABLE_ZONES . " where zone_name = '" . $state . "' and zone_country_id = '" . (int)$order->delivery['country']['id'] . "'"); $state_info = tep_db_fetch_array($state_query); $this->destination_street_address = $street_address; $this->destination_city = $city; $this->destination_state = $state_info['zone_code']; $this->destination_postal = substr($postal, 0, 5); $this->destination_country = $country; } Here is what I changed it to: function _setDestination($street_address, $city, $state, $postal, $country) { global $order; $postal = str_replace(' ', '', $postal); $state_query = tep_db_query("select zone_code from " . TABLE_ZONES . " where zone_name = '" . $state . "' and zone_country_id = '" . (int)$order->delivery['country']['id'] . "'"); $state_info = tep_db_fetch_array($state_query); $this->destination_street_address = $street_address; $this->destination_city = $city; $this->destination_state = $state_info['zone_code']; $this->destination_postal = substr($postal, 0, 5); if ($country == 'GB'){ $country = "UK"; } $this->destination_country = $country; }
  6. Here is what DHL sent me about this issue:
  7. As for now (9:45 AM Pacific Time) it still has not fixed itself. Changing the code above also did not work for me. I just disabled the Express module for now. Seems that USPS change was not good on their part, causing confusion. Or perhaps was since they are going to get TONS of Express orders today rather than Priority and First Class. Probably a better profit margin for them. Disabling the Express in the module worked so now customer can choose FC or Priority. I am leaving Express turned off until USPS gets their act together. I have DHL and UPS for customers to turn to anyway for fast shipments.
  8. I seem to get an error when using the DHL Module. The error is as reads: DHL Express (1 x 2lbs) DHL Express The following errors have occured: 1. Country invalid. I get this whenever I use a UK address. Anyone else getting this error when they are using a certain address? -Nickle
  9. My USPS shipping module was working fine up until today (Wednesday, June 6) where all the sudden customers were getting error. Called USPS and of course no-one there can tell me any reason why it suddenly happened today. The error was across the board - All US orders and international orders. I changed my module from 'test' to 'production' and it started working again. Just a heads up.