Jump to content

_g_

Members
  • Content count

    36
  • Joined

  • Last visited

Everything posted by _g_

  1. _g_

    USPS: My products are lower than .1

    This is not a solution, but a suggestion: If all the products are less than 1 oz. then you can use a flat(table) rate of $0.37.
  2. _g_

    USPS Global Flat Rate w/out getting burned!

    I got similar problems as DEE and whereditgo. I can probably eliminate the small envelope for the intl' customers (which isn't working for me at this time). I sell DVDs and CDs now if someone buys 1 DVD or CD and chooses the flat rate option, its fine, but I have had customers buying 3-4 DVDs and then choose $5 (small envelope) :( Lack of tracking for intl' packages is also killing my business as I have had couple of cases where customers didn't receive the delivery (or may be they did...who knows). I had to refund the money as there was no tracking available and I didn't insure the packages as I already had put a lot of amount from my profits into shipping. Now I am planning to find a shipping by item module and have a flat rate for each item. I read it on usps (not sure though if I understood it right) that they offer a delivery confirmation (a card that is mailed back and nothing elctronic sorts) if it is a parcel post or insured post. My question to people who have been shipping to International locations is that, what should be an average rate for a CD (4-5 Oz) and a DVD (8-9 Oz) for international shipping including insurance and delivery confirmation? The prices I checked for insurance + delivery confirmation were little less than $4.00. So shipping price of $10 per item + $5 per additional item would be ok? I don't want to pay shipping charges from my pocket but on the other hand don't want to earn profits from shipping charges and make my products incompetitve. Hope someone has a solution/advice to this. Thanks in advance
  3. _g_

    [Contribution]Paypal IPN - Devosc

    I believe Paypal is upto something, they are changing stuff, or may be its just some problem at their end. So far my transactions are sending all the emails. So, probably, the Paypal IPN does that at certain times only.
  4. _g_

    [Contribution]Paypal IPN - Devosc

    Ok, Today suddenly, I got the response from the Paypal IPN (for the order placed on 28th) and I got the emails n stuff.
  5. Thanks for the reply. Take your time. I can just mannually delete the cache file till then :)
  6. _g_

    [Contribution]Paypal IPN - Devosc

    Thanks for the replies. So, I'll too assume that it has to do smthng with Paypal's temporary problems and would wait for my next order or myself place a fake order. But can someone help me with my second question (quoted below) Thanks
  7. It didn't, I am using the contrib which includes a different title, meta description and keywords. I hope I didn't miss anything during instalation. Thanks
  8. _g_

    [Contribution]Paypal IPN - Devosc

    lol, perhaps thats what happened. I recceived an order on 25th and it was all smooth, but the order I got yesterday had that problem. Hope a sollution can be found soon. I checked paypal's IPN page and it doesn't say anything about any code change or something. Even they haven't changed their footer. It says "Copyright ? 1999-2004 PayPal." Here is the PHP code that I found on Paypal's IPN page. I don't know if it has been changed or not. PHP 4.1 // read the post from PayPal system and add 'cmd' $req = 'cmd=_notify-validate'; foreach ($_POST as $key => $value) { $value = urlencode(stripslashes($value)); $req .= "&$key=$value"; } // post back to PayPal system to validate $header .= "POST /cgi-bin/webscr HTTP/1.0\r\n"; $header .= "Content-Type: application/x-www-form-urlencoded\r\n"; $header .= "Content-Length: " . strlen($req) . "\r\n\r\n"; $fp = fsockopen ('www.paypal.com', 80, $errno, $errstr, 30); // assign posted variables to local variables $item_name = $_POST['item_name']; $item_number = $_POST['item_number']; $payment_status = $_POST['payment_status']; $payment_amount = $_POST['mc_gross']; $payment_currency = $_POST['mc_currency']; $txn_id = $_POST['txn_id']; $receiver_email = $_POST['receiver_email']; $payer_email = $_POST['payer_email']; if (!$fp) { // HTTP ERROR } else { fputs ($fp, $header . $req); while (!feof($fp)) { $res = fgets ($fp, 1024); if (strcmp ($res, "VERIFIED") == 0) { // check the payment_status is Completed // check that txn_id has not been previously processed // check that receiver_email is your Primary PayPal email // check that payment_amount/payment_currency are correct // process payment } else if (strcmp ($res, "INVALID") == 0) { // log for manual investigation } } fclose ($fp); } ?>
  9. _g_

    [Contribution]Paypal IPN - Devosc

    Hi, First of all, I searched but couldn't find the solution. Any kind of help will be appreciated. I have been using this contrib since a long time now. I haven't faced any problem, but today one of my customers paid the amount and I got the confirmation from Paypal, but didn't get any notification from my store (generally I get 2). Moreover the status of the order didn't change to "Processing" from "Pending". Last thing I modified was Ultimate SEO URLs and Guest Reviews. I don't think they have created any problem, but can someone let me know what file(s) or segment of code responsible for updating the order status and sending the emails to the admin. I also have another question, when I provide Gift Vouchers or Discount Coupons to my customers and sometimes they are 10 - 15 cents less than the order's total. I manualy change the order's status to "Processing" (which is fine with me), but the problem is that, the item(s) sold are not listed in the best sellers. I would really appreciate if someone can help me with these problems. Thanks in advance.
  10. Just added a new product but it didn't have SEOed link but a regular link, deleted the url cache and it had the new link. I have a question - How often is the seo_cacheenglish file updated?
  11. Just installed the contrib and took me not more than 5 minutes. A great work not only code but documentation too. It works great. As someone else asked about the Froogle Data Feed. I also use the Froogle Data feed which is sent to froogle periodically using corn jobs. The initial links that were sent to froogle were like ?product_id=2334 but I changed to product_info.php/product_id/2334 Now I am wondering if someone else using the Froogle Data Feed with the Ultimate SEO URLs mod? If someone else has already modified it then it'll save me a lot of time, if not then I'll try to modify it. I think a couple of query changes will be needed and may be would need to check for the short word function (though I have disabled it.) If it has been already created then plss post the code or I'll post it when am done with it. Thanks again for the contrib, I'll wait fir the next, where you add 301 redirects. BTW oscarg if you use a couple of random blocks on a page then actually the 2 pages (SEOed and Non- SEOed) will be different.
  12. _g_

    Points/Rewards Module

    I wanted to install this mod, but it seems like its not working that great for a lot of people. So, I'll just wait and watch this topic :)
  13. Thanks SMAX. I havn't tried it yet, did someone else try it? Also does anybody know how to get rid of paypal page if the order total is 0? Thanks
  14. I am facing another problem. The sort order where GV is more than DC gives 0.00 in Paypal for GV, but if I use a DC then for like this: Sub-Total: $5.49 Shipping: $2.00 Discount Coupons:xxxxx: $7.45 Total: $0.04 I get -$1.96 on my paypal page. Now how can I solve that? Thanks
  15. Thanks nerd3d, I tried it but it didn't work. Does anybody else know how to get rid of Paypal page when the order total is 0? Thanks
  16. Thanks kagg it showed the checkbox. I also had few other problems, which were due to the settings, but I fixed them. So here are my seetings for GV I didn't understand why would one recalculate the tax on a purchase? Can someone explain what exactly it does? Now everything is good, If I buy a $8.00 product with a $10.00 GV, the order total is 0 and the paypal screen also shows 0, but Paypal won't let the user pay $0.00, so is there a way in which if the total is 0, the customer is not forwarded to paypal, but to the thanks page and the order is assigned Processing status (or whatever after payment is) I also checked the discount coupon. It also works fine for most of the time. I tried to redeem a DC by itself and then a GV and DC both at the same time and both of the cases worked. The only problem I faced was that when the Order total was 0, the paypal screen showed -$2.00 (negative of cost of shipping). It seems like things are getting better :) Once again thanks kagg
  17. No :huh: & I didn't even know about that. It is possible that I have an old version as the download section was too confusing. I just see "Enter Redeem Code" an input box for inputting the code and the Redeem button. Thanks for replying
  18. I have the same problems. I added 2 products $5.49 and $19.99 from category A and B in my cart, had shipping charges = $3.50 and tax = $2.10 Total = 31.08 I issued myself with a "discount coupon" for 31.05 and redeemed it. When I confirmed the order and was forwarded to the Paypal, it showed that I had to pay "-3.47" that is my shipping cost - the balance I had to pay "$0.03" Moreover I assigned the discount coupon to category A and it should have given discount only on $5.49 and not $19.99. Gift Voucher also have weird problems, where I sent a GV worth $10.00 to a customer, he redeemed it and it showed that he has the amount credited but couldn't use it, instead it had a link to send it to someone else. A few weeks back I also created a GV worth $20.00 and bought it and sent $10.00 to another email address. Later I checked that the other person got $10.00 and I still had $20.00 with me. Does anybody has this whole contrib working fine for them? then please upload all the files as it is too confusing and one doesn't know which package to download.
  19. _g_

    Recently Viewed Products

    Thanks a lot. It did work :)
  20. _g_

    Recently Viewed Products

    I installed the contrib and it works fine, except for the error described by expert. Removing those '' from $items_ids_on_display doesn't help. The error only shows when the first product is entered in the history. So when a person visits the store, it is ok, but as soon as he visits the first product the error shows up. But when he visits more products or pages, the error goes away. Also when he clears the history, everything goes away but again when he visits the first product after clearing the history, the error shows up. Does anybody know how to get rid of it?
  21. _g_

    Wishlist 2.0 Support Thread

    Hi! I downloaded the contribution and it works well for most of the part :) thanks for the contrib. I haven't read all 27 pages, but a few. My problem is that if their is no text added to "your message" textbox then I get an email like this But if something is added to the textbox then I don't get links for the products. I did check that $wishliststring .="<ul><li> "."<a href=\"".HTTP_SERVER . DIR_WS_CATALOG ."product_info.php?products_id=".$resultarray[0] ."\">".$resultarray[1]."</a>"."</li></ul>"."\n"; this line is present in the wishlist_email.php Even the store name doesn't have a link? Also if (tep_not_null($HTTP_POST_VARS['yourmessage'])) { $email_body .= $wishliststring.$HTTP_POST_VARS['yourmessage'] . "\n\n"; } I think the var wishliststring is just added with this loop and not when the email is sent without yourmessage. I am using OSc 2.2-MS2 and the latest version of the contribution (2.3). Thanks for any kind of help.
  22. Thanks for the reply! I was using it without spaces. I dunno y the % isn't working with categories only but is working fine with the products....if no one has this problem then I would try upgrading to 5.10b I did a fresh instal for the CCGV yesterday but downloaded an old version :| Thanks for your help
  23. _g_

    EZ new fields v1.0

    Thanks for the contribution, its really worth. I installed it and it is working great except for one thing. In the file advanced_search_result.php when one clicks the the link "Retail" (top 5th column) it gives an SQL syntax error. 1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'limit 0, 20' at line 1 select distinct m.manufacturers_name, p.products_image, m.manufacturers_id, p.products_id, pd.products_name, p.products_price, p.products_retail_price, p.products_tax_class_id, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, IF(s.status, s.specials_new_products_price, p.products_price) as final_price from products p left join manufacturers m using(manufacturers_id), products_description pd left join specials s on p.products_id = s.products_id, categories c, products_to_categories p2c where p.products_status = '1' and p.products_id = pd.products_id and pd.language_id = '1' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and (IF(s.status, s.specials_new_products_price, p.products_price) >= 4) and (IF(s.status, s.specials_new_products_price, p.products_price) <= 6) order by limit 0, 20 All the other links work fine the only link with error is the one which has sort value = 5a, so the link is like http://www.somesite.com/advanced_search_result.php?inc_subcat=1&pfrom=0&pto=500&page=1&sort=5a I tried to search for limit in the file advanced_search_result.php but there is no occurence of the word limit in that file als there are 2 occurences of "order by" in the file (I am not sure if somethings wrong with them). I dunno if everybody faces this problem or is it just me? I am not a PHP expert but I think that since we added more columns, we should have also edited this line Line 304 (for me) in advanced_search_results.php for ($i=0, $n=sizeof($column_list); $i<$n; $i++) { to for ($i=0, $n=sizeof($column_list); $i<=$n; $i++) { Please note that = sign or may be change the variable "$column_list" Am not sure how it can be fixed. Any kind of help will be appreciated. Thanks
  24. Hi everybody, I read 100's if not 1000s of posts. Had some issues with the Contribution but most of them have been solved. I think I am using 5.06 ($Id: ot_coupon.php,v 1.1.2.37 2003/07/24 22:52:59 Strider-Cote Exp $ $Id: ot_coupon.php,v 1.1.2.36 2003/05/14 22:52:59 wilt Exp $) The only problem am facing is also faced by other members. When I create a discount coupon and enter the discount as % for a specified category, the payment module doesn't calculate the discount. But the mod works fine with $ for categories and $ and % for individual products. If someone has a fix for that then plss let us know. Thanks P.S. - I had the problem with shipping charges when buying a GV with other products.... but I solved it. Heres the solution for others who r trying to figure it out (the solution has been already posted 4-5 pages back) Enable Downloads thru Admin > Configuration > Downloads Set the GV's weight = 0 and finally, set the include shipping to false in admin > modules > order total > gift vouchers.
×