Jump to content

Sheepish

Members
  • Content count

    34
  • Joined

  • Last visited

  1. Sheepish

    [Contribution] STS v4

    Hi. I'm in the process of putting a Facebook like button on my products. All working well with STS and the button works but it would be handy to have the product image appear on the Facebook page who liked me (at the moment facebook seems to pick a random image on the page and not the product image). To force that, I need to put (in the header of the product page) the following code... <meta property="og:image" content="<?php print 'http://' . $_SERVER['SERVER_NAME'] . DIR_WS_HTTP_CATALOG . DIR_WS_IMAGES . $product_info['products_image']; ?>" /> At the moment, if I put that in my product_info.php template I get... <meta property="og:image" content="http://www.domain.co.uk/images/" /> i.e. the actual image $product_info['products_image'] isn't tagged onto the end. Excuse my lack of knowledge but I'm assuming that's a mysql array that it's working on? Is there a way of getting the image inserted into the code? Thanks Martin
  2. Sheepish

    [Contribution] STS v4

    Is there a way of having the index.php page different to the others controlled by STS? I have put it in index.php.html but that changes the template for the whole site - can you just do it so the index.php is different? Thanks. M.
  3. Sheepish

    [Contribution] STS v4

    Thanks for the reply, Bill - it's appreciated. I can't believe my stupidity - I have modified my site to use 3 columns of products on the category page so I should have used the file infobox_product_listing_col.php.html instead. All working fine now. Thanks and all the best. Martin
  4. Sheepish

    [Contribution] STS v4

    Morning. I am using sts (wonderful system - I'm liking it) and things are going well except for one thing... I have "Use template for infoboxes" set to true in the modules and that does, indeed, seem to be working - I change boxes/infobox.php.html and all the infoboxes change - excellent. However, it also changes the box where the list of products show when you click on the category. I have modified boxes/infobox_product_listing.php.html but it doesn't seem to effect anything - it's almost as if STS doesn't believe the file is there. So...does anybody have any suggestions as to what I can do to be able to modify the box that lists the products? Thanks M.
  5. Sheepish

    [Contribution] More Category Boxes

    This is a great contribution and works well. But... Does anyone here know how I can select sub categories to be placed in the boxes? At the moment only main categories are listed. Thanks M.
  6. Sheepish

    Who's Online Enhancement 1.4

    I use the "Infobox Anywhere" contrib which allows me to put infoboxes on my html pages. Unfortunately, when somebody hits one of my html pages, WOE shows each of the infoboxes as being a customer from the IP of my server so I can have anywhere upto a 6 ghost customers. Is there a way of blocking an IP address from being listed on WOE? Thanks M.
  7. Sheepish

    RSS Feed contribution support thread

    Hi I've added this but when I try to view the rss.php file I get "Internet Explorer cannot display this feed" and am told there's errors in the feed. When I check the feed at feedvalidator.org I'm told "line 3, column 0: XML parsing error: <unknown>:3:0: xml declaration not at start of external entity [help]" and there are two blank lines at the start of the rss feed - seems that's the problem. Any suggestions on how I get rid of the blank lines? The first line according to feedvalidator is "<?xml version="1.0" encoding="UTF-8" ?> " Thanks M
  8. Sheepish

    protx error

    I had this problem - for me it was caused by using shipping zones. Stop using that and it works fine (just need to find a way of stopping orders from dodgy countries now...) M.
  9. In the osc admin and in modules/payment/protx (the bit where you enter your merchant ID and password), do you have anything in Payment Zone? Or do you have --none-- If it's none then I dunno what's up. If it's something else - try --none-- and see what happens. M.
  10. Sounds like a problem I had. Are you using zones? If so...try it with the protx zone turned off and should work. Question is...how to get it to work with zones... M.
  11. Sheepish

    Impulse Item

    Hi Fredrik I've been looking for a contrib like this for quite a while - great idea. I'd just like to check before trying it out...if I use it, will I be able to use specials normally or will I only be able to use one or the other? Also - is there a list of the modifications in the specials.php files rather than just uploading them? I'm not too sure what differences there are in my current specials.php and I'd hate to break it. Thanks M.
  12. <snip about adding tracking on your own html pages> include (DIR_WS_INCLUDES . 'application_top.php'); </snip> Hi I can get this to work if I have the html (which is set in .htaccess to parse php) in the catalog folder but I can't get it to work outside of the catalog folder. I have my main entry page in the root which then links to my catalog. Is there a way of getting stats for non-osc pages? Ta Martin Error I get is: Warning: main(includes/configure.php): failed to open stream: No such file or directory in /usr/home/abc/www/catalog/includes/application_top.php on line 29 Fatal error: main(): Failed opening required 'includes/configure.php' (include_path='.:/usr/local/lib/php') in /usr/home/abc/www/catalog/includes/application_top.php on line 29
  13. Sheepish

    Seach Engine Friendly URL Support

    No joy - I still have ttp instead of the proper path. Cheers, BY M
  14. Sheepish

    Seach Engine Friendly URL Support

    Well...it was 1.1 that I tried and it didn't seem very fixed to me ;)
  15. Sheepish

    Seach Engine Friendly URL Support

    Do you mean it's fixed and will be OK in a future release or it was fixed in the last release? Thanks for this M.
×