Jump to content

montyrach

Members
  • Content count

    30
  • Joined

  • Last visited

Everything posted by montyrach

  1. montyrach

    Google XML Sitemap SEO

    Hi, so happy to see an update for this addon with image sitemap. Thank you! I tried installing this over my previous version of Google XML Sitemap which always worked great, but I'm getting this error. I see some other people have had this too, but I don't quite understand how to fix mine. Can anyone help? Thanks! Opening /sitemapindex.xml FS_CAT /home1/myhost/public_html/ Server http://www.mydomain.com Save Path / WS_CAT / ERROR: Google Sitemap Index Generation FAILED!
  2. montyrach

    [Contribution] Option Types v2

    Excellent update, but can you tell me how to get the attribute manager working for adding text boxes, text areas and check boxes as options? It would be SO NICE not to have to use the product_attributes when I want to use the Option Types features. Thank you!!
  3. montyrach

    [Contribution] Option Types v2

    I have this working on my 2.3.1 shop. What part of the installation are you having trouble with?
  4. montyrach

    [Contribution] Option Types v2

    Can anyone give me an idea on how to make this work with the AJAX attribute manager? Thank you!
  5. montyrach

    [Contribution] Option Types v2

    I have this working on my 2.3.1 shop. What part of the installation are you having trouble with?
  6. Anyone had success adding two submit buttons on a page using the tep_draw_button function? For instance, how would I go about adding a Wishlist button to my Product_info page using the tep_draw_button function? Example <div class="buttonSet"> <span class="buttonAction" style="float:left;"><?php echo tep_draw_hidden_field('products_id', $product_info['products_id']) . tep_draw_button(IMAGE_BUTTON_IN_CART, 'cart', null, 'primary'); ?></span> <?php // WISHLIST ?> <?php echo tep_draw_button('Add to Wishlist', 'clipboard', null, 'primary'); ?> <? echo tep_image_submit('button_wishlist.gif', 'Add to Wishlist', 'name="wishlist" value="wishlist"'); //WISHLIST ?> </div> <!-- end button set --> and here is the rendered HTML <div class="buttonSet"> <span style="float:left;" class="buttonAction"><input type="hidden" value="1877" name="products_id"><span class=""><button type="submit" id="tdb1" class="ui-button ui-widget ui-state-default ui-corner-all ui-button-text-icon-primary ui-priority-primary" role="button" aria-disabled="false"><span class="ui-button-icon-primary ui-icon ui-icon-cart"></span><span class="ui-button-text">Add to Cart</span></button></span> <script type="text/javascript">$("#tdb1").button({icons:{primary:"ui-icon-cart"}}).addClass("ui-priority-primary").parent().removeClass("tdbLink");</script></span> <span class=""><button type="submit" id="tdb3" class="ui-button ui-widget ui-state-default ui-corner-all ui-button-text-icon-primary ui-priority-primary" role="button" aria-disabled="false"><span class="ui-button-icon-primary ui-icon ui-icon-clipboard"></span><span class="ui-button-text">Add to Wishlist</span></button></span> <script type="text/javascript">$("#tdb3").button({icons:{primary:"ui-icon-clipboard"}}).addClass("ui-priority-primary").parent().removeClass("tdbLink");</script> <input type="image" value="wishlist" name="wishlist" title=" Add to Wishlist " alt="Add to Wishlist" src="includes/languages/english/images/buttons/button_wishlist.gif"> </div> The tep_image_submit button will work and correctly add a product to the user's wishlist and take them to their wishlist page. BUT if you click the 'Add to Wishlist' button created by the tep_draw_button function, the item is added to the shopping cart. This tells me my application_top is correctly setup to discern between adding to the cart and adding to the wishlist, but I THINK the button isn't setup correctly. Do I need to alter my tep_draw_button function to add some parameters? Any help would be MUCH appreciated as this would apply to loads of different add-ons, not just Wishlist. Thank you!
  7. I'm nearly finished updating an existing Gift Registry contribution for OSC 2.3.1. I have one last issue that I desperately need help with. When I add a product to my registry from the product_info page, the product is entered into the registry but also quantity 1 of that product is put into the cart. I'm fairly certain the issue lies in the below code somewhere. Any help would be much appreciated. Here's a link to my live test area. To view the issue directly, login as montyrach@gmail.com with password 12171977 and go to My Account. Then click "click here" on the line of the registry to begin registry mode. Go into a product and try adding it to the registry. You'll see it is also added to the cart :( // customer adds a product from the products page case 'add_product' : if (isset($HTTP_POST_VARS['products_id']) && is_numeric($HTTP_POST_VARS['products_id'])) { $attributes = isset($HTTP_POST_VARS['id']) ? $HTTP_POST_VARS['id'] : ''; $cart->add_cart($HTTP_POST_VARS['products_id'], $cart->get_quantity(tep_get_uprid($HTTP_POST_VARS['products_id'], $attributes))+1, $attributes); //start gift registry if($HTTP_POST_VARS['submit_cart_x']){ if($HTTP_POST_VARS['products_quantity_cart']) { $quantity = $HTTP_POST_VARS['products_quantity_cart']; }else { $quantity = 1; } $cart->add_cart($HTTP_POST_VARS['products_id'], $cart->get_quantity(tep_get_uprid($HTTP_POST_VARS['products_id'], $HTTP_POST_VARS['id']))+$quantity, $HTTP_POST_VARS['id']); }elseif ($HTTP_POST_VARS['submit_registry_x']){ if($HTTP_POST_VARS['products_quantity_registry']) { $quantity = $HTTP_POST_VARS['products_quantity_registry']; }else { $quantity = 1; } $registry->add_cart($HTTP_POST_VARS['products_id'], $registry->get_quantity(tep_get_uprid($HTTP_POST_VARS['products_id'], $HTTP_POST_VARS['id']))+$quantity, $HTTP_POST_VARS['id']); } } tep_redirect(tep_href_link($goto, tep_get_all_get_params($parameters))); break; //end gift registry
  8. montyrach

    Gift Registry for 2.3.1

    What sort of issues are you having getting the gift registry to work in 2.3.1 ?
  9. On which page are you receiving that error? Warning: require(DIR_WS_FUNCTIONScompatibility.php) [function.require]: failed to open stream
  10. montyrach

    ULTIMATE Seo Urls 5 - by FWR Media

    Hi Robert, I just installed the latest version of your Ultimate SEO on a fresh OSC install. I'm getting this error when I set the URI format to rewrite: "the server is redirecting the request for this address in a way that will never complete" I copied the .htaccess from the install files exactly (changing the rewritebase to my directory, of course) Any ideas how to get this working? Thanks a million !
  11. montyrach

    Registry Shipping Address

    Hi Allison, I am working on this same thing. Did you ever get an answer? If so, I'd love to hear how you were able to solve this. Thanks!!
  12. montyrach

    AJAX Attribute Manager support

    I also am experiencing this problem. Has anyone been able to help?
  13. montyrach

    Quickbooks Merchant Service v1.0

    I'm trying to follow the external tutorial found at http://idnforums.intuit.com/messageview.as...p;threadid=7743 and am stuck on step number 2. I was wondering if anyone could help me out. "When creating the application, Quickbooks will ask for an “https:\\” callback url for various functions. It is VERY important that these URLs have a VALID SSL certificate issued by a recognized Certificat Authority (CA). We use RapidSSL here and have never had any trouble with their service or certificates. " Does anyone know what the callback URLs would be for the following on a standard OSC installation? Subscribe URL: * * Need https URL Change URL: * * Need https URL Cancel URL: * * Need https URL Login URL: Marketing URL: I have https://www.mydomain.com but not sure what else would be required. Any help would be greatly appreciated. My client thought they were doing me a favor by signing up for Quickbook Merchant Services, but it's turning out to be an absolute nightmare making it work with OSC, which I love and can usually make work with anything :-( Thank you!
  14. montyrach

    QTPro and Sort Options

    I've installed QTPro on my store and am very happy with it. But I desperately would like to add a sort option contribution so that I can set the order for my options from the Admin section, i.e. I have options that are January, February, March, etc. and I'd like to set a sort order within the attribute setup. I've used a contribution separate of QTPro before, but I can't figure out how to integrate it with QT Pro. Anyone had success doing this before who could give me some tips? Thanks!
  15. Can anyone help me to write a correct if else statement to hide the price for an item if the selected attributes determine the pricing? For instance, I have an item that comes in different sizes and each size is a different price. So rather than display the $products_price I want to hide this if I enter no price in the product maintenace area but put a price using the attribute area. I've tried If ($products_price == 0) { } else { echo $products_price;} but something isn't working. Can anyone help me out?
  16. I love this contribution, but I was wondering if anyone has been able to figure out a way to sort the attributes as desired. I would LOVE to see an extra column in the administration where you can set the order. Say I have three color attributes: red, blue and green. And maybe I want red 1st, blue 2nd and green 3rd. There should be a way to set that order by assigning 1 to red, 2 to blue etc. If anyone can figure this out, I'd love the assistance. There is another contrib I've used before for adding a sort order to attributes but I haven't yet been able to apply it to this contribution.
  17. I've installed the QTpro on my store so I can track stock levels of attributes of my products, i.e. how many widgets I have in each color when I only have one product (widget) and each color as an attribute. Has anyone had luck forcing the product_info.php page to sort the attributes drop-down using price or alphabetical? I've tried to do it myself using a past contribution for sorting this, but it's not working with the QTpro changes. Thanks!!
  18. montyrach

    Family Products 3.3

    I'm not sure if I installed this incorrectly or if I'm using it wrong. I did an entire clean installation with the files I downloaded. When I go into my admin panel and catalog, I see "families" as a choice on the left. I create a new category and assign products, but when I view the product from within my store, the family products are not displayed. Also, when I click on Select Display from within the Families admin area, I only see "Title Value Action" as a header and nothing else. Any ideas where I went wrong?
×