Jump to content

imfinlay

Members
  • Content count

    12
  • Joined

  • Last visited

Everything posted by imfinlay

  1. imfinlay

    Whois_online contribution discussion

    I just installed this on my test site - it looks ok, but after a few moments I get a blank page. Any use of the back button returns more blank pages. Ian
  2. imfinlay

    [Contribution] Family Products v 1.0

    Hiya! First - great contrib. This is really useful. I added the suggestions above to avoid listing inactive products, but found another little issue. Using product attributes, once a product with it's attributes is added to the cart, the product ID looks like productid=30{2}1 . Clicking the link to see the product gives a SQL error in family_products.php. Easy fix to help anyone with the same issue: In /includes/family_products.php, find: $currentid = $HTTP_GET_VARS['products_id']; change to: $currentid = (int)$HTTP_GET_VARS['products_id']; Hope this helps someone else. Cheers, Ian
  3. imfinlay

    Help testing NOCHEX APC

    Hi all, on my MS2 install with the Nochex APC module installed, I seem to have everything working. Main issues were the removal of the thousands separator and the use of a pukka ssl certificate. However, I can't seem to generate a DECLINED message from Nochex to test with. I can't even find out in what circumstances this could occur. Any clues or pointers? Ian
  4. imfinlay

    Nochex gives Syntax Error

    Hi. This is my first post, so I hope I get this right! (All the following is assuming the nochex APC contrib, latest version) I had the same problem trying to get a "Declined" message to test that functionality... It seems to be the number format in the Nochex form submission, not the currency format in the Admin form. In checkout_nochex.php, around line 242, you'll find: tep_draw_hidden_field('amount', number_format($order->info['total'] * $currencies->currencies['GBP']['value'], $currencies->currencies['GBP']['decimal_places'])) Replace that with tep_draw_hidden_field('amount', number_format($order->info['total'] * $currencies->currencies['GBP']['value'], $currencies->currencies['GBP']['decimal_places'], '.', '')) This changes the result of the PHP "number_format" function to use "." as the decimal and nothing as the thousands separator. For others with the same issue on other payment systems, check the PHP doc at this page As always, backup and test and don't blame me! Best of luck, Ian
×