Jump to content

djenniex

Members
  • Content count

    31
  • Joined

  • Last visited

About djenniex

  • Birthday 01/11/1979

Profile Information

  1. djenniex

    Enable/Disable categories contribution

    Hey clongato thanks for the updates. Could you please reply with the filenames for those fixes? Thanks
  2. djenniex

    Enable/Disable categories contribution

    I believe your problem might be your second sql statement. Try: $categories_query = tep_db_query("select c.categories_id, cd.categories_name, c.parent_id from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.categories_status = '1' and c.parent_id = '" . (int)$parent_id . "' and c.categories_id = cd.categories_id and cd.language_id='" . (int)$languages_id ."' order by sort_order, cd.categories_name"); All I did is replace c.parent_id = '0' with c.parent_id = '" . (int)$parent_id . "' Let me know how that works out for you.
  3. I am not sure why this hasn't been caught yet, but in includes\modules\order_total\ot_coupon.php line 428 has a very minor bug, but this is something that can cause a problem if a shop is using prefixes or changed table names. $cat_query = tep_db_query("select products_id from products_to_categories where products_id = '" . $products_id . "' and categories_id = '" . $cat_ids[$i] . "'"); This should be: $cat_query = tep_db_query("select products_id from " . TABLE_PRODUCTS_TO_CATEGORIES . " where products_id = '" . $products_id . "' and categories_id = '" . $cat_ids[$i] . "'");
  4. djenniex

    QBI Quickbooks Import

    Opps, sorry the code in the above post will not work unless you change the constants in qbi_definitions.php Update code // Check if QB Import configured and installed $resultqbc = tep_db_query("select * from " . TABLE_QBI_CONFIG); if ($myrowqbc = tep_db_fetch_array($resultqbc)) { if ($myrowqbc['qbi_config_ver'] == QBI_VER) { if ($myrowqbc['qbi_config_active'] != 1 && $_SERVER['PHP_SELF'] != DIR_WS_ADMIN . 'qbi_config.php') { header("Location: qbi_config.php?msg=1"); } } else { header("Location: qbi_db.php?db_ver=" . $myrowqbc['qbi_config_ver'] . "&qbi_vers=" . QBI_VER); } } else { header("Location: qbi_db.php?db_ver=0.00&qbi_vers=" . QBI_VER); }
  5. djenniex

    QBI Quickbooks Import

    Hey Adam, Thanks for the great contribution. I had a little problem installing it. After about 10 minutes of fooling around with it, I realized what was happening. This might help other people who have the same trouble I did. I followed the installation instructions to the letter, after I installed the database tables, I didn't see the success message. I tried again, and again. Droping the tables and fields, like you indicated in your Installation document. Nothing worked. Finally, I realized that it was qbi_versions.php that was giving me the trouble. So I rewrote the code a little to fix the problem. Here is the fix. // Check if QB Import configured and installed $check_qbi_config_version_query = tep_db_query("select qbi_config_ver, qbi_config_active from " . TABLE_QBI_CONFIG); if ($check_qbi_config_version = tep_db_fetch_array($check_qbi_config_version_query)) { if ($check_qbi_config_version['qbi_config_ver'] == QBI_VER) { if ($check_qbi_config_version['qbi_config_active'] != 1 && $_SERVER['PHP_SELF'] != DIR_WS_ADMIN . 'qbi_config.php') { header("Location: qbi_config.php?msg=1"); } } else { header("Location: qbi_db.php?db_ver=" . $check_qbi_config_version['qbi_config_ver'] . "&qbi_vers=" . QBI_VER); } } else { header("Location: qbi_db.php?db_ver=0.00&qbi_vers=" . QBI_VER); } The database array variable was not getting initialized before it was being tested. This could have also been fixed by putting brackets around both statements, but I like this solution because it lays the code out nice and easy to read. Thanks JINX
  6. What version of osCommerce are you using? Cause there is another version out there for osCommerce 2.2 MS2 Category Description MS2 Contribution Try downloading the latest version of this contribution. I have installed this version and it works perfectly.
  7. djenniex

    payflow pro credit card error

    Did you read the Payflow Pro Developers Guide? It gives detailed instructions on how to use the service. Also, what is the error code you are receiving?
  8. djenniex

    Refunds to VeriSign's Payflow Pro

    Hi, I was wondering if anyone out there has (or is think of) developing a refund module for VeriSign's Payflow Pro. After looking at the Developer's manual for the Payflow Pro system, I know that this can be accomplished, but I was just wondering if anyone has any ideas about how to go about doing this. I believe that is is a critical area in which osCommerce falls short. The system itself is awsome, it just needs some slight improvements to be able to compete against bigger e-commerce makers (IE. Micro$oft). Thanks for you time.
  9. djenniex

    email to Manufacturer of products

    You might want to check out Vendor Auto Email. That might do the trick.
  10. djenniex

    Enable/Disable categories contribution

    Hey Tim, thanks for the correction, but what file is that in? Is it the /includes/functions/general.php file? As for a suitable thread, I think you just started one for this Contribution.
  11. I am trying to merge the Enable/Disable Categories with Category Description Contributions. I followed the instuctions for the Category Description Contribution, then I installed the Enable/Disable Categories Contribution. My problem is that when I disable a category in the admin panel, if you manually enter the category into the address bar of a web browser, the category still shows up. Also, when you edit an active (or enabled) category in the admin panel, it's status resets to inactive (or disabled). Any help with these problems would be greatly appreciated. Thanks
×