Jump to content

Patty

Members
  • Content count

    364
  • Joined

  • Last visited

Everything posted by Patty

  1. Sorry for the late response. I've been away for the past few days. And JcMagpie seems to be MIA, I hope he's alright. I'll try to replicate the issue when I find some free time. But glad you've found an alternative for a supported addon. ๐Ÿ‘
  2. Patty

    [Contribution] Ship In Cart

    I just thought that maybe some of the changes in one of the latest versions could have fixed it. So I just tried today on 1.0.7.1 and thought it was worth mentioning it so maybe it would save somebody else's time in trying. I know the addon hasn't been updated yet.
  3. Patty

    [Contribution] Ship In Cart

    Just to inform that this error is still occurring on v1.0.7.1 I was hoping that maybe it would've fixed itself on newer version, but unfortunately it hasn't.
  4. After hours of trying to figure this out (mind you, I'm not a coder, I think I finally found a fix for the above mentioned issues. This is my code. If someone could try it and confirm it's really working, I'll update the addon. Just replace the code between the script tags. File: includes/modules/header_tags/ht_jcm_no_stock.php <script> $(document).ready(function() { $('*[data-in-stock]').filter(function () { return $(this).data('in-stock') <= 0; }).each(function() { $(this).addClass('disabled fas fa-ban text-danger').text('$no_stock_text'); // use to change appearance $(this).attr('disabled', true); // $('btn-product-listing.btn-buy').addClass('text-white').text('$no_stock_text'); // $('.btn.btn-light').text(''); // $('.btn.btn-success.btn-product-info').addClass('text-white').text('$no_stock_text'); $('.btn.btn-success.btn-product-info').removeClass('btn-success text-danger').addClass('btn btn-product-info text-white $no_stock_color').text('$no_stock_text'); // $('.btn.btn-light').removeClass('btn btn-light').addClass('btn $no_stock_color'); // $(this).prepend('<span>{$no_stock_text}</span>'); }); }); </script>
  5. Patty

    [Contribution] Ship In Cart

    I'm testing the latest version. No problem. I'll wait. Tks!
  6. Patty

    [Contribution] Ship In Cart

    Unfortunately I'm not a coder and I can't afford to pay one, otherwise I wouldn't have the need to be here asking for help in a community that has always been so helpful. The only thing I have to contribute right now is my time. So I'm testing a lot of addons that I think would be useful and luckily most of them are working fine in the latest version. The ones that are not I'm trying to fix the best I can, but sometimes it's over my head, like this one. Anyway, thank you for being such a great helper. I appreciate your efforts. Phoenix is the best osCommerce has been ever! ๐Ÿ™‚
  7. Patty

    [Contribution] Ship In Cart

    It's not live, it's on testing environment.
  8. Patty

    [Contribution] Ship In Cart

    Well, I tried, but this is too complicated for me. I think this addon will have to be completely revamped for the latest Phoenix versions, for they are very different from the earlier ones. I hope someone tackles it soon, for this is an important feature to have in the store. IMHO I think it should be part of the project.
  9. Another nice addon. It's working almost 100% on v1.0.58. The only flaw is that the badge does not show on product_info.php and shopping_cart.php Can this be fixed? I tried to find a solution but haven't been able to. And yes, both pages are selected on the addon admin. TIA for any help with this!
  10. Patty

    [Contribution] Ship In Cart

    OK, Tks for pointing me the direction. ๐Ÿ‘
  11. Patty

    [Contribution] Ship In Cart

    Has anybody been able to install this on Phoenix v1.0.58? I'm getting the following error on the shopping cart after installing it and I'm at loss. Any clues? Fatal error: Uncaught Error: Call to a member function fetch_to_address() on null in C:\xampp\htdocs\Phoenix1058\includes\system\versioned\1.0.5.3\order.php:170 Stack trace: #0 C:\xampp\htdocs\Phoenix1058\includes\system\versioned\1.0.5.3\order.php(27): order->cart() #1 C:\xampp\htdocs\Phoenix1058\includes\modules\content\shopping_cart\cm_sc_shipping.php(61): order->__construct() #2 C:\xampp\htdocs\Phoenix1058\includes\system\versioned\1.0.4.0\osc_template.php(147): cm_sc_shipping->execute() #3 C:\xampp\htdocs\Phoenix1058\shopping_cart.php(15): oscTemplate->getContent('shopping_cart') #4 {main} thrown in C:\xampp\htdocs\Phoenix1058\includes\system\versioned\1.0.5.3\order.php on line 170
  12. I cannot develop, but I can make simple things work, if pointed in the right direction. ๐Ÿคจ Thank you!
  13. Thank you for your reply. By the way, your addons are great, congratulations! I tried to update it by comparing the modules, but they were so different that I thought I was comparing the wrong ones (sorry, I'm not a coder... ) I believe it's just the PI side that needs to be duplicated and then add the KissIT functions, right? Just please point me in the right direction and I'll try to do the rest. Thank you! Have a great Sunday and stay safe! ๐Ÿ™Œ
  14. Hi there. I'm trying to install it on Phoenix v1.0.58. It seems to work fine with the regular product_info modules, but if I try to install it on the modular product info on modules_pi.php I get the following error: Fatal error: Uncaught Error: Cannot access protected property pi_gallery_kissit::$group in C:\xampp\htdocs\Phoenix1058\admin\modules_pi.php:43 Stack trace: #0 {main} thrown in C:\xampp\htdocs\Phoenix1058\admin\modules_pi.php on line 43 Any guidelines on how to make this work on that page? Or any ETA on an update compatible with v1.0.58? TIA for any help.
  15. Yes, same issue with v1.0.58 Buy now cart icon disappears and button changes to the same color as defined for the no stock button. Other than that, it's working as it should. Have you found a fix for that?
  16. Thank you! That worked! Uncompressed back up was restored! But it won't restore the compressed back up file. Also it's forcing the restoring of all tables, not just the selected ones. Like you said, it's just a temporary fix, but the code should be reviewed to make it work as it's supposed too. In any case, thank you for your help with this! Have a great week and stay safe! ๐Ÿ˜™
  17. Yes, it does. Both compressed and uncompressed files look fine.
  18. Yeah, but the point is to be able to use the automated backup. I also just started with Phoenix and I'm trying some useful addons. Thanks anyway.
  19. Thank you! That fixed the Notice error. But the addon still doesn't restore the database. Any fix for this?
  20. It doesn't work with v1.0.50+ Are you planning on updating this to make it compatible with the newer versions? Great work, by the way!
  21. Unfortunately this is not working for Phoenix 1.0.56 I'm getting errors like Notice: Undefined index: listing in C:\xampp\htdocs\phoenix\admin\backup.php on line 41 And when I try to restore a back up, it created an uncompressed back up file, but neither back ups can be restored: Error: no tables selected for restore Can someone please help making this addon compatible with Phoenix latest versions? This one should be made part of the project. TIA!
  22. Oh, ok! Thank you! But I think it's a lit bit more complicated than that. I was comparing this file with a v1.0.5.7 moneyorder file and there's more code that needs to be updated. I'm not very familiar with Phoenix yet to adventure in doing it myself.
  23. Thank you, but I don't see how it's relevant to this issue. Those posts are from 2005 for a completely different addon, while this is a new issue related to new code. I'm sorry, but I'm not a coder and I can't find a solution there. But thanks for trying to help anyway. ๐Ÿ˜‰
  24. Hi there! First of all, I'd like to congratulate you for a ton of great contributions that you are making to this project! Excellent job! โค๏ธ Now the issue with this addon. On Phoenix v1.0.57 it's throwing the following error on the payment modules installation page: Would you be kind enough to update this addon so it will be compatible with the newer versions? Unfortunately I'm not a coder so this is a little beyond me to fix. ๐Ÿ˜• TIA for your help! And keep up the good work!
  25. Patty

    Fake accounts

    Hi guys. A client's old 2.2 store have been attacked for the past couple of days with over 1000 fake accounts in a couple of hours! I disabled the create_account.php and it stopped. I re-enabled it and not too long after over 400 accounts were created again! All accounts have different names and addresses, several had the same IP, mostly from 45.XX.XX.XX, so I blocked all IPs starting with 45. This store uses 2 extra fields for address number and I noticed these 2 fields have the same information for all fake accounts. Also all of them have the same DOB. Is anyone else having this problem? They were able to place 3 orders from different accounts using a custom credit card payment method so that can be where the hacker's interest lies. Do you recommend to install both Honeypot and View Counter contributions to mitigate and maybe even stop this? Or just one of them would be enough? In this case, which one? Also which Google captcha contribution will work for an old 2.2 store? (I know, it needs to be updated, but it's a big store that's been on for many years already, it's very customized, and we need time and planning to do it right). TIA for your help.
×