Jump to content

Webstera17

Members
  • Content count

    290
  • Joined

  • Last visited

Everything posted by Webstera17

  1. Webstera17

    Thumbnailing Headaches

    How do people get the great looking thumbnails that aren't distorted? I am adding inventory to our site at www.tnpaintballers.com & if you look you will see the thumbnails are all horrible. -Jason
  2. Webstera17

    RMA Returns error for 2.2 MS2

    I don't mean to double post this question, but haven't got a response yet. I searched this thread & found that a guy over a year ago asked this question & never got an answer for it. This RMA System works just find except for one area that I found. The RMA System is returning the list price. It isn't taking away the discount he got. I had a item for $50.00 & shipping for $5.00. The order total was $55.00, but he had a discount code that saved him $5.50. He only paid $49.50 total, but he should only get back $44.50 which is the $49.50 he paid less shipping since shipping cost aren't refunded. I was told that the RMA System by default doesn't return the shipping the customer pays at checkout. I can post code, but not sure while file to post.
  3. Webstera17

    "Categories Specials" MySQL Error

    Has anyone else ran into the same problem that I am having?
  4. Webstera17

    Attribute Product Codes [Contribution]

    Sorry about those three post above...I was having problems w/internet. I attempted to post my reply, but page wouldn't load so I just tried it again until the page loaded. I didn't realize that it did post the first two time.
  5. Webstera17

    Attribute Product Codes [Contribution]

    I was looking over the install file & seen something that doesn't make sense. Here you are replacing the display of the product model number with displaying the product code, but in that second piece of code from the install file you are still inserting the model into the db as well as the product code & you print the product code in the order email confirmation. Wouldn't it be easier to just use the existing product model column in the db & insert the product code into products_model since you are just adding a forward slash & the attribute number...AP1/G to the existing model number? You are just adding to the model number the attribute number & inserting the modified model you call the code number into the code field...right? ############################################################# ********** In catalog/admin/orders.php ***************** Find: around line 233 echo ' </td>' . "\n" . ' <td class="dataTableContent" valign="top">' . $order->products[$i]['model'] . '</td>' . "\n" . Change To: echo ' </td>' . "\n" . ' <td class="dataTableContent" valign="top">' . $order->products[$i]['code'] . '</td>' . "\n" . ############################################################# ############################################################# ********** In catalog/checkout_process.php ***************** Find: around line 160 $sql_data_array = array('orders_id' => $insert_id, 'products_id' => tep_get_prid($order->products[$i]['id']), 'products_model' => $order->products[$i]['model'], 'products_name' => $order->products[$i]['name'], 'products_price' => $order->products[$i]['price'], 'final_price' => $order->products[$i]['final_price'], 'products_tax' => $order->products[$i]['tax'], 'products_quantity' => $order->products[$i]['qty']); tep_db_perform(TABLE_ORDERS_PRODUCTS, $sql_data_array); Change To: $sql_data_array = array('orders_id' => $insert_id, 'products_id' => tep_get_prid($order->products[$i]['id']), 'products_model' => $order->products[$i]['model'], 'products_code' => $order->products[$i]['code'], 'products_name' => $order->products[$i]['name'], 'products_price' => $order->products[$i]['price'], 'final_price' => $order->products[$i]['final_price'], 'products_tax' => $order->products[$i]['tax'], 'products_quantity' => $order->products[$i]['qty']); tep_db_perform(TABLE_ORDERS_PRODUCTS, $sql_data_array); #############################################################
  6. Webstera17

    Attribute Product Codes [Contribution]

    I was looking over the install file & seen something that doesn't make sense. Here you are replacing the display of the product model number with displaying the product code, but in that second piece of code from the install file you are still inserting the model into the db as well as the product code & you print the product code in the order email confirmation. Wouldn't it be easier to just use the existing product model column in the db & insert the product code into products_model since you are just adding a forward slash & the attribute number...AP1/G to the existing model number? You are just adding to the model number the attribute number & inserting the modified model you call the code number into the code field...right? ############################################################# ********** In catalog/admin/orders.php ***************** Find: around line 233 echo ' </td>' . "\n" . ' <td class="dataTableContent" valign="top">' . $order->products[$i]['model'] . '</td>' . "\n" . Change To: echo ' </td>' . "\n" . ' <td class="dataTableContent" valign="top">' . $order->products[$i]['code'] . '</td>' . "\n" . ############################################################# ############################################################# ********** In catalog/checkout_process.php ***************** Find: around line 160 $sql_data_array = array('orders_id' => $insert_id, 'products_id' => tep_get_prid($order->products[$i]['id']), 'products_model' => $order->products[$i]['model'], 'products_name' => $order->products[$i]['name'], 'products_price' => $order->products[$i]['price'], 'final_price' => $order->products[$i]['final_price'], 'products_tax' => $order->products[$i]['tax'], 'products_quantity' => $order->products[$i]['qty']); tep_db_perform(TABLE_ORDERS_PRODUCTS, $sql_data_array); Change To: $sql_data_array = array('orders_id' => $insert_id, 'products_id' => tep_get_prid($order->products[$i]['id']), 'products_model' => $order->products[$i]['model'], 'products_code' => $order->products[$i]['code'], 'products_name' => $order->products[$i]['name'], 'products_price' => $order->products[$i]['price'], 'final_price' => $order->products[$i]['final_price'], 'products_tax' => $order->products[$i]['tax'], 'products_quantity' => $order->products[$i]['qty']); tep_db_perform(TABLE_ORDERS_PRODUCTS, $sql_data_array); #############################################################
  7. Webstera17

    Attribute Product Codes [Contribution]

    I was looking over the install file & seen something that doesn't make sense. Here you are replacing the display of the product model number with displaying the product code, but in that second piece of code from the install file you are still inserting the model into the db as well as the product code & you print the product code in the order email confirmation. Wouldn't it be easier to just use the existing product model column in the db & insert the product code into products_model since you are just adding a forward slash & the attribute number...AP1/G to the existing model number? You are just adding to the model number the attribute number & inserting the modified model you call the code number into the code field...right? ############################################################# ********** In catalog/admin/orders.php ***************** Find: around line 233 echo ' </td>' . "\n" . ' <td class="dataTableContent" valign="top">' . $order->products[$i]['model'] . '</td>' . "\n" . Change To: echo ' </td>' . "\n" . ' <td class="dataTableContent" valign="top">' . $order->products[$i]['code'] . '</td>' . "\n" . ############################################################# ############################################################# ********** In catalog/checkout_process.php ***************** Find: around line 160 $sql_data_array = array('orders_id' => $insert_id, 'products_id' => tep_get_prid($order->products[$i]['id']), 'products_model' => $order->products[$i]['model'], 'products_name' => $order->products[$i]['name'], 'products_price' => $order->products[$i]['price'], 'final_price' => $order->products[$i]['final_price'], 'products_tax' => $order->products[$i]['tax'], 'products_quantity' => $order->products[$i]['qty']); tep_db_perform(TABLE_ORDERS_PRODUCTS, $sql_data_array); Change To: $sql_data_array = array('orders_id' => $insert_id, 'products_id' => tep_get_prid($order->products[$i]['id']), 'products_model' => $order->products[$i]['model'], 'products_code' => $order->products[$i]['code'], 'products_name' => $order->products[$i]['name'], 'products_price' => $order->products[$i]['price'], 'final_price' => $order->products[$i]['final_price'], 'products_tax' => $order->products[$i]['tax'], 'products_quantity' => $order->products[$i]['qty']); tep_db_perform(TABLE_ORDERS_PRODUCTS, $sql_data_array); #############################################################
  8. Webstera17

    Attribute Product Codes [Contribution]

    In the default OSC script when viewing an order you see the Model number which is like the item number for each item in the store. Will this contribution display the Model number like he has it above...AP1, AP1/G, AP1/R & etc? I am asking because I see the following MySQL Query line to run & this is adding another column. ALTER TABLE `orders_products` ADD `products_code` varchar(20) NOT NULL default '' AFTER `products_model`;
  9. Webstera17

    RMA Returns error for 2.2 MS2

    Look at the Database first & see if you have that column in your table already...
  10. Webstera17

    RMA Returns error for 2.2 MS2

    To try & answer your question look at the orders_products table & see if you already have that column products_returned as that is normally when you get that Duplicate column name error. If you already had an older version installed then you probably have all the right columns added from the previous install. You might either want to look at the sql file & see if it is adding any columns you don't you don't have & if so then add those columns manually.
  11. Webstera17

    RMA Returns error for 2.2 MS2

    Next to the quote & reply buttons at the bottom of each post you should see a edit button if not then it is too late to edit the post.
  12. Webstera17

    RMA Returns error for 2.2 MS2

    Can you edit this post & remove the link to www.shoppinginurpjs.com domain as it isn't showing anything, but is popping up a Username & Password field for cPanel each time the page loads. I put two letter d's in that link to show you that you don't have anything linked from your site & that it is just a blank link.
  13. Webstera17

    RMA Returns error for 2.2 MS2

    If you are talking about the person that never got an answer then no it was someone else...here is the link to their post. http://forums.oscommerce.com/index.php?act...&pid=638425
  14. Webstera17

    RMA Returns error for 2.2 MS2

    I searched this thread & found that a guy over a year ago asked this question & never got an answer for it. This RMA System works just find except for one area that I found. The RMA System is returning the list price. It isn't taking away the discount he got. I had a item for $50.00 & shipping for $5.00. The order total was $55.00, but he had a discount code that saved him $5.50. He only paid $49.50 total, but he should only get back $44.50 which is the $49.50 he paid less shipping since shipping cost aren't refunded. I was told that the RMA System by default doesn't return the shipping the customer pays at checkout. I can post code, but not sure while file to post.
  15. Webstera17

    "Categories Specials" MySQL Error

    I am having problems with the code in the Admin side. I get this when I click the Edit button 1054 - Unknown column 'A.products_id' in 'on clause' select count(*) as total from products A, products_description B, products_to_categories E left join specials C on C.products_id = A.products_id left join special_product F on A.products_id = F.product_id left join special_category D on E.categories_id = D.categ_id where E.categories_id = 5 and E.products_id = A.products_id and A.products_id = B.products_id and B.language_id = '1' I have tried to troubleshoot this, but I can't find any code in the category_specials.php file that has select count(*) as total in it. That bit of code isn't in that file. I re downloaded another version of this & still have the same errors. If I try to insert a new category sale I get this error 1054 - Unknown column 'A.products_id' in 'on clause' select A.products_id, B.products_price from products_to_categories A, products B left join specials C on C.products_id = A.products_id where A.categories_id = 1 and B.products_id = A.products_id and C.products_id IS NULL [TEP STOP] I was going to post my file below, but it very long.
  16. Webstera17

    Contribution Release

    I have made my first contribution for OSC & I would like to release it to the public for downloading, but only for testing & debugging. I have a few bugs & glitches in this & would like others to install this & help me debug it. It is basically a Help Center w/full admin control from the admin panel. I read in this section of the forum to but for now I just want it out there for testing & debugging. How do I do this? -Jason
  17. Webstera17

    Contribution Release

    Help please...if this is a stupid question then please provide me a link to the instructions for this.
  18. I am sure this question has been asked before, but this thread is around 175 pages & I can't find a search button to search only this thread. I see that in the categories_description table in the database the following columns... categories_htc_title_tag varchar(80) categories_htc_desc_tag longtext categories_htc_keywords_tag longtext categories_htc_description longtext I know that the categories_htc_title_tag is the <title></title> code. I know that the categories_htc_desc_tag is the <meta name="Description" content=" "/> code. I know that the categories_htc_keywords_tag is the <meta name="Keywords" content=" "/> code. What is the categories_htc_description for? What text is used here & where is this text displayed. I couldn't find this anywhere in the page source for the categories.
  19. Webstera17

    Graphical Borders on RSS News

    I just installed this contribution & like how it looks, but for some reason in IE I have horizontal scrolling which I will not have on my sites. I installed this code just as it said to & got this horizontal scrolling...has anyone else had this problem? How do I fix this?
  20. Webstera17

    Gift Cards Code Prints

    Use the CCGV system. You will basically just giving Gift Vouchers as the default system is labeled. You will have to go throughout your site & rename everything that says Gift Voucher to Gift Card. For printing them out, just make a Gift Voucher/Card & use the Code ID number for the Gift Card number you give out.
  21. Webstera17

    Recently Viewed Products

    I am not trying to bump this question, but it has been a week & no response. I still need help with this...
  22. Webstera17

    Recently Viewed Products

    I have read over this support thread. I have the recently viewed installed & viewing it as a box on the right column. Is there an update that I missed because this box looks nothing like the rest of the boxes. I don't even have a includes/boxes box file for this...it is listed in the modules folder.
  23. I still unable to get this to work. Any help? Also in the login.php file for this contribution this line is wrong. Currently this is the code around Line 43 tep_session_register('login_first_name'); It should be this blow...the session name was wrong. tep_session_register('login_firstname'); I found this when I was writing some custom functions & wasn't able to print their first name out.
  24. Webstera17

    PayQuake

    I am going to be using PayQuake for our store, but since they use the Authorize.net gateway I am not sure if I need to use the contribution for PayQuake. The Sales person at PayQuake said he is familiar with OsCommerce & thinks I should be able to use the Authorize.net part since we using an Authorize.net gate way. I found this PayQuake contribution, but not sure if I need it. http://www.oscommerce.com/community/contri...ns,4713/page,19 Does anyone here use PayQuake & how did you set it up in your OsCommerce store?
×