Jump to content

ChrisW123

Members
  • Content count

    301
  • Joined

  • Last visited

About ChrisW123

  • Birthday 02/18/1961

Profile Information

  1. ChrisW123

    Picture Enlargment

    I don't have all of those, but here's my settings which work good for me: Small image width: 150 Small image height: 120 Now, these settings assume that your large image will have the same "aspect ratio" of 150 x 120, such as 450 x 360. If your original image does not have the same aspect ratio, it may look funny as a thumbnail. I think I also added some code to flip the demensions if the input image if it's portrait. The aspect ratio is always the same, but if portrait (360 x 450, as opposed to 450 x 360) my code would know this and swap the demensions. Subcategory image width: 100 Subcategory image height: 80 Calculate image size: true Image required: true
  2. ChrisW123

    Picture Enlargment

    I always used a large image, say 500 x 400, for the large picture and then the website would size that down for when it shows thumbnails. Did you setup the thumbnail settings in Admin setup? I forget which category it is (near the top). Maybe you haven't set that up?
  3. ChrisW123

    PayPal WPP Direct Payments & Express Checkout Support

    Do you have the fix that Dallas posted to remove spaces in the ccard number? You'll get that error without it or if you don't remove the spaces yourself.
  4. ChrisW123

    PayPal WPP Direct Payments & Express Checkout Support

    Did you guys try the fixes above that I and Sticky posted? I had problems with the Express Checkout also until I made the fixes I mentioned above. That fixed it for me.
  5. ChrisW123

    PayPal WPP Direct Payments & Express Checkout Support

    Stickypod, correct my first line was also remmed out (with // in front). Sorry, I didn't mention that. :D Glen, I'm lost now. My register_globals = ON currently. But above you say the line is only needed if it's OFF, but my Express Checkout was not working with it remmed out and with My register_globals = ON. However with it un-remmed, it works. So are you sure about this? Even tho I'm no expert, it seems that the new order (I found from a previous post in this thread) seems correct: tep_session_register('paypal_ec_payer_info'); $_SESSION['paypal_ec_payer_info'] = $paypal_ec_payer_info; It seems that you would need to Set paypal_ec_payer_info first and then use it. Do you agree? Can you (or anyone) confirm if the above order is correct or not? Stickypod seems to say it works. But the other post said reversing them worked. So I'm not sure what is right.
  6. ChrisW123

    PayPal WPP Direct Payments & Express Checkout Support

    I figured it out... A few months ago someone posted this: There was a problem validating your account. Please try again.Several people have posted about this error recently (jlong07, MechBun), but the fix (which seems to have done the trick for me) was posted on March 23 by giz286sim:Around line 516 in the file /catalog/includes/modules/payment/paypal_wpp.php change: $_SESSION['paypal_ec_payer_info'] = $paypal_ec_payer_info; tep_session_register('paypal_ec_payer_info'); TO: tep_session_register('paypal_ec_payer_info'); $_SESSION['paypal_ec_payer_info'] = $paypal_ec_payer_info; That fixed the "There was a problem validating your account. Please try again." error message using Express Checkout. Looks like all is well. All that's left is to install my new live WPP key and test again.
  7. ChrisW123

    PayPal WPP Direct Payments & Express Checkout Support

    I don't think I set it up right... I probably only have a merchant test account. But it did go through like the transaction was sucessfull. Not sure, I'll have to look at my test accounts closer, turn on debug emails, and try it again.
  8. ChrisW123

    PayPal WPP Direct Payments & Express Checkout Support

    Hey Glen, Have you ever heard this: When testing "Express Checkout With PayPal" (sandbox setting) and logged into my paypal dev account, I'm able to apparently "pay" for a test purchase with my dev account but when I returned to my website, I see this message in osC: "There was a problem validating your account. Please try again." Huhhhh? My question is, does "Express Checkout With Paypal" work reliably most of the time and if so, do you think it's a pain for customers use? It seems like a real hassle for customers to have to go there first and hope they don't get "lost" somehow. Seems very "klunky" to me. Any thoughts on this?
  9. ChrisW123

    PayPal WPP Direct Payments & Express Checkout Support

    Thanks Glen, the ccard fix works great! Yes I'm using the sandbox. I'm going to apply for a real Key probably today. Thanks for the great work on this contribution.
  10. ChrisW123

    PayPal WPP Direct Payments & Express Checkout Support

    Holy crap, 68 pages of replies!?? :lol: I have 2 suggestions and 1 question for anyone who wants to reply: Suggestions: 1) When updating from version .5 to version .73, do follow the install instructions and uninstall the module first, and then reinstall after updating the two changed files catalog\checkout_payment.php and includes\modules\payment\paypal_wpp.php! It makes things work. :) 2) CCard numbers with spaces don't work. Update code to add some text to notify the user, like this: Add: define('MODULE_PAYMENT_PAYPAL_DP_TEXT_CREDIT_CARD_NUMBER_INFO', '(<b>No spaces</b>)'); To: catalog/includes/languages/english/modules/payment/paypal_wpp.php Then add: 'field' => tep_draw_input_field('paypalwpp_cc_number', '') . '?<small>' . MODULE_PAYMENT_PAYPAL_DP_TEXT_CREDIT_CARD_NUMBER_INFO . '</small>'), To: catalog/includes/modules/payment/paypal_wpp.php, just below: array('title' => MODULE_PAYMENT_PAYPAL_DP_TEXT_CREDIT_CARD_NUMBER, Question: Why doesn't Paypal complain when the user enters a bogus ccard expiration date or "check number"? It seems that the service isn't checking the credit card information fully. Is this a problem??? Thanks for any feedback... -Chris.
  11. ChrisW123

    Should I Use PayPal Payment Pro?

    Hi everyone, I have PP Payment Pro installed and working in the Sandbox, using a pretty old contribution (I think the first version) of it. Does anyone think I shouldn't use it and instead use something else like Authorize.net, etc? Should I upgrade to the newest contribution version? Thanks!
  12. ChrisW123

    PayPal WPP Direct Payments & Express Checkout Support

    Good news... Initial testing shows everything is working fine! Can't believe it, amazing. Quick check-out works (saves new account info, paypal checkout, back to my site, emails, order logged), on site ccard check works perfectly also. Donation is in the mail, thank you so much for the awesome contribution!!! Well worth the install effort. This is a new installation of the latest contribution version... So given this, is there any specific area I should give more testing to, or any known bugs that I may be missing and need to test for? I haven't made any modifications that might be in this thread yet. Any heads up would be appreciated. -Chris.
  13. ChrisW123

    PayPal WPP Direct Payments & Express Checkout Support

    Thanks for replying... I'm embarrased... I thought that you didn't need to fill in the path in Admin if the default path shown on screen was correct which it was, but after specifying the path in the field everything begain working. So far so good, I just need to figure out how to get PayPal sandbox to send me a confirmation email so I can fully test with the Sandbox. This is a great contribution so far. Thanks to all who made it possible! -Chris.
  14. ChrisW123

    PayPal WPP Direct Payments & Express Checkout Support

    I'm getting an error message during checkout: Warning: paypal_init(Services/PayPal.php): failed to open stream: No such file or directory in /home/wholehea/public_html/includes/modules/payment/paypal_wpp.php on line 273 Fatal error: paypal_init(): Failed opening required 'Services/PayPal.php' (include_path='.:/usr/local/lib/php') in /home/wholehea/public_html/includes/modules/payment/paypal_wpp.php on line 273 The lines in paypal_wpp.php causing the error are: require_once ('Services/PayPal.php'); require_once ('Services/PayPal/Profile/Handler/Array.php'); require_once ('Services/PayPal/Profile/API.php'); I've installed the Pear folder on the server and it does appear to contain folder the code is looking for. The path to the file(s) is: /public_html/pear/Services And in Admin setup for this contrib, the path seems correct: Pear Modules If you installed the included pear modules, where are they stored? Should be: /home/wholehea/public_html/pear/ Leaving this blank will use the server's default include path. Has anyone else seen this problem? -Chris.
  15. ChrisW123

    Merchant Account- Linkpoint

    Ooops you should not have signed up with them. You need to go with a provider that has a contribution or other built in feature in osC to handle the payments from that provider. Just cancel them and look for another provider. I'm looking for one also. Currently I think Authorize.net is the best, but still looking. Good luck.
×