Jump to content

mojohost

Members
  • Content count

    5
  • Joined

  • Last visited

  1. mojohost

    HoneyPot Captcha

    This is going to be a weird one. I think this was caused because I had previously emptied my countries table and manually added back just United States and Canada from within the admin interface. I reverted that change earlier today with a database restore (that was the only change), and now when I tried to create the account it worked without issue. So, for reference, if someone has messed with their list of countries via the database, that might potentially cause the country/state issue regardless of the setting in Honey Pot.
  2. mojohost

    HoneyPot Captcha

    @Jack_mcs Thanks for the reply. I'm using the official 2.3.4.1 (not BS or other community versions). I'll try setting to false and let you know the results. I appreciate the detail about the wording as well. I know it works the same with logins and not telling them specifically which item is incorrect. I wasn't sure if it was due to the issue or by design. I did notice that the instructions reference changing a line that mentions the create_account.php file directly whereas my version uses the variable FILE_CREATE_ACCOUNT instead. Edit: I set Create Account Check to false, and I was able to create an account no problem. I think it should be a flag to the issue that the log is telling me that it's failing the state/country check even though I have state/country check set to false. This implies a problem with the addon at this point rather than my create_account.php file. One, the state and country match and two, I have it set to false so it should be ignoring it regardless of a match or not. Honey Pot shouldn't be failing the state/country match when it's set to false.
  3. mojohost

    HoneyPot Captcha

    I just installed 1.9 (first time), and I'm having a couple of problems. One, if I enable the captcha on create_account, I get this text showing on the form: FORM_REQUIRED_INPUT near the captcha input box. Is this intentional that I would see this next to the input box for the captcha? That's just a visual issue, however, no matter what I do, I cannot get an account to create. I keep receiving the message, The account could not be created. Please contact us for assistance. If I revert the create_account.php changes back to my default I can create accounts no problem. I also tried just now to set HoneyPot as least restrictive as I can to see if it was one of the settings by enabling them one by one, but at the least restrictive settings below I still get the account cannot be created error. Any ideas? I just looked at the HoneyPot_log, and it's telling me this: Denied due to a country - state mismatch.This IP has 15 violations. However, I have the Country/State match set to False, so it shouldn't be checking or denying. Not only that, but I've tried "Oregon" and "United States" along with "OR" and "United States", and I'm still getting the same error in the HoneyPot_log. Additionally, I would expect an error message on why they're being blocked rather than "The account could not be created. Please contact us for assistance". I don't want these to lead people to contact the shop if I can avoid it. Installed Version: osCommerce Online Merchant v2.3.4.1
  4. mojohost

    html content in popup (Large Image)

    That doesn't make any sense to me. Why would you add HTML only? It seems the HTML is so you can create a caption for the image. Also, if you add one with just HTML and no image it removes that image item when you save the product. If you add an image and HTML, as the first poster said, only the HTML appears. The thumbnail appears correctly on the product page, but the color box only has the HTML, which looks horrendous by the way.
  5. This didn't work for me. I tried my existing payment zone, but I also tried adding one with all countries all zones. Shipping information still isn't calculated.
×