Jump to content

blueedge

Members
  • Content count

    155
  • Joined

  • Last visited

Everything posted by blueedge

  1. I apologize in advance because I don't exactly know what add-ons I have. :) After the recent USPS changes, retrieving USPS rates and having them displayed and calculated during the checkout process is not a issue. Everything appears to function properly for that aspect. Thankfully. However, what is an issue after the recent USPS changes is the USPS shipping label function in the admin no longer works. The shipping address information is no longer imported/populated into the USPS site to create a label (https://cns.usps.com/go/Secure/LabelInformationAction!input.action). Sometime back, as a result of a previous USPS change, admin modifications where made to a file called usps_ship_label_fix.php, which is the utility used to import the shipping address info into USPS.com in order to create the label. Has anyone else experienced problems with creating USPS shipping labels as a result of the 1-26 USPS changes?
  2. As of today, with the new USPS changes, has anyone been able to successfully import shipping address information to USPS.com in order to create a shipping label? If so, what changes did you make? Thanks.
  3. I'm not sure what jshroff did. However, as a quick fix that works for me, I added the following around line line 970 (just after the MODULE_SHIPPING_USPS_DMST_SIG_CONF section) in the USPS.php file: $handlingfactor = 1.05; $postage = $postage * $handlingfactor; It adds 5% to the USPS cost. I only ship via Priority Mail and, therefore, do not have to contend with different handling fees for different shipping types. I would be interested to see how others are treating the handling charge.
  4. blueedge

    [Contribution] - USPS Methods

    I tried this from post 12 of http://forums.oscommerce.com/topic/393466-heads-up-july-28-2013-usps-name-change-for-express-mail/ It works in terms of getting USPS rates. However, as other have reported, it does not include the handling charges. Does anyone have a solution for including the handling that are sent in the USPS shipping module in the admin?
  5. blueedge

    USPS Rate V4, Intl Rate V2 (official support thread)

    Same for me. The Domestic Handling Charges are not added in.
  6. blueedge

    USPS Shipping Labels

    The state does not appear in the USPS label form because the form is looking for the two-letter state abbreviation. However, in the case of my site, the full state name is being sent to the USPS label form. To remedy the situation, I modified Wes_SFLL's uspslabelfix.php file as follows: Added: $state_query = tep_db_query("SELECT zone_code FROM " . TABLE_ZONES . " where zone_name = '" . $order->delivery['state'] . "'"); $state_abbreviation = tep_db_fetch_array($state_query); Changed: <input type="hidden" name="form.deliveryState" value= "<?php echo $order->delivery['state'];?>" id="stateTo"> To: <input type="hidden" name="form.deliveryState" value= "<?php echo $state_abbreviation['zone_code'];?>" id="stateTo"> I hope that helps.
  7. blueedge

    USPS Shipping Labels

    Well, I'm making progress. By including <? include('uspslabelfix.php');?>, the label function now works. However, like the poster above, all of the info is imported into the USPS form except for the state.
  8. blueedge

    USPS Shipping Labels

    Unfortunately, I'm not getting the fix to work. I uploaded the uspslabelfix.php file to the admin directory. Instead of editing the admin/orders.php file, I edited the admin/includes/filenames.php file and replaced define('FILENAME_ORDERS_USPS_SHIP', 'usps_ship.php'); with define('FILENAME_ORDERS_USPS_SHIP', 'uspsshiplabelfix.php'); Now when I click on the USPS label button from the orders.php page, a new window appears with a "Ship a USPS Package" button and the order ID in the URL. When I click on the button (and after logging into the USPS.com site), no shipping info (name, address, etc) appears in the label form on USPS.com.
  9. blueedge

    Can't get UPSxml module to work

    It seems that UPS.com is working. However, as a result of the hack, I wonder if the XML rate feed will simply be restored or if the feed will be modified, requiring OSC changes.
  10. blueedge

    [Contribution] oscThumb

    Since installing oscThumb, it seems that images are very slow to load. Does anyone have any suggestions how I can make the images load faster? Could there be some type of setting I overlooked? Also, in the July 20, 2011 update to the contribution, it states: Does the entire contribution need to be updated or just the two files mentioned? Are there changes to other files than the ones listed? Thanks.
  11. I have read the install instructions. However, I'm a little confused. I have unique header tags for each page but I do not have a catalog/includes/header_tags.php file. I do, however, have catalog/includes/meta_tags.php and catalog/includes/classes/seo.class.php file, which includes references to USE_SEO_HEADER_TAGS. Is these comparable to header_tags.php or am I totally off base? In addition, the last update to this contribution is dated 23 Mar 2010. So, for the catalog/includes/functions/html_output.php code, should the code included in the contribution be used or the code displayed in post #111 of this thread be used (because it is more recent)? Thanks.
  12. [This was originally posted in the wrong forum.] I have Authorize.net Credit Card AIM installed as a payment method. When an order is created, the site sends the customer the standard text version email summarizing the order. A second email is also sent to the customer. The second is an html version email that also summarizes the order. It must be trigger somewhere in the Authorize.net payment contribution because the email contains the Authorize.net transaction ID and it only happens with credit card orders. At first, I thought that it was an Authorize.net developer's setting. However, when I switch it over to production with another account, it still produced the html version emails. Although I'm pretty sure that the setting have to be somewhere in OSC, I cannot find setting the the admin payment module for the email. Since I think that it may be confusing for the customer to receive a text and html version of the order acknowledgement, how do I turn off the html order email that is trigger somewhere by Authorized.net? Thanks.
  13. Thanks for the reply, Jack_mcs. I didn't know if there was something else I needed to do to get the desired redirects. The good news is it looks like I have the contribution installed correctly and functioning properly!
  14. Installed on my site is Ultimate SEO URLs v2.2d contribution.( Unfortunately, I do not know the “sub-version”.) It seems to be working fine. However, I’m not exactly sure what types of re-directing this contribution is supposed to handle and what it does not address. First of all, category and product pages correctly appear as: http://www.domain.com/valid-category-name-c-22.html http://www.domain.com/valid-product-name-p-44.html That’s the first hurdle! When the text portion of a category (or product) URL is altered, such as http://www.domain.com/valid-WRONG -category-name-c-22.html, the URL is correctly redirected (“301 Moved Permanently“) back to the valid URL. That’s the second hurdle! However, when the category or product number in a URL is altered to a nonexistent number, such as http://www.domain.com/valid-category-name-c-2999992.html, the page is redirected (“301 Move Permanently “) to http://www.domain.com/-c-2999992.html, a nonexistent page. The page layout is similar to other pages but merely states “Let’s See What We Have Here” in the center. In the situation of a URL being altered to a nonexistent category (or products) number, shouldn’t a 404 response (not a 301) be displayed? Also, when a product that is marker inactive/inaccessible is attempted to be accessed, the address bar still displays the valid URL, the page content is displayed as “Page Not Found” and a 200 http header response code is returned. Is a 200 code correct for a product/page that is no longer available? Should a 404 code be returned? Thanks.
  15. I have Authorize.net Credit Card AIM installed as a payment method. When an order is created, the site sends the customer the standard text version email summarizing the order. A second email is also sent to the customer. The second is an html version email that also summarizes the order. It must be trigger somewhere in the Authorize.net payment contribution because the email contains the Authorize.net transaction ID and it only happens with credit card orders. At first, I thought that it was an Authorize.net developer's setting. However, when I switch it over to production with another account, it still produced the html version emails. Although I'm pretty sure that the setting have to be somewhere in OSC, I cannot find setting the the admin payment module for the email. Since I think that it may be confusing for the customer to receive a text and html version of the order acknowledgement, how do I turn off the html order email that is trigger somewhere by Authorized.net? Thanks.
  16. blueedge

    [Contribution] oscThumb

    I have installed the oscThumb contribution. It works pretty well. However, I have a couple of quirks with the text watermark feature. I have been trying to hunt down solutions but, so far, no luck. Hopefully, someone can point me in the right direction. Quirk #1: “Text Watermark Position” is set to “Top.” However, the text watermark actually appears in the lower right. When trying to change the position in the admin, I get the following error when clicking on the edit button: Fatal error: Call to undefined function tep_cfg_pull_down_watermark_alignment() in /home/mysite/public_html/admin/configuration.php(125) : eval()'d code on line 1 Quirk #2: I have changed the product_info.tpl.php to now use PRODUCT_INFO_IMAGE_WIDTH and PRODUCT_INFO_IMAGE_HEIGHT. So, the size of the image that appears on the individual product page is now controlled by the “Product Information Image” settings in configuration/image. However, the appearance of a text watermark on the image that appears on the individual product page is controlled by the “Text Watermark in Pop-up Images,” and not by “Text Watermark in Product Information Thumbnails.” The image that appears on the individual product page seems to also use the settings for pop-up images and not the control settings for product information images. How do I get the text watermark to appear on the pop-up image but not the image that appears on the individual product page? Similarly, how do I get a frame to appear around the pop-up image without also appearing around the image that is on the individual product page? (“Text Watermark in Small Thumbnails” seems to work fine, It does control the appearance of the text watermark on the product images on the category/subcategory listings.) Quirk #3: When I click to edit the “Text Watermark Font Name” setting, I get the following error: Fatal error: Call to undefined function tep_cfg_pull_down_installed_fonts() in /home/mysite/public_html/admin/configuration.php(125) : eval()'d code on line 1 Quirk #4: Changing the “Text Watermark Size” setting has no impact on the size of the text watermark.
  17. I have an old version of OSC that uses Ultimate Images Pack for product images. I like that the Ultimate Images Pack allows for three different images - a small product image on the category page, a slightly larger product image on the product page and an even larger image for the "click to enlarge" pop-up. I am now trying to put together a new store using v2.2 RC2a. I have been reading all of the image contributions but I'm at a loss as to which image contribution or contributions to use. Any advise, suggestions or recommendations would be appreciated.
  18. blueedge

    Which Image Contribution(s) To Use?

    Thanks, spooks! Just one more question (for now). I promise. :D Should I use BTS, STS or simply the stock version? Does it matter? (I read a thread that attempted to solicit the merits of BTS vs STS. However, it really didn't seem like any conclusions were reached.) In your opinion, which do you believe is the best way to go? Any advise would be appreciated. Thanks.
  19. blueedge

    Which Image Contribution(s) To Use?

    spooks, thanks once again for your reply and for your patience. I think I do understand (?) about osCThumb, in that I only need to have one full-size image, as oppose to three images of different sizes with Ultimate Images Pack. osCThumb will allow me to specify various smaller-sized images. What I'm confused about, and was trying to ask, was . . . is it possible to use Simple Multi Image Add-on (Un-Limited) with Fancy Popups for image pop-ups in multiple locations of the product page or do I have to group all product images in one location of the product page? Basically, can I have a product page layout like the following: [medium-sized image with Simple Multi Image Add-on (Un-Limited) with Fancy Popups] for pop-up] Then, display text about the product. [multiple small-sized images with Simple Multi Image Add-on (Un-Limited) with Fancy Popups] for pop-ups] Thanks for your help.
  20. blueedge

    Which Image Contribution(s) To Use?

    Thanks for your reply, spooks! I had been reading your entries in both forum threads for those two contributions. I very much appreciated your supplying a link in your forum post to a real example of of what Simple Multi Image Add-on (Un-Limited) with Fancy Popups looks like so it can been seen is action. (So few contributions have real examples so you can see how they look/perform BEFORE you install them.) The Simple Multi Image Add-on (Un-Limited) with Fancy Popups makes pop-up images very professional. I failed to mention that with my old version of OSC, I also had additional product images that were displayed on the product page. So, with the Ultimate Images Pack, I had a small product image (120x100) that was displayed on the category page. Then, there was a medium-sized product image (250x200) displayed on the product page, when clicked would pop up to reveal a large image (600x600). In addition to those images, I also had additional images displayed on the product page that would would display different features for the product. The additional images would be located in a different section of the page than the medium-sized image mentioned above. The addition images were 120x100 but would pop up and enlarge to 600x600 when clicked. So, my question is, with Simple Multi Image Add-on (Un-Limited) with Fancy Popups, can I have a medium-sized product image (roughly 250x200) appear in one section of the product page and smaller images (120x100 which would pop up to 600x600) displaying other product features in another section of the product page? Or, do all of the images that appear on the product page have to be grouped/displayed in the same section? I would like to have one medium-sized image (roughly 250x200) on the product page to catch the customer's eye, and have available alternative product images displaying other features. However, I don't want the alternative images as large as the "main" product image because that would take up too much room. Is there a way to do that? Yes, I had been reading about the woes of osCthumb and file encryption. That's why I was unsure about using it. But, as you suggested, I guess I could use it but not use the encryption feature.
  21. blueedge

    UPS Price Discrepancies?

    I have UPS shipping set up for my store. In the admin, I have the following settings for the UPS module: UPS Pickup Method - RDP (Daily Pickup) UPS Packaging - CP (Your Packaging) UPS Residential Delivery - RES (Residential) In addition, I have added a handling fee to cover the cost of the box. The problem I have been encountering is that sometimes the shipping fee charged by the store's shopping cart doesn't reconcile to what I'm charged by UPS. I can't seem to figure out what causes the problem. (The packages involved are rather small. So, the problem does not involve dimenisional weight.) An example occured this morning. A customer brought two items. The two items plus tare weight totaled 6 pounds generating a $9.46 shipping fee (including the handling fee). However, the actual shipping weight was only 5 pounds but the UPS charge to me was $10.23. How can the charge to the customer for a heavier package, which also includes a handling fee, be less than what UPS charges me if all of the other variables are the same? Other times, the shopping cart shipping fee works fine and I can reconcile the charges. However, as in the case above, I don't understand how the shopping cart is coming up with a fee that it so much less (especially since I charge a handling fee in addition to the UPS charge). What causes the discrepancy? Has anyone else experienced this problem?
  22. Has anyone else recently experienced a problem with accessing UPS rate info? Today, I notice that a slow response in retrieving UPS rate info is causing my shopping cart page to take an incredibly long time to load. (USPS and UPS rates are displayed on the shopping cart page.) Last week, when USPS was having problems, my site was timing out trying to access USPS rates. Today, when the shopping cart was once again taking so long to load, I initially thought that the problem was with USPS. However, I have played around with enabling and disabling UPS and USPS shipping and have determined that the problem is with accessing UPS, not USPS, rates. I’m not sure what version or even which shipping contribution I have. In looking in includes/modules/shipping/ups.php, it looks like I use a “get” function to access ups.com//using/services/rave/qcostcgi.cgi (if that make any sense). Is anyone else having trouble with access UPS rate info? Thanks.
  23. This is not really a shipping module problem but more of a business process question involving a shipping dilemma. For those store owners that use more than one method of shipping, I would like to solicit your opinion. Here goes . . . I ship orders using one of two methods. I use either USPS Priority Mail or UPS Ground. Typically, for those orders weighing under 3 pounds, it is cheaper to ship USPS Priority Mail and takes 2 to 3 days. UPS Ground is cheaper for heavier orders and takes 2 to 5 days. I currently allow the customer to choose which method he/she wants. However, I'm having second thoughts about this. I'm wondering if offering the customer a choice in shipping methods creates more of a problem than it is worth. Initially, I thought that the customer would appreciate the freedom to select the shipping method. However, now after seeing customers selecting USPS Priority when UPS Ground would be much cheaper and also seeing customers selecting UPS Ground when USPS Priority would be cheaper AND faster, I'm wondering if the customer really understands and is making a conscious selection. I wonder if the whole “choice thing” is confusing for the customer. Also, in some cases, offering a choice can be expense for me. The customer is charged solely on weight. However, if dimensional weight applies, USPS is incredibly expensive. In addition, I have some products that can only be shipped via UPS because they are shipped by the vendor. I state "UPS shipping only" on those pages. Yet some customers still select USPS. Now for your opinion . . . those who have more than one shipping method, do you allow the customer a choice? Or, do you streamline the process, thereby, removing any confusion and simply post "your shipping will be $X?" Thanks for your thoughts!
  24. blueedge

    USPS rate increase may 12 2008

    tmeister, are you sure that First Class rates are not available? I recall in the dcumentation the USPS emailed that they were making some changes. Could it be that the data is no longer compatiable with the Rate request API being used by OSC? (I don't use First Class, nor do I know what the heck I'm talking about when it comes to API.) From the USPS: IntlRate: Besides the price differences, the former First Class Mail International (FCMI) with Service ID=”3” is replaced with up to three nodes: FCMI Letter ID=”13”, FCMI Flat ID=”14”, and FCMI Parcel ID=”15”. In addition, currency values are returned in a two-decimal-place fixed format (was inconsistent before). Additionally, there are a few subtle differences in First Class Mail International nodes returned for IntlRate: • Hyphen in name. Was “First-Class” but now will be “First Class” as shown. • MaxWeight in pounds. Previously, all nodes returned <MaxWeight/> in pounds except for First Class Mail which was in ounces. Now, they are all in pounds including FCMI. • We already mentioned that the The currency values will be formatted to two decimal places. • There are various changes to the text within <MaxDimensions/> and <SvcDescription/> as appropriate for the new shapes.
  25. blueedge

    USPS rate increase may 12 2008

    No problems. Just remember that the Rate Request API used by OSC reports the Retail, not Commercial, rates. I would assume that the new Rate Request API (RateV3) includes both Retail and Commercial rates.
×