Jump to content

xmanflash

Members
  • Content count

    36
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Pete N
  1. Just wanted to say thanks for all you are doing for osc 2.3.1 Jim, your work is excellent, and hopefully worth it to you in the end, it certainly has helped me greatly with my osc 2.3.1 stuff!

  2. xmanflash

    [Contribution] Products Specifications

    Thanks Jim - Much appreciated..
  3. xmanflash

    [Contribution] Products Specifications

    fyi.. the tabs_css.css file is not in the latest 2.3.1 distribution.. However even adding the CSS (from the Beta) did not make it work.. Cheers, Pete
  4. xmanflash

    [Contribution] Products Specifications

    Yep - that fixed em! Is there a live site with the tabs working in /product_info.php somewhere? - Mine are not working - the 4 tab headers show up but not in tabs. I suspect CSS/div layout issues but need something working to compare it with! Thanks, Pete
  5. xmanflash

    Multi_Vendor_Shipping new thread

    Ok Thanks Jim, I'll have a closer look at it..
  6. xmanflash

    Multi_Vendor_Shipping new thread

    Can anyone who has added this to a customised osc v2.3.1 tell me how long it took? I am pretty proficient with adding modules and adapting code, but this MVS module would replace some home brew code that currently works, but is not quite so functional.. Is there a 2.3.1 version install in the works Jim? Thanks!
  7. xmanflash

    [Contribution] Products Specifications

    btw: I have part 1 of the admin stuff working now.. - I needed to remove the 'product_column_id' setting from the Specification.. I also have it displaying in the front end now - somehow forgot to save the WinMerge changes.. So just the cosmetic stuff left :) Cheers, Pete
  8. xmanflash

    [Contribution] Products Specifications

    Hi Jim, Excellent work as always.. I just installed into osc 2.3.1 and came across a few cosmetic issues.. 1. Deprecated: Function ereg_replace() is deprecated in \admin\products_specifications.php on line 1408 2. The "New Specification" Button on this page is currently labelled "New Product" 3. admin/products_specifications.php?sgpath=1&spath=1&fid=1&action=edit_filter shows "IMAGE_SORT" on the Image sort button (missing the ENGLISH definition) My Products Admin Issues: I set up two Specifications Groups and applied them to my test category and added Specifications and Options correctly 1. I can see all the tabs but don't get any Options listed under the Specifications Tab 2. Any other entered data in tabs is not saved.. I checked the code and believe I have everything in the "categories.php" file correctly.. Any pointers? Thanks!, Pete
  9. xmanflash

    Seperate Pricing Per Customer v3.5

    Excellent work on the 2.3.1 SPPC code JohnAtYM - thanks - saved me quite a bit of time!.. It all seems to work fine for me as well.. Cheers, Pete
  10. xmanflash

    [Addon} Modular SEO Header Tags

    Hi Jim, just a FYI - I installed CKEDITOR as my preferred wysiwyg editor in 2.3.1 and it automatically formats the content exactly the way shown above - in other words, some of us are not adding it - its the editor.. For the sake of ease of use it might be worth stripping out the tabs in a future update.. (just for descriptions and articles etc) Cheers Pete
  11. xmanflash

    [Addon} Modular SEO Header Tags

    Hi Jim, I had the same issue - once I removed your (3 bits of ?) code from /admin/categories.php I was able to add products again.. I am still busy working on my 2.3.1 templating system so didn't get to debugging.. I also found a 2.3.1 core bug which deletes product information when a product edit times out !! grr.. Cya! pete
  12. xmanflash

    ULTIMATE Seo Urls 5 - by FWR Media

    I Would also like to know this, before I try to add the 2.2 version to my spanky new 2.3.1 install! :)
  13. xmanflash

    Header Tags SEO

    Hi Jack, The patch I needed to apply to your code to get it working for me is as follows.. /admin/header_tags_seo.php v 3.0.8 Line 679 FROM: <td align="center"><?php echo (tep_image_submit('button_update.gif', IMAGE_UPDATE) ) . ' <a href="' . tep_href_link(FILENAME_HEADER_TAGS_SEO, '') .'">' . '</a>'; ?></td> TO: <td align="center"><?php echo (tep_image_submit('button_update.gif', IMAGE_UPDATE[b],' name="x"'[/b]) ) . ' <a href="' . tep_href_link(FILENAME_HEADER_TAGS_SEO, '') .'">' . '</a>'; ?></td> ..and what purpose does the empty href serve? I actually don't understand how anyone using this code can actually select a page, and update their Title or Description or Keywords, or Logo Text, or Include settings without this fix as it all depends on the 'x' parameter being present..!?? Cheers Pete
  14. xmanflash

    Header Tags SEO

    I may have worked it out - will be back!
  15. xmanflash

    Header Tags SEO

    Hi Jack, Thanks for that - I understand now that the that the $_POST(['x']) isolates the Update function in the form processor.. However I cannot find any form variables in this file with a name of 'x' that I might be missing in my code (I just copied your code in their so dont see why the 'x' is not triggering database saves... On what line of code in is this variable provided - I can only see that it is possible to use the Update Button without javascript tricks, and this uses a tep_image_button() function, that appears to have no 'name' input variable..? Cheers Pete
×