Jump to content

Tranbo

Members
  • Content count

    49
  • Joined

  • Last visited

Everything posted by Tranbo

  1. Tranbo

    [Contribution]Paypal IPN - Devosc

    I override the order.php with the stock order.php for testing and the attribute option come back. One thing I notice the option order listed is in revesered. The last option is listed on top in the account history info. I will try to run optimized the database see if it work. Thanks for the info.
  2. Tranbo

    [Contribution]Paypal IPN - Devosc

    When in doubt tested with the stock osC but the reality is no production site using the stock osC. Yes I had serveral mod installed just don't know which one is the culprit :) .
  3. Tranbo

    [Contribution]Paypal IPN - Devosc

    Quote from my other post: I am trying to isolate this problem and hopefully some one can point me to the right direction. Problem: --All the product options show in the shopping cart properly --After gone through the check out process and arrived to the checkout confirmation page the option attribute is gone all I have is - : - : - : - : - : - : - : - : The Question: What happen to the date in the shopping cart during the checkout process and what files supplied the data to the confirmation page? Thanks for all your input. And also quote from other thread: Link to other thread regarding the error -: After further investigating I confirm that 2.6a ipn caused the problem "-:" witht the product attribute...I uninstalled the contribution and it work fine. Thanks for the info Greg, Are We going to see any update code soon?
  4. I've checked there are ton of question about this and I am clueless to get this thing to work. will some one kindly break it down how to get this senario implement. Thanks Millions for all that responsed. Shipping option: 1. Local delivery 2. UPS Shipping Choice: 2 day air and 3 day Select. 3. Free UPS ground shipping for all orders. Mod that I had used: Local delivery, UPS Choice, Free Shipping. How do I set it up for the above senario?
  5. Thanks for the replied, I hacked the local delivery mod and changed the text to the free shipping it work like a champ. Thanks
  6. Tranbo

    [Contribution]Paypal IPN - Devosc

    After checkout from paypal users were redirect back to the checkout-success page and being given the option off print out the ther order details. when user click on the print they received this error in the popup windows suppose to show them the invoice of their order. Warning: htmlspecialchars() expects parameter 1 to be string, array given in /var/www/html/includes/functions/general.php on line 42 Warning: htmlspecialchars() expects parameter 1 to be string, array given in /var/www/html/includes/functions/general.php on line 42 now here is the content of general.php file line 42: return htmlspecialchars($string); If user click print in their account history everything will be just fine. They can see their order invoice with all the details. This error only show when user comeback from paypal checkout and click on print. I am using the latest 2.6a ipn contribution. Any idea to fix this? Thanks all.
  7. Tranbo

    PayPal Module for Dummies

    Can Some One please explain the process of getting the site to used the PayPal IPN and made this a sticky? to help other newbies. here is what i did so far 1. Sign up for the Bussiness Account with Pay-Pal. 2. Installed the PayPal IPN mod 3. Configured the Paypal in the admin with the Paypal Login Email address. 4. Create account with the sandbox? for testing? or 5. Using the testing build in to the IPN mod? How do you used the test build in? Is there a step by step guide and idot proof? for this process some where? Thanks.
  8. Tranbo

    [Contribution]Paypal IPN - Devosc

    I have no clue how to fix this. The code in this section is below <tr> <?php //begin PayPal_Shopping_Cart_IPN if (strtolower($order->info['payment_method']) == 'paypal') { include(DIR_FS_CATALOG_MODULES . 'payment/paypal/admin/orders.inc.php'); } else { ?> <td><table border="0" cellspacing="0" cellpadding="2"> <tr> <td class="main"><b><?php echo ENTRY_PAYMENT_METHOD; ?></b></td> <td class="main"><?php echo $order->info['payment_method']; ?></td> </tr> <?php }//else not paypal //end PayPal_Shopping_Cart_IPN <?php if (tep_not_null($order->info['cc_type']) || tep_not_null($order->info['cc_owner']) || tep_not_null($order->info['cc_number'])) { ?> Line 222 is the last 4 lines begin with <?php Thanks all for helping.
  9. Tranbo

    Wolfen Featured Sets SUPPORT

    Yes that would be great. Thank-You
  10. Tranbo

    Wolfen Featured Sets SUPPORT

    add the missing bracket got new error the 355 line look like this
  11. Tranbo

    Wolfen Featured Sets SUPPORT

    The 266 line is the last line, if (isset($HTTP_POST_VARS['products_image']) && tep_not_null($HTTP_POST_VARS['products_image']) && ($HTTP_POST_VARS['products_image'] != 'none')) { right after the Feature Set 1.0 code. I will have to try do it again. Thanks for all your hard work on the code & fine contribution.
  12. Tranbo

    Wolfen Featured Sets SUPPORT

    Thanks for the great contribution. I have not able to integrate it to the site due to many mods :D :D :D . So I start from scatch Current config: Stock osC install and Wolfens Feature Set 1.0 Two Stop error in the Admin page: When click on contents under Catalog link I get here is the code in that section $products_date_available = (date('Y-m-d') < $products_date_available) ? $products_date_available : 'null'; //Begin Wolfen Feature Set 1.0 $sql_data_array = array('products_quantity' => tep_db_prepare_input($HTTP_POST_VARS['products_quantity']), 'products_model' => tep_db_prepare_input($HTTP_POST_VARS['products_model']), 'products_price' => tep_db_prepare_input($HTTP_POST_VARS['products_price']), 'products_date_available' => $products_date_available, 'products_weight' => tep_db_prepare_input($HTTP_POST_VARS['products_weight']), 'products_featured' => tep_db_prepare_input($HTTP_POST_VARS['products_featured']) //End Wolfen Feature Set 1.0 if (isset($HTTP_POST_VARS['products_image']) && tep_not_null($HTTP_POST_VARS['products_image']) && ($HTTP_POST_VARS['products_image'] != 'none')) { Other Error is when click on the Manufacturers link in the catalog on the admin page The code on that section: <tr> <!--Begin Wolfens Feature Set 1.0 !--> <td valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="2"> <tr class="dataTableHeadingRow"> <td class="dataTableHeadingContent"><?php echo TABLE_HEADING_MANUFACTURERS; ?></td> <td class="dataTableHeadingContent" align="center"><?php echo TABLE_HEADING_MANUFACTURERS_FEATURED; ?></td> <td class="dataTableHeadingContent" align="center"><?php echo TABLE_HEADING_MANUFACTURER_FEATURED; ?></td> <td class="dataTableHeadingContent" align="right"><?php echo TABLE_HEADING_ACTION; ?> </td> </tr> <?php $manufacturers_query_raw = "select manufacturers_id, manufacturers_name, manufacturers_image, date_added, last_modified, manufacturers_featured, manufacturers_featured_until, manufacturer_featured, manufacturer_featured_until from " . TABLE_MANUFACTURERS . " order by manufacturers_name"; $manufacturers_split = new splitPageResults($HTTP_GET_VARS['page'], MAX_DISPLAY_SEARCH_RESULTS, $manufacturers_query_raw, $manufacturers_query_numrows); <!--End Wolfens Feature Set 1.0 !--> $manufacturers_query = tep_db_query($manufacturers_query_raw);
  13. Tranbo

    RMA Returns error for 2.2 MS2

    I would like to give it a try, how do I get the files?.
  14. Tranbo

    Thumbnail Generator Problem

    oops! I encounter the script error and it went to loops creating thumbnails images none stop :D :D :D here is the error on the client machine Warning: copy(/var/www/html/images/subcategory_1394cards_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thum b_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_t humb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thum b.jpg_backup.jpg): failed to open stream: File name too long in /var/www/html/admin/thumbs.php on line 10 Warning: getimagesize(/var/www/html/images/subcategory_1394cards_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thum b_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_t humb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thumb_thum b.jpg_backup.jpg): failed to open stream: File name too long in /var/www/html/admin/thumbs.php on line 11 I have about thousand of those heheheh Cheer!
  15. Spaceboy, Thank-you so much for posting the code. I merged yours to mine and it is almost perfect like the way I wanted. I had consitance look in all the log in pages like the orignal osC. As I said it is almost perfect, I still can not change the input boxes to span the entire page right now it is just taking 60% of the page and leave me with the big gap between the input box and the right columm. Also do you know how to change the color of the * from black to red?. I have serverel block with black and the rest of the * is red :-). Thanks for all the help.
  16. Tranbo

    Thumbnail Generator Problem

    Have any one able to get this to work? Please share of you do. Thanks
  17. Tranbo

    [Contribution] Dynamic MoPics

    Does any one successfullly get this thing to use the jpg or other graphic format beside the gif? I can get the gif files display but not others. my configuration in the admin Big Images Directory images_big/ Thumbnail Images Directory thumbs/ Main Thumbnail In Thumb Directory false Number of Pics per Row 5 Mo Pics Extension _pic Main Big Pic Extension _big Mo Pics Thumbnail Image Type gif Mo Pics Big Image Type jpg and the picture is in the right format and naming convention. I can only get the picture to show when the "Mo Pics Big Image Type jpg" is set to gif and yet i have both set in gif and jpg format. Thanks for all your input
  18. Bug with this mod. If you are using the IE browser everything will work fine. If you are using mozilla on linux machine--that what i have. When you select the item on the the drop down list you will get the undefine in the price box. If you have the picture enable click on Enlarge will show the url with the undefine is not found. ---this kick rear for the last couple days!!!. couldn't figured out what the H I did Wrong Doh!
  19. So you get to work?. How do you add product to the drop down list?. I think I think I got it install properly but couldn't see anything in the drop down list. But on the other hand you see it twice. One must be mine? :-). Thanks
  20. Tranbo

    Attribute Sets Contribution

    Does anyone know if this contribution work with "Product Attributes - Option Type Feature" ? Product Attributes - Option Type Feature
  21. Spaceboy, If you don't mind can you post your code for the Order_info_check.php here?. Thanks.
  22. Where do you change the PWA form sign-up background and boxes to made it consistance with the stock OSCMS2.2 created account form?. Any idea?
  23. I have the same error too. I wonder if any one able to get it to work on stock installation. As for me I have several mod installed must be a conflict some where. It is a nice mod and it would be nicer if We can get it to work. Thanks
  24. Quick question for you all. I can see the store logo in the popup print windows in the invoice and packing slips from the admin pannel. When I log in as user the logo doesn't show on the print product details popup windows. How do I enable logo?
  25. Tranbo

    [Contribution] Dynamic MoPics

    Ok I got it to work!. Great contribution thanks. Below is my installation amendded to the orginal installation instruction. I hope it help some one. ==================================== Installation: for Stock ocsms2.2 installation ==================================== Step 1: open catalog includes/filenames.php and add the following line in the appropriate section: define('FILENAME_DYNAMIC_MOPICS', 'dynamic_mopics.php'); ==================================== Step 2: open catalog includes/languages/english/product_info.php and add the line: define('TEXT_NO_MOPICS', 'coming soon!'); repeat this step for each product_info.php language file (spanish/product_info.php, etc.) ==================================== Step 3: open catalog product_info.php Place this where you would like the MoPics to show up: <tr> <td> <?php include(DIR_WS_MODULES . FILENAME_DYNAMIC_MOPICS); ?> </td> </tr> If you want to put it below the product description and above the "This product was added.." put it around line 187 below the: <td class="main"><?php echo sprintf(TEXT_MORE_INFORMATION, tep_href_link(FILENAME_REDIRECT, 'action=url&goto=' . urlencode($product_info['products_url']), 'NONSSL', true, false)); ?></td> </tr> <tr> <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td> </tr> ==================================== Step 4: copy catalog popup_image.php and includes/modules/dynamic_mopics.php to their appropirate locations. Set the permision 755 --Edit popup_image.php on line 61. add // or comment line 61 to remove the image path links to your picture in the popup windows. // echo DIR_FS_CATALOG . $image_path . $image_base . $image_addon . $image_ext . '<br>'; ==================================== Step 5: Import dynamic_mopics.sql into the database ==================================== Step 6: If Updating from a version earlier than v2.1, delete the Dynamic MoPic configuration variables from catalog/includes/configure.php ==================================== Installation is now complete. Naming scheme configuration is defined in "Admin -> Configure -> Dynamic MoPics" Note: If you see error relate to permission made sure you set the read permission. Mine is set to 755 and it work.
×