Latest News: (loading..)

maritc

Members
  • Content count

    31
  • Joined

  • Last visited

1 Follower

About maritc

Profile Information

  • Real Name
    Marit
  • Location
    Norway
  • Website
  1. I have the same problem. I'm missing the public_flag and downloads_flag from my orders_status table. I've been having problems for the last week, when my host changed some server settings. I uploaded the new files but ran my backup, and obviously this is something new with the program. Can someone post a sql query similar to the one I have, but with the 2 new fields? I'm guessing that should fix the problem, if we insert the 2 missing fields? I could try myself, but I'm not that comfortable with sql queries yet. TIA! :)
  2. I installed this add-on about a year ago, and it works great with % discounts. I've been trying to get it to work with a fixed amount, but it's way off. I know it says in the manual that it can be off with a few cents or whatever, but this is way off. I'm making a giftcertificate worth 250 NOK and have set the fixed amount to 250, the min order and max order amounts to 250. So there should be a 250 NOK discount on the order. But when I test this out (and I have created several coupons that all show the same), only a discount of 180 NOK is displayed and subtracted at the checkout. That's 70 NOK off and that's about $15 difference (not just a few cents). What's causing this? This is what I have my coupon module set as: Display Discount Coupon true Sort Order 1 Display Discount with Minus (-) Sign true Display Subtotal with Applied Discount true Random Code Length 6 Display Discount Total Lines for Each Tax Group? false Use the language file to format display string? true Display Format for Order Total Line Discount Coupon applied Any ideas? I've been subtracting GCs manualle up until now, and just been using the codes for % discounts in newsletters etc, but I would really love to get the fixed amount to work. I have no other order total modules installed, if that's any help.
  3. PM sent! Thanks!! :D
  4. I downloaded the 3.5 pack again and this time it's working! I only have one slight problem, and that is when I try to e-mail my wishlist to someone, I get the error message that I have to write in at least one name and e-mail. Any ideas on this one?? After going back and forth and back and forth between 2.4 and 3.5 over the last 4 days, I'm so happy to have made it this far LOL
  5. I have the wishlist working properly now, so if I could only get the e-mails sent right, too, I'll call this a wrap! I'm sure 3.5 has a lot more features than 2.4, but this will do for now LOL The e-mails are being sent out, but instead of listing each item as a link, it's just listing them like this (if it was fruit I'm selling) AppleBananaKiwi etc I've tried to edit the code myself, but without luck so far. I'm pretty sure I'm looking in the right area, though... It has to be somewhere in this query, am I correct? This is the original code from wishlist_email.php <? $wishliststring = FORM_FIELD_TEXT_AREA; $wishlist_query_raw = "select tab2.products_id, tab1.products_name from " . TABLE_WISHLIST . " as tab2, " . TABLE_PRODUCTS_DESCRIPTION . " as tab1 where tab2.customers_id='" . (int)$customer_id . "' and tab1.products_id = tab2.products_id and tab1.language_id = '" . (int)$languages_id . "' order by products_name"; $wishlist_query = tep_db_query($wishlist_query_raw); while ($resultarray=mysql_fetch_row($wishlist_query)) { $wishliststring .=""."<li><a href=\"".HTTP_SERVER . DIR_WS_CATALOG ."product_info.php?products_id=".$resultarray[0] ."\">".$resultarray[1] ."</a></li>".""; } ?> If anyone who knows more about php code than I do could point me in the right direction, I'd be most grateful! :)
  6. Thanks for the tips! I did install 3.5 3 more times, just to see if I had made some syntax error during the install, but the same thing happened every time. The wishlist.php just comes up blank. This is the only page on my entire site that comes up blank, so that's why I was wondering about the register_globals issue. But I'll try the other things, too.
  7. After having problems with Wishlist 3.5 (newest version - just got a blank page every time I tried to go to the wishlist), I installed Wishlist 2.4b instead. I can now view the wishlist, but I have 2 problems: 1. The items added to the wishlist are not being displayed, but it says they're there. I looked in the database, and they do get added into customers_wishlist, but as product_id 0. customers_id is correct, but there is nothing for products_model and products_name, and the 3 last fields say 0.00 and 0. How can I get the right info added? When I edit one of the fields and just write in a product_id, it's displayed in the wishlist. 2. When e-mailing the wishlist, the URLs aren't displayed, as they should be as far as I can tell from wishlist_email.php. Only the product titles are displayed in the e-mail. Any advice? My knowledge of php code is still a bit limited, and I would really like to get this up and running. TIA! :)
  8. Hello, I just installed Wishlist 3.5 and unfortunately I just get a blank page when I click on Add to wishlist or My wishlist in the top menu (that's where I added the link). If I click Back after I add the product to my wishlist, I do get the message that the product has been added to my wishlist. Also, I've been using the column controller, so I have no Right colum in my store (so I need to see the wishlist.php to see the products in the wishlist). I know a blank page can mean something as tiny as a "punctuation error" (can't think of the proper name right now LOL), but my store is now running on a server where register globals is off, so I just wanted to check if this could be what's causing it before I start going through everything again. Any ideas?? TIA! This mod seems perfect for me, so I'm anxious to get it to work! :)
  9. Paypal has now added Norwegian krone (NOK) to it's currency selection, and as I'm in Norway I would like my customers to be able to pay with NOK. I've been using EUR up until today for Paypal payments. How can I add the NOK to the check-out process? Can I add it to this piece of code in includes/modules/payment/paypal.php? QUOTE (!in_array($my_currency, array('CAD', 'EUR', 'GBP', 'JPY', 'USD'))) or is it somewhere else I need to add it? TIA! :)
  10. Sorry... I think I posted this in the wrong thread :blush:
  11. Paypal has now added Norwegian krone (NOK) to it's currency selection, and as I'm in Norway I would like my customers to be able to pay with NOK. I've been using EUR up until today. How can I add the NOK to the check-out process? Can I add it to this piece of code in includes/modules/payment/paypal.php? or is it somewhere else I need to add it? TIA! :)