Jump to content

aspiringarts

Members
  • Content count

    144
  • Joined

  • Last visited

  1. aspiringarts

    Links Manager II

    I will look into doing that when/if I get the time. In the meantime, do you know why my installations fails to successfully read the links? As in, at admin interface, links.php, clicking on a link brings up correct info in the sidebar (except Link Located), but when I press Check Link, I get Link Check Result: Error Reading URL? This despite it showing that it is able to locate the site? Thanks, Susan
  2. aspiringarts

    Links Manager II

    Okay... why? I have a large and complex site structure running an old, heavily-edited version of OSC (1.1). If I update that piece, it may be like adding a new part onto an old car - the old structure won't handle it, and I'll end up spending countless hours updating something I hardly use anymore. I updated your contrib only because it never worked right, but people were clicking on the links, so I thought I might try to update and maybe monetize it a bit. I've already spent waaaaay more time than I could afford on it. All I want to do is to make the SEO work the way it did on the old version. Is it that complicated? Has the code changed that much?
  3. aspiringarts

    Links Manager II

    Thanks to both of you. Yes, the database updates reset that links display option. Thank you for pointing it out. Now it's working fine. As far as the SEO rewriter, I have Chemo's SEO URLs installed. They work great everywhere else in the site and did work great on your old links contrib. Here is the .htaccess code, or at least some of it: Options +FollowSymLinks RewriteEngine On RewriteBase / RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING} RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING} The Title field isn't populating correctly (web page title). I'm wondering why. Thanks again.
  4. aspiringarts

    Links Manager II

    Timed out on editing my reply - here is my actual response: How are they displaying fine on the links pages? Can *you* click the links? I can't! Again, the names show up, but the links are *not* clickable. To clarify again: links.php is displaying the categories correctly, and the links are clickable. But once you click on the individual categories, the tables show up with names, but without clickable links. The code has to be in the links.php file, right? I see nowhere else it can be. Also, a more minor point - your code broke my SEO. :-( Thanks for any help.
  5. aspiringarts

    Links Manager II

    How are they displaying fine?? Can *you* click the links? I can't! Again, the names show up, but the links are *not* clickable. Thanks for any help.
  6. aspiringarts

    Links Manager II

    I need more help now, unfortunately. I've updated the code in all the files to match the most current version, and the database fields look correct too. Most things are working, including things that never worked before, like submitting new links. But the links are not showing up as links in the tables (see http://www.aspiring-arts.com/links.php). Well, they are on the Links page, but not in the categories tables. I thought I'd go back and try to do the step-by-step changes to see if I missed anything. I've done everything, but the links are still not showing. Any suggestions of where to look or code to post here? Thanks, Susan
  7. aspiringarts

    Links Manager II

    Yes, I just misread the line as being part of the same field, not a separate field. Little brain glitch. I'm now fighting with the files because my site is heavily customized, so the default contrib files look *really bad*. But without some of the newer code, the link names/tables show up but aren't clickable. This will require more digging than I can finish tonight. Thanks for your help.
  8. aspiringarts

    Links Manager II

    Okay, I've gone through all the database changes, and all of the admin pages except one now work. The one that doesn't work is Link Categories. The page displays: select c.link_categories_id, cd.link_categories_name, c.parent_id from link_categories c left join link_categories_description cd on c.link_categories_id = cd.link_categories_id where cd.language_id = '1' and c.parent_id = '0' order by c.link_categories_sort_order, cd.link_categories_name [TEP STOP] On a likely related note, the catalog also does not display correctly, though it's better. The current message is: 1054 - Unknown column 'lc.parent_id' in 'field list' select lc.link_categories_id, lcd.link_categories_name, lcd.link_categories_description, lc.link_categories_image, lc.parent_id from link_categories lc left join link_categories_description lcd on lc.link_categories_id = lcd.link_categories_id where lc.link_categories_status = '1' and lc.parent_id = '0' and lcd.language_id = '1' order by lc.link_categories_sort_order, lcd.link_categories_name I'm guessing that this is because I had trouble updating the table as indicated in the setup file. This is the command: link_categories_id int NOT NULL auto_increment, parent_id INT(11) NOT NULL DEFAULT '0' I'm not sure where to put "parent_id INT(11)". Any suggestions?
  9. aspiringarts

    Links Manager II

    Having looked through the archives of this thread and at my database, I'm guessing that the problem may be due to missing database tables. Since links_setup won't run due to the previous install, how do I add the new tables and modify the old ones? Do I have to go in and tinker with mysqladmin? It's been a long time... thanks for suggestions.
  10. aspiringarts

    Links Manager II

    I tried applying the fix listed in the end of the readme/install instructions. Now I get this error in the admin interface: 1054 - Unknown column 'l.links_reciprocal_disable' in 'field list' select l.links_id, l.links_url, l.links_image_url, l.links_date_added, l.links_last_modified, l.links_status, l.links_clicked, ld.links_title, ld.links_description, l.links_contact_name, l.links_contact_email, l.links_reciprocal_url, l.links_reciprocal_disable, l.links_status from links l left join links_description ld on l.links_id = ld.links_id where ld.links_title like '%%' or l.links_url like '%%' order by ld.links_title limit 0, 20 Suggestions? Thanks!
  11. aspiringarts

    Links Manager II

    Okay, well that destroyed my website pretty well. On the admin interface for Links Manager, now I get "Fatal error: Call to undefined function tep_hide_session_id() in [my server]/admin/links.php on line 759". And on the page on my website, I get "1054 - Unknown column 'lf.links_all_pages' in 'where clause' select l.links_id, l.links_url, l.links_image_url, ld.links_title, ld.links_description from links l left join links_description ld on l.links_id = ld.links_id left join links_featured lf on l.links_id = lf.links_id where l.links_status = 2 and lf.links_all_pages = '1' and (ld.language_id = '1' or ld.language_id = 99) and lf.expires_date >= now() order by RAND() [TEP STOP]" I uploaded all the new files (replacing a bunch of old ones) and ran the database update file - should be fine, right? But no go. My website is http://aspiring-arts.com , if you want to have a look. Links are under Resources - or would be, if you could see them. :-) Thanks for any help. Susan
  12. aspiringarts

    Links Manager II

    Sorry about the duplicate post.
  13. aspiringarts

    Links Manager II

    I'm trying to update an old site from Links Manager (original) to II and can't find documentation on how to do this. The Setup file aborts. The original install never worked properly anyway; new links submitted wouldn't show, and the link checker returned errors. But I'd like to keep the links in the database that I have. Should I go step by step in the Update_Docs changes? Again, trying to go from original to II. Thanks. Susan
  14. aspiringarts

    [CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

    Hey, I just did the same thing myself! :-) Now if only I could fix all the other problems, LOL...
  15. aspiringarts

    [CONTRIBUTION] Ultimate SEO URLs v2.1 - by Chemo

    It looks fine... you do know you have the osc id showing up the whole time, don't you? Check the thread on how to fix that... I forget offhand. Susan
×