Jump to content

Rwe

Members
  • Content count

    105
  • Joined

  • Last visited

Everything posted by Rwe

  1. Rwe

    Ultimate Seo Urls 5 Pro

    I fixed it with this: RewriteRule ^write.php$ ext/modules/content/reviews/write.php [NC,L,R] Placed just above the USU5 rewrite rules in .htaccess Or is there a better way? Thanks Reinder
  2. Rwe

    Ultimate Seo Urls 5 Pro

    Okay i understand. I think this same issue will also affect write_pwa.php? ( addon purchase without account) . I cannot test this at the moment as the review link is in the order confirmation e-mail.
  3. Rwe

    Ultimate Seo Urls 5 Pro

    Does the url need to be rewriten? Once logged in and then clicking the link it just works with in the adress bar http://www.myshop.com/ext/modules/content/reviews/write.php?products_id=3 It is like something goes wrong with processing the href_link over the login page?
  4. Rwe

    Ultimate Seo Urls 5 Pro

    USU5. just noticed a problem with the write review URL's. when not logged in to my shop and trying to write a review , then after login the link to write a review should be : www.myshop.com/ext/modules/content/reviews/write.php in fact it redirects after login or after create a new account to : www.myshop.com/write.php (this returns a 404) when already logged in there is not a problem with the url. I suspect it has something to do with : "set php_self in the local scope" in application_top.php because when i set the old code back it works as it should. but my knowledge is limited on this.. anyone have some ideas how to fix this ? thanks Reinder
  5. @René H4 Rene did you install the D3 donator code already? This one is fixing large product listing images if i am right
  6. No only for the main h1 tags, sorry i thought you where looking for this.
  7. It will make them smaller, i thought you wanted that.
  8. Try : .display-4{font-size:200%!important}
  9. https://validator.w3.org/ Validate the page by URL or the pages that the validator cannot access ( checkout and account) you can use validate by direct input: source to textfield
  10. On the checkout and 'my account' pages there are also a few validating errors.
  11. index.php?cPath=1 Duplicate attribute class. line 103 <select name="filter_id" onchange="this.form.submit()" class="form-control input-sm" class="form-control">
  12. product_reviews.php?products_id=4 validating errors: <img src="images/apple-1.jpg" alt="Apples" title="Apples" width="100" height="80" class="img-fluid" hspace="5" vspace="5" /> The hspace attribute on the img element is obsolete
  13. product_info.php with product options : label gives a validating error. (for="input1") <label for="input1" class="col-form-label col-sm-3 text-left text-sm-right"> (The value of the for attribute of the label element must be the ID of a non-hidden form control.)
  14. Hello @raiwa installed the Related_Products_234_BS_6.6. google structured data test gives all related products as separated products and not related to any product w3c validatation gives the following errors: Error: The itemprop attribute was specified, but the element is not a property of any item. ( isRelatedTo, url, name, offers, pricecurrency, price) i have installed the HT product_schema.php wich works correctly for the main product. is there something missing in the HT product_schema.php, some code for related products? i am Using Frozen v2.3.4.1 CE
  15. Maybe u can take a look in the server error log to see if there is an indication of the problem
  16. Rwe

    Email queuing system

    Please can u also explain why? Just curious to know. Best regards.
  17. @raiwa How can this addon be placed above the header navbar? thanks in advance
  18. @raiwa Thanks for your explaination, I made it by moving the files to the modules/content/navigation folder and make the nescessary changes in the files.( _HEADER_ to _NAVBAR etc. ) i did not change template_top.
  19. I noticed that the header navbar has changed too. More options for background and screensize Categoriebox can set level of subcategories to show, inside the code, nice. A few of my addon modules need to be updated for bs4 Needs some work but until now not difficult to do. its fast and adapts better to smaller screensizes ig tablet size. Thanks @burt
  20. Rwe

    Fake accounts

    These seem to be forum spammers, they sign up and later they will try to spam their sh*t on your forms using the signup details. if i look in my error.log i can see that they also try to visit contact_us.php and www.forum.mysite.nl even if it does not exist. i block them by honeypot system, its working .
  21. Rwe

    Fake accounts

    The registration is commonly made by robots who look at the right form fields. firstname, lastname , email etcetera. I had this problem too the last weeks of fake accounts exactly as mentiont earlyer. I did the following to trick them; 1 in create_account.php duplicate the firstname input field (just plain html input field can too)and place it before the original firstname field and add a class to the div and and hide it (css display:none ! not use a style="") 2 rename the original firstname field with a newname ( name ="newfirstname") + change : $firstname = tep_db_prepare_input($_POST[newfirstname']); 3 make a rule to give an error when the formfield fistname is being filled up by the robot and place it in the top somewhere between the other fom check codes: if(!empty($_POST['firstname'])) { $error = true; } Finished. i can see in the server logs that the robot has been trying but could not make an account. for now this is working for me. i hope i could help with this .
  22. Rwe

    SQL injection?

    Just a normal url on my live site , nothing that you often look at 😜
  23. Rwe

    SQL injection?

    This week i started to notice this in my error logs: Fri Aug 24 17:27:50.185002 2018] [proxy_fcgi:error] [pid 87397:tid 139653059434240] [client xxx] Premature end of script headers: index.php [Fri Aug 24 17:27:50.192088 2018] [proxy_fcgi:error] [pid 87397:tid 139653059434240] [client xxx ] AH01070: Error parsing script headers above 30 times the same in a row access.log: xxx-c-211.html?osCsid=prvpp15vi15v0vrkm88rele6qc&view=all%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%5C%27A%3D0 HTTP/1.0" 301 1010 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-PT; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)" This is only one entry from maybe hundred after eachoter, all with the "view=all" parameter in it and they get longer by each line. i blocked already several ip's but they keep comming, what are they trying ...anyone ?
  24. Nevermind, i fixed it by replacing the files with ones from my previous installation.
  25. installed ultimate seo urls for BS , i thought it was working as expected but checking the cache function it seems this is not working on each of the 4 cache options ( mysql, file, sqlite, memcache). Setting it on sqlite or memcache gives internal server error these might not be supported. No data is stored. The folder permissions for file/ sqlite are 755 ( checked 777 too with same results). i made a debug test: Standard URI produced: 24 SEO URI produced: 114 Query Count: 112 Queries Saved: 2 Cache load time: 0.0001 seconds ( includes gzinflate/base64_decode/unserialize ) Data loaded from cache: false ( Cache System: File_Cache_Module ) Total query time: 0.0042 seconds Cache system is On --------------------------------------- Anyone has an idea? Thanks in advance.
×