Jump to content

jjanguda

Members
  • Content count

    139
  • Joined

  • Last visited

Posts posted by jjanguda


  1. this time i tried a different amount of order.

     

    what I see in my admin page is this.

     

    Transaction Activity 
          Date              Status          Details   Action      Gross      Fee      Net Amount  
    
    Sep. 17, 2004          Completed        Details               $164.03    $0.00      $164.03  

     

    In the test ipn panel, I input $164.03 for gross and $0.00 for mc fee.

    (In a live store, mc fee will be automatically calculated by paypal according to their rate plan?)

     

    PayPal Response 
    ------------------------------------------------------ 
    INVALID 
    
    ------------------------------------------------------ 
    Connection Type 
    ------------------------------------------------------ 
    curl: 1 transport: domain: www.paypal.com port: 
    
    ------------------------------------------------------ 
    Email and Business ID config 
    ------------------------------------------------------ 
    Store Configuration Settings 
    Primary PayPal Email Address: sales@xxx.com 
    Business ID: sales@xxx.com 
    ------------------------------------------------------ 
    PayPal Configuration Settings 
    Primary PayPal Email Address: sales@xxx.com 
    Business ID: sales@xxx.com 
    
    ------------------------------------------------------ 
    IPN INSERTED 
    ------------------------------------------------------ 
    IPN 3 has been inserted

     

     

    now it's ok?

     

     

    At the same time, in the admin page, the order has been changed from

    pending to processing. In a live store, in this case, can I actually ship a product

    to my customer?

     

    Furthermore, in a live store, when a customer didn't pay full amount, "accpet" button under the auction column will be displayed?

     

     

    Thanks for your continous help!!


  2. wow.. thanks for your quick response..

     

    I didn't notice that my cart test failed..

     

    I changed my product price to $0.01 and its shipping cost was also $0.01.

     

    So the total gross is $0.02. Then what mc value will be?

     

    Even though my cart test failed, the status of the order has been changed to

     

    "On Hold" mode and shows me the "Accept" button. Is tihs the way it works?

     

    I think I put $0.01 for mc gross and $0.01 for mc fee.

     

    it should be $0.02 and $0.01?


  3. oh.. thanks I just tired to test IPN and it seems working now... this is the reseult i got.

     

    Test Complete 
    
    ------------------------------------------------------ 
    PayPal_Shopping_Cart_IPN Debug Email Notification 
    ------------------------------------------------------ 
    business=sales@xxx.com 
    receiver_email=sales@xxx.com 
    verify_sign=PAYPAL_SHOPPING_CART_IPN-TEST_TRANSACTION-00000000000000 
    payment_date=04:02:58 Sep 17, 2004 PDT 
    digestKey=9649d3edc68b63f177143a965fade074 
    first_name=jjang 
    last_name=guda
    payer_business_name= 
    payer_email=jjanguda@xxx.com 
    payer_id=PAYERID000000 
    payer_status=verified 
    invoice= 
    address_name=jjanguda
    address_street=xxxxxxxxxxxxxxxxxx
    address_city=New York
    address_state=New York 
    address_zip=11111
    address_country=United States 
    address_status=confirmed 
    payment_type=instant 
    txn_type=cart 
    custom=193030d3874bcdf86e901443ad5637d6 
    txn_id=193030d3874bcdf86 
    parent_txn_id= 
    num_cart_items=1 
    notify_version=1.6 
    memo=PAYPAL_SHOPPING_CART_IPN TEST 
    mc_currency=USD 
    mc_gross=0.01 
    mc_fee=0.01 
    settle_amount=0.00 
    settle_currency= 
    exchange_rate=0.00 
    payment_status=Completed 
    pending_reason= 
    reason_code= 
    submit=Test IPN 
    
    
    ------------------------------------------------------ 
    PayPal Response 
    ------------------------------------------------------ 
    INVALID 
    
    ------------------------------------------------------ 
    Connection Type 
    ------------------------------------------------------ 
    curl: 1 transport: domain: www.paypal.com port: 
    
    ------------------------------------------------------ 
    Email and Business ID config 
    ------------------------------------------------------ 
    Store Configuration Settings 
    Primary PayPal Email Address: sales@xxx.com 
    Business ID: sales@xxx.com 
    ------------------------------------------------------ 
    PayPal Configuration Settings 
    Primary PayPal Email Address: sales@xxx.com 
    Business ID: sales@xxx.com 
    
    ------------------------------------------------------ 
    IPN INSERTED 
    ------------------------------------------------------ 
    IPN 2 has been inserted 
    
    ------------------------------------------------------ 
    Cart Test 
    ------------------------------------------------------ 
    Invalid Cart Test 
    Store (converted) order total: 0.02 USD 
    PayPal MC Total: 0.01 USD ?

     

     

    how do you think?

     

     

    There are a few things that I want to make sure for settings..

    When my store goes live, things I have to change compared with

    presettings above are...

     

    1. Set Test Mode off.

     

    How about digest key? Can I just leave it as PayPal_Shopping_Cart_IPN instead of using signature ID like 193030d3874bcdf86e901443ad5637d6?

     

     

    Besides, is there another setting that I have change when i go live?

     

    BTW, these signature ID is just for a testing?

    When i set test mode off, ipn will be automatically generated?

     

    Once again..

     

    Thanks for the great contribution.

     

     

     

    jjanguda


  4. first of all, thanks for the great contribution.

     

    I'm afraid of saying that I have difficulties to test IPN panel.. this is how I did..

     

    After installed the latest version of the contribution, I did checkout via the store using a created user(by myself). After clicked "Confirm" button, the page was automatically transferred to https://www.paypal.com/cgi-bin/webscr

     

    As you said, I stopped and logged into OSC-Admin and found the order I just created. On this page, I didn't see any signature ID. It said

     

    a.gif

     

     

    Above the PayPal logo, there is only information like

    Customer's address, telephone number, email address, shipping, and billing address. That's it.

     

     

    My PayPal settings are here..

     

    Enable PayPal Module
    True
    
    E-Mail Address
    email@mydomain.com
    
    Business ID
    email@mydomain.com
    
    Transaction Currency
    Only USD
    
    Payment Zone
    --none--
    
    Set Pending Notification Status
    Pending
    
    Set Order Status
    Processing
    
    Set On Hold Order Status
    On Hold
    
    Set Canceled Order Status
    Canceled
    
    Synchronize Invoice
    False
    
    Sort order of display.
    0
    
    Background Color
    White
    
    Processing logo
    oscommerce.gif
    
    Store logo
    
    
    PayPal Page Style Name
    default
    
    Include a note with payment
    No
    
    Shopping Cart Method
    Aggregate
    
    Enable PayPal Shipping Address
    No
    
    Digest Key
    PayPal_Shopping_Cart_IPN    (for Digest Key, I don't know what to put so I leave it as default like PayPal_Shiping_Car_IPN)
    
    Test Mode
    On
    
    Cart Test
    On
    
    Debug Email Notifications
    Yes
    
    Debug Email Notification Address
    email@mydomain.com
    
    PayPal Domain
    www.paypal.com
    
    Return URL behavior
    1

     

     

    I don't think I have an installation problem.. but my setting might go wrong... way..

    But, one thing for sure is Primary Email and Business ID are configured correctly.

     

     

    I'll appreciate for any help.

     

    Thank.

     

    jjanguda


  5. Hi,

     

    I've installed Date of Birth mod by Alparslan Ozturk,

    http://www.oscommerce.com/community/contributions,154

     

    But I'm getting this error:

     

    Fatal error: [] operator not supported for strings in c:\appserv\www\loja\create_account.php on line 459

     

     

     

     

    This line is:

                $dob_day[] = array('id' => sprintf('%02d', $i), 'text' => sprintf('%02d', $i));

     

     

     

     

    This is part of the Date of birth mod, it defines the pull down to show days.

     

    Now the interesting is: the first time I access the file it loads the creat account form with no problems. IF there are no errors in the form, it gets processed and the client gets the email. But if there is an error on the form, when it reloads the page for the client to correct things the form stops and the Date of birth placement with the error I've mentioned.

     

     

    I'm a complete noob with php. Until now I've found that I think this is related to the state option; it is set to true in Admin, and there are 3 zones defined that define shipping options, if the user when registering writes a state not recognized it will open the same page but with a pull down for him to select the possible states. I'm not shure, but I think these too arrays may be coliding?

     

    do you know why?

     

    please help.

     

    Thanks.

     

     

     

    jjanguda


  6. hi, thanks for the great contribution.

     

    I just installed it, but want to change something...

     

    In my create_account.php page, for a country option,

     

    I eliminate all other countries except United States.

     

    So, instead of showing "Select" in the country select option box,

     

    it is already selected to "United States". Once I changed it back

     

    to "Select" option, the page is refresh and on the top of the page shows

     

    me an error message like this.

     

     Please select your Gender. 
    Your First Name must contain a minimum of 2 characters. 
    Your Last Name must contain a minimum of 2 characters. 
    Your E-Mail Address must contain a minimum of 6 characters. 
    Your Street Address must contain a minimum of 5 characters. 
    Your zip code must contain a minimum of 4 characters. 
    Your City must contain a minimum of 3 characters. 
    You must select a country from the Countries pull down menu. 
    Your State must contain a minimum of 2 characters. 
    Your Telephone Number must contain a minimum of 3 characters. 
    Your Password must contain a minimum of 5 characters.

     

    If I add all these info, then it's ok.. however,

     

    why is the page refreshed by itself?

     

    I don't want it to be refreshed...

     

    is there way I can stop refreshing the page?

     

     

    thank you for your help.

     

     

    jjanguda


  7. wow.. what a powerful and useful search function is it!!!

     

    I just installed the same contribution and have the same error..

     

    But, in my case, my default country setting is United States and this is

     

    the only option for the country.. By miskate, I clicked that box and put it as

     

    "Select" As soon as I changed it, it showed me the same error message..

     

    What's wrong with this? Any idea will be helpful.

     

     

     

    jjanguda


  8. nrlatsha,

     

    I guess that you've answered my questions partially..

     

    I found other places where I want retail price to be shown...

     

    You will see what I mean by looking at the thread on the top of this page.(I attached a picture. =pink layout=)

     

    As you can see, this page just shows me product name, final price, and a buy now button.

     

    I don't know which file I have to take a look at in order to change some..

     

    What I'd like to do with this is ..

     

    Product name

    Product Manufactuer

    Retail Price

    Your Price

    Your Save

    Buy Now button

     

     

    So, it'll probably look like this.

     

    Die Hard With A Vengeance

    Manufactuer: WD

    Retail Price: $100

    Your Price: $40.00

    You Save: $60 (60%)

    Buy Now

     

     

    Just like the one in main page(what's new product for July box)

     

    Please need your help here..


  9. View All Product is one of the contributions I've installed.. and its address is this.

    http://www.oscommerce.com/community/contributions,1785

     

     

    As I've already explained above, because of all_product.php I can't list all my products in catalog/products_new.php

     

    Basically the number of catalog/products_new.php and catalog/all_products.php are the same and from the admin page ->config -> MAX values

     

    Search Results works with all_products.php and New Products Listing works with products_new.php.

     

    Right now I've set them up to 16 so that they have the equal split number.

     

    If I set 16 for search results and 12 for New Products Listing, then the split page number will be up to 2 for all products and 2 for New Products Listing as well..

    But for New Products Listing, it should be up to 3 because the total item number is 31. (make sense to you?)

     

     

    But, if you can split products_new.php into two columns(default is one), then it may take care of this...

     

     

    Right now I have one default column and 16 rows for New Products Listing which makes my products_new.php a lot longer from the top..(doesn't look good!!)

     

    Another thing that I've noticed from this is...

     

    If you use Fancy split page results one time(either in all product or product_new), then it works fine.

     

     

     

    When you take a look at the code, if possible, can you think of splitting default products_new.php column(1 column) into two columns?

     

    Since I have more than 400 items, it's kinda annoying to show 10 or 16 products in one page... Furthermore, this products_new.php doesn't contain many info... only price, manufactuerer, added date, and buy now button.. that's it..

    It wastes lots of spaces where I might put more products...

     

    and I didn't modify catalog/products_new.php.. it's the way it is... OSC v.2.2

    except the code for split_page_results.. I only modified that part..

     

     

     

    BTW thanks for all your support and kindness!!


  10. I just installed Review in products display.. it works fine..

     

     

    The problem is if the lengh of the written review text goes over 60 aphabets,

    it extends the default box width which doesn't look good.

     

    The orginal code source from catalog/product_reviews_info.php

    <?php echo tep_break_string(nl2br(tep_output_string_protected($review['reviews_text'])), 60, '-<br>')

     

    But, the code writer used htmlspecialchars($reviews_values['reviews_text'],)

    <?php echo sprintf(tep_image(DIR_WS_IMAGES . 'stars_' . $reviews_values['reviews_rating'] . '.gif', sprintf(BOX_REVIEWS_TEXT_OF_5_STARS, $reviews_values['reviews_rating']))) . ' – <i>' . $reviews_values['customers_name'] . ', ' . $date_added . '</i><br>' . htmlspecialchars($reviews_values['reviews_text']) ?>

     

    Macromedia Dreamweaver MX2004 says that the way of using html specialchars is used like this.

    htmlspecialchars(string string, [int quote_style], [string charset])

     

     

    Can anyone help me on this matter?

    I'd like to limit the number of text to 60 aphabets.

     

    I'll appreciate for any help.


  11. thanks for your help..

     

    i guess I modified products_listing.php but i don't know where I've edited...

     

    I'll see this weekend when you're able...

     

    BTW, can you take a look at the Facy split_page_results thread.. I posted a question for you...

     

     

    Thanks again!!


  12. nrlatsha,

    I just noticed that you released EZ Fields 5.0 and installed it successfully..

    Thank you so much for all your work..

     

    I guess the problem that Minuteago mentioned above has been solved by modifying catalog/includes/modules/new_products.php.

     

    But, I found other places where I want retail price to be shown...

     

    You will see what I mean by looking at the picture below.

     

    temp.jpg

     

    As you can see, this page just shows me product name, final price, and a buy now button.

     

    I don't know which file I have to take a look at in order to change some..

     

    What I'd like to do with this is this..

     

     

    Product name

    Product Manufactuer

    Retail Price

    Your Price

    Your Save

    Buy Now button

     

     

    So, it'll probably look like this.

     

    Die Hard With A Vengeance

    Manufactuer: WD

    Retail Price: $100

    Your Price: $40.00

    You Save: $60 (60%)

    Buy Now

     

     

     

     

     

    Another problem I have is displaying a product model number in catalog/specials.php.

     

    What I did was this..

     

     

    I added p.products_model in $specials_query_raw (like this)

    $specials_query_raw = "select p.products_id, pd.products_name, p.products_price, p.products_retail_price,  p.products_tax_class_id, p.products_image, p.products_model, s.specials_new_products_price from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . "

     

     

    and added .'Model Number: ' . $products_new['products_model'].

    <td align="center" width="33%" class="smallText"><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . 
    $specials['products_id']) . '">' . tep_image(DIR_WS_IMAGES . $specials['products_image'], $specials['products_name'], SMALL_IMAGE_WIDTH, 
    SMALL_IMAGE_HEIGHT) . '</a><br><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $specials['products_id']) . '">' . 
    $specials['products_name'] . '</a><br>'. 'Model Number: ' . $products_new['products_model'] .'<s>' . $retail . '<br>Wholeslae Price: ' .$currencies->display_price($specials['products_price'], 
    tep_get_tax_rate($specials['products_tax_class_id'])) . '</s><br><strong><span class="productSpecialPrice">Special Price: ' . 
    $currencies->display_price($specials['specials_new_products_price'], tep_get_tax_rate($specials['products_tax_class_id'])) . '<br>'.'<br></strong></span></td>'

     

     

    What I see in catalog/specials.php is

    The Matrix

    Model Number:

    Retail Price: $39.99

    Wholeslae Price: $30.00

    Special Price: $29.00

     

     

    What happened to the model number?

    It only shows me a text part(model number), but no model number.. hmmm..

     

     

    I haven't much to say about this contribution, but Awesome :lol: :lol:


  13. When you go to yoursite/index.php?cPath=numbers,

     

    you can only see product name, model number, price, and buy now button.

     

    How can I add retail price betwwen model number and price..?

     

    Except that page, all have retail, our price shown.

     

     

    great contribution ..no matter how many time I think of it...

     

    Amazied~!!!


  14. I guess I found the reason why it doesn't work well..

     

    I installed "View All Products" and it displays 20 items on each page.

     

    As the number of page increases in all product page, the number of page in the product new page goes up. (The page number just follows up the all product page.)

     

    The problem is this.

     

    The number of item shown in the product new page is 10 and 20 for all products(I don't know how to edit this number though..)

     

    Since their scales are different, I don't know how to handle this..

     

    I guess the easiest way to solve this error is to change 20 to 10 or

     

    make 2 columns in the product new pages so that each column can have 10 items each(which makes the total 20.) I think it's better...

     

    Well.. I don't know whether I can ask such an unrelated question....

     

    But, it should be looking a lot better...

     

    How do you think?

     

    If you don't mind, can you take a look at product_new.php code so that

    all new products are displayed in 2 columns (I think the default setting for this is

    10 products in one column per a page)


  15. While I tried to modify the product_info.php, I found some difficulties.

     

    I want All 'retail price', 'our price', and 'save x%' to be located in the middle of the product_info.php. (Not right next to the product picture)

     

    I want these 3 lines to located inside the box which I made underneath the product picture.

     

    If I copy and paste the code you provided, it won't work...

    I think I need add/delete some tags such as </td>, </tr>, or </table>

     

    Can you tell me an easy instruction which explains how to move those 3 lines wherever I want.. ?

×