Jump to content

Longsword

Members
  • Content count

    41
  • Joined

  • Last visited

Profile Information

  1. Hi I have got the same problem and it seem to by a database error: The cration of database: CREATE TABLE user_tracking ( customer_id int(11) default NULL, click_id int(11) default NULL, full_name varchar(64) NOT NULL default '', session_id varchar(128) NOT NULL default '', ip_address varchar(15) NOT NULL default '', time_entry varchar(14) NOT NULL default '', time_last_click varchar(14) NOT NULL default '', last_page_url varchar(64) NOT NULL default '', page_desc varchar(64) NOT NULL default '' ) TYPE=MyISAM; does not make the column 'referer_url' that is required from the file "/admin/user_tracking.php" app. line 152: $whos_online_query = tep_db_query("select customer_id, full_name, ip_address, time_entry, time_last_click, last_page_url, page_desc, referer_url," . " session_id from " . TABLE_USER_TRACKING . " where time_entry > " . ($time_frame - 86400) . " and time_entry < " . $time_frame . " order by time_last_click desc"); Solution: Simply add a column to the end of the table named "referer_url", Datatype: "varchar(255)". If you are lazy ;-) you can simply use the following sql-replace of your current table: DROP TABLE IF EXISTS `user_tracking`; CREATE TABLE `user_tracking` ( `customer_id` int(11) default NULL, `click_id` int(11) default NULL, `full_name` varchar(64) NOT NULL default '', `session_id` varchar(128) NOT NULL default '', `ip_address` varchar(15) NOT NULL default '', `time_entry` varchar(14) NOT NULL default '', `time_last_click` varchar(14) NOT NULL default '', `last_page_url` varchar(255) NOT NULL default '', `page_desc` varchar(64) NOT NULL default '', `referer_url` varchar(255) NOT NULL default '' ) TYPE=MyISAM; -please backup your data first. This version delete all present data. Good luck: -Jes Hjemmealarmer
  2. First a big thx to the author of the WYSIWYG editor. I looks perfect. However I've got strange malfunction when I want to insert a new product: When a product is edited I can make a preview. When I the want to press INSERT or BACK nothing happens. The only thing I'm aloud to is cancel the product. Does someone know the problem and a work around for it? Best regards Jes
  3. Getting tired of having a "customer" making false accounts I made this little modification so I was able to see the IP address of the accounts created and modified. It gives a field in the Admin/customers menu so you are able to see the IP address directly. Have fun :-) Jes
  4. Hi. How do I modify or get the feature that make the free shipping in shipping module become "bypassed" if COD are chosen? Or do I need another contribution? Anyone? Jes -----------------
  5. Hej All Finaly I got my (advance) Guest Book and it works :-) I only have to major problems some of you properly know the answer to: 1) When your want to post a message, the big comment/tex field is still blue. I have tried to se if there should be wrong bgcolor setup but its complete like the other fields. 2) When I preview a messesage and want to go back again to continue writing, the message dissapear!!! Not good :? My shop is here: Homealarms Best regards, Jes :-)
  6. Longsword

    [Contribution] Family Products v 1.0

    TEP ERRORS on products page when follow a link from an ad directly to a product. Contributions: Ad_tracker v.2.0 by Adam Safran together with Family Products V1.1 by Chris Sullivan If you have both contributions installed you?ll properly ran into this problem if you follow a specified link from an ad link like: ?http://www.path_to_your_product?ad=your_ad? If you get this error message from OSC(ver2.2.M1) ----------------- 1064 - You have an error in your SQL syntax near '?ad=google.dkSkur' at line 1 select products_family from products where products_id = 76?ad=google.dkSkur [TEP STOP] ----------------------------------------------------------- fix this problem by a change in /catalog/product_info.php AND in /catalog/includes/modules/family_products.php. Alter the lines $currentid = $HTTP_GET_VARS['products_id']; to $currentid = (int)$HTTP_GET_VARS['products_id']; (Both is related to Family Products) Voila... then you can use Ad_tracker without problems :-) Jes Saxe
  7. Hi girls and guys I've have installed the contribution product_description_1.2 on my shop (OSC2.2_M1) but get some "minor" problems: :? 1) the class defination doesn't work. 2) The teaser (the product_description) is shown the wrong place. I should like it to be a table line under the standard listing of each product. I've tried several solutions, mixed some code from another contrib (Description in Product Listing Hack v.2) but that gives only mess. The file that need to be changed is catalog/includes/modules/product_listning.php around line 130: case 'PRODUCT_LIST_IMAGE': $lc_align = 'center'; if (isset($HTTP_GET_VARS['manufacturers_id'])) { $lc_text = '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'manufacturers_id=' . $HTTP_GET_VARS['manufacturers_id'] . '&products_id=' . $listing['products_id']) . '">' . tep_image(DIR_WS_IMAGES . $listing['products_image'], $listing['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '</a>'; } else { $lc_text = ' <a href="' . tep_href_link(FILENAME_PRODUCT_INFO, ($cPath ? 'cPath=' . $cPath . '&' : '') . 'products_id=' . $listing['products_id']) . '">' . tep_image(DIR_WS_IMAGES . $listing['products_image'], $listing['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '</a> '; } //----BOF--- prod_desc added 20 maj 03 by jss if (PRODUCT_LIST_DESCRIPTION && $listing['products_description'] && PRODUCT_LIST_DESCRIPTION_MAX_LENGTH) $lc_text .= '<br> <table border="0" cellpadding="0" cellspacing="0" width="100%"> <tr> <td class="productDesc">' . tep_flatten_product_description($listing['products_description'], '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'manufacturers_id=' . $HTTP_GET_VARS['manufacturers_id'] . '&products_id=' . $listing['products_id']) . '">' . TEXT_MORE . '</a>') . ' </td> </tr> </table>'; //--------EOF break; case 'PRODUCT_LIST_BUY_NOW': $lc_align = 'center'; $lc_text = '<a href="' . tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action')) . 'action=buy_now&products_id=' . $listing['products_id']) . '">' . tep_image_button('button_buy_now.gif', TEXT_BUY . $listing['products_name'] . TEXT_NOW) . '</a> '; break; } $list_box_contents[$cur_row][] = array('align' => $lc_align, 'params' => 'class="productListing-data"', 'text' => $lc_text); } } Here is the contribution http://www.oscommerce.com/community/contributions,1210 -and here is an exeample from my tiny shop: http://www.tyvstop.dk/shop/default.php?cPa...=27&language=en Anyone with the bright :idea:? Best regards, Jes
  8. This is exactly what I need for my OSC :) This should indeed be a part of the next OSC release. Unf. I'm not a PHP nerd so all I can do in this case is some simple copy/paste :? Hope someone have the knowlegde and time to fix such a tiny little mod ;-) Regards, Jes
  9. Longsword

    Newsletter module v02

    Hi Kenny I'd the same problem as yours: The solution is to do as the following: 1) Delete the file: "catalog/includes/classes/snoopy1.class.php" 2) mark out line 3 in the file "catalog/newsletters_subscribe.php" It should look like this: //include "includes/classes/snoopy1.class.php"; Good luck :-) /Jes
  10. Longsword

    Header Tags Controller Admin outdate

    Solved now. Instead of replacing the code as described in the "header tag admin contol" files i found the small pieces and inserted them bit by bit. :-) /longsword
  11. Longsword

    Header Tags Controller Admin outdate

    thx, I'll try again :-)
  12. Hi I've installed Linda McGrath Header Tags Controller ver. 2.0 on my OSC MS1 and it seems to work great :) I've installed the Header Tags Controller Admin v0.01 by Richard Fielder but there seems to be some trouble with the compability to MS1. :?:Does someone have an admin update?? Best regards Jes
  13. Longsword

    FAQDesk version 1.0 --- Released

    Hi Carsten. Just installed your news desk I'm very surprised over the functionality. OSC is now the only CMS that handle news in multiple languages for real. (yep, Nuke's doesn't). Apart from som minor problems with the SQL file (problems with inserting data) everything seems to work fine :) If you one day are about to make som modifications to the news system, a possiblity to set an end date on the news (and start and end on the categories as well) should be welcome. :wink: Thx for letting us useing it:-) /longsword
  14. Longsword

    [Contribution] FAQ system v.1.0

    Hi What FAQ are you using? I have installed the zz_FAQ_SYSTEM_VER1.0 but I can only make it work in the admin module. To me it looks like there are no boxes for the catalog part. Regards Jes
  15. Hi Ole og Kim (Written in Danish now... *B*) Jeg ogs? p? vejt til at blive bruger af OSC. Kunne vi lave et lille dansk forum med vores specielle problemstillinger p? dette? Mvh Jes
×