Latest News: (loading..)

annekmadison

Members
  • Content count

    82
  • Joined

  • Last visited

About annekmadison

Profile Information

  • Real Name
    Anne K Madison
  1. Goodness. I didn't, and I wish I had, as it would have saved me quite a bit of work and head-scratching. I signed up for updates to the forum, and I always try to hunt before I ask, but the topic updates arrive in clumps all at the same time, and by the time they do, I've forged ahead. I've been fooling around with it on and off for months, but it wasn't until today that I saw the typo in the currency class. Just my little contribution to lowering the signal-to-noise ratio. :) Oh, well. It was a good exercise for me to work on. Right? Right! Thanks, Anne
  2. OK, so I'm answering this myself. It's easy to set up a variable in sts_user_code.php to display an abbreviated version of the user's shopping cart wherever on your page you may want one. You can base it on the "OSC Tip and Trick" found here: http://oscommerce.info/kb/osCommerce/Gener...s_and_Tricks/56 with one HUGE exception. There's an error in that code. This line: if ($cart->count_contents() > 0) { echo '<br>Total: ' . $osC_Currencies->format($cart->show_total()); needs to read: if ($cart->count_contents() > 0) { echo '<br>Total: ' . $currencies->format($cart->show_total()); Once that's taken care of, error messages disappear, and you can set up a few lines in includes/modules/sts_inc/sts_user_code.php as follows: //shopping cart wherever you want one $sts->start_capture(); ?> <table border="0" width="100%" cellspacing="0" cellpadding="0"> <tr> <td class="shoppingCartContents"> <?php echo $cart->count_contents() . ' Items'; if ($cart->count_contents() > 0) { echo '<br>Total: ' . $currencies->format($cart->show_total()); } ?> </td> </tr> </table> <?php $sts->stop_capture('cart'); //shopping cart ends Set up a new class in your stylesheet called shoppingCartContents, and you can use $cart# wherever you want it. It should be possible to spruce it up quite a bit with a little shopping cart icon, a link to checkout, or whatever. All this does is give you one line with the number of items and a second with the total. So I'm a happy person. :rolleyes: Regards, Anne
  3. Bill, thanks! Those will be very helpful, and hopefully I'll be able to go in there and set up what I need. I'll pay special attention to the bug fixes. I've actually been working on this to the extent that I need to take a break and go do something else--walk the dog, watch TV, read a book. If I'm successful, I'll spend some time with my notes, I'll contact the other people who have contributed, and I'll set up a little bookseller's package for the community. Much appreciated. I'll either be back in the morning crowing or crying. ;) Anne
  4. Hi Bill, I'm using the August 2006 update. Have not upgraded to Online Merchant. STS version is 4.4. Let me ask you this: I've become quite a dab hand at modifying the STS version of sts_inc/product_info.php to show what I want it to show. This basically involved modifying the basic query and setting up a couple of new template variables based on the results. In my particular case (working on a bookseller site), that involved going into the manufacturer's table and also adding a couple of new fields (products_isbn and products_binding) to the products table, fetching query results for those, and setting up variables for them as well. So I now have three very useful new variables for my content template: $productbinding$, $productisbn$, and $manufacturer$. (Manufacturer in this case equates to Publisher.) If I wanted to set up a modification that would permit a content template for the manufacturer's page, which files would need to be addressed? What I have here is the almost-completed nucleus of a toolkit for developers of book or library sites--even publishers. In addition to the stuff mentioned here, there are template pages for "recommended reading," author bios, and a number of others. Getting a customized manufacturer's product info page would really tie the whole together and might make it worth sharing with the community at large. Of course my work so far has built on a number of other peoples' contributions both in the contribs section and from posts here in the forums. In the course of my work for this client, I've been to about a million publisher sites and have gained impressions of the good, the bad, and the ugly--all of which I'm trying to apply to this installation. If you wouldn't mind setting my feet along the right path, I think I'm equal to the task. In return, I would gladly share what I've done. I suspect there are booksellers out there who would benefit. Thanks, Anne
  5. This question is regarding the CONTENT templates. These are working fine for categories. I have a nice set of templates per category, and when the user approaches the catalog from a category standpoint, the category template is displayed. I'm not having any success building a CONTENT template for MANUFACTURER. When the user picks a manufacturer to browse, product information is displayed in the ugly default format and without any of the defined variables I want. How do I set up CONTENT template per MANUFACTURER? Perhaps it is the naming convention I have wrong?? If it's not possible to do this, could somebody please tell me that rather than just ignoring? Thanks, Anne
  6. Hmm. I probably didn't do a good job of laying out the problem. Actually, $manufacturerbox is on every page, over in the left-hand column. It's configured as a pull-down menu, and at this point is used for the publishers of the books--and there are a LOT of publishers. Where I'm in trouble is on the custom product templates--the "content" templates. What I have is: Title: (the product) Author: (I used model number, increased the length of the field) Product Description: (same as always) Image: (same as always) Add to Cart button: (same as always) Price: (same as always) What's missing from this nice little block is the ability to add the specific "manufacturer" or publisher, of that specific book. Because it's a specialized bookstore, that is information that purchasers will want to know. In looking through the sts_user_code I find instructions for adding a new box (which I don't need to do). There are instructions for declaring a new variable, but it appears it will always be the same: $sts->template['MyText']='Hello World'; -- every time I place $MyText in a template, we'll see the same string--"Hello World" What I need to do is set up so that I can have a variable that allows me to add "$manufacturer" and have it display the manufacturer associated with the specific product. If I can get that done, it should be a simple matter to declare some additional variables for custom fields I might create including ISBN number, binding (hardcover/softcover), etc. -- the bibliographic data people want when they buy a book. I believe a bookseller has already written a contrib for those extra fields, but it doesn't mesh with STS as far as displaying them. This would make STS a really powerful ally for indie bookstores wanting to use OSC. Thanks!! Anne
  7. I have a somewhat urgent problem. I need to have the manufacturer field appear on my /content/product info pages. This is a bookseller, and I am using the manufacturer field to hold publishers, of which I have about fifty. To be truthful, I don't have time to practice and learn the techniques for adding custom fields as described in the documentation. (Yes, that's very bad, I know.) I am wondering if someone has worked this out already and would be willing to share, or if perhaps there's a contribution that will do it for me. You can have a look at the site-in-progress here: http://www.stbedesbooks.com Select any of the new books from the front page, and you'll see immediately why this variable is so important. Site is under construction, and top links do not yet work--infoboxes work if you want to have a look. Thanks in advance, and in much haste, Anne
  8. The client actually weighs their items in grams--each individual item can be quite small, though people generally order items in large quantities. There are over 800 products in the store. We are shipping to the direct USPS connection for shipping. I believe this will be much more accurate over the long term. I've been able to express each product's weight as one ounce. I know that the USPS requires weights to be expressed as decimal fractions per pound--thus 8 ounces or 1/2 pound is expressed as 0.5. My questions/problems are: 1) Does anybody know if I can express weight in fractions of ounces? As for example, 0.02 or 0.03? What's the smallest unit of measure the Post Office will accept? 2) The precision expressed in the database field for products_weight is two decimal places, as 0.00. Would I incur any disasters in altering that to three decimal places? I love my home, but gee, it would be so convenient if we could actually finally convert to metric. :-) Thanks in advance to all who read this, Anne
  9. This question relates to the Knowledge Base "Tips and Tricks" entry regarding placing a shopping cart summary at the top of each page. That's located here: http://oscommerce.info/kb/osCommerce/Gener...s_and_Tricks/56 A code snippet is provided, and you also need to define a class in your stylesheet. The code is placed in header.php. I've tried doing this, and I can't get it to show up in the header. I know STS takes over a great deal of the header.php, and I'm wondering if there is some specific location in that file where the code should be placed. I've seen this implemented on sites that use STS, so I know it can be done. Thanks, Anne
  10. I just saw this. I'm finding a lot of little bumps and squiggles with my local server. My semi-educated guess is that it has to do with files and paths. You could try setting up a couple of plain-vanilla HTML documents (not to be visible to visitors) on your production server in a couple of different directories, then linking from one to the other--then copy them to your test environment and see if those links still function properly. That would rule out all the additional factors in the OSC/STS environment. I had a LOT of trouble getting the STS templates to locate the images directory on the local host. Since I'm under a time crunch, and I have a production server I can work with, I just set up an unused domain on the production server and am doing all my STS work there--with the catalog directory passworded at the moment. Not everybody has that luxury, and if I didn't, I'd be looking at those paths. Regards, Anne
  11. Thanks, Bill! :-) I used the version of STS4 that came out with Header Tags Controller, which is also integrated at the site. I didn't use the Infobox Templates--not sure why, but I just sort of customized my own. They're done by completely editing out any title or heading information from the boxes. Those little tabs are actually placed on the template just above the relevant $infobox tag, with just a line break in between. The appearance somehow pleased me better that way. The stylesheet is heavily customized with some new classes, different font colors, sizing, and line spacing. I created a single category template with content template and simply multiplied it by re-naming it for each category--that was easy. The other contrib that's related to formatting is the one that allows you to place products in columns. Each info page is custom-formatted, and here is where STS really shines. It allowed me to present information in what I feel is a readable "one screen at a time" format. That also allowed me to have a real "customer service center" page with all policies, procedures, and other info presented in a readable FAQ format. I'm no end pleased with the way it's turned out--awfully glad I got it working here on my local UNIX server so I can customize clients' sites in a non-production environment (and make all the goofs I want.) :) Regards, Anne
  12. Bill, we have to chalk this one up to a "D'oh!" I re-installed this morning--this time by simply moving all the files rather than copying. STS came up right away, first shot, and allowed me to configure it with no difficulty at all. Sometimes a bit of a rest break can be a Good Thing. :) Incidentally, you may not have seen my own site with its new STS configuration. You can have a look at it here: http://www.atelier-beads.com . I am as pleased with it as I can possibly be, and especially with the ease under STS of installing the many resource and information pages needed for a site of this nature. Other STS sites in the pipeline include a substantial local bookseller going online for the first time and a baby care/products site which is also basically "bricks and mortar." The current "problem" site has been on OSC since April 2004 and was long due for an update and refresh. They're a wholesaler, and they'll remain online while I do the updates on my new Core Duo. Thanks and sorry for the false alarm! Regards, Anne
  13. Hi Bill, Running PHP 4.4 and MySQL 5.??, which matches up with what I run on my production server. I'll re-install and see what results I get. Will the module patch help with the above configuration? Looks as though I have my choice between PHP4 and 5, but no choice as to the MySQL version. I'll report back on what happens after the re-install. One of the advantages of developing this locally is that I can do all the experimentation I want/need to. Thanks, Anne
  14. I'm having a bit of difficulty with installing the newest STS4 locally. This is a Mac, and I use a program called MAMP to control my local Apache server, php, and mySQL. It works exceptionally well for packages like OSC. The only major difference for OSC is that I need to go into .htaccess and set "register globals." At that point, I have a full-fledged OSC running locally and can work with it as I choose. The only trouble I've run into is with STS. The newest version seems to install correctly (nothing appears broken), but when I go into Admin to enable it, I notice two things: 1) The "install" button is somewhat deformed--it's occupying a wide space and distorting the look of that page; 2) If I click on that "install" button, nothing happens. STS doesn't install, no changes are made. Am I missing something stupidly obvious? Failing to chmod a folder? Something else? Unfortunately, reverting back to the immediate previous version is worse--OSC simply Goes Away. Thanks, Anne