Jump to content

sandrasp

Members
  • Content count

    19
  • Joined

  • Last visited

  1. sandrasp

    Help solving errors needed

    Hi everyone. I recently place my site online and still have some problems/errors to fix. sadly my php knowledse is not huge, and some error's are above my grade of understanding phpπŸ™ˆ Since my iDeal isn't working and some of the erro'rs are in ideal.php. I think ill start there? so hopefully solving the error's in there, wil also solve the ideal not working problem. lets start with the first 2 error's....and hopefully you all wil work that way also throught the other error's... a few at a time.😁 so i"m in payment details when i want to order something... and I see 2 error's there first: Notice: Use of undefined constant token - assumed 'token' in /var/www/vhosts/sandraspetsparadise.nl/httpdocs/shop/includes/classes/idealm.php on line 767 If i go to the named file then on line 767 it looks likes this: && token != null seccond: Notice: Undefined variable: res in /var/www/vhosts/sandraspetsparadise.nl/httpdocs/shop/includes/classes/idealm.php on line 722 so if I go to that named file it shows on line 722 this: $res .= fgets($fsp, 128); Can anyone tell me how to fix these errors? Thanks in advance!
  2. i think i better make a new subject for solving all other error's including the ideal error's Thank you all for helping me out here! I'm super grateful for you all and your willingness to help!πŸ€— Hope to see the same help and willingnes on my new error_solving post πŸ˜…
  3. ok. i've tried another type of error reporting code...and this version is working. my site now shows errors. i've tried this code now in includes/aplication_top.php error_reporting(E_ALL & E_NOTICE ); ini_set('display_errors','1');
  4. Okay, good to know! thankyou. i'm wondering. This way of showing the errors. Does this show ALL error on the site? because my ideal function isn't working...but when i put this error reporting code in the aplication_top.... is still don't see ANY errors on my site...
  5. okay i have put this back to true...like this: and i can stil create an account and put an item in the cart! yesssπŸŽ‰πŸ˜
  6. omg. πŸ˜ƒπŸ˜ƒπŸ˜ƒ it's working!!! i can create an account AND put an item in the cart! it was probably those cache and gzip settings! thank you soooooooo much! πŸ’ so if i put that error reporting code in aplication-top. will next time something goes wrong an error or something occur? so that i can find out what it is? If yes... i am going to change that line (i couldn't find an Error_log) Because i have much more testing to do. IDeal for instant. but that is for an next time. I have had Enought braintraining for today🀣
  7. i thought that Oscommerce 2.3.4 wasn't compatible with php 7+ πŸ€”
  8. This version: thanks.... i made the changes to the files as you have shown in the edited files you send. THanx for the advise. As you already probably thougt....it did not fix my problem, But at least my files are having those mistakes fixed.😁 so. i put my edited file her again. Hoping that someone would be able to see what to do to so that customers would be able to create an account and put items in the shoppingcart. Both still isn't possible.πŸ˜” this is the include/configure.php file as it is in the moment. define('HTTP_SERVER', 'https://www.sandraspetsparadise.nl'); define('HTTPS_SERVER', 'https://www.sandraspetsparadise.nl'); define('ENABLE_SSL', true); define('HTTP_COOKIE_DOMAIN', 'www.sandraspetsparadise.nl'); define('HTTPS_COOKIE_DOMAIN', 'www.sandraspetsparadise.nl'); define('HTTP_COOKIE_PATH', '/shop/'); define('HTTPS_COOKIE_PATH', '/shop/'); define('DIR_WS_HTTP_CATALOG', '/shop/'); define('DIR_WS_HTTPS_CATALOG', '/shop/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/'); define('DIR_FS_CATALOG', '/var/www/vhosts/sandraspetsparadise.nl/httpdocs/shop/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); and this the admin/include/configure.php: define('HTTP_SERVER', 'https://www.sandraspetsparadise.nl'); define('HTTP_CATALOG_SERVER', 'https://www.sandraspetsparadise.nl'); define('HTTPS_CATALOG_SERVER', 'https://www.sandraspetsparadise.nl'); define('ENABLE_SSL_CATALOG', 'true'); define('DIR_FS_DOCUMENT_ROOT', '/var/www/vhosts/sandraspetsparadise.nl/httpdocs/shop/'); define('DIR_WS_HTTPS_CATALOG', '/shop/'); define('DIR_WS_ADMIN', '/shop/admin/'); define('DIR_FS_ADMIN', '/var/www/vhosts/sandraspetsparadise.nl/httpdocs/shop/admin/'); define('DIR_WS_CATALOG', '/shop/'); define('DIR_FS_CATALOG', '/var/www/vhosts/sandraspetsparadise.nl/httpdocs/shop/'); define('DIR_WS_IMAGES', '/shop/images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/'); define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/'); define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); define('USE_PCONNECT', 'false'); define('STORE_SESSIONS', 'mysql'); define('HTTPS_SERVER', 'https://www.sandraspetsparadise.nl'); define('ENABLE_SSL', true); define('HTTP_COOKIE_DOMAIN', ''); define('HTTPS_COOKIE_DOMAIN', ''); define('HTTP_COOKIE_PATH', '/shop/'); define('HTTPS_COOKIE_PATH', '/shop/'); define('DIR_WS_HTTPS_ADMIN', '/shop/admin/'); 🀞hoping someone can help
  9. define('USE_PCONNECT', 'false'); define('STORE_SESSIONS', 'mysql'); define('HTTPS_SERVER', 'https://www.sandraspetsparadise.nl'); define('ENABLE_SSL', true); define('HTTP_COOKIE_DOMAIN', ''); define('HTTPS_COOKIE_DOMAIN', ''); define('HTTP_COOKIE_PATH', '/shop/'); define('HTTPS_COOKIE_PATH', '/shop/'); define('DIR_WS_HTTPS_ADMIN', '/shop/admin/'); this is the last i've tried...sadly, without the wanted result πŸ˜₯ @Hotclutch, thanx for the tips and trying to figure this out wiht me.πŸ’ Maybe someone else will have another idea
  10. that is the way i tried it.
  11. Well...i've tried both...with and without the extra /.... no difference on my website.. Still not able to create an account OR to ad a item in the shoppingcart.
  12. I'll try....but before that... doesn't it have to have a slash behind the "shop"? like this: '/shop/'
  13. so i understand out of the responses....the problems still should be somewhere in the config files. I will, thanks! SO...here are my config files: first the include/configure.php define('HTTP_SERVER', 'https://www.sandraspetsparadise.nl'); define('HTTPS_SERVER', ''); define('ENABLE_SSL', true); define('HTTP_COOKIE_DOMAIN', 'www.sandraspetsparadise.nl'); define('HTTPS_COOKIE_DOMAIN', 'www.sandraspetsparadise.nl'); define('HTTP_COOKIE_PATH', '/shop/'); define('HTTPS_COOKIE_PATH', '/shop/'); define('DIR_WS_HTTP_CATALOG', '/shop/'); define('DIR_WS_HTTPS_CATALOG', '/shop/'); define('DIR_WS_IMAGES', '/shop/images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . '/shop/icons/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/'); define('DIR_FS_CATALOG', '/shop/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); and seccond the admin/include/configure.php: define('HTTP_SERVER', 'https://www.sandraspetsparadise.nl'); define('HTTP_CATALOG_SERVER', 'https://www.sandraspetsparadise.nl'); define('HTTPS_CATALOG_SERVER', ''); define('ENABLE_SSL_CATALOG', 'true'); define('DIR_FS_DOCUMENT_ROOT', '/var/www/vhosts/sandraspetsparadise.nl/httpdocs/shop/'); define('DIR_WS_HTTPS_CATALOG', '/shop/'); define('DIR_WS_ADMIN', '/shop/admin/'); define('DIR_FS_ADMIN', '/var/www/vhosts/sandraspetsparadise.nl/httpdocs/shop/admin/'); define('DIR_WS_CATALOG', '/shop/'); define('DIR_FS_CATALOG', '/var/www/vhosts/sandraspetsparadise.nl/httpdocs/shop/'); define('DIR_WS_IMAGES', '/shop/images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . '/shop/icons/'); define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . '/shop/images/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/'); define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/'); define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); define('USE_PCONNECT', 'false'); define('STORE_SESSIONS', 'mysql'); define('HTTPS_SERVER', ''); define('ENABLE_SSL', true); define('HTTP_COOKIE_DOMAIN', ''); define('HTTPS_COOKIE_DOMAIN', ''); define('HTTP_COOKIE_PATH', '/'); define('HTTPS_COOKIE_PATH', '/'); define('DIR_WS_HTTPS_ADMIN', '/shop/admin/'); I'm not even going to react on this. You should have read the rest of this (my) topic....and you would have known the answer πŸ˜‰
  14. Hi it's me again, Thanx for the tip. I have chaged some ssl Settings and now my website does not give a SSL error anymore. BUT somehow... customers cannot make a new account. But isn't giving any errors or other notifications either. So i have been trying to figure this one out the past weeks (in my spare time) but still cannot find the problem and i am starting to wonder if i still have to look into the 2 configure.php's . when yes... then i simply don't see itπŸ™ˆ By the way: creating an account did work in localhost. Anybody any idea where to look? Thanx in advance! Sandra
  15. YEs! that was it! πŸ˜€ I shoud have thought of thatπŸ™ˆπŸ™ˆ πŸ˜‚ thanks all of you for helping out!🌹 know i'm going to find a solution for a much bigger problem. the SSL error the site is giving when i want to log in my admin and when the customers want to create an account. (they cannot at this momen i discoverd) sadly my localhost didn't give these errors.😒 for further help on that...(in case I'm not able to figure it out) should i make a new topic, or can i post it here?
×