Jump to content
Latest News: (loading..)

hyperweb

Members
  • Content count

    5
  • Joined

  • Last visited

Profile Information

  • Real Name
    Pfft Lol
  • Gender
    Male
  1. Looping through an array

    @@MrPhil I asked a simple question. I received two very condescending replies. Why would I be interested in helping at this point? User @@frankl pointed out what I discovered myself the night before. Which was a simple misplaced location of where the looping was taking place. I was slightly unfamiliar with this old school way that OsCommerce was built. I refreshed my own memory, and discovered what I needed to.
  2. Looping through an array

    @@14steve14 Not really interested.
  3. Looping through an array

    @@frankl Thanks for your time here. I figured out what I was missing last night.
  4. Looping through an array

    First time poster, I hope this is the right thread as I seem to be having some trouble, I am new to OsCommerce, as I have just picked up a client who has used this platform for some 13 years. I am trying to loop this bit of html. <div class="ms-slide"> <?php echo tep_image('images/' . $product_info['products_image'], addslashes($product_info['products_name'])); ?> <img class="ms-thumb" src="images/<?php echo $product_info['products_image']; ?>" alt="thumb" /> </div> I need this loop to look like this on output : <div class="ms-slide"> <img src="image/main.jpg" /> <img class="ms-thumb" src="image/main.jpg" alt="thumb" /> </div> <div class="ms-slide"> <img src="image/01.jpg" /> <img class="ms-thumb" src="image/01.jpg" alt="thumb" /> </div> <div class="ms-slide"> <img src="image/02.jpg" /> <img class="ms-thumb" src="image/02.jpg" alt="thumb" /> </div> However, I seem to be having a really hard time figuring out how to write a forEach loop regarding the product images. This output would give me my image slide and thumbnails on the product_info.php page. There are no modules in the way to interfere, I themed a copy of the bootstrap edition and I am trying to integrate the product images into my display theme properly. Any help is appreciated! Thanks in advance!
×