Jump to content

mcmannehan

Members
  • Content count

    390
  • Joined

  • Last visited

  • Days Won

    4

Everything posted by mcmannehan

  1. mcmannehan

    Umlaute

    Alle Sprachen Dateien müssen unbedingt als Datei "utf-8 ohne boom" abgespeichert werden. Das ist kein Trick, sondern Standard!
  2. mcmannehan

    WAWI

    https://www.cao-faktura.de/
  3. mcmannehan

    oscommerce und SSL

    Na, das freut mich für Dich.
  4. mcmannehan

    oscommerce und SSL

    Nur diese Änderungen in den entsprechenden Dateien, nichts weiter hinzufügen. .In der /catalog/includes/configure.php ändere zu: define('HTTP_SERVER', 'https://www.stickermogul.de'); define('HTTPS_SERVER', 'https://www.stickermogul.de'); define('ENABLE_SSL', false); in der /catalog/admin/includes/configure.php ändere zu: define('HTTP_SERVER', 'https://www.stickermogul.de'); define('HTTP_CATALOG_SERVER', 'https://www.stickermogul.de'); define('HTTPS_CATALOG_SERVER', 'https://www.stickermogul.de'); define('ENABLE_SSL_CATALOG', 'false'); Da HTTP_SERVER auf https:// steht kann man auch getrost ENABLE_SSL auf false lasen. Beide Änderungen sind aus Deinen geposteten Dateien entnommen. Im übrigen ist es bei 1&1 und bei vielen Providern egal ob Du www vor den Domainnamen schreibst oder nicht, denn das SSL Zertifikat gilt für beides. Über ein 'Gefällt mir' würde ich mich freuen. Danke!
  5. mcmannehan

    oscommerce und SSL

    Per FTP auf Deinem Server einloggen und die CHMOD für die Dateien /catalog/includes/configure.php und in der /catalog/admin/includes/configure.php die Benutzerberechtigungen auf 444 setzen. Aber vorher in beiden Dateien, genau in das Ändern was Jepi und ich vorgeschlagen habe. Was CHMOD ist findest Du per Google.
  6. mcmannehan

    oscommerce und SSL

    ändern in: define('HTTP_SERVER', 'https://www.stickermogul.de'); // <-- geaendert define('HTTP_CATALOG_SERVER', 'https://www.stickermogul.de'); // <-- geaendert define('HTTPS_CATALOG_SERVER', 'https://www.stickermogul.de'); // <-- geaendert define('ENABLE_SSL_CATALOG', 'true');// <-- geaendert in der /catalog/includes/configure.php und in der /catalog/admin/includes/configure.php
  7. mcmannehan

    Frage? 2.2 php 7.0.27

    @IngoPhisto @isdochwurst Ein Teammember schreibt so etwas? Ich fass es ja nicht. Einen alten 2.2 shop auf PHP 7 zum laufen zu bringen ist nicht etwas was man empfehlen sollte. 2.2 ist über 10 Jahre alt! Oder will mir jemand sagen dass er noch Windows 98 benutzt? Man muss einfach akzeptieren dass man früher oder später auf eine neue Version umsteigen muss. Darum empfiehlt es sich auch immer nicht all zu grosse Änderungen am Core-Code vorzunehmen damit das umsteigen einfacher wird. 1.: Sehr gute Programmierkenntnisse sind erforderlich 2.: Der Aufwand dafür ist nicht ratsam. Es geht ja nicht nur darum PHP 7.0 konform zu sein oder um "schauen wir mal wie lange ich 2.2 verwenden kann" es geht auch darum osC endlich mal vorwärts zu bringen. Jeglicher Support um einen 2.2 auf derzeitgen Servern zum laufen zu bringen müsste verweigert werden egal ob der Shopbesitzer deswegen ne Kriese kriegt. Ein Team Member wie Du das bist sollte mit gutem Beispiel vorangehen und alles mögliche tun die noch 2.2er Shop zu überzeugen umzusteigen. Wenn nicht auf Burts Edge version dann halt zumindest auf Haralds 2.3.4.1 Version. Auch wenn diese nicht mehr up to date ist, aber sicher besser als 2.2, 2.3.1 Die osC 2.2 wird im englische Forum schon lange nicht mehr supported und Hilfe wird nicht gegeben. Was vor 10 Jahren galt und war, ist Schnee von gestern. Und auch dies ist unbedingt zu beachten:
  8. mcmannehan

    Login mit PayPal funktioniert nicht mehr?

    Prüfe nochmals Deinen PM Eingang hier. Die PM ist raus.
  9. mcmannehan

    Login mit PayPal funktioniert nicht mehr?

    In allen. Ist seltsam, wenn nichts am Code oder am Server geändert wurde. Habe Dir eine PM gesendet.
  10. mcmannehan

    Neue Regeln für Internetshops

    Dies hat nur bedingt mit den neuen Regeln zu tun. Aber auch ich stelle immer wieder fest, dass viele Online Shop Betreiber sich nicht an die Regeln halten. Mit Ausagen wie "Ich bin ja nur ein kleiner Shop, die kommen bestimmt nicht zu mir" reden sich viele heraus. Alle Online Shops die sich nicht an die Regeln halten, gehören bestraft und die die denken es betrifft Sie nicht, bekommen Abmahnungen das ist gut so. Alle Shops die ich betreue, entsprechen den Regeln und sind https://www.internet-siegel.net konform. Internetsiegel ist sehr zu empfeheln, damit keine Abmahnungen kommen.
  11. mcmannehan

    Rechnungserstellung?

    Viel zu alt, nicht zu ermpfehlen
  12. mcmannehan

    Login mit PayPal funktioniert nicht mehr?

    Welche PHP Version und welche MySQL Version läuft auf dem Server? Prüfe ob die Varaiablen, die von Paypal kommen, noch die selben sind. Prüfe das $_POST['xxxxx'] verwendet wird und nicht $HTTP_POST_VARS['xxxxx']. Sieht so aus, als ob Dein Provider Server Änderungen gemacht hat. Paypal hat vieles geändert. Es sollte das neuste Paypal add-on verwendet werden: https://apps.oscommerce.com/NCd2s&log-in-with-paypal oder https://apps.oscommerce.com/fZMiN&paypal-app
  13. mcmannehan

    Neue Regeln für Internetshops

    Somit steht fest, dass die Aussage, " Die Checkboxen zur Bestätigung des Datenschutzes, der AGB und des Widerrufsrechtes sollen wegfallen " falsch ist. Im Gegenteil, es müssen weitere Checkboxen eingebaut werden. Der Rest ist schon lange bekannt.
  14. mcmannehan

    Neue Regeln für Internetshops

    Links zu den entsprechenden Seiten mussten schon immer gesetzt werden UND die Checkbox zur Bestätigung. Wenn nicht bestätigt wird, kann auch nicht bestellt werden. Ich denke da ist jemand bei dieser einen Verbraucherzentrale total auf dem falschen Dampfer. Solch eine wichtige Änderung würde auf allen Anwaltsseiten im Netz ganz oben zu finden sein. Bis jetzt, Nichts, rein gar nichts dergleichen.
  15. mcmannehan

    Neue Regeln für Internetshops

    Nur eine Verbraucherzentrale? Bitte mal Links und mehr Infos. Bis jetzt sind keine gesetzlichen Änderungen aufgetaucht.
  16. mcmannehan

    Neue Regeln für Internetshops

    Das wäre eine Änderung von § 305 Abs. 2 BGB und da ist nichts davon in Sicht.
  17. Die Zeit läuft aus und die aktive Unterstützung und Sicherheitsunterstützung für PHP5.6 endet am 31.12.2018 in 9 Monaten Die Zeit läuft aus und die aktive Unterstützung und Sicherheitsunterstützung für PHP7.0 endet am 03.12.2018 in 8 Monaten Es ist unglaublich, wie schnell die Zeit vergeht. Mehr Infos hier: http://php.net/supported-versions.php PHP7.3 wird Ende 2018 veröffentlicht. Weitere Informationen finden hier: https://react-etc.net/page/php-7-3-features-release-date
  18. mcmannehan

    veraltete Shopversion osC 2.2

    @Tsimi *kneif, kneif* Gespürt? Okay, ne Du träumst nicht.
  19. Wer weiterhin osC 2.2 einsetzt, sollte sich darüber im klaren sein, das er damit 50.000,-- bis 100.000,-- Euro Strafe riskiert. Mehr Info hier: https://www.estrategy-magazin.de/2015/it-sicherheit-neue-gesetzliche-pflichten-fuer-alle-website-und-onlineshop-betreiber.html#c6119
  20. mcmannehan

    veraltete Shopversion osC 2.2

    Typisch große Firmen, wenn dann der Crash kommt ist das 'Geschreie' groß. Und die Sicherheit von Win XP lässt grüßen.Kenne dies seit Jahrzehnten. Die großen Firmen haben nur Geld für die 'Manager' aber für die IT bleibt nichts übrig. Der große Gau ist vorprogrammiert! Habe nur noch PHP7.+ im Einsatz und funktioniert sehr gut. Überzeugungsarbeit ist eine schwierige Aufgabe, aber im Endeffekt haben alle was davon und sind langfristig gerüstet.
  21. mcmannehan

    veraltete Shopversion osC 2.2

    Hoffentlich ist dieser einer auch auf Online Recht spezialisiert.
  22. mcmannehan

    veraltete Shopversion osC 2.2

    OMG, wer verwendet den noch WinXP oder IE8?
  23. mcmannehan

    veraltete Shopversion osC 2.2

    Toll, endlich mal wieder gute Infos und Kritik. So muss ein Forum sein. Also, die osC 2.2 die ich betreue, wurden sehr wohl von "TÜV" geprüft und der osC 2.2 in seiner Grundstruktur (ohne Änderungen) entspricht nicht den Anforderungen und sollte nicht benutzt werden. Sicherlich kann man die osC so modifizieren (sehr viel Arbeit) das er dem IT-Sicherheitsgesetz von 2015 und mehr entspricht. Richtig, sehr vieles wäre zu tun, zu viel. :-). Diese Version https://github.com/gburton/Responsive-osCommerce von Burt aus dem englischen Forum entspricht zu fast 100% den Richtlinen. Es ist sicherlich sehr ratsam, die osC 2.2 nicht mehr zu verwenden oder benutzt noch jemand Windows 98? Im englischen Forum gibt es schon gar keine Hilfe mehr für osC 2.2.
  24. mcmannehan

    Merchant v2.2 und php 7.0.27

    Geil einfach geil. Ich amüsier mich köstlich!!!!
  25. mcmannehan

    Merchant v2.2 und php 7.0.27

    @leatherdealer1533006774 So ein strukturierter, primitiver und neidischer Menschen, wie @leatherdealer1533006774 ist mir bis jetzt noch nicht untergekommen. Man lernt eben nie aus. Und wieder Beleidigungen von @leatherdealer1533006774. Es gibt exact zwei Menschen im Forum die mich nicht ernst nehmen und diese zwei sind @Yepi1533005574 und @leatherdealer1533006774. Und warum? Ganz einfach: NEIDISCH!!! Geilt Euch weiter an meinen Kommentaren auf, ich habe echt Spass diese zu lesen. Es zeigt auf welchem Level Ihr Euch befindet!!! Über euch zwei kann ich nur:
×