Latest News: (loading..)

joe122joe

Members
  • Content count

    81
  • Joined

  • Last visited

About joe122joe

Profile Information

  • Real Name
    joe
  1. Thank you Jim @kymation I downloaded the Header Tag modules from the latest Edge release and installed it, The Product Title Module (Enable Product Title Module) it set to True, but still not shown the product titles on the page title ,The another modules(Category Title,Manufacturer Title) working well. any help Thank your Joe
  2. Hello @kymation, everyone I still have some issue with install Header Tags SEO addon by @Jack_mcs with Modular Product Page (Bootstrap) installed, Here is the code whats need to change in product_info.php : In products_info.php FIND: require(DIR_WS_INCLUDES . 'template_top.php'); ADD BENEATH: /*** Begin Header Tags SEO ***/ echo "<a name=\"\$header_tags_array['title']\"></a>"; /*** End Header Tags SEO ***/ FIND: $product_info_query = tep_db_query("select p.products_id, pd.products_name, pd.products_description, p.products_model, p.products_quantity, p.products_image, pd.products_url, p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.manufacturers_id, p.products_gtin from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = '" . (int)$_GET['products_id'] . "' and pd.products_id = p.products_id and pd.language_id = '" . (int)$languages_id . "'"); $product_info = tep_db_fetch_array($product_info_query); tep_db_query("update " . TABLE_PRODUCTS_DESCRIPTION . " set products_viewed = products_viewed+1 where products_id = '" . (int)$_GET['products_id'] . "' and language_id = '" . (int)$languages_id . "'"); REPLACE WITH: /*** Begin Header Tags SEO ***/ $product_info_query = tep_db_query("select p.products_id, pd.products_name, pd.products_description, p.products_model, p.products_quantity, p.products_image, pd.products_url, p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.manufacturers_id, p.products_gtin, pd.products_head_sub_text from products p, products_description pd where p.products_status = '1' and p.products_id = '" . (int)$_GET['products_id'] . "' and pd.products_id = p.products_id and pd.language_id = '" . (int)$languages_id . "'"); $product_info = tep_db_fetch_array($product_info_query); $product_info['products_name'] = $header_tags_array['title_alt']; /*** End Header Tags SEO ***/ tep_db_query("update products_description set products_viewed = products_viewed+1 where products_id = '" . (int)$_GET['products_id'] . "' and language_id = '" . (int)$languages_id . "'"); FIND: <?php echo stripslashes($product_info['products_description']); ?> REPLACE WITH: <?php /*** Begin Header Tags SEO ***/ ?> <?php echo HTS_Highlight(stripslashes($product_info['products_description']), $header_tags_array['keywords']); ?> <?php /*** End Header Tags SEO ***/ ?> FIND: </div> </form> ADD ABOVE: <?php /*** Begin Header Tags SEO ***/ if (tep_not_null($product_info['products_head_sub_text'])) { echo '<div class="hts_sub_text" style="padding:10px 0;">' . $product_info['products_head_sub_text'] . '</div>'; } if (HEADER_TAGS_DISPLAY_CURRENTLY_VIEWING == 'true') { echo '<div id="hts_viewing">' .TEXT_VIEWING; $header_tags_array['title'] = (tep_not_null($header_tags_array['title']) ? $header_tags_array['title'] : $product_info['products_name']); echo '<a title="' . $header_tags_array['title'] . '" href="' . tep_href_link('product_info.php', 'products_id=' . $product_info['products_id'], 'NONSSL') . '"/# ' . $header_tags_array['title'] . '">' . $header_tags_array['title'] . '</a>'; echo '</div>'; } if (HEADER_TAGS_DISPLAY_SOCIAL_BOOKMARKS == 'true') { echo '<div style="float:right; margin-top:5px; margin-right:4px;">'; include('includes/modules/header_tags_social_bookmarks.php'); echo '</div>'; } /*** End Header Tags SEO ***/ ?> Can you please advice me Thank you Joe
  3. @PiLLaO Can you please share the solution . Thank you Joe
  4. @Jack_mcs Thank you, My issue fixed by @kymation https://forums.oscommerce.com/topic/409214-addon-modular-product-page-bootstrap/?do=findComment&comment=1757133
  5. @kymation Thank your Well done...
  6. Hello, I have Modular Product Page (Bootstrap) installed, and I would like to install Header Tags SEO addon by @Jack_mcs. and on the Header Tags SEO addon installation doc need changes in product_info.php file. and i cant find where is the code for calling the database .. find $product_info_query = tep_db_query("select p.products_id, pd.products_name, pd.products_description, p.products_model, p.products_quantity, p.products_image, pd.products_url, p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pd.products_id = p.products_id and pd.language_id = '" . (int)$languages_id . "'"); $product_info = tep_db_fetch_array($product_info_query); REPLACE WITH: /*** Begin Header Tags SEO ***/ $product_info_query = tep_db_query("select p.products_id, pd.products_name, pd.products_description, p.products_model, p.products_quantity, p.products_image, pd.products_url, p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.manufacturers_id, pd.products_head_sub_text from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pd.products_id = p.products_id and pd.language_id = '" . (int)$languages_id . "'"); $product_info = tep_db_fetch_array($product_info_query); $product_info['products_name'] = $header_tags_array['title_alt']; /*** End Header Tags SEO ***/ Thank you in advance, Joe
  7. Hello @Jack_mcs.. Thank you for this addon.. I would like to ask you, I am trying to install it on osc 2.3 bs Edge. I have Modular Product Page (Bootstrap) installed.. so the product_info.php so different ,I found almost all the changing code but still one change I didn't find it , Do you have any idea where I can change or add this code : FIND: $product_info_query = tep_db_query("select p.products_id, pd.products_name, pd.products_description, p.products_model, p.products_quantity, p.products_image, pd.products_url, p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pd.products_id = p.products_id and pd.language_id = '" . (int)$languages_id . "'"); $product_info = tep_db_fetch_array($product_info_query); REPLACE WITH: /*** Begin Header Tags SEO ***/ $product_info_query = tep_db_query("select p.products_id, pd.products_name, pd.products_description, p.products_model, p.products_quantity, p.products_image, pd.products_url, p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.manufacturers_id, pd.products_head_sub_text from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pd.products_id = p.products_id and pd.language_id = '" . (int)$languages_id . "'"); $product_info = tep_db_fetch_array($product_info_query); $product_info['products_name'] = $header_tags_array['title_alt']; /*** End Header Tags SEO ***/ Joe
  8. By deleting SEO URLs SQL Rows from configuration Table, and opening the shop in browser will recreate new SEO URLs SQL Rows ,, and that was fix my issue. Thank you @@Jack_mcs. Joe
  9. @@Jack_mcs when I want to check the admin->Configuration->SEO URLs it log me out from the admin and it go to admin login page!!! :shifty:
  10. Hello @@Jack_mcs, How I can remove ?osCsid=xxxxx" from every url end .. I tried this define('HTTP_COOKIE_DOMAIN', '.www.domain.com'); define('HTTPS_COOKIE_DOMAIN', '.www.domain.com'); but url still have the osCsid Joe
  11. Hello everyone. I noticed that, on same browsers when chose category or any page (contact us, shipping , etc ) the whole page reload, but on another browser just the index reloading. the boxes, nav, footer . etc .. not reloading. I think it should be like that. is it something to do with CSS or what? any help plz Joe
  12. Thank you @@kymation includes/classes/hooks.php it was there.. now its working after re-backup osc.
  13. thank you @@LeeFoster its working now after re-backup the Osc
  14. Thank you @@Jack_mcs Do you have any idea why if I add this require(DIR_FS_CATALOG . 'includes/classes/hooks.php'); I get a blank page on the whole site.. I fixed the DIR_FS_CATALOG definition, but still same.. Joe
  15. @@Jack_mcs Thank you Where i can get the full path? Can I find it on Admin -- Tools--- Server Info? Joe