Jump to content

duckydan

Members
  • Content count

    51
  • Joined

  • Last visited

Everything posted by duckydan

  1. I installed the products extra fields add-on (https://apps.oscommerce.com/wFnge) and it works great for new products and search, but on existing products I cannot get the custom field to display. It's skipping over it and not displaying it. In the first screenshot you can see where it shows the UPC (it should display below weight but I moved it up intentionally just in case it was a CSS issue). In the second screenshot, that product has a UPC (I manually entered it) and can search for it, but it doesn't prompt for the field.
  2. Son of a... thanks for the help all. I read the SQL and apparently there is a hidden command you can use called "all" pef WHERE category_id like '% " . $current_category_id . ",%' OR category_id=" . $current_category_id . " OR category_id='all' OR pef.category_id=(SELECT c.parent_id FROM " . TABLE_CATEGORIES . " as c WHERE c.categories_id = " . $current_category_id . ") I changed category to "all" and it worked
  3. Sorry I didn't reply sooner... I never received a notification I received a reply and just logged in today to bump this So I did not know I had to add them to a category and thought I could leave category blank and it would be universal... we have several hundred "categories" based on how the store is laid out. Is there a way to make it global?
  4. duckydan

    updated certificates

    Bobber see my post above. You need to change gateway to gateway2 in the aim file in includes/modules/payment. It appears three times. That will fix it.
  5. duckydan

    updated certificates

    John, thanks for your answer. changing all instances of gateway. to gateway2. was the solution for me. This really needs to be posted as an update or upgrade for the module as i am certain others are going to be posting with this problem.
  6. duckydan

    updated certificates

    John, i'm having the same issue as Ken. I updated my certs but still get the same issue. Everything was working Sunday and fell to hell on Monday. Any idea? I'm running OSC 2.3.4
  7. Bumping to see if anyone has an answer to the issue above.
  8. I'm having an issue with this mod. Right now if I have a $10 off $100 coupon and someone applies it and then edits their cart they can essentially get $10 off $10. How can I force a recheck on submit?
  9. I know this is an older mod but just starting having a problem with it... the mod is working great, but when I send an order update e-mail or create an order and send a notification, the update is blank. It has the subject "Your order has been updated" but no body content. I tried to see what could be the problem but nothing stands out. I tried it with a new customer, with an existing customer and without a customer and it all yields the same result. I am using OSC 2.3.4. (I'm assuming it's with this mod but it may also be the order editor portion of the mod that is broken)
  10. Sorry to bump, but wondering if anyone has any ideas to fix this?
  11. Hello all, a problem just came up that wasn't happening before... i found it was a fixed issue but don't see the fix. We are using the PayPal app and the PayPal Express option. Just today we started getting: The totals of the cart item amounts do not match order amounts It works when using a credit card but not PayPal. I see the PayPal fix, but that doesn't help because the code for the app is completely different from the old IPN.
  12. duckydan

    NEW! Complete Order Editing Tool!

    I'm having a problem using the version for OSC 2.3. I have Discount Codes and Shipping Insurance mods installed. The Discount Codes work fine. I can add a coupon on the backend with no issue. Shipping insurance however will not let me add $1.95 to the field. This is a pre-populated field on the front end where if a user selects it, it is automatically added. If I edit the order and add $1.95 to that field it resets it back to $0. I also cannot add any fields to the order totals by hitting the + even though it is an option. Does anyone have any ideas as to why this Is happening or how to fix it?
  13. Hoping someone here can help. We are using the PayPal app with the PayPal express option. We get daily e-mails telling us that Please check your server that handles PayPal Instant Payment Notifications (IPN). IPNs sent to the following URL(s) are failing: .com/ext/modules/payment/paypal_ipn/ipn.php If you do not recognize this URL, you may be using a service provider that is using IPN on your behalf. Please contact your service provider with the above information. If this problem continues, IPNs may be disabled for your account. The issue is that we are using the paypal app... that file does not exist obviously. I'm not sure how it's even being set yet alone called. I did a code search and replace on every file on my server and I see nothing even containing ipn.php let alone sending it out.
  14. duckydan

    Paypal IPN warning with Paypal App / Express

    @@241 - I do not have a file includes/modules/payment/paypal_ipn.php @@frankl - I replaced all of the module files with those that came with the app. In fact my entire modules/payments folder contains nothing except for the authorize.net modules and the paypal app modules (paypal_express.php, paypal_pro_dp.php, paypal_prop_hs.php, paypal_prop_payflow_dp.php, paypal_pro_payflow_ec.php, paypal_standard.php)
  15. duckydan

    Paypal IPN warning with Paypal App / Express

    So just an update... the old server has been shutdown and we are still getting these warnings. There are no calls at all to that file anywhere in any file on the server and the paypal return URL is turned off. I'm completely baffled at this point and any help would be appreciated. Paypal insists we are sending the data in a notify_url string. My awstats shows that the file was called 186 times over the past 2 days even though it doesn't exist. With the paypal app, return url is set to off and just for safe measure I set it in paypal to checkout_process.php am I missing anything?
  16. duckydan

    Paypal IPN warning with Paypal App / Express

    So I don't see anything but we migrated from OSC 2.2. I didnt copy the config table though as I manually rebuilt that and I am using 2.3.4. This is a really dumb question.... The old server is up but dormant... It can't be accessed but is standing in case we need to access it for a missing file. Does that IPN dial out without someone checking out? Like for a status check for a refund or anything like the paypal app does?
  17. duckydan

    Paypal IPN warning with Paypal App / Express

    I thought so but we turned the IPN return url setting to off but just for good measure we set it to be checkout_process.php. When we contacted paypal they told us it was being sent in the notify url but again that would have to be coded somewhere and it's not.
  18. I've tried installing the PayPal App and also the Discount Coupons app. Both separately. Both of them yielded the same result which was the error message below. My server error logs show no errors. The files from what I can tell are all there and have no errors. I'm at a loss as to why this is happening. It happens when I access the paypal.php or the coupons.php config pages from the admin. More annoyingly, they work on the test server but not prod! The server encountered an internal error or misconfiguration and was unable to complete your request.Please contact the server administrator at webmaster@bowhunterssuperstore.com to inform them of the time this error occurred, and the actions you performed just before this error. More information about this error may be available in the server error log. Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
  19. duckydan

    Server Error on multiple Add-Ons

    EDIT: I figured it out and that sucked and was stupid! permissions had to be set to 644 and not 664. 664 caused a failure.
  20. duckydan

    [Contribution] Option Types v2

    @@Tsimi, thanks for the reply... I hadn't logged in in a few days. I went back and found I missed one line in one off the class files. Fixed that and it worked. Should have updated this thread but I had posted in a ton with the number of errors I experienced and couldn't remember them all. Thanks!
  21. duckydan

    [Contribution] Option Types v2

    I'm having an issue with this mod where on my confirmation e-mails, invoice, packing slip and on the checkout confirmation page it still says "CUSTOMER-INPUT" instead of the text value that the customer assigned. I checked all of the files that were to be updated and everything is there. What is missing and why isn't the data there? EDIT: I checked the database and it's going to the database as CUSTOMER-INPUT as well.
  22. Thank you very much, that worked!
  23. Just an update... I got the updated key and sure enough it did work. With that said, Authorize.net is not seeing the invoice number, only the amount. What do I need to do to fix that?
  24. We processed a refund on the site and it isn't reflecting in OSCommerce 2.3.4. Is there something else we need to do to make it appear so that when we process the refund on the paypal side it is reflected on the OSC side? Like a few of my other posts, this worked for us on 2.2. We are using the base Paypal Express module.
  25. Right what I mean is, if I test connection without my API key in, I get a test successful result. If I enter my API key in, it fails. Additionally, if I enter a sandbox API key in, it works. The owner of the store I am working on is fairly PO'd so trying to CMB and prove it's defintely the key. They gave me a contact number and authorize says that it is a card in person account and that's the problem but their authorize vendor says that's BS so at this point i'm just trying to get things straight.
×