Jump to content

blucollarguy

Members
  • Content count

    739
  • Joined

  • Last visited

Everything posted by blucollarguy

  1. blucollarguy

    Multi_Vendor_Shipping new thread

    Here is a possibility, I happened across this while researching an issue with another combination of contribs: Try that, ya never know. I only know for sure that it didn't hurt anything on my test server. Craig :) :thumbsup:
  2. blucollarguy

    Multi_Vendor_Shipping new thread

    I did notice that! And that's a good thing! I really can't think of any other cause. As far as I know, you are the only one who has ever had this problem. I would suggest only signing up for a host on a one month(or less if possible) contract, just in case you encounter the same problem. There certainly are plenty of hosts to choose from. I know that the package works with: Server Host: (an IP address noone needs to see) Database Host: localhost (127.0.0.1) Server OS: Database: MySQL 4.1.9-max Server Date: Feb 14, 2007 at 07:07 PM Datebase Date: Feb 14, 2007 at 07:07 PM Server Up Time: HTTP Server: Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.2.0 PHP Version: 5.2.0 (Zend: 2.2.0) If you use that as reference, I can only guess it will work for you. Good luck, Craig :) :thumbsup:
  3. blucollarguy

    Multi_Vendor_Shipping new thread

    You will definitely have to do some serious integration in order for MVS to work while still allowing everything else to work as well. This type of conversation is not allowed on the osC forums, no commercial messages. Contact a few people from the forums via PM, and you can get more info on this. Good luck, Craig :) Quick response: each product is assigned a vendor, each vendor has it's own shipping modules, when the customer checks out, a quote for each vendor's product(or products) will be shown to the customer, they will have to choose the method for each vendor(the group of products from each individual vendor). LInks to the demo are in my signature. Good luck, Craig :)
  4. blucollarguy

    Multi_Vendor_Shipping new thread

    I suppose it is possible, but I did all my testing and development on a webserver I have in my house, and it was, at that time, running MySql 3.23. But I guess it could be. But, if you can work with your other modules(payment, order_total) then I would say that isn't it either since the "vendor_modules" file was written from the standard osC "modules" file in the admin. I dunno thomp, I wish I could give you something more definite, but that's all I've got on your problem. Craig :( KP, MVS does offer different ORIGIN zipcode(ship from locations) in order to offer an accurate shipping quote. MVS does NOT consider the customer's location at ANY point in the process. However, you can setup your "Vendors" using shipping modules that you isolate to the "zones" you want to use, all the shipping modules written for MVS should be "zones" compatible, meaning you can decide to only allow certain zones for any particular shipping module in order to check out. You may need to add some additional text when there is not shipping available for a particular product, but that is not that big a deal. Good luck, Craig :)
  5. blucollarguy

    Multi_Vendor_Shipping new thread

    I don't know what else to tell you, thomp, I am at a loss. I have NEVER seen such an issue before. It really is nothing more than a form like every other form in osCommerce. I will try to keep thinking about it and if I come up with any more ideas I will let you know. Good luck, Craig :huh:
  6. blucollarguy

    Multi_Vendor_Shipping new thread

    That's correct about the stipslashes function, you would have to double them there (\\n) in order for that to work. You should be ok witht the proper "mime" setting, most clients are blocking images more than just "html" so most people should be able to get the email formatted properly. Good luck, Craig :)
  7. blucollarguy

    Multi_Vendor_Shipping new thread

    What I don't see thomp, is the "$action" variable, add that in so we know is being set. But you can see that you aren't getting ANY data passed to the file to update the database. I guess you should double check the "form" build to make sure there are no errors or missing code there, the form get's built around line 240, "tep_draw_form". I would sat to just look through the file very closeley to and see if looks like anything is out of place. This is a VERY strange problem, so I am just guessing at all of this from a "troubleshooting" standpoint. Good luck, Craig :( You can simply replace the <br>'s with \n's or whatever your system supports, or you can go to your Admin, under Configuration->Email Options, and set "Use MIME HTML When Sending Emails" to true, that should fix your email problem. Good luck, Craig :)
  8. blucollarguy

    Multi_Vendor_Shipping new thread

    If you got no response from this then the form is not submitting properly at all. Move the echo outside the block that begins with "switch" and add the variable: $action, like this: echo 'the $value: <pre>' . print_r($value) . '</pre><br>and the $key: <pre>' . $key . '</pre> and the $action: ' . $action; if (tep_not_null($action)) { switch ($action) { case 'save': And see if the action is being set at all. It sounds like your losing all posted data, which I have dealt with on a couple of hosts servers myself, I have had to go back through ALL code and manually set sessions for all variables, and then be sure to "unset" all the sessions after the work of the form submission is finished. Very tedious work and a BIG pain in the @%#. Good luck, Craig :)
  9. blucollarguy

    Multi_Vendor_Shipping new thread

    I don't think any one has. One would have to write a custom "order_totoal" module that would take the "Vendor" information form the cart and decide what the fee, if any, would be applied. It can be done, just will take a little work to get all the variables passed to the module properly so that it can then do the math it needs to do. Good luck, Craig :) This is a very strange problem, can't tell you what code to work on since the code is no more than a "form" passing information and then updating the database. I am positive that the files in the package on the contrib page are written correctly to do this since there are literally thousands of folks using them. The more approprate question seems to be: what is different about your environment that is causing the problem? Do you have any coding experience? What I would do in your case is add print(echo) statements in the vendor_modules.php file in a spot where the data that is "posted" to be added to the database is posted to. Something like this: echo 'the $value: <pre>' . print_r($value) . '</pre><br>and the $key: <pre>' . $key . '</pre>'; I would place this code at around line 24 or 25 so that the block of code from @ line 20 to @ line 26 would be: if (tep_not_null($action)) { switch ($action) { case 'save': while (list($key, $value) = each($HTTP_POST_VARS['configuration'])) { echo 'the $value: <pre>' . print_r($value) . '</pre><br>and the $key: <pre>' . $key . '</pre>'; if( is_array( $value ) ) $value = implode( ", ", $value); This should print out onto your screen all of the values that you entered while updating the shipping information. Good luck, Craig :)
  10. blucollarguy

    Multi_Vendor_Shipping new thread

    Yes there is an addition to the admin/categories.php file to be made. If you download the original "Indiv-Ship" contrib, you will find the needed code implementations there, install that according to the instructions excluding ALL changes to the files in the "catalog" side of the shop. Good luck, Craig :)
  11. blucollarguy

    Multi_Vendor_Shipping new thread

    Thomp: I think the "multi-zones" module would do what you are trying to do, check at the old MVS conrib page, search for "vendor" on the contrib page and you will find the module there. Did you modify the "Multi-Indiv Ship" contribution Helle? I am not sure that one has been mnodified for MVS yet, so that may be the issue. Good luck to you both, Craig :)
  12. blucollarguy

    Multi_Vendor_Shipping new thread

    This was an attempt at a double post!
  13. blucollarguy

    Multi_Vendor_Shipping new thread

    HTML Editor? For the email maybe? There are many contributions adding HTML and Email editing for osC now, I am sure that you can find one that works for you Helle. That's an interesting name, can you enunciate it for me? Keep in mind that MVS completely replaces osC's shipping code, which means that only shipping modules written for or modified for MVS will work correctly. Individual Shipping has been modified for MVS, you can download the correct files from the MVS contrib page. If you have already modified your "categories.php" file, you will not need to change anything, only add the modified indiv_ship.php(or whatever the filename is) to catalog/includes/modules/vendor_shipping and catalog/includes/languages/english/modules/vendor_shipping. After that, you should see the module and be able to install and setup your vendors. Good luck, Craig :)
  14. blucollarguy

    Multi_Vendor_Shipping new thread

    Sorry to everyone for my absense, I have been absolutely overwhelmed with work and the holidays didn't help one bit. Let's see if I can keep this straight for everyone: Nancy, the setting you are referring to is the one you need. The status you select here will be when the order email is sent to the Vendor. Tax is only charged for the store state, this would be the only prudent way to do this and not have to file for a state business license in every state where you make a sale. You would have to pay the tax collected to each individual state. Not a good way of doing things, and besides, the law says you don't have to, except in California and maybe a few others. The email is written using html, so you need to make sure your admin settings are correct: In your Admin, under Configuration->Email Options; set "Use MIME HTML When Sending Emails" to true and "E-Mail Linefeeds" are set to LF. (line feed) I still am trying to finish the next update for MVS, several bug fixes and corrections to the instructions as well as a few small enhanements. :blush: Good luck to everyone, Craig :thumbsup:
  15. blucollarguy

    Multi_Vendor_Shipping new thread

    This is just a quick response to all those who have posted over the past many days without a response. Sorry about the "no response", been incredibly busy, I hope to relesease the next update to MVS over the next week or so that will deal with most of the issues. The "dimensional support" seems to be a bit of an enigma, it is working for some but not others so I am not 100% sure it will be fixed. The Vendor handling fees will be moved from each individual shipping module to the "vendor_shipping" class to avoid these issues with the individual shipping modules not adding them correctly. Several other minor updates will be included as well. Again, I am sorry for no resoponse to everyone, but my normal jobs(my full time job and my business) have had me running ragid. Hope all have a great holiday, Craig :)
  16. I forgot to include the short cut to "EZ_Price_Updater" in the admin. Here it is: And in catalog/admin/includes/column_left.php add wherever you want the shortcut: require(DIR_WS_BOXES . 'pqu.php'); I will update the instructions.
  17. blucollarguy

    Multi_Vendor_Shipping new thread

    If you are woking with MVS with "register_globals" off, then you will have to add some code to accomodate MVS. I can't help with exactly what since I have never gone through it myself. But if you search through this thread very carefully, you will find several posts from another user who worked through it and got everything working. I can't give you any dates but it was a couple of months ago. Good luck, Craig :) Sam, I see the price you got from the UPS website in the response, double check your allowed shipping types(ground, next day and whatnot) and you should get what you need. Note that the response also indicates additional charges being applied for overweight package. Read through the response a couple of times and you will see what you need to see. I would suggest deleting everything, and then do a test order(only 1) so you won't have so much data to sift through in log file. Good luck, Craig :)
  18. blucollarguy

    Multi_Vendor_Shipping new thread

    That error should only happen under one of a couple senarios: you do not have a shipping module installed for the vendor of the product you are buying, or you don't have your vendors setup at all(the product does not have a vendor assigned), you may have not uploaded the "vendors_shipping" directory with all the MVS modules to your server(upload the directory to fix it). To find out: Look to see if the directory is there and full of modules for MVS(catalog/includes/modules/vendors_shipping) Then make sure that you have a shipping module installed for the vendor whose product you are trying to buy, and that it is configured properly and the product is eligable for shipping. Next, double check your edits to the following files; catalog/includes/classes/ --- shopping_cart.php and order.php catalog/checkout_shipping.php, checkout_payment.php, checkout_process.php The other thing to do is to check the array for data, in vendor_shipping.php, above the block of code being referenced in the error message, add something like this: echo 'Array Data Test:<pre>'; print_r($modules_array); echo '</pre>'; And see if you have anything there. Good luck, Craig :)
  19. blucollarguy

    Multi_Vendor_Shipping new thread

    Have you assigned your products to the vendors as needed? The other files to look into are: "includes/classes/order.php" and "includes/classes/shopping_cart.php". These files collect the data and pass it to the others for use. Good luck, Craig :)
  20. blucollarguy

    Multi_Vendor_Shipping new thread

    This is a very strange problem. If the page "updates" without errors, it should add all data to the database. The only possibility I can think of is if "all" error messages are turned off from your server and you don't have permissions set up to "write" to the database. Just a couple of thoughts, Craig :)
  21. blucollarguy

    Multi_Vendor_Shipping new thread

    The orders_shipping table has nothing to do with storing the Vendor's module info. That is stored in the table "vendor_configuration". Are you installing the modules via the "Manage" button? You could drop all the vendor related tables and start over and see if that helps. Good luck, Craig :)
  22. blucollarguy

    Multi_Vendor_Shipping new thread

    The error message states that the table does not exist, that table name is a 'constant' that is set the way that is described in that post, if you are still having the error then you have another much more obscure problem that I cannot even guess about. Good luck, Craig :)
  23. blucollarguy

    Multi_Vendor_Shipping new thread

    If the EP file from the link I gave you earlier doesn't provide you with any vendor info, then you have another problem. That file is in use on over a dozen other sites and is functioning very nicely. The language issue: within the EP file there are parameters to be set, you will need to read the EP documentation to find exactly where it is. Good luck :) You must install all the "other" aspects of the UPSXML contirb, the table changes, the file changes(categories.php and others) and added files being added. The upsxml.php file does have dimesional support built in, but only after you install the rest. It is not designed to do what you are asking about, but I suppose it could be done. I have never considered this possibility but I am sure someone else has. I suggest a thorough search in the contrib site for someone who has already done the work, you will then need to integrate it with MVS if you intend to use both. Look at this post: Post Preview This exact issue is discussed. Craig :)
  24. blucollarguy

    Multi_Vendor_Shipping new thread

    Paste 4 or five more lines from in front of and after this block. That error usually comes when a "php tag" (<?php) has not been closed and another has been added. Craig :)
  25. blucollarguy

    Multi_Vendor_Shipping new thread

    I am intrigued Stew, just hadn't had the chance to encourage you into working it out and telling us what you find! LOL This could easily be your host configuration, script time limits to control processor usage. The code iteself does go through quite a few loops for each box, but really shouldn't be a problem. Have you tested this in a more controlled environment(a home/personal/local server)? It could also be someting from UPS. I am not aware of any limits from them, but that doesn't mean there aren't any. Craig :)
×