Jump to content

blucollarguy

Members
  • Content count

    739
  • Joined

  • Last visited

Everything posted by blucollarguy

  1. blucollarguy

    Multi_Vendor_Shipping new thread

    My first guess would be simply a corrupted file. Try unpacking and copying it over again. As far as I know, no body else has had this problem. Good luck, Craig :)
  2. blucollarguy

    Multi_Vendor_Shipping new thread

    Check the language files for the kg/lb thing. I am not sure about where else that may be changed right now, there is something in the back of my mind about it, but I can't quite put a finger on it. The handling fee: do a search for it, you should find some code posted some pages back, several of the modules did not end up with the right code to add the vendor handling fee. Good luck, Craig :) This sounds a lot like the edits in classes/order.php in the Admin. If all is well there, then double check your edits in checkout_process.php on the catalog side. That file does all the database work for each order, and obviously, is very important. Good luck, Craig :)
  3. blucollarguy

    Multi_Vendor_Shipping new thread

    Did you set the Vendor to "send emails" in the Vendor admin page, and set the "status" for when the email would be sent to the proper status? If you've done those things and it still doesn't work, then you will need to check your edits in "checkout_process.php", that's where the emails are built and sent. Good luck, Craig :)
  4. blucollarguy

    Multi_Vendor_Shipping new thread

    Check your php settings, depending on your server, you may have a number of things you can do. It's hard to say exactly what, but you can play with it a bit and see what you can get. Craig :)
  5. blucollarguy

    Multi_Vendor_Shipping new thread

    Now the currencies would be an issue. There is nothing within MVS that deals with the currency, that is all handled by osC, and I don't think osC has the ability to use different currencies for different products. You may be able to find another contrib that can do that though. Try this one: Show Price in each Currency Good luck, Craig :)
  6. blucollarguy

    Multi_Vendor_Shipping new thread

    Another user had posted recently the same problem, he discovered there was a problem with his mysql version, read back several pages(2 or 3, maybe 4) and you should find his posts. Craig :) I assume you mean "MVS" not "AVS"? If so, the taxes are not actually handled by MVS 'per sey', taxes are still handled by osCommerce, so the accurate answere is: you should be able to do what you are asking about with osC and MVS installed. Craig :)
  7. blucollarguy

    Multi_Vendor_Shipping new thread

    This error is coming from something you did in that file(configure.php), your settings in that file locate EVERY directory for osC. Craig :)
  8. blucollarguy

    Multi_Vendor_Shipping new thread

    Your on the right track here, if you have this much of an idea, take a look at the "product_info.php" file, search for "products_image" and you will find all the references to pulling and displaying the product image. From there, you should be able to work out how get it, and how to display it(what size and such). Good luck, Craig :)
  9. blucollarguy

    Multi_Vendor_Shipping new thread

    I have been seeing complaints about the orders not updating lately and still have not been able to replicate this in any way other than by messing up the code in catalog/checkout_process.php. The emails are probably a server configuration issue, were you able to send emails with the stock version of osC? And did the orders update properly with the stock version of osC? We recently saw a user who found the issue(I think he was having problems with the changes in the Admin not being saved to the database) by switching servers(the mysql version tuned out to be the problem). I would suggest doing some testing with a standard osC install, that way you can eliminate your server as the issue. Good luck, Craig :)
  10. blucollarguy

    Multi_Vendor_Shipping new thread

    No, that particular module should work as is, it should not need to be modified in any way, MVS should have no effect on it's function as it does not change the "order total" system in osC, only the shipping calculations. If it doesn't work, you would need to work with any support thread for that module. Good luck, Craig :)
  11. blucollarguy

    Multi_Vendor_Shipping new thread

    The standard osC "Free Shipping"(set up from Order Totals) module should work based on the order total, not considering any vendor information. I have personally never checked though. I assume you have set it up and it didn't work? I think I have seen a post or 2 about this though, did you do a search through the thread for it? If you have tried all of the above, post what exactly is wrong, with any errors, and we can see if we can work through it. Craig :)
  12. blucollarguy

    Multi_Vendor_Shipping new thread

    Well, this should only be able to happen if you also have the "flat rate" shipping module set up(or whatever module you are using for Free Shhipping) for that Vendor as well. Double check that the ONLY shipping module enabled for that Vendor is the one for you want. If this really is the case, then I am so completely perplexed that I can't even guess what the problem might be. Probably not much real help, sorry, Craig :) Sorry for no reply before, but I don't really have time myself to get into it. It is designed as an "order total" module, which means it should work as is. It will NOT work "per vendor", but will function according to the total amount of the order. If you need it to work "per vendor", that will take a bit more work as we have done anything with the "vendor" system to work with the order totals. Sorry, but for now, it is not in the plans either, way down on the list. Good luck, Craig :)
  13. blucollarguy

    Multi_Vendor_Shipping new thread

    I can't help you with the insurance thing, but there already is an EP for MVS, my apologies however for not being more specific, the Vendors Auto-Email contrib was where MVS came from(that was my first major step towards MVS), and therefore, is also for MVS. I am sorry for not posting this before, but it just recently occured to me that many of the users of MVS nave no idea that the 2 contribs are related. Again, my apologies, Craig :blush: :-"
  14. blucollarguy

    Multi_Vendor_Shipping new thread

    There are copies in both the main EP page(you will need to dig down through the versions, there has not been an update to it for quite a while) and on the OLD MVS download page(do a search for Multi Vendor, and you will find the old page). Good luck, Craig :) :thumbsup:
  15. blucollarguy

    Multi_Vendor_Shipping new thread

    I understand your issue, in the forums, IPN has been discussed several times: in catalog/includes/modules/payment/paypal/catalog/checkout_process.inc.php, edit with the changes from catalog/checkout_process.php The IPN contrib bypasses the update functions of osC and does that work on it's own, if you are using the version from the osC developers, you have to do the same thing with module file, paypal_ipn.php. Good luck MVS should work fine wiht all of these. You would need to do a good bit of manual editing however, as they ALL effect may of the same files. You will need to also merge changes for EP, there is a version of EP for MVS, you will probably need to work through that with the changes for the "New Fields" contrib. Just take your time and use a compare program, you will get it. Craig :)
  16. blucollarguy

    Multi_Vendor_Shipping new thread

    Did you run the sql? It sounds like you didn't, since the table being referenced is from the MVS sql. Craig :)
  17. blucollarguy

    Multi_Vendor_Shipping new thread

    Try this: http://forums.oscommerce.com/index.php?act...hlite=%2BPayPal If you look through the first page or so, you may find your answer. Good luck, Craig :)
  18. blucollarguy

    Multi_Vendor_Shipping new thread

    I think what he did was he put the file: catalog/checkout_shipping.php in the languages directory or something of that nature. Good luck, Craig :) Email me and I will send you some files to work with. Craig :)
  19. blucollarguy

    Multi_Vendor_Shipping new thread

    Helle, MVS should not effect standard order emails, you should double check all your edits in checkout_process.php, that file does all order update work and sends the emails. You will see in that file where the customer is sent their order email and where the "send extra order emails" is set up. If for whatever reason, that isn't working(I have encountered a number of sites myself where this is the case) you can hardcode your own email there. Good luck, Craig :) Jeff, the best suggestion I would have for this is to create a new Vendor for this purpose, and turn on "Stock Tracking" in your store, updating the products you don't want to worry about stock to a very large number of stock, and the others with the true number. Could be a pretty time cosuming process if you have a lot of products, but if you have not been tracking stock, and now you want to track stock, I think that is the only way to handle it. Good luck, Craig :)
  20. blucollarguy

    Multi_Vendor_Shipping new thread

    It sounds like your server may be interpreting line endings differently than the format of the file is showing. What you can try is go to the end of line 444 and delete the "return" from there so that there is NOT a blank line after it. It could be as simple as that. IF that doesn't do it, try uploading it in another format(ASCII or BINARY) and see if that helps. That file shoould be ok so it is probably something of that nature. Good luck, Craig :)
  21. blucollarguy

    Multi_Vendor_Shipping new thread

    Are you debugging checkout_process.php? That is the file that actually updates the database with the order info, and then sends the emails. Double check all your edits there, very important file. If you look through that file, you will be able to work out the various arrays of data, and you can then check each one by adding the debug code to the top of that file. This will aslo prevent the order from being completed, so you will be able to continue to work with it by hitting the back button, updating/changing any files you think need it, and then trying to check out agian. Craig :)
  22. blucollarguy

    Multi_Vendor_Shipping new thread

    That's correct, that would be the second part of the same bug, you made that change in admin/orders.php right? If so, that should do it. Craig :)
  23. blucollarguy

    Multi_Vendor_Shipping new thread

    Double check your edits in catalg/classes/shopping_cart.php and order.php, that is where all the information is collected and passed. Good luck, Craig :)
  24. blucollarguy

    Multi_Vendor_Shipping new thread

    Your code looks fine, and really shouldn't contribute to that specific error(BTW, there should be some additions to for the language file to show some actual text there, fix by adding: define('ERROR_NO_SHIPPING_SELECTED_SELECTED', 'Please select a shipping method for your order.'); to your english file). That error is generated from the payment page not recognizing the selected shipping method. You could try adding some debug code to the top of the checkout_payment.php, like this: echo 'this is to dbug the shipping selections: <br><pre>' . print_r($shipping) . '</pre>'; Add that line to the top of the file, just below this line: require('includes/application_top.php'); And test again, you should get the full array of information on the screen(shipping selection, method, price, etc...), you may also get an error about "headers have already been sent", just take note of the information you see and hit the "back" button on your browser, and then remove that line we added. Let us know what you get, Craig :)
  25. blucollarguy

    Multi_Vendor_Shipping new thread

    That is a bug. In catalog/checkout_process.php, find: //let's get the Vendors $vendor_data_query = tep_db_query("select v.vendors_id, v.vendors_name, v.vendors_email, v.vendors_contact, v.vendor_add_info, v.vendor_street, v.vendor_city, v.vendor_state, v.vendors_zipcode, v.vendor_country, v.account_number, v.vendors_status_send, os.shipping_module, os.shipping_method, os.shipping_cost, os.shipping_tax, os.vendor_order_sent from " . TABLE_VENDORS . " v, " . TABLE_ORDERS_SHIPPING . " os where v.vendors_id=os.vendors_id and v.vendors_id='" . $vendors_id . "' and os.orders_id='" . (int)$oID . "' and v.vendors_status_send='" . $status . "'"); while ($vendor_order = tep_db_fetch_array($vendor_data_query)) { and replace with: //let's get the Vendors $vendor_data_query = tep_db_query("select v.vendors_id, v.vendors_name, v.vendors_email, v.vendors_contact, v.vendor_add_info, v.vendor_street, v.vendor_city, v.vendor_state, v.vendors_zipcode, v.vendor_country, v.account_number, v.vendors_status_send, v.vendors_send_email, os.shipping_module, os.shipping_method, os.shipping_cost, os.shipping_tax, os.vendor_order_sent from " . TABLE_VENDORS . " v, " . TABLE_ORDERS_SHIPPING . " os where v.vendors_id=os.vendors_id and v.vendors_id='" . $vendors_id . "' and os.orders_id='" . (int)$oID . "' and v.vendors_status_send='" . $status . "' and v.vendors_send_email = '1'"); while ($vendor_order = tep_db_fetch_array($vendor_data_query)) { Somehow, the call to check to see if the email was enabled was missing from the query. Surprising that noone else has happened across this yet, thank you very much Craig :)
×