Jump to content

akmac

♥Ambassador
  • Content count

    447
  • Joined

  • Last visited

Everything posted by akmac

  1. akmac

    Google XML Sitemap SEO

    Bingo. Jack, you are the man. Changing define('DIR_FS_CATALOG' in mysite.com/includes/configure.php to the actual path worked. Thank you!
  2. akmac

    Google XML Sitemap SEO

    Hmmm read that whole thread and the answer is not obvious, as I don't have any of the errors mentioned in the thread... Is this the line in mysite.com/includes/configure.php that may be containing an error? define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME'])); And, if I change this line, I wonder what else in my site I might be breaking... If you can't tell, changing values in my config files makes me uneasy. ;-)
  3. akmac

    Google XML Sitemap SEO

    I have confirmed that the files are in the proper directory and are all 777 permissions.
  4. akmac

    Google XML Sitemap SEO

    Ok, I heard from my host and I have a rewrite rule that causes any directory with index.php to hide it from the display url. The effect of this is that it cause the script to not execute. I originally renamed the file map-index.php, but the rewrite rule then rewrote the url to /map- (removed index.php) and returned a 404. So, I renamed the file again to index-map.php and NOW it is executing, and finally showing errors. That's right, I'm happy to finally see errors! Here they are: Opening /sitemapproducts.xmlFS_CAT Server http://www.mysite.comSave Path /WS_CAT /ERROR: Google Product Sitemap Generation FAILED!Opening /sitemapcategories.xmlFS_CAT Server http://www.mysite.comSave Path /WS_CAT /ERROR: Google Category Sitemap Generation FAILED!Opening /sitemapimages.xmlFS_CAT Server http://www.mysite.comSave Path /WS_CAT /ERROR: Google Images Sitemap Generation FAILED!Opening /sitemapindex.xmlFS_CAT Server http://www.mysite.comSave Path /WS_CAT /ERROR: Google Sitemap Index Generation FAILED!Array( [QUERY] => Array ( [PRODUCTS] => Array ( [STATUS] => success [NUM_ROWS] => 2343 ) [CATEOGRY] => Array ( [STATUS] => success [NUM_ROWS] => 280 ) [IMAGES] => Array ( [STATUS] => success [NUM_ROWS] => 2343 ) ) [SAVE_FILE_XML] => Array ( [0] => Array ( [file] => /sitemapproducts.xml [status] => failure [file_exists] => false ) [1] => Array ( [file] => /sitemapcategories.xml [status] => failure [file_exists] => false ) [2] => Array ( [file] => /sitemapimages.xml [status] => failure [file_exists] => false ) [3] => Array ( [file] => /sitemapindex.xml [status] => failure [file_exists] => false ) )) Opening /sitemap_mobileproducts.xmlFS_CAT Server http://www.www.mysite.comSave Path /WS_CAT /ERROR: Google Product Sitemap Generation FAILED!Opening /sitemap_mobilecategories.xmlFS_CAT Server http://www.mysite.comSave Path /WS_CAT /ERROR: Google Category Sitemap Generation FAILED!Opening /sitemap_mobileimages.xmlFS_CAT Server http://www.mysite.comSave Path /WS_CAT /ERROR: Google Images Sitemap Generation FAILED!Opening /sitemap_mobileindex.xmlFS_CAT Server http://www.mysite.comSave Path /WS_CAT /ERROR: Google Sitemap Index Generation FAILED!Array( [QUERY] => Array ( [PRODUCTS] => Array ( [STATUS] => success [NUM_ROWS] => 2343 ) [CATEOGRY] => Array ( [STATUS] => success [NUM_ROWS] => 280 ) [IMAGES] => Array ( [STATUS] => success [NUM_ROWS] => 2343 ) ) [SAVE_FILE_XML] => Array ( [0] => Array ( [file] => /sitemap_mobileproducts.xml [status] => failure [file_exists] => false ) [1] => Array ( [file] => /sitemap_mobilecategories.xml [status] => failure [file_exists] => false ) [2] => Array ( [file] => /sitemap_mobileimages.xml [status] => failure [file_exists] => false ) [3] => Array ( [file] => /sitemap_mobileindex.xml [status] => failure [file_exists] => false ) )) Completed!
  5. akmac

    Google XML Sitemap SEO

    Just sent you the links. I'm sure I'm missing something simple, but darned if I can find it...
  6. akmac

    Google XML Sitemap SEO

    Found the display error code and changed it manually, still nothing written to the xml files, and no errors showing. Somewhere along the line I doubled up on the mysql insert though, because I have some entries repeated on my Google XML SEO configuration page: Enable Images Map true Enable Images Map false Enable Manufacturers Map false Enable Mobile Map false Enable Mobile Map false Enable Specials Map false Enable Standard Pages Map false Enable Article Manager Topics Map false Enable Article Manager Topics Map false Enable Diagnostic Output true Exclude these pages Mobile URL http://mobile_domain.com/ Mobile URL http://mobile_domain.com/ It's a head scratcher! (for me)
  7. akmac

    Google XML Sitemap SEO

    Hi Jack, Ok, I was previously running version 1.2, but it doesn't appear to have been working for quite a while. I implemented the changes in the update docs (ran the sql and added the code block to admin/includes/functions/general.php). I deleted the old googlesitemap directory and all its contents and replaced it with the 1.9 version. Navigated to the googlesitemap/index.php on my site and am still getting blank xml files and no diagnostic output. I do have a heavily modified osc install, so maybe it's conflicting with something else...
  8. akmac

    Google XML Sitemap SEO

    Hi Jack, I uploaded the new files (was running one from 2006) to my server, ran the sql, and changed permissions to 777 on the ones I want to use, but the xml files are empty. I Enabled diagnostic Output, but where is it generated? I assumed it would be on mysite.com/googlesitemap/index.php, but I don't see any errors. When I navigate to the xml files I get: XML Parsing Error: no element found Location: http://www.mysite.com/sitemapcategories.xml Line Number 1, Column 1: Does this contrib work on older 2.2MS2 sites? Thanks for your time!
  9. akmac

    Google Tag Manager

    Where should the code be pasted on a 2.2 ms2 install? Header or footer maybe?
  10. Hello all, I'm attempting to switch to authorize.net and have installed Harald's AIM module. Before I can go about fiddling with further configuration, I've noticed that this module moves the payment form from the payments page to the confirmation page-which is not user-friendly. Does anyone have an idea on how to move it back to the payments page? Should I be using a different module? Any help appreciated!
  11. Jim, Thanks very much for the rapid response! That's a bummer. I have a number of mods on that page... FEC and CCGV. I'm no coder, but can copy/paste bits if the instructions are written for a 9 year old. Are you aware of a mod anywhere that I might be able to use to combine the pages?
  12. akmac

    [Support] TrustCommerce payment module

    I just updated to the most recent version and am getting this error when I click "Install" in admin/modules/payment/trustcommerce 1062 - Duplicate entry '0' for key 1 INSERT INTO trustcommerce_avs (avs, avs_description) VALUES ('0', 'General decline or other error.'), ('X', 'Exact match, 9 digit zipcode.'), ('Y', 'Exact match, 5 digit zipcode.'), ('A', 'Street address match only.'), ('W', '9 digit zipcode match only.'), ('Z', '5 digit zipcode match only.'), ('N', 'No match on street address or zipcode.'), ('U', 'AVS unavailable on this card.'), ('G', 'Non-US card issuer, AVS unavailable.'), ('R', 'Card issuer system currently down, try again later.'), ('E', 'Error, ineligible - not a mail/phone order.'), ('S', 'Service not supported.'), ('O', 'Not applicable.'); [TEP STOP] Any help?
  13. akmac

    Header Tags SEO

    Installed and running great for a few months now-BUT I noticed that the breadcrumb trail is now "mirroring" itself. Instead of reading: home > Parent category > subcategory > product name > Meta information It's reading (in a category): Meta information > sub category > home > parent category > Sub category And for a product: Meta Information > Sub category > Item Name > Home > Parent Category > Sub Category > Item style # Any idea why it's listing some information twice now?
  14. Hello Simon,

    Do you have a support thread for this contribution? I noticed that if a product has an apostrophe in the title, the image won't show at all.

  15. akmac

    Header Tags SEO

    Have you run fill tags yet?
  16. akmac

    Header Tags SEO

    Apologies for the confusion. The portion that is now working is the slashes being stripped from the text. Also, the generic override in Admin/Fill Tags is correctly adding the category titles and descriptions to the category pages that the customers can see, but it is not "overriding" the Meta Tags for the same categories. In other words, the title and description text on the category pages is appearing, but the title, description, and keywords meta tags for the category pages are remaining the default tags set in page control. It's entirely possible that I'm misunderstanding the function of the mod-but I assumed that the category meta tags would be customizeable in Fill Tags/Generic Override. Is this correct?
  17. akmac

    Header Tags SEO

    It works-Thanks! I've changed the other three lines accordingly. Slashes are now stripped correctly. New question: It doesn't appear that the generic override is replacing the category head tags, as I'm still getting the generic title, description and keywords tags in the categories I just tested. The text on the page is displaying correctly, but the meta tags are all still generic. Am I doing something incorrectly?
  18. akmac

    Header Tags SEO

    For example, I have the category Men's Rings. With subcategories of different types. If the apostrophe appears in the category name (ITEMNAME) it appears correctly, but when I write "Men's rings from Blah blah ship free to Elbonia", the slashes before the apostrophes appear in the category titles and category descriptions. I'm writing them manually in the fill tags "generic Override" section.
  19. akmac

    Header Tags SEO

    Disregard previous post- Fill all tags only fills the selected tags when only some categories are checked. New question- Is there a way to keep slashes from appearing in the text? All my apostrophes/' look weird...
  20. akmac

    Header Tags SEO

    OK, it appears to be functioning correctly upon running fill tags a second time. Now, I am going back and customizing the category descriptions for each category per the instructions on the docs, but there is one area that is not explicit. I would like to select category groups in the "Filter by Category" section and give them all the same category description (except for the ITEMNAME) but I don't see a radio button option for "Fill selected tags" in options at the bottom. Do I select Fill all tags, and trust that it will only fill the selected tags-or is what I'm trying to do impossible? (I don't want to overwrite the category descriptions I've already customized manually)
  21. akmac

    Header Tags SEO

    great. Now getting this error: Fatal error: Maximum execution time of 30 seconds exceeded in /blahblah/admin/includes/functions/header_tags.php on line 490 Any ideas?
  22. akmac

    Header Tags SEO

    Running the headertags_seo_update.sql did not work as expected. it ran fine in phpmyadmin, but when I'd made all the file changes I was getting a tep-stop error on all category and product pages. Panicking, I uploaded and ran the uninstall script, knowing it would delete all my previous tags, but that's better than a dead site. That returned an error, so I uploaded the install script and ran it (which also returned an error), then ran the uninstall script (worked this time), and the install script once more (which seems to have worked). SO, I lost my previous tags. trying now to get them filled again...
  23. akmac

    Header Tags SEO

    I am currently running header tags controller 2.3.7 on the live site. So, will running headertags_seo_update.sql work? I don't mean to be redundant, I just want to be sure that the headertags_seo_update.sql file is correct because none of the Update_Docs reference a version as old as the one I'm currently running. They start at 2.6.3 and I'm running 2.3.7.
  24. akmac

    Header Tags SEO

    Jack, OK, I got this up and running on my dev site (I had made a copy/paste error not deleting enough code from the earlier version in admin/includes/categories.php). Now I would like to install it on the live site using the edited files from the dev site, but I don't want to lose all the header tags info already in the db. To get this running on the dev site I ran the uninstall sql then the install sql, but naturally that emptied all existing tags. I see that there are some update sql files for people who are upgrading, but they only go back to 2.6.x and I have 2.3.x installed. Should I run one of the update files, or do I need to start from scratch like on the dev site?
  25. akmac

    Header Tags SEO

    Yes-unfortunately it isn't available for mac. The nearest I have is the "compare files" option in an old copy of Golive. I'll try to reinstall the mods to that file incrementally and see where it gets me. Unfortunately, I have zero PHP skills so an out of place character looks just like the rest of the Greek to me. ;-)
×