Jump to content

thiartj

Members
  • Content count

    31
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Johan Thiart
  1. @Jack_mcs, Wow!! That was a weird one to troubleshoot, thanks Jack I changed product title and now it works.
  2. @@Jack_mcs Hi Jack, I was incorrect that products was created after SEO Url changes done for Mobile website since I see last working product was create 11 May 2015 and Mobile OSC was installed with SQO URL's update 13 May 2015 so yes no new products created after Mobile OSC Install and SQO URL's changes to support Mobile OSc
  3. @@Jack_mcs, Hi Jack please see example (the first 2 newly created products listed on www.hdcabling.co.za), from the 3rd one it works fine.
  4. @Jack_MCS, picture of new product is correct on home page and when SEO Url's switched off and product link opened other information is also displayed fine.
  5. @@Jack_MCS, When I duplicate a previous product working it also works. Path is generated fine on new and old duplicate products, except the new product does not work when clicked on it and it redirects back to the main page. When editing a cloned product and saving it / all details changed then it does not work again. Disabling SEO URL's is working. This is very odd since I used this add-on fir a long time and we created products after the Mobile OSC Changes and after a few weeks now we cannot get new products to work.
  6. @@Jack_mcs Hier Jack, I tried uninstalling and receive the error below Warning: array_merge(): Argument #2 is not an array in "path removed" /configuration.php on line 79 Warning: reset() expects parameter 1 to be array, null given in "path removed" /object_info.php on line 17 Warning: Variable passed to each() is not an array or object in "path removed" /object_info.php on line 18
  7. @@Jack_Mcs adding to above it does the same on mobile OSC site for newly created products.
  8. @Jack_mcs, Hi Jack, when we create a new product it is displayed on homepage but when clicked on it it does not open and take me back to homepage. Same if we search for the product and click on it is is redirected to home page. For old products on home page and search this works fine. When SEO Url's disabled the product work normally but then all products SEO Url optimization is switched off. Any ideas ? We only created a product now after a month, I did clear SEO Cache as well on admin side.
  9. @Jack_mcs Thanks Jack I think that will do the trick, I will monitor it next 2 days
  10. @Jack_mcs, Hi I have checked with Service provider and mod_security is disabled. Is there a file or database field I can edit to set default Filter Short words to 0 ? This is the only option I change from default config hence other options are fine on default.
  11. @@raiwa, Hi after Mobile IOSC installation we receive the error below when running a .php script to feed products to another website. The URL for the feed is http://www.hdcabling.co.za/bidorbuy.php?debug=0&zip=0&add_vat=1. The company providing the feed does not know either why the error below occurs and I told them no SQL security changes were done and not sure why this would occur after mobile upgrade. If you have any ideas please let me know since it seems like an authentication issue but from tests below it is not SQL database related. Nowhere in the .php file is user 'hdcablin' specified only in the configure.php "Warning: mysql_query(): Access denied for user 'hdcablin'@'localhost' (using password: NO) in /home/hdcablin/public_html/bidorbuy.php on line 292 Warning: mysql_query(): A link to the server could not be established in /public_html/bidorbuy.php on line 292 Access denied for user 'hdcablin'@'localhost' (using password: NO)" On the specific bidorbuy.php file line 292 code below $results = mysql_query($products_query) or die(mysql_error()); When I create a subdomain with old FTP backup before iOSC Mobile website Installation and using the same database as after mobile upgrade the code works fine as at http://test.hdcabling.co.za/bidorbuy.php?debug=0&zip=0&add_vat=1. I really need someone's help on this since I am clueless on where the error could be and skills on .php very poor since it works on the same database from pre-mobile iOSC install.
  12. @@Jack_mcs, thanks will speak to service provider to disable it.
  13. thiartj

    [Addon} Modular SEO Header Tags

    @kymation Hope you can assist, I was referred to @@Gergely but see no response from him. I noticed after installing Mobile Site under header tags for alternate mobile links that the source for alternate is generated for desktop version e.g. http://www.hdcabling...tCancelled=true as mobile version / alternate link http://mobile.hdcabl...eters-p-78.html When I copy and paste this into a browser it does not work and gives a NOT Found page error, the actual link on mobile site is http://mobile.hdcabl...tCancelled=true where the -p- in SEO URL is changed to -mp-. Is this normal and is the -mp- generated when switched to mobile view and will this affect google crawling ? I am using modular_seo_header_tags_1.4.6_min as at http://addons.oscommerce.com/info/7646 with the Mobile add-on v1.0 on the same add-on page. I noticed on mobile site that the canonical tags point to mobile site version -mp- where it should point to desktop version -p- product page e.g <link rel="canonical" href="http://mobile.hdcabl...ers-mp-78.html" /> is shown on mobile product pages and on desktop version as the alternate mobile link shows <link rel="alternate" media="only screen and (max-width: 640px)" href="http://mobile.hdcabl...ters-p-78.html" /> which should include the -mp- to mobile website and not the -p- URL. I have Ultimate_SEO_URLSv22d_14a installed for SEO URLS and the Ultimate SEO 2-2.2d-14a Updates for Mobile iOSC 7.5
  14. @@Jack_mcs Hi Jack, when I set Filter short words to 0 after a few hours when I login to admin again this value changes back to 3 ? Can you please assist since currently Google is seeing Duplicate Title tags since URL's it crawled has 0 short words and other 3 and it is the same product but with different URL.
  15. thiartj

    [Addon} Modular SEO Header Tags

    @@Gergely, below initial post on problem in iOSC Thread " Hi I noticed after installing Mobile Site under header tags for alternate mobile links that the source for alternate is generated for desktop version e.g. http://www.hdcabling...tCancelled=true as mobile version / alternate link http://mobile.hdcabl...eters-p-78.html When I copy and paste this into a browser it does not work and gives a NOT Found page error, the actual link on mobile site is http://mobile.hdcabl...tCancelled=true where the -p- in SEO URL is changed to -mp-. Is this normal and is the -mp- generated when switched to mobile view and will this affect google crawling ? "
×