Jump to content

allymacneil

Members
  • Content count

    156
  • Joined

  • Last visited

1 Follower

About allymacneil

  • Birthday 10/30/1975

Profile Information

  1. allymacneil

    Optional Related Products, Version 4.0

    Hi there, I was looking through the thread for an example of the contribution on a live site, the couple of links I clicked on where broken or did not have the contribution installed. Could you post a few links of sites with the contribution working. Thanks, Ally
  2. allymacneil

    Protx Direct v2.22

    Vger/Tom, Thanks for your replys. Am going forward with a Streamline/Protx VSP Direct solution. Have also discovered that if you are a member of the Federations of small businesses the set up at streamline is free (takes the pain out of a separate merchant account for virtual terminal) The processing rates for streamline with Federation of Small business membership are 1.98% - Mastercard 1.95% - Visa 30.5p per Maestro Cards transaction £130 membership to FOSM, think I will join
  3. allymacneil

    Protx Direct v2.22

    Hi there, I am getting ready to use protx for the first time. I very much would like the benefits of keeping the customer on the site for the whole transaction and only sending encrypted data to Protx which I believe is what is happening with Protx Direct. When I look at the protx site though, is the self certification necessary because the CC details are transmitted from the secure server to protx and not done directly on their site? http://www.protx.com/products/vsp_direct.asp "Certification under the PCI audit. As credit card details are collected by you and not by Protx, you may be required to undergo an audit to ensure that credit card data is kept secure. Click here for more information" ie. credit card details are only transmitted between server and protx not stored on server? Thanks, Ally
  4. allymacneil

    [CONTRIBUTION] Nochex APC Payment Module

    I have the same problem with it sending out order confirmation emails before the payment is collected - also seems stupid as there are a number of abandonments at this point (am seriously thinking of switching to Google Checkout) Does this not happen for you, maybe it is a quirk in my setup Maybe we can work together... Do you have skype or IM.
  5. allymacneil

    new install but no payment mods HELP!!!!

    I changed: define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT); to define('DIR_FS_DOCUMENT_ROOT', '/var/www/test/'); and all works, I can now see settings in Admin -> Modules -> Payment, shipping and order total. HTH, Ally
  6. allymacneil

    [CONTRIBUTION] Nochex APC Payment Module

    Reinstalled the latest contrib from 15th December that uses NOChex new Payment Pages and now have it working, here's what I did: Warning: ereg() [function.ereg]: REG_EMPTY in /home/footdeto/public_html/checkout_nochex.php on line 226 Looking at the code I changed: if(ereg($order->info['currency'],MODULE_PAYMENT_NOCHEX_APC_ALLOWED_CURRENCIES)) { $nochex_currency = $order->info['currency']; } else { $nochex_currency = MODULE_PAYMENT_NOCHEX_APC_DEFAULT_CURRENCY; } to $nochex_currency = $order->info['currency']; around line 242 change "amount=".urlencode(number_format($order->info['total'] * $currencies->currencies['GBP']['value'], $currencies->currencies['GBP']['decimal_places'])), to "amount=".urlencode($order->info['total']), if you also add in this line after it you will not get the delivery address appearing "hide_billing_details=".urlencode('true'), I then logged in to Nochex control panel to customise "Payments Page Setup" so as the Nochex pages looks like my site. For creating osC buttons this is a great site http://www.oscbuttons.com Also in checkout_success.php I changed what the contib says to add to the following: //BOF NOCHEX $orders_query = tep_db_query("select orders_id from " . TABLE_ORDERS . " where customers_id = '" . (int)$customer_id . "' order by date_purchased desc limit 1"); $orders = tep_db_fetch_array($orders_query); $sql_data_array = array('orders_id' => $orders['orders_id'], 'orders_status_id' => '50001', 'date_added' => 'now()', 'customer_notified' => '0', 'comments' => 'NoChex Returned to Checkout Scuccess'); tep_db_perform(TABLE_ORDERS_STATUS_HISTORY, $sql_data_array); tep_db_query("update " . TABLE_ORDERS . " set orders_status = '50001', last_modified = now() where orders_id = '" . (int)$orders['orders_id'] . "'"); $NAVBAR_TITLE_2 = NOCHEX_NAVBAR_TITLE_2_OK; $HEADING_TITLE = NOCHEX_HEADING_TITLE_OK; $TEXT_SUCCESS = NOCHEX_TEXT_SUCCESS_OK; $cart->reset(TRUE); //EOF NOCHEX That got things to work for me in my store which is already heavily modedfied of the stock osC store HTH, Ally B)
  7. allymacneil

    [CONTRIBUTION] Nochex APC Payment Module

    Thats further than I got. I didnt get that module to work, when I installed it and tried to make a payment I got: I then uninstalled it and have installed the previous version, am waiting for my nochex merchant account to be enabled to day to start going forward again.
  8. allymacneil

    [CONTRIBUTION] Nochex APC Payment Module

    Paul is it the 15 Dec 2006 version you have installed, I think it is this afternoon that my account is to be activated will likly be working on it tonight. No Joy with any response from the original other
  9. allymacneil

    [CONTRIBUTION] Nochex APC Payment Module

    MightyMidget, I PM'd SlickUK who submitted the last update and he said he was not the third party that had updated it but would get in touch with them to see if they would be willing to look in on this thread to possibly help out...
  10. allymacneil

    [CONTRIBUTION] Nochex APC Payment Module

    Hi Paul, I have uninstalled the latest version (15 Dec 2006 ) and rolled back to version 6 Sep 2004, installed okay and is doing the same as yours, My merchant account should be acctivated tomorrow, I think the version I just uninstalled had an option in the admin panel for Merchant or seller which would have distinguished what page to send you to (I beleive), I've just looked at the previous version, Secure (SSL) Payment via Nochex (6 Sep 2004) and there is no such option. If you figure this out before me, appreciate if you could give any pointers, thanks, ally
  11. allymacneil

    [CONTRIBUTION] Nochex APC Payment Module

    Have also installed the contrib from 15th Dec and having problems. When I click to confirm Payment the site www.footdetox.uk.com goes to /checkout_nochex.php but this is what is displayed: In Admin Payment Modules it says: Credit or Debit Card (via Nochex) Enable Nochex + APC Module - True Nochex Account Type - seller E-Mail Address - my nochex address Checkout Mode - test When I click on Nochex APC -> Transactions, I get the error: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-100, 100' at line 1 select * from nochex_apc_transactions order by transaction_id desc limit -100, 100 [TEP STOP] I have made all the .txt changes, added all the php files, double checked having made the file changes and uploading them and running the sql and that the new table exists. Can anyone help before I roll back the changes and try a previous or other nochex contrib, was wanting to upgrade my account to merchant and this seemed just like the ticket
  12. allymacneil

    Attribute Qty Product Info

    Instruction file still has this descrepency, found another also In the instruction file for application top it says this: when I add a product to the cart I was getting no option or price, when I compared it to the application_top.php file I found this was another typo, when I changed my code to be the same as in the application_top.php file, it worked for me: $c = array((int)$HTTP_POST_VARS['b'] => (int)$value); hth, ally
  13. allymacneil

    Numpty question - button image font?

    Had just been googaling on the same thing, Heres a great tool: http://www.oscbuttons.com/index.php :thumbsup:
  14. Hi there, up untill recently I had been using the: "On the Fly Thumbnailer" using PHP GD Graphics Library by Nathan Welch (v1.5) Used in conjunction with product_thumb.php thumbnail generator. This was producing good results but my page loads where slower than I wanted and my host kept telling me that if an extra php file had to be called 20 times a category page was loaded (or how ever many thumbnails there where) it was going to slow things down. Took the plunge this evening and installed Automatic Thumbnail http://www.oscommerce.com/community/contributions,1484 It was faster but the thumbnails where awful. By this point I'd understood a little more what was going on, got back in touch with my host and he gave me the idea to use the code from the on the fly thumbnailer to calulate the width and height for the thumbnails which I did and things are now much better. Posting the change here, if people want to comment on how well this works for them I will add it as a new package to the contrib so people trying it for the first time can benefit. in catalog/includes/functions/html_output.php find // Do we calculate the image size? if (CONFIG_CALCULATE_IMAGE_SIZE && !$dont_calculate) { // Get the image's information if ($image_size = @getimagesize($src)) { $ratio = $image_size[1] / $image_size[0]; // Set the width and height to the proper ratio if (!$width && $height) { $ratio = $height / $image_size[1]; $width = intval($image_size[0] * $ratio); } elseif ($width && !$height) { $ratio = $width / $image_size[0]; $height = intval($image_size[1] * $ratio); } elseif (!$width && !$height) { $width = $image_size[0]; $height = $image_size[1]; } // Scale the image if larger than the set width or height if ($image_size[0] > $width || $image_size[1] > $height) { $rx = $image_size[0] / $width; $ry = $image_size[1] / $height; if ($rx < $ry) { $width = intval($height / $ratio); } else { $height = intval($width * $ratio); } $image = '<img src="product_thumb.php?img='.$src.'&w='.tep_output_string($width).'&h='.tep_output_string($height).'"'; } replace with if ((CONFIG_CALCULATE_IMAGE_SIZE == 'true' && $src != DIR_WS_IMAGES . 'pixel_black.gif' && $src != DIR_WS_IMAGES . 'pixel_trans.gif' && $src != DIR_WS_IMAGES . 'pixel_silver.gif' )) { $ratio = $image_size[1] / $image_size[0]; // Set the width and height to the proper ratio if (!$width && $height) { $ratio = $height / $image_size[1]; $width = intval($image_size[0] * $ratio); } elseif ($width && !$height) { $ratio = $width / $image_size[0]; $height = intval($image_size[1] * $ratio); } elseif (!$width && !$height) { $width = $image_size[0]; $height = $image_size[1]; } // Scale the image if larger than the set width or height if ($image_size[0] > $width || $image_size[1] > $height) { $rx = $image_size[0] / $width; $ry = $image_size[1] / $height; if ($rx < $ry) { $width = intval($height / $ratio); } else { $height = intval($width * $ratio); } $src=thumbimage(DIR_FS_CATALOG . '/' .$src, $width, $height, 1, 1, DIR_FS_CATALOG . '/' . DIR_WS_IMAGES . 'imagecache'); if ((($image_size[1]/$height) > ($image_size[0]/$width) ) && $height>0) { $width=ceil(($image_size[0]/$image_size[1])* $height); } elseif ($width>0) { $height=ceil($width/($image_size[0]/$image_size[1])); } } } That should be it, wanting to test it here before uploading to the main contrib area Results using on the fly thumbnailer with product_thumb.php Family category -> Parse time = approx 0.055 - 0.60 -> page loads in approx 900ms (using firebug plugin for fire fox) All Products -> Parse Time = approx 0.110 - 0.120 - > Page loads in approx 4.3 secs Results using Automatic Thumbnail with change above Family category -> Parse 0.078 -> page loads approx 700ms All Products -> Parse 0.370 - 0.390 -> page loads in 2.28 secs parse times a little longer but the pages are loading quicker HTH, Ally :thumbsup:
  15. :thumbsup: Thanks again Chris, it works now with the way it was The blog links go where they are supposed to, so http://test.newlifehealthcare.co.uk/blog.p...fatty-acids.php goes to a blog page, essentially a redirect on: http://test.newlifehealthcare.co.uk/blog.php Catlog links however http://test.newlifehealthcare.co.uk/family-c-50.html display the correct url in the address bar but display the contents of the blog page http://test.newlifehealthcare.co.uk/blog.php Blog links display the correct url in the address bar http://test.newlifehealthcare.co.uk/blog.p...index-diets.php and the contents of the http://test.newlifehealthcare.co.uk/blog.php page which is correct (it isnt clever enough to be displaying just that post yet) And catalog pages: http://test.newlifehealthcare.co.uk/body-care-c-25.html DISPLAYS CATLOG PAGES, YOU ARE A STAR :thumbsup: SHOP WORKS, CAN ADD TO CART etc again ah you are great, I love open source, I love people who help the little guy, thanks for taking the time to help me out ally
×