Jump to content

Predd0

Members
  • Content count

    162
  • Joined

  • Last visited

Everything posted by Predd0

  1. We have a website, Amino Z, which has been built on osCommerce. As you can see, it is very heavily modified. We have personal training clients that we bill weekly and we currently use a third-party company to process these payments for us (via credit card and also out of their bank account). But because it works out so much cheaper for us to do the recurring debits ourselves (though ANZ eGate for credit cards or the bank for bank transfers), I am looking for a software solution for this. Does anyone know of some billing software we can utilise for this? It needs to have a recurring payment option and also basic reporting capabilities. Thanks in advance!
  2. Contribution URL: http://addons.oscommerce.com/info/871 Just downloaded and installed the latest version of Order Logging 3.0. Great contribution. Got an idea for an enhancement. In the admin, if an order isn't procesed correctly but is logged, a button could be there to convert the logged entry into an order. In addition to this, the customer would be send an order notification, identical to if they did return to checkout_success.php originally.
  3. Okay I've installed the script and submitted to Google. Google gets back to me with "ERRORS". Upon clicking on ERRORS it displays the following error message: General HTTP error General HTTP error: 200 (Success) [?] I open the sitemap up in my browser and it appears in XML format and all seems to be correct. I've tried browsing through this thread for a similar problem but have been unable to locate one. PS. I have not included application_bottom. I have put the sitemap in the main directory (www.domain.com/sitemap.php). Any help most appeciated!
  4. Couldn't track down a thread specific to the SID Killer - so I've started this one. I have installed it at http://www.aminoz.com.au If you go there, the ID still shows in the URL sometimes - and I can't work out why! Upon going there initially, the ID tag shows up in the URL and I suspect this could be from the Autologin mod I've installed. Whilst this goes away on the next click, it seems as though other visitors browsers keep it in the URL. Any ideas?
  5. Predd0

    Shipping Zone Rates with SQL

    I've installed the 'toll zip zones' contribution, that calculates shipping rates based upon your postcode and total weight (from a huge SQL table). What I'd like to do is insert a field on the product page where the user can type in their post code and a popup will display the shipping price of that product only. Has anyone got any ideas? Thanks!
  6. I've installed the 'toll zip zones' contribution, that calculates shipping rates based upon your postcode and total weight (from a huge SQL table). What I'd like to do is insert a field on the product page where the user can type in their post code and a popup will display the shipping price of that product only. Has anyone got any ideas? Thanks!
  7. Predd0

    Wishlist 2.0 Support Thread

    Issue # 2 (revised) DId some more testing and found out it's not a problem with items that don't have attributes. Rather, if you don't add in a message in the message field (when emailing to a friend), no products will be displayed.
  8. Predd0

    Wishlist 2.0 Support Thread

    Jorgeo Issue # 2 When a product without attributes is added onto the wishlist, I've tried to use the 'email to a friend'. However the email has no products in it at all...
  9. Predd0

    Wishlist 2.0 Support Thread

    Jorgeo Thanks for adding the wishlist.php addon. I've added it in and so far I've come up with one issue: I added a product without any attributes to be chosen. When I added it, it took me to my wishlist page and successfully added it in. HOWEVER there was an error message at the top of the page: Lines 449-450 in application_top.php are: Cheers
  10. Predd0

    Wishlist 2.0 Support Thread

    hrmmm...am I missing something because I can't find the coding to put into wishlist.php.
  11. Predd0

    Wishlist 2.0 Support Thread

    Sounding good mate!
  12. Predd0

    Wishlist 2.0 Support Thread

    ah actually on 2nd thought...I think that type of coding is beyond my self-taught php skills (or lack of) lol. I'm 2nd in line for testing!
  13. Predd0

    Wishlist 2.0 Support Thread

    Jorgeo: Ah cool sounds good...in theory anyways :P I'll give it a go and post it up if I can get it working. gl with the exam too :)
  14. Predd0

    Wishlist 2.0 Support Thread

    Just wondering if there's any way to incorporate attributes into the wishlist? So you can select what colour you want the product on the product page, and then add it to the wishlist. On the emails it would include these attributes too. Also when you move the product to the cart.
  15. Predd0

    Wishlist 2.0 Support Thread

    worked it out :D Used jorgeo's idea but put it into application_top (where the process actually occurs). This is my new coding for case 'add_wishlist':
  16. Predd0

    Wishlist 2.0 Support Thread

    jorgeo Thanks for the help...but it won't work. Basically because when the user loads the page, they will already be logged in. All customers already have an ID of greater than 0 so the wishlist will display. If the session times out, exactly the same thing is going to happen, they will be diverted to the login page and the SQL entry will have a customer_id of 0. Any other ideas?
  17. Predd0

    Wishlist 2.0 Support Thread

    I've installed the WishList 2.0 at http://www.audiocave.com.au But I have a big bug. If someone is logged in and they goto the product page and add a product to their wish list, it works fine. BUT if they add it once their session has timed out, they are redirected to login. Then they can login again and the product is in their wish list. Here's the problem: you can't delete this item or move it to the shopping cart. After further investigation, ALL users will now have this item in their wishlist, and cannot delete/move to cart. I looked at the SQL table, and the customer_id field in the customer_wishlist table is set to 0. Does anyone know how to get around this bug? Thanks heaps!
  18. I've just put up a new contrib. This mod for 2.2 CVS. Current as of July 2004. It's a modified version of Lloyd Swadling's Toll courier rates. This mod is now for TNT Australia. However I have got a bug in it and was wondering if anyone could help out. I've Changed shipping charge calculation to the following: total shipping = {[x * (y - 15) + z]*1.10 * a}+ b where: x= charge per kilo over 15kg (changed in sql table) y= total weight (I have deducted 15 kg from this because weight charge is only over 15kg) (total weight derived from product listing) z= consignment charge (changed in sql table) a= surchage factor (default 1.1) b= handling fee (changed in oscommerce admin) and the 1.10 bit is for GST The only big bug I have is in the php file in catalog\includes\modules\shipping\. On line 90 I have the equation to calculate the final shipping cost. However if the product weight is LESS than 15kg, you will receive an incorrect shipping calculation (try it yourself in the equation above). Unfortunately my programming skills aren't very good at all so if anyone knows the correct syntax for an IF statement would you be able to help out please? Basically to say the following: IF product weight (y) is LESS than 15 then perform following equation: {[z]*1.10 * a}+ b IF product weight is 15 kg or MORE then perform following equation: {[x * (y - 15) + z]*1.10 * a}+ b Thanks! http://www.oscommerce.com/community/contributions,2266
×