Latest News: (loading..)

current

Members
  • Content count

    12
  • Joined

  • Last visited

1 Follower

About current

Profile Information

  • Real Name
    Kevin McDonald

Recent Profile Visitors

2,365 profile views
  1. Hi There all, I have installed the module, and I am able to send a newletter and preview it in my admin. The emails arrive well. However newsletter that are viewed online through "view_newsletter.php" show up empty and no information is showed, just the heading "View Newsletter". It does provide the correct newsletter number. It looks like the page is abruptly broken off because the other columns are not displayed either. My gues is that it has something to do with the:echo $module->html_content(); but I am not sure. --------- <?php $Id$ osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright (c) 2010 osCommerce Released under the GNU General Public License require('includes/application_top.php'); require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_VIEWNEWS); $breadcrumb->add(NAVBAR_TITLE, tep_href_link(FILENAME_VIEWNEWS)); require(DIR_WS_INCLUDES . 'template_top.php'); require('includes/application_top.php'); ?> <h1><?php echo HEADING_TITLE; ?></h1> <div class="contentContainer"> <div class="contentText"> <? $nID = (isset($HTTP_GET_VARS['nID']) ? tep_db_prepare_input($HTTP_GET_VARS['nID']) : 0); //newsletter products $newsletter_query = tep_db_query("select title, content, module, template from " . TABLE_NEWSLETTERS . " where newsletters_id = '" . (int)$nID . "'"); if (tep_db_num_rows($newsletter_query) == 1) { $newsletter = tep_db_fetch_array($newsletter_query); $newsletter_products_query = tep_db_query("select products_id from " . TABLE_NEWSLETTERS_TO_PRODUCTS . " where newsletters_id = '" . (int)$nID . "'"); while ($newsletter_products = tep_db_fetch_array($newsletter_products_query)) { $news_products[] = $newsletter_products['products_id']; } $newsletter['products'] = $news_products; if ($newsletter['module'] == 'newsletter_products') { include('catalog/admin/includes/modules/newsletters/newsletter_products.php'); include('catalog/admin/includes/languages/english/modules/newsletters/newsletter_products.php'); $module = new newsletter_products($newsletter['title'], $newsletter['content'], $newsletter['products'], $newsletter['template']); }}*/ echo $module->html_content(); } else { echo nl2br($newsletter['content']); } //end newsletter products } else { echo TEXT_NOT_FOUND; } echo "\n"; ?> </div> <div class="buttonSet"> <span class="buttonAction"><?php echo tep_draw_button(IMAGE_BUTTON_CONTINUE, 'triangle-1-e', tep_href_link(FILENAME_DEFAULT)); ?></span> </div> </div> <?php require(DIR_WS_INCLUDES . 'template_bottom.php'); require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>
  2. @@auzStar Thank you for your response. However I do not have this option as there is not link that says "content". It almost looks like I have to upgrade the admin panel first before I can see that actual "content" link you are referring to. Is this correct. Thank so much.
  3. Hi, am I missing something here... I have to keep the folder structure intact, but how can I install modules if I do not see the content link in Modules (admin panel)? Should I install something else first? I normally install modules under header tags.Thanks everyone. Go to "admin->modules->content" then: -> "Install Module" -> "Category Name" -> "Install Module" -> "Category Messages" -> "Install Module" -> "Category Description" -> "Install Module" -> "Category Sub-categories Listing" -> "Install Module" -> "Category New Products" -> "Install Module" -> "Category Upcoming Products"
  4. Hi there, My problem I describe here starts already with the jQuery Owl Carousel v1.3.3 installation which I can install, However I cannot edit. It provides an error when I click on edit in admin header tags module: Call to undefined function tep_cfg_disabled() in /home/xxx/public_html/catalog/admin/modules.php(232) : eval()'d code on line 1 All the order modules we installed under are working just fine, so it is not likely in the modules.php file. I looked through the code of the 2 files used by this carousel, but the code checker I use (http://phpcodechecker.com/) provides many errors on the files mostly to do with brackets etc. I have modified the files so it actually does not provide errors, but the error described above is still there. But all you people do not have any problems, so why do I get this error. I use OSCommerce V 2,3,4 bootstrap. I also uploaded the files in the ext folder. Any suggestions?
  5. Thanks Harald, that works as well indeed. :)
  6. After putting backups back and spending hours on this issue, we finally figured it out. Problem description: V2.3.4 Oscommerce with PayPal Express Modules. When an item is in the cart and send to paypal Express the site correctly went to the PayPal site with the item, but as soon as you hit the button "Pay Now" the Paypal site is authorizing the payment and then after a few seconds goes back to the store without processing the order. No error mails where provided, so we had no clue except that the transaction was cancelled in some strange way. The solution is in the the catalog/includes/configure.php file and two lines we changed were from: define('HTTP_COOKIE_DOMAIN', 'http://www.yourdomain.com'); define('HTTPS_COOKIE_DOMAIN', 'https://www.yourdomain.com'); to: define('HTTP_COOKIE_DOMAIN', ''); define('HTTPS_COOKIE_DOMAIN', ''); I hope this helps with anyone having a similar problem.
  7. After putting backups back and spending hours on this issue, we finally figured it out. Problem description: V2.3.4 Oscommerce with PayPal Express Modules. When an item is in the cart and send to paypal Express the site correctly went to the PayPal site with the item, but as soon as you hit the button "Pay Now" the Paypal site is authorizing the payment and then after a few seconds goes back to the store without processing the order. No error mails where provided, so we had no clue except that the transaction was cancelled in some strange way. The solution is in the the catalog/includes/configure.php file and two lines we changed were from: define('HTTP_COOKIE_DOMAIN', 'http://www.yourdomain.com'); define('HTTPS_COOKIE_DOMAIN', 'https://www.yourdomain.com'); to: define('HTTP_COOKIE_DOMAIN', ''); define('HTTPS_COOKIE_DOMAIN', ''); I hope this helps with anyone having a similar problem.
  8. Is the issue on Paypal Express V3.1 resolved with chrome when the client in paypal presses "Pay Now", It brings it back to the store and empty the cart without the payment actually processed?
  9. Try in Internet explorer and it works, but Chrome will not process it correctly.... I do not know why yet.
  10. We had a similar problem with Paypal Express 3.1. Without SSL, paypal includes Shipping and Taxes worked fine fo than a year. We installed SSL and with SSL Enabled and tested o.k. now Paypal completely ignores shipping and taxes. Luckily we found out sone enough without losing money. We tried and disabled Paypal Instand Update by setting it in the payment module of OSCommerce V2.3.4 to False and now everythings seems to work fine. Try and check please. Thanks Kevin.