Jump to content

whoolieshop

Members
  • Content count

    10
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Shane Martin
  1. @@raiwa Okay just to confirm, Authorize.net's SIM module seems to work just fine with the mobile version with no config changes or code modifications on the OSC side. You will have to add the following urls to your response/relay url page on your authorize.net control panel to allow the customer to check out via the mobile site. http://<yourstore.url>/mobile/checkout_process.php http://<yourstore.url>/mobile/checkout_success.php it is also advised (by authorize.net) to add the same url with the www. ahead of it but my particular configuration would not work with the www before the domain name alone, i had to add the domain without the www before it would stop giving the error. Thanks for your help getting this set up, now just to get the mobile site looking the way I want! *Edit* On another note, what files can i safely delete from my server that were installed from the old version? is everything now in the /mobile/ directory? can I get rid of all the mobile_somefile.php in the root ?
  2. @@raiwa The problem seemed to be that I used the old versions on my authorize.net allowed url's page. adding http://whoolie.com/mobile/checkout_success.php http://whoolie.com/mobile/checkout_process.php seems to have resolved the error. http://www.whoolie.com/mobile/checkout_success.php http://www.whoolie.com/mobile/checkout_process.php alone were not enough i had to add both so anyone else who is looking to use this module should add BOTH to their authorize.net configuration. I will run a test sale through it in a bit to confirm 100% that it is working.
  3. @@raiwa Authorize.net Server Integration Method (SIM) Version: 2.0 API Version: 3.1 The desktop side is working fine and accepting payments, the mobile site gives the error 14
  4. @@raiwa you are a wizard. Thanks so much for helping me get this sorted out. I think I have one final question. I use auth . net for payment processing, is there something that needs to be updated in the payment module to send the user to the correct referrer/return url for the mobile site? I don't see a place to set that under the admin panel, but like several of these problems perhaps I just missed something! I am currently getting the following error: (14) The referrer, relay response or receipt link URL is invalid. I have logged into authorize.net and added the following urls as valid response/return urls. http://whoolie.com/mobile_checkout_process.php http://whoolie.com/mobile_checkout_success.php http://www.whoolie.com/mobile_checkout_process.php http://www.whoolie.com/mobile_checkout_success.php
  5. @@raiwa Thanks, yes that changed things a lot and the store seems to have picked up the theme.. New question, I am able to create a new account via mobile but not login via mobile. the buttons, text fields etc all show up under create account but they do not when you click account or sign in. The only options visible on sign in are the classic view button and the main navigation. http://whoolie.com/mobile/login.php Also some product images are not showing up when on product_info.php, all images seem to appear when For Example: http://whoolie.com/mobile/product_info.php?products_id=43 <-- No photo http://whoolie.com/mobile/product_info.php?products_id=80 <-- Works All three of these are in the same category. http://whoolie.com/mobile/product_info.php?products_id=96 <- Works http://whoolie.com/mobile/product_info.php?products_id=101 <- No Photo http://whoolie.com/mobile/product_info.php?products_id=104 <- Works No HTML is used for the product photos in the catalog, all products have at least two photos, one photo being common through most of them. All photos show up as thumbnails in products.php properly. Occasionally ill get a spinning wait icon in the center of the site which does not seem to go away unless I reload the page then select the product again. Once I reload and select the product it pulls up the product info page, these seem to almost never load the product photo... Is this a resize failure?
  6. Okay, got these sorted out it seems and now i've got another issue. http://whoolie.com/mobile/catalog_mb.php?cPath=1_17_26&osCsid=hukum92cjaectmohktrnq66ds1 when I go to a category and actually pull up an item there is no information shown, do I need to make modifications to my database to get this part to work? I haven't run the db setup php file yet but didn't see that it was required and would rather not modify my database unless its required!
  7. Ah you're very right, sorry for not looking I just assumed the latest version of the full package was the download link. Next question i've installed the mobile files into my store and now when I go into: www.whoolie.com/mobile/ I get the following error: Warning: require(DIR_WS_INCLUDESfilenames.php) [function.require]: failed to open stream: No such file or directory in /var/www/html/whoolie/includes/application_top.php on line 57 Fatal error: require() [function.require]: Failed opening required 'DIR_WS_INCLUDESfilenames.php' (include_path='.:/php/include;/www/functions:/usr/local/php/include/ZendGdata-1.12.3/library/') in /var/www/html/whoolie/includes/application_top.php on line 57 It LOOKS like the DIR_WS_INCLUDES variable isn't being turned into the proper text by the require statement. It also threw this error on line 41 of application_top.php // require(DIR_WS_FUNCTIONS . '/compatibility.php'); changing the line to this: require('functions/compatibility.php'); let it go on and then throws the error again on line 57.
  8. I tried to use the above link once before... This appears to only have the paypal mobile support files in it. Ie the full iosc files are not included on that particular page. Despite it saying full package at the bottom. The download link gives me: PayPalMobileSupport.zip which includes paypal_express.php and paypal_pro_dp.php without all of the other files that were included in the older download.
  9. I downloaded this contribution the other day after I switched to Auth net as my processor. I was previously using a reworked version of my web store on a subdomain as mobile. after finding this I would like to use the iOSC as my mobile frontend and have it kinda working.. My problem is that some of the links go back to the desktop site rather than the mobile site, for the most part I have found and fixed these in the source. However; I have one that has halted me. if you go here: http://whoolie.com/mobile_product_info.php?cPath=26&products_id=43 click the add to cart button, it does add the item to the cart but pulls up the web version instead of the mobile version. if you manually change the URL to: http://whoolie.com/mobile_shopping_cart.php the mobile cart comes up. if you need any more info please let me know! I appear to be trying to use version: Release v2.0c according to iOSC Description.txt is there a newer version somewhere I should be working with? My osCommerce version is a modified osCommerce Online Merchant v2.3.3.4
  10. Just thought I would share my experience with this Add-on. It does NOT mention this in the readme so I feel like it's important to share... This add-on has an install directory just like a standard install of osCommerce, it will let you specify any database you like.. If you already have a database in place, and you specify that database at install time, the add on will completely overwrite it and fill it with the stock items without prompting! I know it goes without saying to have backups before doing anything but with this one you better hope you did! :P
×