Jump to content

AngusD

Members
  • Content count

    101
  • Joined

  • Last visited

Everything posted by AngusD

  1. AngusD

    Can anyone help this situation

    Your over-all internet-speed doesn't matter. If your wireless-connection is poor, then you get this error. Check the wireless-setting in your router. Try to switch channels and maybe this is enough to improve your connection again. Or try this: Download a copy of the javascript-file, upload it to your server and adjust the path to the javascript in your "includes\template_top.php"(?), or wherever the .js is being loaded. AD
  2. AngusD

    Can anyone help this situation

    Hi, stupid question: The laptop is connected to the internet via Wi-Fi and your other computer via ethernet (LAN)? This is the important part of the error messages: Poor network connectivity. That's why the javascript was blocked by your browser. Connect your laptop via ethernet to the internet and try again. AD
  3. AngusD

    PayPal shows blank page

    Update: The vanishing order error has been resolved, too. In our case, it was caused by the "Order Status" setting in the "PayPal Payments Standard" config. The option "Store Default Order Status" caused the order to be deleted after checkout. There's no reason why it does this. There are no "delete"-queries anywhere near the checkout_process/checkout_success-scripts. We set the "Order Status" to "Delivered". This seemed to fix the issue. AD
  4. AngusD

    PayPal shows blank page

    Hello, currently, PayPal shows a blank page when I click the "Confirm Order"-Button. We're still using v4.039 of the App. Were there major changes in the current version of the App that would cause this sort of behaviour at PayPal? Did anyone encounter a similar/the same problem in the past and knows how to fix this? Thank you. AD
  5. AngusD

    PayPal shows blank page

    Hi, both. I tested it live and the order vanished. I had several windows, browsers and stuff running and maybe I got confused there. Then I closed the unnecessary windows and browsers and did a sandbox-test. Everything worked the way it should. So I'm not sure if everything is really ok or not. I'm monitoring the checkout and hope for the best... AD
  6. AngusD

    PayPal shows blank page

    Addendum 2: Issue resolved; Removed some code that somehow caused now trouble. New issue: Order vanishes after checkout from the database. Head -> Desk Edit: New issue was probably between chair and keyboard. Keeping an eye on it.
  7. AngusD

    PayPal shows blank page

    Addendum: Installed the most recent version: PayPal App v5.018 No changes. AD
  8. Hi, you should install the PayPal App for your OsC-Version. This doesn't mean it'll fix the error, but the App saves a log that helps track down the error. There are two possible sources for your error: 1.) The Sandbox-Server doesn't work right. This happened to us, when we tested the PayPal App after switching hosts. The App expects a certain response from the PayPal-Server, but the Sandbox didn't send it. Result: The "purchase" failed. After we switched from Sandbox to Live, the error went away. 2.) The Live-Server doesn't send the order_id back to your store. This is an ongoing issue with us. Sometimes the PayPal-Server forgets to send back the order_id and the PayPal payment-module can't finalize the order. Our "fix": The Payment-Module grabs the last order of the customer and tries to finalize the order with the order_id. In your case, I guess the source of the error is the Sandbox, but without the log of the PayPal-App it's hard to be sure. AD
  9. AngusD

    PayPal App missing invoice parameter

    So, I'm convinced it's a PayPal issue and it has nothing to do with our store or the PayPal App itself. I thought long and hard about it, but in the end, I had no choice: I altered the PayPal App. If the invoice-parameter is missing, the script grabs the order_id from the database and works with this value. AD
  10. Hi, in the last couple of days, we had the issue that the PayPal App (IPN) couldn't finalize an order, because it was missing in the database. This shouldn't happen, or this should only happen when a customer returns to the checkout payment-page. I checked the PayPal log and found that the invoice parameter was missing from those orders. I don't know how this could have happened. I assume, the PayPal App couldn't insert the order into the database and continued without it. When the customer came back from PayPal, he was transfered to the checkout payment-page; maybe with an error-message he couldn't understand correctly, and the order was removed from the database. Why the App couldn't set up the order, I don't know and I'm not sure how to find out if this was the case. After the first time this happened, I put the App in Sandbox mode and tested the checkout. Everything worked as it should. Afterwards we had orders that were finalized correctly, until it happened again. I'm not sure how to deal with it. I've added a check to the PayPal payment module, if there's an order_id present for the current order, but I'm not sure if this is the right thing to do: $insert_id = NULL; $insert_id = tep_db_insert_id(); if(empty($insert_id)){ // The insert_id (=order_id) is missing. Why is the order_id missing? Get back to the payment page and try again. tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'error_message=' . urlencode(ERROR_ORDER_MISMATCH), 'SSL')); exit; } Any advice? AD
  11. AngusD

    PayPal App missing invoice parameter

    I'm using PayPal Standard with IPN (PayPal App v4.039) AD
  12. AngusD

    PayPal App missing invoice parameter

    I tested it again, but this time in live-mode. After they're finished in PayPal, the customers are being directed to the shopping cart, without any error-message on their part. The order is correctly entered in our database, but the invoice parameter ist missing in the PayPal transaction log. Pretty strange... AD
  13. AngusD

    PayPal App missing invoice parameter

    I have "Log Transactions" set to "All". There are no errors in the log. Everything looks good. Nothing that screams "Error". If I check the details of a "successful" transaction in the log, the second (_notify-validate [iPN]) or third (_notify-synch) "Request" is "invoice". This request is missing in the "failed" transactions. I guess the order_id wasn't transfered to PayPal and so PayPal didn't send it back. AD
  14. AngusD

    Trying to understand PayPal V4.039

    @@Dan Cole Thank you. The IPN-script handles confirmation emails, so there should be any problems. We're selling downloads and they're always in stock. ;) Only our coupons/vouchers would have needed the checkout_process, but I was able to process them in the IPN-script with the help of hooks. AD
  15. Hi, we're running a pretty ancient version of the paypal_standard payment module (signature: 1.0) and now I want to upgrade to the newest version. While checking out the new files, I noticed that the standard_ipn-script kills the shopping cart, when everything is said and done. This is fine and great, but here's the point that confuses me. The paypal_standard payment module sets checkout_process as return parameter, but one of the first lines in the checkout process tells the store to direct the customer to the shopping cart if the cart is empty. So, how does this work? Do I have to set the return URL in the PayPal-Account? Why is the checkout process set, when it wouldn't work? I couldn't find anything about this in the documentation of the app. AD
  16. AngusD

    Trying to understand PayPal V4.039

    @@Mikepo Thank you. I'll do this. AD
  17. AngusD

    Trying to understand PayPal V4.039

    Hi @@Dan Cole Thanks for the answer. Do you use the PayPal IPN? I found a posting by @@burt, where he says you should set the return URL in PayPal to checkout_success.php. I guess, I need to test the right setup when the time comes. AD
  18. Hi, just tested it with Opera 12.17 (my default browser) and Opera 31.0. In Opera 12.17 it looks good, in Opera 31.0 however the display is a bit messed up. "Lethal Weapon" slips in the next line, leaving an empty place on the right side of "Fire Down Below" and "Under Siege 2" is alone in the last line. (Sidenote: Opera 12.17 loads the page in Grid-View and the view buttons work perfectly, no redirection to the index-page) (Edit: Same with Opera 31.0) AD
  19. AngusD

    Wishlist for 2.3 - Last Problem

    Hello, the problem is the missing "public_id" in the form. Find the "tep_draw_form"-line and change it to: <?php echo tep_draw_form('wishlist_form',tep_href_link($PHP_SELF, 'public_id='. (int)$public_id, 'SSL')); ?> Could work. No promisses. AD
  20. Thanks, because it is relatively easy. You just need to create a thumbnail once and that's when you upload an image. I've used the GD-library, but ImageMagick works too. What I've seen, it's probably even easier with ImageMagick. AD
  21. Hi, I wouldn't call it an addon. I've modified the categories.php and upload.php myself, so that it creates a thumbnail when I upload an image, when I create a new product or edit an existing product. It's not perfect, but it satisfies my needs. AD
  22. Hi, I've solved this (small thumbnail with big pop-up image) this way: echo tep_image({THUMBNAIL}, '', SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'id="piGalImg_' . $pi_counter . '" data-highres="'. {BIG POPUP} .'"'); In which "{THUMBNAIL}" is the thumbnail (including the path) (i.e. "DIR_WS_IMAGES . $pi['image']") and "{BIG POPUP}" is big image (including the path). AD
  23. Hi, can someone please explain the (design(?)) decision to remove the "Products Ordered"-box from the "Payment Information" page? Was this intended, a mistake or am I using the wrong version? Personally, I would keep "Products Ordered"-box in all checkout pages. Other than that, wonderful work. Thank you. AD
  24. AngusD

    I Just don't get it!

    @@14steve14: Thanks, but this doesn't work for me. I can't modify the path of the file to upload in the file-input field. Clicking the input field to edit the path opens the upload-file dialog again. Changing the path in the upload-file dialog gives me an invalid filename error in Windows. I tried Linux, but the OS displays the path differently than Windows (C:\path\to\file.jpg <> /path/to/file.jpg). Either I'm doing something terribly wrong, or this trick just doesn't work (anymore). AD
  25. AngusD

    I Just don't get it!

    Hi, maybe "Easy Populate" (http://addons.oscommerce.com/info/500) can help you with putting your existing product-images into sub-folders, though this won't help you with new images. That's why I modified the upload- and categories-script, so that it uploads the product-images to a sub-folder and creates a thumbnail in the same process. AD
×