Jump to content

---luke---

Members
  • Content count

    23
  • Joined

  • Last visited

Everything posted by ---luke---

  1. ---luke---

    ULTIMATE Seo Urls 5 - by FWR Media

    Hello I have a simple question Is is possible to change the letter -p- diplayed in the link into books and the -c- into books-category? Even better if I could change that letter depending on the language. Thank you in advance. Luke
  2. ---luke---

    Multi_Vendor_Shipping new thread

    Hi Jim, That solved the problem -thank you very much! Do you think there is a future for oscommerce - how is the developpement going?
  3. ---luke---

    Multi_Vendor_Shipping new thread

    Hello it seems that there is still a huge community behind the mvs - thats great! I have a integrated MVS into OsCommerce 2.3 and my hosting is going to upgrade my php Version to 5.4. Now I'm getting an error during the checkout: Warning: Illegal string offset 'id' in xxx/includes/classes/vendor_shipping.php on line 48 Warning: Illegal string offset 'id' in xxx/includes/classes/vendor_shipping.php on line 48 Warning: Cannot modify header information - headers already sent by (output started at /is/htdocs/wp11108156_NTRJ7UJ9SV/librumstore/includes/classes/vendor_shipping.php:48) in xxx/librumstore/includes/functions/general.php on line 50 Here is my vendor_shipping.php script starting at line 48: if ( (is_string($module)) && (in_array(substr($module['id'], 0, strpos($module['id'], '_')) . '.' . substr($PHP_SELF, (strrpos($PHP_SELF, '.')+1)), $modules_array)) ) { $include_modules[] = array('class' => substr($module['id'], 0, strpos($module['id'], '_')), 'file' => substr($module['id'], 0, strpos($module['id'], '_')) . '.' . substr($PHP_SELF, (strrpos($PHP_SELF, '.')+1))); } else { reset($installed_modules_array); foreach ($installed_modules_array as $value) { $class = substr($value, 0, strrpos($value, '.')); $include_modules[] = array('class' => $class, Is this a ovious problem? Is there a solution you can give?
  4. ---luke---

    Multi_Vendor_Shipping new thread

    Okay now once again i had problems with the order emails and other stuff... Then I went back to the standard paypal module and added some code a member (he's a hero) had posted once (http://forums.oscommerce.com/topic/101973-multi-vendor-shipping-new-thread/page__view__findpost__p__1561954) to catalog/includes/modules/payment/paypal_standard.php Now all is working like a charm!
  5. ---luke---

    Multi_Vendor_Shipping new thread

    Oke I added the similar code like in checkout_process.php to the standard_ipn.php modul. But after payment some error occured... After that I found a solution for a other paypal ipn module on http://addons.oscommerce.com/info/4129/category,all/search,MVS. Then i had a problem with the price display per item (the shipping costs were too hight). Then I selected an option to only transfer the aggregate amount to paypal. Then everything was working! Anyway I'll say thank you! Regards lu
  6. ---luke---

    Multi_Vendor_Shipping new thread

    Hi Jim Thank you very much now I know what was wrong. You were right the checkout goes through the standard_ipn.php file. But it seems very different from the checkout_process.php file. Is there just one little code to add or would it be a lot of things I have to think about? Is there already a integration in mvs for the paypal standard module? I didn't found one yet. I'm not very good in php so its a lot of work for me to integrete it. I would be thankfull if you can give me some more hints. Otherwise i will go through some hours of searching in the forums to understand the code and find a solution - probably that would also be good for me to become familliar with all this stuff ;) standard_ipn.php
  7. ---luke---

    Multi_Vendor_Shipping new thread

    Thank you, no this wasn't the solving answer. After the payment paypal redirects the customer to checkout_process.php. The paypal module consists of only one file and is integrated in the system...
  8. ---luke---

    Multi_Vendor_Shipping new thread

    Hello, I installed it to my 2.3.3 Store and after a bit of hard work everything works now exept one issue: When a customer uses the standard paypal module for payment - then it redirects to checkout_process.php and the confirmation page appears and everything seems workîng. But the order information isn't written in the orders_shipping table. With the other payment methods its working fine. I've already replaced the checkout_process.php file with the clean one, without any modification, the same happened. Is it this file which is corrupt? Does someone have an idea about a solution? Thanks for any respone!
  9. ---luke---

    Multi_Vendor_Shipping new thread

    Hope you saved Your client. Thank you for your replay. But the $_GET['order_id'] I had already changed to (int) $_GET['order_id'] and that didn't fix it. Only some data like the Shipping Module and the Shippingdestination and the weight appeared after this changes but not the model number, amount and prizes. I have the same problem in the admin/orders.php file where the shipping method, shipping cost, model number, and all prizes of a single product aren't displayed. When i turn the debug mode on, nothing else happens. The Table "vendors" and "orders_shipping" are filled with the data. I have also a vendors_info table which is empty maybe there's the falut? Best Regards
  10. ---luke---

    Multi_Vendor_Shipping new thread

    Hi Jim On the way to implement the MVS in my 2.3.3 Version of OsCommerce: I've got a problem with the account_history_info.php file. When I look on a specific order the order information like products name, quantity, total isn't showing up. In the vendor_order_info.php file there is a variable like "$product_data['orders_products'][$i]['name'];" which isn't defined. Can you have a look at this file and the vendor_order_data.php where this variables gets defined. In my database there are all information... I have learned a lot about php in the weeks ago but those big array structure is killing me ;) Regards luke
  11. ---luke---

    Multi_Vendor_Shipping new thread

    Dear Forum I have tested MVS on my oscommerce 2.3 and ran into a problem: If I buy only a virtual product (weight = 0) I have to pay the shipping costs. Is there already a solution which works also with mixed products? It would be great if someone could give me a hint! luke
  12. ---luke---

    Multi_Vendor_Shipping new thread

    Perfect - thats the solution!
  13. ---luke---

    Multi_Vendor_Shipping new thread

    Hi Marco That would be great if you can post your email solution! Im no expert either... So when I use the print_r function the "orders_id" appears but in the database table there is a zero. I don't know whats going wrong here.If I'm right this is the code which performs the writing in the database but it seems theres everything oke: $sql_data_array = array ('orders_id' => $orders_id, 'vendors_id' => $vendors_id, 'shipping_module' => $shipping_method, 'shipping_method' => $shipping_data['title'], 'shipping_cost' => $shipping_data['cost'], 'shipping_tax' => $shipping_data['ship_tax'], 'vendors_name' => $vendors_name, 'vendor_order_sent' => 'no' ); tep_db_perform (TABLE_ORDERS_SHIPPING, $sql_data_array); Regards Luke
  14. ---luke---

    Multi_Vendor_Shipping new thread

    I have the same problem. Tell me if you can fix it! I have an other problem: the "vendors_id" is not being inserted in the "orders_shipping" table. Instead of the ID there is only a "0" in this database table. So the orders wont appeare in the "Orders by Vendor" List. Is this an known issue? I have already searched in the thread but I have only got the hint to look in the chekout_process.php file. I'm trying to fit the MVS in oscommerce 2.3... Best Regard luke
  15. ---luke---

    Multi_Vendor_Shipping new thread

    I found the problem in an older post: http://forums.oscommerce.com/topic/101973-multi-vendor-shipping-new-thread/page__st__4240#entry1554873 Now it is working!
  16. ---luke---

    Multi_Vendor_Shipping new thread

    Hi Jim, I didn't managed to fix it therefore I have chosen an existing shipping module. Now its working ok. The system is working fine but one error at the checkout_confirmation.php site: Warning: strpos() expects parameter 1 to be string, array given in catalog\includes\modules\order_total\ot_shipping.php on line 48 I can order the products. The only effect ist that afterwards the order doesn't appear under the Vendors->Vendors Orders List but only in the Customners->Orders list. Do you know where this error could come from? Can you help me one step forward a solution? luke
  17. ---luke---

    Multi_Vendor_Shipping new thread

    The first two changes were sucessfull! From the last bit of code for ($i=1; $i <= $this->num_chpp; $i++) { $keys[count($keys)] = 'MODULE_SHIPPING_CHPP_COUNTRIES_'. $ij . '_' . $vendors_id; $keys[count($keys)] = 'MODULE_SHIPPING_CHPP_COST_ECO_'. $ij . '_' . $vendors_id; $keys[count($keys)] = 'MODULE_SHIPPING_CHPP_COST_PRI_'. $ij . '_' . $vendors_id; } only some blank fields appeared in the admin page, with nothing in it.
  18. ---luke---

    Multi_Vendor_Shipping new thread

    Thank you VERY much for your fast response, your a little hero! The Error Messages disapeared. But there ist still a problem (chpp.php): The Shipping Modul Settings aren't aviable when it is installed at the "Vendor Shipping Modules" Page. Further when I check out with some products it says: "Unfortunately it is not possible to dispatch into this country". Through the check out there is another issue at the checkout_confirmation.php page which says: Warning: strpos() expects parameter 1 to be string, array given in E:\xampplite\htdocs\shop.librum\includes\modules\order_total\ot_shipping.php on line 48 And at the checkout_process.php page it says Fatal error: Cannot redeclare class shipping in E:\xampplite\htdocs\shop.librum\includes\classes\shipping.php on line 13 But thats due to other things i have to find out. For the moment im struggeling whith the shipping modul issue. Whith the other shipping modules I have no problems.
  19. Dear osCommerce Forum I've installed the Multi Vendor Shipping (http://addons.oscommerce.com/info/4129 , Version 1.2.3) to my shop. Now I will include a shipping modul which i used before. But with the MVS it need to be converted. I've done the code modifications like described in "modues.txt" file but got these errors when attempting to install the Module in the admin vendor panel: Warning: Missing argument 1 for chpp::chpp(), called in E:\xampplite\htdocs\shop\admin\vendor_modules.php on line 130 and defined in E:\xampplite\htdocs\shop\includes\modules\vendors_shipping\chpp.php on line 46 Warning: constant() [function.constant]: Couldn't find constant MODULE_SHIPPING_CHPP_HANDLING1 in E:\xampplite\htdocs\shop\includes\modules\vendors_shipping\chpp.php on line 325 Warning: constant() [function.constant]: Couldn't find constant MODULE_SHIPPING_CHPP_TAX_CLASS1 in E:\xampplite\htdocs\shop\includes\modules\vendors_shipping\chpp.php on line 325 Warning: constant() [function.constant]: Couldn't find constant MODULE_SHIPPING_CHPP_ZONE1 in E:\xampplite\htdocs\shop\includes\modules\vendors_shipping\chpp.php on line 325 Warning: constant() [function.constant]: Couldn't find constant MODULE_SHIPPING_CHPP_SORT_ORDER1 in E:\xampplite\htdocs\shop\includes\modules\vendors_shipping\chpp.php on line 325 Is there someone who is familiar with this Mod and can go throw the code and give me a hint? I'm not really good in coding, therefore i would be happy for every hint! I Attache the Shipping Method Code (chpp.php) after my modifications. Also the instructions text (modules.txt)how to change the code for MVS. Best regards luke
  20. ---luke---

    MVS - Shipping Modul Modification

    It's moved to http://forums.oscommerce.com/topic/101973-multi-vendor-shipping-new-thread/page__st__4580#entry1687632 Thank you Jim! I didn't manage to delete this thread, maybe it isn't possible?
  21. ---luke---

    Multi_Vendor_Shipping new thread

    Dear osCommerce Forum I've installed the Multi Vendor Shipping (http://addons.oscommerce.com/info/4129 , Version 1.2.3) to my shop. Now I will include a shipping modul which i used before. But with the MVS it need to be converted. I've done the code modifications like described in "modues.txt" file but got these errors when attempting to install the Module in the admin vendor panel: Warning: Missing argument 1 for chpp::chpp(), called in E:\xampplite\htdocs\shop\admin\vendor_modules.php on line 130 and defined in E:\xampplite\htdocs\shop\includes\modules\vendors_shipping\chpp.php on line 46 Warning: constant() [function.constant]: Couldn't find constant MODULE_SHIPPING_CHPP_HANDLING1 in E:\xampplite\htdocs\shop\includes\modules\vendors_shipping\chpp.php on line 325 Warning: constant() [function.constant]: Couldn't find constant MODULE_SHIPPING_CHPP_TAX_CLASS1 in E:\xampplite\htdocs\shop\includes\modules\vendors_shipping\chpp.php on line 325 Warning: constant() [function.constant]: Couldn't find constant MODULE_SHIPPING_CHPP_ZONE1 in E:\xampplite\htdocs\shop\includes\modules\vendors_shipping\chpp.php on line 325 Warning: constant() [function.constant]: Couldn't find constant MODULE_SHIPPING_CHPP_SORT_ORDER1 in E:\xampplite\htdocs\shop\includes\modules\vendors_shipping\chpp.php on line 325 Is there someone who is familiar with this Mod and can go throw the code and give me a hint? I'm not really good in coding, therefore i would be happy for every hint! I Attache the Shipping Method Code (chpp.php) after my modifications. Also the instructions text (modules.txt)how to change the code for MVS. Best regards luke
×