Jump to content

ladc_314

Members
  • Content count

    8
  • Joined

  • Last visited

  • Days Won

    1

ladc_314 last won the day on October 2 2014

ladc_314 had the most liked content!

Profile Information

  • Real Name
    Luis Diaz
  1. Hi! i have one weird error, i have an Spanish shop, when modify the birthday greeting module and write "¡" (exclamation mark) all the email encoding goes to trash: letter Ñ, ! marks, accents, etc. appears in bad format. When i erase "¡" the email template fixes. How can i fix this error?
  2. @@rpdesign Thanks for your work! I have installed v1.851 in a clean oscommerce 2.3.3.1 and got this error when go to separate_rate.php in admin: 1146 - Table 'gevey4s.shipping_mode' doesn't exist select c_mode, c_sep from shipping_mode where c_id =2 I see the update18.sql file and noted that this include the creation of table shipping_mode, in a new installation it is supposed to create the necessary tables when installing the module, right? then there is some missing part in the admin/module/box installation. Next, Tried to run the update18.sql file to fix the admin/separate_rate.php error and got this another error in phpMyadmin: Error consulta SQL: ALTER TABLE `shipping_table_rates` ADD `c_ind` INT( 2 ) NOT NULL DEFAULT '0' AFTER `p_stat`, ADD `p_ind` INT( 2 ) NOT NULL DEFAULT '0' AFTER `c_ind`; MySQL ha dicho: Documentación #1060 - Duplicate column name 'c_ind' I see the shipping_table_rates table and c_ind and p_ind was already defined (that was causing the error), i run manually the next query: ALTER TABLE `shipping_rates` DROP `c_mode`, DROP `p_mode` ; update `configuration` set `configuration_value` = '1.85' where configuration_key = 'MODULE_SHIPPING_SEPARATE_VERSION'; CREATE TABLE IF NOT EXISTS `shipping_mode` ( `mode_id` int(255) NOT NULL AUTO_INCREMENT, `c_id` int(255) NOT NULL DEFAULT '0', `p_id` int(255) NOT NULL DEFAULT '0', `c_mode` int(2) NOT NULL DEFAULT '0', `p_mode` int(2) NOT NULL DEFAULT '0', `c_sep` int(2) NOT NULL DEFAULT '0', `p_sep` int(2) NOT NULL DEFAULT '0', PRIMARY KEY (`mode_id`) ) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci AUTO_INCREMENT=11 ; And problems in admin/separate_rate.php solved. have i corrected in the correct way?
  3. @@rpdesign i was clear, have tried V1.85 in new installations and updating several times, it is not an installation error, always same error on checkout_shipping.php when using SSPP V1.85: 1054 - Unknown column 'p_ind' in 'where clause' select distinct p_id, `p_rate`, p_free, p_status, p_per, (p_rate * cb.customers_basket_quantity) as p_qty, c_id, `c_rate`, c_free, c_status, c_per,(c_rate * cb.customers_basket_quantity ) as c_qty, cb.customers_basket_quantity, cb.customers_basket_id from shipping_rates , (select * from customers_basket where customers_id='1' ) cb inner join products_to_categories ptc on (ptc.products_id = cb.products_id) where (p_status = '1' or c_status = '1' ) and (cb.products_id = p_id or ptc.categories_id = c_id) and (p_free = '0' and c_free = '0') and (p_ind and c_ind = '1') [TEP STOP] My OsCommerce version is 2.3.3.1, have tried V1.85 on my modified shopping cart and in a clean oscommerce installation without other add ons and always same error.
  4. @@rpdesign First, i try the V1.85 and give me the error. Uninstalled and reinstalled several times and always same error. Try the update18.sql file and SQL give me this error: Error consulta SQL: ALTER TABLE `shipping_table_rates` ADD `c_ind` INT( 2 ) NOT NULL DEFAULT '0' AFTER `p_stat`, ADD `p_ind` INT( 2 ) NOT NULL DEFAULT '0' AFTER `c_ind`; MySQL ha dicho: Documentación #1060 - Duplicate column name 'c_ind' Then i tried previous versions and all work fine (V1.812, V1.811 and V1.731)
  5. I have Oscommerce 2.3.3.1, tried to install SSPP V1.85 and always got this error when go to checkout_shipping: 1054 - Unknown column 'p_ind' in 'where clause' select distinct p_id, `p_rate`, p_free, p_status, p_per, (p_rate * cb.customers_basket_quantity) as p_qty, c_id, `c_rate`, c_free, c_status, c_per,(c_rate * cb.customers_basket_quantity ) as c_qty, cb.customers_basket_quantity, cb.customers_basket_id from shipping_rates , (select * from customers_basket where customers_id='1769' ) cb inner join products_to_categories ptc on (ptc.products_id = cb.products_id) where (p_status = '1' or c_status = '1' ) and (cb.products_id = p_id or ptc.categories_id = c_id) and (p_free = '0' and c_free = '0') and (p_ind and c_ind = '1') [TEP STOP] V1.812 works OK
  6. Great contribution! I have some problems like other users (SQL and no function on frontpage). I am using MTS (template manager), search field use his own code and of course the changes made in bm_search.php don't function, that is the reason of problems (is not a problem of contribution) I managed to modify the MTS code and now SmartSuggest works like charm. I am not an expert and maybe it is obvious for experienced user, but this can help other people.
×