Latest News: (loading..)

CosmicA

Members
  • Content count

    15
  • Joined

  • Last visited

3 Followers

About CosmicA

Profile Information

  • Real Name
    Steve

Recent Profile Visitors

4,908 profile views
  1. I helped raiwa (Rainer) with testing Version 7 (Mobile OSC 7) of this much required add-on. I'm not a programmer at all, but he helped me along with any queries and was very fast to understand what I was trying to put accross to him in non-techie terms. I think you have done a remarkable job with this add-on, Rainer. :)
  2. Same here. Modular Front Page is great! But I've tried adding backslashes to the odd apostrophe to counteract this glitch, but no cigar. What is causing this?
  3. Hi Rainer. Changing all 4 seems to work. I probably copied the above code contained in includes/application_top.php from the SEO URLS 5 contribution support package. I will go through it again to check. Is this support package still relevant? Some links in Mobile My Account are not SSL. Maybe this isn't set up. For example, "Your Password" does not work as SSL, but "My Order history" works. Another thing I just noticed was the mobile stylesheet isn't working in SSL mode in chrome. It works fine in Firefox and on my Android phone. Weird! Thank you for all your help. I will re-check everything. Steve
  4. Hi Rainer. My code is slightly different. Probably because I have SEO URLS PRO5 installed. Can you possibly confirm which part(s) require changing. Thanks :) Section from my includes/application_top.php - if($mobile_site != $_SERVER['REQUEST_URI']) { $mobile_url = (($request_type == 'SSL') ? HTTPS_MOBILE_SERVER . DIR_WSS_HTTP_MOBILE : HTTP_MOBILE_SERVER . DIR_WS_HTTP_MOBILE) . $mobile_site; } else { $mobile_url = (($request_type == 'SSL') ? HTTPS_MOBILE_SERVER . DIR_WSS_HTTP_MOBILE : HTTP_MOBILE_SERVER . DIR_WS_HTTP_MOBILE) . $_SERVER['REQUEST_URI']; } } else { $mobile_site = basename($PHP_SELF); if (strpos($_SERVER['REQUEST_URI'], 'index.php') && (strpos($_SERVER['REQUEST_URI'], 'manufacturers_id=') || strpos($_SERVER['REQUEST_URI'], 'cPath='))) { $mobile_site = str_replace('index.php', 'catalog_mb.php', $mobile_site); } if (tep_not_null(tep_get_all_get_params())) { $mobile_url = (($request_type == 'SSL') ? HTTPS_MOBILE_SERVER . DIR_WSS_HTTP_MOBILE : HTTP_MOBILE_SERVER . DIR_WS_HTTP_MOBILE) . '?' . rtrim (tep_output_string(tep_get_all_get_params()), '&'); } else { $mobile_url = (($request_type == 'SSL') ? HTTPS_MOBILE_SERVER . DIR_WSS_HTTP_MOBILE : HTTP_MOBILE_SERVER . DIR_WS_HTTP_MOBILE);
  5. Here is my includes/configure.php file as instructed - <?php define('HTTP_SERVER', 'http://www.mywebsite.com'); define('HTTPS_SERVER', 'https://www.mywebsite.com'); define('ENABLE_SSL', true); define('HTTP_COOKIE_DOMAIN', 'mywebsite.com'); define('HTTPS_COOKIE_DOMAIN', 'mywebsite.com'); define('HTTP_COOKIE_PATH', '/catalog/'); define('HTTPS_COOKIE_PATH', '/catalog/'); define('DIR_WS_HTTP_CATALOG', '/catalog/'); define('DIR_WS_HTTPS_CATALOG', '/catalog/'); //BOF Mobile define('HTTP_MOBILE_SERVER', HTTP_SERVER); define('HTTPS_MOBILE_SERVER', HTTPS_SERVER); define('DIR_WS_HTTP_MOBILE', DIR_WS_HTTP_CATALOG . 'mobile/'); define('DIR_WS_HTTPS_MOBILE', DIR_WS_HTTPS_CATALOG . 'mobile/'); (defined('MOBILE_SESSION') ? define('DIR_WS_IMAGES', HTTP_SERVER . DIR_WS_HTTP_CATALOG . 'images/') : define('DIR_WS_IMAGES', 'images/')); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); (defined('MOBILE_SESSION') ? define('DIR_WS_INCLUDES', '../includes/') : define('DIR_WS_INCLUDES', 'includes/')); //EOF Mobile define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); //BOF Mobile define('DIR_MOBILE_IMAGES', 'images/'); define('DIR_MOBILE_INCLUDES','includes/'); define('DIR_MOBILE_MODULES', DIR_MOBILE_INCLUDES . 'modules/'); define('DIR_MOBILE_CLASSES', DIR_MOBILE_INCLUDES . 'classes/'); define('DIR_MOBILE_HEADERS', DIR_MOBILE_INCLUDES . 'headers/'); define('DIR_MOBILE_LANGUAGES', DIR_MOBILE_INCLUDES . 'languages/'); //EOF Mobile //BOF Mobile (defined('MOBILE_SESSION') ? define('DIR_WS_DOWNLOAD_PUBLIC', HTTP_SERVER . DIR_WS_HTTP_CATALOG . 'pub/') : define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/')); //EOF Mobile define('DIR_FS_CATALOG', '/home/sites/mywebsite.com/public_html/catalog/'); //BOF Mobile define('DIR_FS_MOBILE', DIR_FS_CATALOG . 'mobile/'); //EOF Mobile define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); define('DB_SERVER', 'localhost'); define('DB_SERVER_USERNAME', 'myusername'); define('DB_SERVER_PASSWORD', 'mypassword'); define('DB_DATABASE', 'mydatabase'); define('USE_PCONNECT', 'false'); define('STORE_SESSIONS', 'mysql'); define('CFG_TIME_ZONE', 'Europe/London'); ?>
  6. Thanks. I Sent you a Message. I guess if the 'Show mobile view' box link doesn't work for me i can do without. But it's better with it there isn't it.
  7. Hi Rainer. I have PROPER ssl now. I still have the same issue as before. redirect from the "Show mobile view" box doesn't work in SSL. It works fine in non-ssl. And the classic view link in the mobile site works perfectly in SSL. Incidentally, I am testing using 2.3.3 installed in a subdirectory. Example - mysite.com/catalog/mobile/ SEO URLS PRO 5 is installed. I uploaded the IOSC support package for this, following instructions. I have checked the following files as instructed to the best of my ability - functions/general.php and functions/html_output.php, includes/application_top.php and includes/configure.php. Any ideas why this link doesn't work? The rest of my website seems OK. Faithfully, Steve
  8. Thanks again. i will recheck those files to see if i did forget something. I will probably get proper ssl soon. The url when shifting to mobile from login.php in classic has DIR_WSS_HTTP_MOBILE contained in it. Example: "https://web-secure.co.uk/mystie.comDIR_WSS_HTTP_MOBILE" ...So this is probably my error.
  9. Thanks Rainer. You are a real magician. "define('TABLE_HEADING_TOTAL', 'Total');" was missing. "define('SUB_TITLE_SUB_TOTAL', 'Sub-Total:');" is there, so maybe it's something new. Or I messed something up. One test site has seo urls installed, another does not. both sites live in subdirectories. Shared SSL works fine so far, just the transition between mobile and classic sites does not work in shared SSL. Maybe real SSL works fine. I don't have it yet.
  10. Hello. I have tried IOSC on two 2 3.3 test sites and it looks excellent. IS SHARED SSL RECOMMENDED at all for this add-on? I've been testing with it and there is a problem when flipping between mobile and classic views. I also noticed one tiny glitch in the shopping cart with, "TABLE_HEADING_TOTAL" showing where simply, "total" should be. I was wondering if i missed out something on installation.
  11. I just found some info in this thread a couple of pages back here - http://forums.oscommerce.com/topic/349814-ultimate-seo-urls-5-pro/page__st__460 But still wasn't to remedy sorting out the issue 't'. I set 'all non-alphanumeric characters' to false, no cigar. But I'm probably worrying over nothing anyway.
  12. Hi there. Just been testing this module. It's great. There's one thing I would like to edit if possible, and pardon me if this question has been answered already in the forum.. I couldn't find it anywhere. Your 'filter short words' option doesn't allow me to display say, http://www.mysite.com/mycategory/fantastic-t-shirt ...etc It's filtered to.. http://www.mysite.com/mycategory/fantastic-shirt ....etc I imagine this might be a problem for t-shirt sites etc. Or will this not matter to search engines? Where can I edit this to ignore certain letters from filtering?