Jump to content

HowardR

Members
  • Content count

    45
  • Joined

  • Last visited


Reputation Activity

  1. Like
    HowardR reacted to Tsimi in [Contribution] Option Types v2   
    Hmmm... and I thought I had everything fixed to run with Edge. I haven't tested this addon with the latest Edge version but I'll do that tonight and see if I can recreate that error.
    As raiwa already said instead of adding those definitions try to replace them with the correct paths.
    I'll report back asap.
  2. Like
    HowardR reacted to raiwa in [Contribution] Option Types v2   
    @HowardR,
     
    These are no bugs.
    Filenames and Paths are now hardcoded in 2.3.4 Bootstrap and most path definitions in configure.php and the file filenames.php with the filename definitions have been removed.
    So you are going the wrong way, instead to re-add the definitions to configure.php, you should update the add-ons which have not yet been updated.
    To get older Add-Ons which are still using filename and path constants to work, you have 2 possibilities:
    1. Update all filename constants in the add-on files from Example: FILENAME_DEFAULT to the real filenames Example: 'index.php'
      Update all path constants in the add-on files from Example: require(DIR_WS_INCLUDES . 'database_tables.php'); to the real path: require('includes/database_tables.php');
    or
    2. Install the compatibility add-on: Add-On Compatibility for 2.3.4 EDGE
    1 is the preferred method
     
    Please Google or search the forum about these subjects. You'll find many posts for clearance.
    rgds
    Rainer
  3. Like
    HowardR got a reaction from frankl in New Payflow requirement: TLS 1.2 & HTTP/1.1   
    I think I finally understand the TLS 1.2 issue.  This is a very serious issue. There are a lot of OSCommerce owners that will wake up to a nasty surprise on May 1. Those of you who are not new to this, please let me know if I am wrong in any of my statements below:
     
    1. This only affects PayFlow, if you have PayPal Express Checkout also installed in your store, that should keep working. So you won't be able to accept Credit Cards, but you will be able to still accept PayPal payments.
     
    2. PayPal threatened to require TLS 1.2 on May 1, 2016. but they relented. Now they say that they are going to require it on May 1, 2017. I think that they are going to follow through this time.
     
    3. If you have an older PayPal PayFlow module installed, it will stop working on May 1. If you have version 3.1 of the PayFlow module installed on May 1, you are OK.
     
    4. There are two versions of 3.1 on addons created by Harald Ponce de Leon. Both work. The best one is the newest:
     
    http://addons.oscommerce.com/info/9184 -- March 1, 2017 -- designed for  upcoming OSCommerce 2.3.5 but works with tweaking for earlier versions  http://addons.oscommerce.com/info/5660 - June 9, 2014 -- designed for the standard (not responsive) version of OSCommerce 2.3.4  
    5. These versions require TLS 1.2  (the latest security standard)  which does not run on OpenSSL 0.9.8, which just happens to be the version of Open SSL that is installed on most servers these days, due to security problems that were encountered with early versions of OpenSSL 1.0.1 and 1.0.2.  You can test which version of TLS 1.2 that you have by using the following php code in a simple php file on your system:
     
    <?php function get_tls_version($sslversion = null)
    {
    $c = curl_init();
    curl_setopt($c, CURLOPT_URL, "https://www.howsmyssl.com/a/check");
    curl_setopt($c, CURLOPT_RETURNTRANSFER, true);
    if ($sslversion !== null)
    {
    curl_setopt($c, CURLOPT_SSLVERSION, $sslversion);
    }
    $rbody = curl_exec($c);
    if ($rbody === false)
    {
    $errno = curl_errno($c);
    $msg = curl_error($c);
    curl_close($c);
    return "Error! errno = " . $errno . ", msg = " . $msg;
    }
    else
    {
    $r = json_decode($rbody);
    curl_close($c);
    return $r->tls_version;
    }
    }
    echo "<pre>\n";
    echo "OS: " . PHP_OS . "\n";
    echo "uname: " . php_uname() . "\n"; echo "PHP version: " . phpversion() . "\n";
    $curl_version = curl_version();
    echo "curl version: " . $curl_version["version"] . "\n";
    echo "SSL version: " . $curl_version["ssl_version"] . "\n"; echo "SSL version number: " . $curl_version["ssl_version_number"] . "\n"; echo "OPENSSL_VERSION_NUMBER: " . dechex(OPENSSL_VERSION_NUMBER) . "\n"; echo "TLS test (default): " . get_tls_version() . "\n"; echo "TLS test (TLS_v1): " . get_tls_version(1) . "\n"; echo "TLS test (TLS_v1_2): " . get_tls_version(6) . "\n"; echo "</pre>\n";
    ?>
     
    So, if you have a store that uses PayFlow and you are using an older PayPal module, you could find yourself in deep doodoo on May 1. You better start making the transition today.
×