Jump to content

Clement

Members
  • Content count

    85
  • Joined

  • Last visited

1 Follower

Profile Information

  1. Hello, It seems like the EP doesn't work (can't upload the data) with the PHP 5 version. Can anyoane confirm this? Thank you very much, Clement
  2. Clement

    FAQDesk version 1.0 --- Released

    Hello, If you use MS2 osC then the error occure because of the differences of the splitPageResults() function in MS1 and MS2. In order to fix this you have to edite the file from: catalog/includes/modules/faqdesk/faqdesk_listing.php there around the line 14 FIND $listing_split = new splitPageResults($HTTP_GET_VARS['page'], MAX_DISPLAY_FAQDESK_SEARCH_RESULTS, $listing_sql, $listing_numrows); AND REPLACE WITH $listing_split = new splitPageResults($listing_sql, MAX_DISPLAY_FAQDESK_SEARCH_RESULTS, '*', $HTTP_GET_VARS['page']); Good luck, Clement
  3. Clement

    FAQDesk version 1.0 --- Released

    Hello, For all having problem with the IE6 crash when trying to insert a new FAQ i can certain tell you that the problem occure from the html bar editor. I don't know a fix so I just commented out the html editor part from admin/includes/modules/faqdesk/html/editor/content_bb.php and summary_bb.php . So, this is not a fix but ay least you can work with this great contribution. Best Regards, Clement
  4. Clement

    QTPro Contribution question

    Thank you very much for all info you provided. Best Regards, Clement
  5. Clement

    QTPro Contribution question

    Hello Lynda, Thank you very much for your fast replay. I think I have to wait for a next release of this great contribution. Do you know if an MS2 version is planned? Thank you again, Clement
  6. Clement

    QTPro Contribution question

    Hello to everyone, I need to know if qtpro contribution has a version compatible with MS2 version. I search the main site of QTpro but it seems to be down. Is this the right url for the official site? http://www.vary.net/qtpro Thank you very much for your help. Best regards, Clement
  7. Clement

    Seperate Pricing Per Customer v3.5

    Check here: http://www.oscommerce.com/community/contributions,716 Good luck!
  8. Clement

    Seperate Pricing Per Customer v3.5

    Ok. Here is how I fixed the problem of special groups prices in modules/new_products.php >>>>>>>>>>>> REPLACE $new_products_query = tep_db_query("select p.products_id, p.products_image, p.products_tax_class_id, if(s.status, s.specials_new_products_price, p.products_price) as products_price from " . TABLE_PRODUCTS . " p left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id where products_status = '1' order by p.products_date_added desc limit " . MAX_DISPLAY_NEW_PRODUCTS); WITH $new_products_query = tep_db_query("select products_id, products_image, products_tax_class_id, products_price from " . TABLE_PRODUCTS . " where products_status = '1' order by products_date_added desc limit " . MAX_DISPLAY_NEW_PRODUCTS); >>>>>>>>>>> REPLACE $new_products_query = tep_db_query("select distinct p.products_id, p.products_image, p.products_tax_class_id, if(s.status, s.specials_new_products_price, p.products_price) as products_price from " . TABLE_PRODUCTS . " p left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c, " . TABLE_CATEGORIES . " c where p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and c.parent_id = '" . (int)$new_products_category_id . "' and p.products_status = '1' order by p.products_date_added desc limit " . MAX_DISPLAY_NEW_PRODUCTS); WITH $new_products_query = tep_db_query("select distinct p.products_id, p.products_image, p.products_tax_class_id, p.products_price from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c, " . TABLE_CATEGORIES . " c where p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and c.parent_id = '" . (int)$new_products_category_id . "' and p.products_status = '1' order by p.products_date_added desc limit " . MAX_DISPLAY_NEW_PRODUCTS); >>>>>>>>>> BEFORE $info_box_contents[$row][$col] = array('align' => 'center', 'params' => 'class="smallText" width="33%" valign="top"', 'text' => '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $new_products['products_id']) . '">' . tep_image(DIR_WS_IMAGES . $new_products['products_image'], $new_products['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '</a><br><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $new_products['products_id']) . '">' . $new_products['products_name'] . '</a><br>' . $currencies->display_price($new_products['products_price'], tep_get_tax_rate($new_products['products_tax_class_id']))); ADD $special_price_query = tep_db_query("select specials_new_products_price from " . TABLE_SPECIALS . " where products_id = '" . $new_products['products_id'] . "' and customers_group_id = '" . $customer_group['customers_group_id'] . "' and status <> '0'"); if ($special_price = tep_db_fetch_array($special_price_query)) { $new_products['products_price'] = $special_price['specials_new_products_price']; } Good Luck!!
  9. Clement

    Seperate Pricing Per Customer v3.5

    Also, If I have a special price for "Resseler" group, the modules/new_products.php show tho everyone this special price. Have a great day,
  10. Clement

    Seperate Pricing Per Customer v3.5

    Hello everybody, Here are some problems that I found into 3.5 version for different specials for each new group: A. In the install instructions ------------------------------------ 1. At catalog/specials.php changes: Around line 80 After $row = 0; $specials_query = tep_db_query($specials_split->sql_query); while ($specials = tep_db_fetch_array($specials_query)) { $row++; Add $customer_group_query = tep_db_query("select customers_group_id from " . TABLE_CUSTOMERS . " where customers_id = '" . $customer_id . "'"); $customer_group = tep_db_fetch_array($customer_group_query); $row = 0; $specials_query = tep_db_query($specials_split->sql_query); while ($specials = tep_db_fetch_array($specials_query)) { $row++; $customer_group_price_query = tep_db_query("select customers_group_price from " . TABLE_PRODUCTS_GROUPS . " where products_id = '" . $specials['products_id'] . "' and customers_group_id = '" . $customer_group['customers_group_id'] . "'"); if ( $customer_group['customers_group_id'] != 0) if ($customer_group_price = tep_db_fetch_array($customer_group_price_query)) $specials['products_price']= $customer_group_price['customers_group_price']; I think there must be "replace" and not "add" because if I just add the seccond part of code then I've got an arror into specials.php file. 2. For catalog/includes/functions/general.php changes the instructions say that : Around 200 After $select_string .= '>'; Add ....... But "$select_string .= '>';" is only in admin/includes/functions/general.php , so I think at this point all changes must be swiched to the admin/functions/general.php A. Runing the script ------------------------------------ 3. The special prices for "Resellers" - not the default group - arn't displayed from the catalog/includes/modules/new_products.php 4. If I setup a special price for "Reseller" as percent, then the special price is calculated based on the default group price not as a percent from the "reseller" price. Thank you very much for this contribution,
  11. Thanks Lee, This will be a great improvment of an already great contribution :) Please let me know if you will upload those changes in the contrib area... Thank you again, Clement
  12. Hello Lee, Thank you for your help. Here is what works for my problem: admin/htmlarea/popups/file/config.inc.php In this file, between the lines 14-16 I found a hardcoded path: So, I have to change "catalog/download" to "download" .. Thank you for the custom info inserting help, too. Also, I have to know 2 more things: 1. How to create a custom button? - how to create the reaction on click for that custom buton; - how to change the face (grafhics) of any custom button 2. How to handle the showing and not showing a custom button in different pages (product description or email sending...) I ask that because I noticed for example that in the basic mode, is a custom button for inserting some html code (a logo from http://www.kmart.com.au/images/top/KmartLogo.gif and some text). So, can I have a custom button displayed in the "Send Email" section but not in the "Product description". Also, this button is in the basic mode but isn't in the advanced mode. IF the answers of my questions are in this topic (in the previous posts) JUST TELL ME ... I wont to spend your time with no reason. Thank you very much for your support. Clement
  13. Sure. But the path for it is /home/******/public_html/download NOT /home/******/public_html/catalog/download As I said the script isn;t installed under a "catalog" directory ... It is instaled in the domain root directory.. Thank you, Clement
  14. Hello, I just installed this great contrib as the first mod on a fresh MS2. Everything is just fine.. EXCEPT: When I try to use the "Link to a file" icon an error occure: That's right because I don't have a "catalog" folder (the shop is installed in the public_html direcory). So, please tell me where I need to change (fix ?) this path. Also, I can't figure out how to setup some "Custom info" for repetitive use. Thank you for helping, Clement
  15. So, if we remove this line, where the members can see the GV FAQ or send email Vouchers and other GV stuff ? Thank you, Clement
×