Jump to content

yogeshnaik

Members
  • Content count

    38
  • Joined

  • Last visited

  • Days Won

    2

yogeshnaik last won the day on April 12 2013

yogeshnaik had the most liked content!

1 Follower

Profile Information

  • Real Name
    Yogesh
  • Gender
    Male

Recent Profile Visitors

9,499 profile views
  1. yogeshnaik

    Quickly Update Product Stock

    Ok... used another addon.. price adjuster..... version 1.21 by Kevin L. Shelton Had to modify a bit to make it work... someone suggested to replace all instances of mysql_query with tep_deb_query and as far as the redirecting issue is concerned... after adding tep_hide_session_id(); before the closing form tag.... (where those dropdown menus occur... with that tep_draw_pull_down_menu() function ) ... it seemed to work.. I've no idea how this works... but it did...... prices are getting updated... <?php echo tep_hide_session_id(); ?></form>
  2. yogeshnaik

    Quickly Update Product Stock

    Is the problem over here.....?? (in admin/quick_stockupdate.php) <select name="filter_type" id="select" onchange="this.form.submit();"> <option value="1"<?php if($filter_type==1){echo ' selected="selected"';}?>><?php echo QUICK_CATEGORY ?></option> <option value="2"<?php if($filter_type==2){echo ' selected="selected"';}?>><?php echo QUICK_MANUFACTURER?></option> </select> This echos the dropdown in quick_stockupdate page with options as Category and Manufacturers Now does that drop down needs to be wrapped in tep_draw_pull_down_menu() function...?? I tried but not getting the proper syntax...
  3. yogeshnaik

    Quickly Update Product Stock

    How to avoid the page redirecting to admin login......... ? :( I know it has something to do with sessions.... but don't know where to fix......
  4. yogeshnaik

    Quickly Update Product Stock

    I was having this issue yesterday....... i used mysqli instead of mysql...... and kept $$link as the first parameter in the return statement.... so it was like... //Credit to surfalot (Run SQL Script) function qs_db_query($query, $link = 'db_link') { global $$link; return mysqli_query($$link, $query); } Worked for me... It updated.... But issue is it worked in my localhost.... on server when i change that dropdown thing.. i mean the categories........ it redirects me to admin login page...... works fine in localhost though......
  5. yogeshnaik

    Paypal Fee not getting displayed in Paypal page

    Thanx Sir, I put this code in paypal_standard.php (catalog/includes/modules/payment) $paypal_fee = tep_round(((MODULE_ORDER_TOTAL_PAYPAL_FEE/100) * $order->info['total']), $currencies->currencies[DEFAULT_CURRENCY]['decimal_places']); inside function process_button() { so its like function process_button() { global $customer_id, $order, $sendto, $currency, $cart_PayPal_Standard_ID, $shipping; $paypal_fee = tep_round(((MODULE_ORDER_TOTAL_PAYPAL_FEE/100) * $order->info['total']), $currencies->currencies[DEFAULT_CURRENCY]['decimal_places']); $process_button_string = ''; $parameters = array('cmd' => '_cart', 'upload' => '1', 'handling_cart' => $this->format_raw($order->info['shipping_cost']), 'shopping_url' => STORE_URL.'/'.FILENAME_STORE, 'tax_cart' => $paypal_fee, 'business' => MODULE_PAYMENT_PAYPAL_STANDARD_ID, Thing is.... Paypal Fee is now visible in Paypal page... but it rounds off the amount... I mean if Paypal fee is 0.64 it will show as 1.00 Is there any way to show the exact amount..? I guess it rounds up... Is it because of tep_round function..? any other function can I put instead of tep_round...?
  6. yogeshnaik

    Paypal Fee not getting displayed in Paypal page

    Thanx for your reply sir.... Actually I'm using this add on.... http://addons.oscommerce.com/info/3132/v,22
  7. Hi People. I've got some issue with paypal_standard...... I know where is the issue, but I'm not able to rectify it........ Problem is, in my checkout_confirmation.php .....prices of products and Paypal Fee value clearly gets displayed..... But when I hit "Confirm Order" button.... it leads me to Paypal Page...... here product name, prices... everything is visible, except Paypal Fee. I just checked paypal_standard.php page via firebug on mozilla... and there i saw these entries... <input type="hidden" value="_cart" name="cmd"> <input type="hidden" value="1" name="upload"> <input type="hidden" value="8.50" name="handling_cart"> <input type="hidden" value="STORE_URL/FILENAME_STORE" name="shopping_url"> <input type="hidden" value="0.00" name="tax_cart"> that tax_cart value i changed in firebug editor itself and clicked the "Confirm Order" button... and this time "Paypal Fee" was visible... In paypal_standard.php the code is like.... $process_button_string = ''; $parameters = array('cmd' => '_cart', 'upload' => '1', 'handling_cart' => $this->format_raw($order->info['shipping_cost']), 'shopping_url' => STORE_URL.'/'.FILENAME_STORE, 'tax_cart' => $this->format_raw($order->info['tax']), 'business' => MODULE_PAYMENT_PAYPAL_STANDARD_ID, 'currency_code' => $currency, Issue is somewhere here I guess 'tax_cart' => $this->format_raw($order->info['tax']), Any idea how to fix this .... ?
  8. Fixed....... Went to admin panel.... Configuration---> Sessions and did these changes... Session Directory ------------ /tmp Force Cookie Use -------------False Check SSL Session ID -------------False (was on True) Check User Agent -------------False (was on True) Check IP Address -------------False (was on True) Prevent Spider Sessions -------------True Recreate Session -------------False This worked for me......
  9. yogeshnaik

    Wishlist 3.0 Support Thread

    I'm getting this notice........... Notice: Undefined property: wishlist::$wishID in /home/mysite/public_html/includes/modules/boxes/bm_wishlist.php on line 37 Any idea what is it...?
  10. Its not throwing any error..... only the page refreshes.... Another weird thing is that... this issue is only on server.... I'm able to login in localhost.... :wacko:
  11. Noticed this thread now......... I'm working on oscommerce 2.3.3 and I've got some login issue. I installed this addon (SEO URL). http://addons.oscommerce.com/info/6768 But after I enable it through the admin panel. I'm not able to login. In fact any member can't login. If i disable it, customer login works fine. Did anyone encountered any similar issues?
  12. Thumbnails are getting generated, but my issue is, they are not getting displayed in my site..... in catalog/includes/functions/html_output.php..... i guess this line is supposed to display the image..... $image = '<img src="product_thumb.php?img=' . $src . '&w=' . tep_output_string($width) . '&h=' . tep_output_string($height) . '"'; But when I check through firebug.... firebug says 'failed to load the given url'....... any idea how $src can be modified... so that it points to images/thumbnails...
  13. Hi People, got some issues implementing the thumbnail addon. I'm using this addon ('On The Fly' Auto Thumbnailer using GD Library for v2.3.1): http://addons.oscommerce.com/info/8104/v,23 I followed all the instructions, replaced the tep_image() function as told... Thing is my thumbnails are getting generated in thumbnails folder, but its not visible in my site. I know this will be some path issue, but I'm unable to figure it out... I guess this function displays the image function tep_image() and particularly this line $image = '<img src="product_thumb.php?img=' . $src . '&w=' . I inspected this in firebug and its saying failed to load url... Actually this addon is creating thumbnails with same file name plus the extension. Its like say if I have a file name abc of jpg type in images directory.....it creates thumbnail abc.jpg.thumb_93x130 in images/thumbnails That last number is random.... I guess width and height. any idea what i need to add in this line.. in function tep_image() $image = '<img src="product_thumb.php?img=' . $src . '&w=' .
  14. yogeshnaik

    shop by price

    Worked like a charm........... Perfect..... !! Thanx. :)
×