Jump to content

Judith.Precision

Members
  • Content count

    29
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Judith Winner

Recent Profile Visitors

2,759 profile views
  1. Perhaps I am just being dense, but I can understand why the BS version isn't yet "released into the wild". I'm not very active on any forums (mostly coming here when I have a specific problem I can't suss out myself). But, I am convinced that osC Responsive (I *like* that name) is going to happen. For me, I currently have it only in a test status (using the Gold edition) mainly because of one (to me) major issue - the shipping - in particular, the USPS shipping module. The one that is 'standard' with the core osC doesn't work. an unfortunately, I have not been successful in getting the add-on USPS Methods to work with the osC Responsive. I think that @@burt is doing a great job with the development on the responsive codebase. I for one am looking forward to its official release. Until that time, I will keep checking in and trying new ideas to get the shipping module to work so that I can move forward to getting my store updated (official store is using 2.3.4) to the responsive codebase.
  2. I guess my needs are fairly simple - I would like either the (core) included USPS shipping module to be updated, or have an add-on that is compatible with 2.3.4®/2.4.
  3. Judith.Precision

    ULTIMATE Seo Urls 5 - by FWR Media

    Hey all, I'm seeing a series of strange errors in my error_log file (from host server). The error(s): PHP Catchable fatal error: Argument 1 passed to aPage_Modules::linkText() must be of the type array, null given, called in /home/imprint/public_html/storefront/includes/modules/ultimate_seo_urls5/page_modules/product_info.php on line 170 and defined in /home/imprint/public_html/storefront/includes/modules/ultimate_seo_urls5/abstracts/page_modules.php on line 338 PHP Warning: Invalid argument supplied for foreach() in /home/imprint/public_html/storefront/includes/modules/ultimate_seo_urls5/page_modules/product_info.php on line 102 PHP Catchable fatal error: Argument 1 passed to aPage_Modules::linkText() must be of the type array, null given, called in /home/imprint/public_html/storefront/includes/modules/ultimate_seo_urls5/page_modules/product_info.php on line 170 and defined in /home/imprint/public_html/storefront/includes/modules/ultimate_seo_urls5/abstracts/page_modules.php on line 338 PHP Warning: Invalid argument supplied for foreach() in /home/imprint/public_html/storefront/includes/modules/ultimate_seo_urls5/page_modules/product_info.php on line 102 In using a Reverse IP lookup, I notice that this "error batch" only seems to happen with various 'bots (the set above are from BingBot). Is this a common thing to see regarding the different 'bots out there? Should I be concerned about the errors showing up for the 'bots? Thanks! Judith
  4. Judith.Precision

    Important USPS API Updates Releasing January 27

    Would this be causing an issue with the checkout_shipping.php page returning an error? (update) *sigh* NEver mind. Turns out the ISP ended up rebuilding their web servers... and subsequently upgraded their PHP installation. *grumble grumble* Now to go through and "fix" everything they broke. Judith
  5. Judith.Precision

    PayPal modules after USPS fix

    @@Jack_mcs - I actually found: if (!class_exists('httpClient')) { include('rc2a/catalog/includes/classes/http_client.php'); } above $http = new httpClient(); So I commented it out and added the code snippet you provided, since I recognized that the path in the 'original' was part of the error I kept getting. @@kymation - It may not be the best solution, but it works and that's good enough for me. :) Thank you both! :)
  6. Judith.Precision

    PayPal modules after USPS fix

    So, with the recent changes required for getting the USPS shipping module working correctly, I am now having problems with my PayPal modules. I stepped through the updates (v 6.x) for USPS Methods, including the USPS Methods 6.1c modified for osc 2.3 and now, when going to the payment portion, I get the following errors. Warning: include() [function.include]: Failed opening 'rc2a/catalog/includes/classes/http_client.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/imprint/public_html/storefront/includes/modules/shipping/usps.php on line 982 Fatal error: Class 'httpClient' not found in /home/imprint/public_html/storefront/includes/modules/shipping/usps.php on line 984 Not sure where to look for this one. Judith
  7. Ok, so I stepped through the updates (v 6.x) for USPS Methods, including the USPS Methods 6.1c modified for osc 2.3. Works a treat... for that part. It seems that with all the shenanigans I had to go through to get my shipping rates issue fixed has now managed to fubar my payment module (PayPal Express Checkout and PayPal Website Payments Standard). Pointers on where I should look to get this fixed? Thanks, Judith
  8. Judith.Precision

    USPS Rate V4, Intl Rate V2 (official support thread)

    Ok, so if I've got the USPS module installed, and as far as I can tell it's working correctly (using Priority mail options) with PayPal Express set up for payment processing,... Can anyone point me in the direction of where/why I keep getting the following error when continuing with the checkout/payment process? Fatal error: Class 'httpClient' not found in /home/imprint/public_html/storefront/includes/modules/shipping/usps.php on line 288
  9. Judith.Precision

    USPS Rate V4, Intl Rate V2 (official support thread)

    So, I've installed this wonderful module (got it working, too!) but now I have a strange error when trying to get to the payment processing. (We have PayPal Express module installed). When proceeding to the actual payment, I'm getting the following error: Fatal error: Class 'httpClient' not found in /home/imprint/public_html/storefront/includes/modules/shipping/usps.php on line 288 The URL calling up this error is: http://precisionimprint.com/storefront/ext/modules/payment/paypal/express.php Help?
  10. Judith.Precision

    osc 2.3.3 USPS module

    @@altoid Thanks so much. If you saw an earlier version of this post, please ignore it. I found what I was looking for in the link you provided for the support. :) Have a great day!! Judi
  11. Judith.Precision

    osc 2.3.3 USPS module

    Created a new store with a clean install of osC 2.3.3. I'm trying to get a usable version of the USPS shipping module installed and working. Clarification: A more up-to-date version of the included USPS shipping module. The version that is included with 2.3.3 has this information in the code header: "Based on USPS Methods 26-Feb-2010 http://addons.oscommerce.com/info/487" I have tried installing "USPS Methods 6_0" and had it completely mess up my installation (Internal Server 500 Error) to the point where I had to delete the store and re-install (then import my backed up data). Currently, the USPS (catalog -> includes -> modules -> shipping -> usps.php) module only gives the option of "Library Mail." Can someone point me to an updated version of a working and compatible USPS for version 2.3.3? Thank you. Judith
  12. Judith.Precision

    osc 2.3.3 USPS (included) module

    Created a new store with a clean install of osC 2.3.3. I'm trying to get a usable version of the USPS shipping module installed and working. The version that is included with 2.3.3 has this information in the code header: "Based on USPS Methods 26-Feb-2010 http://addons.oscommerce.com/info/487" I have tried installing "USPS Methods 6_0" and had it completely mess up my installation (Internal Server 500 Error) to the point where I had to delete the store and re-install (then import my backed up data). Currently, the USPS (catalog -> includes -> modules -> shipping -> usps.php) module only gives the option of "Library Mail." Can someone point me to an updated version of a working and compatible USPS for version 2.3.3? Thank you. Judith
  13. Judith.Precision

    Which USPS Add-On to use for a new 2.3.3 Store

    Ok, so going on the USPS website, I found the following url for registering to use their Ecommerce API: https://secure.shippingapis.com/ I've gone through the registration process, but as I have yet to hear bac (takes about 24 hours - from their website info) so I don't yet know if this will be "the fix." Judith
  14. Judith.Precision

    Which USPS Add-On to use for a new 2.3.3 Store

    An added problem to the default/included USPS Shipping Module for osC v2.3.3 is that it still lists the requirement of having an account with USPS Priority Mail. "You will need to have registered an account with USPS at http://www.uspsprioritymail.com/et_regcert.html to use this module" Thank you. Judith
×