Jump to content

xaratax

Members
  • Content count

    22
  • Joined

  • Last visited

Posts posted by xaratax


  1. Hi

     

    I am trying to add a new box to my shop. Everything works ok in IE but for some reason in firefox the box takes the whole of the page destroying the whole layout in the center.

     

    you can see it here:

     

    http://magipedia.com/index.php?language=en

     

    Also when you click on a product , you can see the description fine but the buy button doesnt appear in firefox (in IE works fine)

     

    You can see it here:

     

    http://magipedia.com/product_info.php?products_id=51

     

    I have been suffering with this for 4 days nows, and I cannot find a solution, please if someone can help me with this one you will make me very happy.

     

    Thanks :)


  2. I don't remember if I asked this previously, but:

     

    1) How many languages does your store use?

    2) Do you have names for each product in each language?

    3) Is one of the languages set as the default?

    4) Try switching to a different language, then create the product iif and see if the product names show up.

     

    These answers will help me. I don't have time today to look into this, but will put it near the top of my list to troubleshoot soon.

     

    Thanks,

    Adam

     

    Hi Adam

     

    Do you have any idea yet of what may be the problem I have?


  3. I don't remember if I asked this previously, but:

     

    1) How many languages does your store use?

    2) Do you have names for each product in each language?

    3) Is one of the languages set as the default?

    4) Try switching to a different language, then create the product iif and see if the product names show up.

     

    These answers will help me. I don't have time today to look into this, but will put it near the top of my list to troubleshoot soon.

     

    Thanks,

    Adam

     

    Hi Adam

     

    I use 2 languages in my store (english and spanish). I have a name for each product in both languages. Spanish is default. I tried to switch to other language to create the iif file but I got the same problem. Thanks for looking into this, I am really desperate. :(


  4. Version 2.02 has just been posted.

     

    Version 2.02 corrects some bugs that were found in 2.00 and 2.01. Also, a few additions have been made to the manual, and both Word and PDF versions are included.

     

    Instructions for upgrading from version 1.00, 1.01, 2.00, or 2.01 are provided.

     

    If you have already made all the fixes posted in the ongoing forum discussion, then you don't need to upgrade from 2.01 to 2.02.

     

    2.02 1/27/05

    1. Added missing semicolon in documentation for qbi_payosc table definition.

    2. Removed incorrect quotations in SQL file for v1 to v2 upgrade.

    3. Array error for product model and name was generated under some conditions, fixed.

    4. Incorrect field name for a discount table field fixed.

    5. Negative sign was missing on price for non-group items.

     

    - Adam

     

     

    Hi Adam

     

    I just upgraded to the 2.02 vertion but I get the same error than before, when I import the products iff file, in the name field only appears the names of the atributtes of the products with atributtes and those are the only ones that are to quickbooks from the iif file. I already emailed you the iif file so you can take a look at it. I am sure I am doing some stupid mistake but I dont know what :'(


  5. Hi Adam, thanks for writing this great importer/exporter.

     

    I've been setting it up for my store and found a couple of little bugs you might like to take a look at.

     

    First, I found that in the documentation you refer to creating two folders called qbi_import and qbi_export if I remember correctly, but then I found that the code needs folders called something more like qbi_input and qbi_output so the documentation may need to be modified.

     

    Second, I am not using item groups. I'm trying the qbi_orders.iif to get all my current store orders into quickbooks for a fresh new company setup. I first used qbi to get all my items into quickbooks with the appropriate options so that I should not have to set up any matching and just let the item:option method work as default. I found that qbi was creating an export of all the orders but with items and no item option tagged onto them. I followed up on the bug to a line in qbi_functions that appears incorrect related to the default language. In qbi_engine_orders.php you are using a function call to get the language id for the default language and it calls this function:

     

    function get_language_id($language_code) {

      $languages_query = tep_db_query("select languages_id from " . TABLE_LANGUAGES . " where code = '" . (int)$language_code . "'");

      while ($languages = tep_db_fetch_array($languages_query)) {

    $language_id=$languages['languages_id'];

      }

      return $language_id;

    }

     

    This appears wrong because you are converting a string language code ("en" in my case) into an integer by casting in the SQL where clause. This is causing the function to return blank as my default language id instead of returning '1' as it should.

     

    Once I removed the (int) cast above, the export works fine for me. I didn't know if you use this function elsewhere, so I just made another fixed copy of the function and called that one from qbi_engine_orders.php instead which seems to work for me.

     

    Thanks again for this cool importer/expoter. I was modifying some of the older quickbooks iif creators for OsC when I checked back and found you had just created this great comprehensive system.

     

    BTW, my name is Jim ... This forum seems to be putting my post under another users name (?)

     

     

    Hi Again Adam

     

    It seems to me that I may having a similar problem exporting the products. I sended you my iif file so you can have a look a it like you told me. I opened it with excel and interchanging the name of two of the colums (NAME and PURCHASEDESC) I managed to export all my products , but then the order export is not working I guess because of this change. I am using 2 languages, I don?t know if that has something to do with my problem.

     

    Thanks for looking into this :(


  6. You are using "Utilities" "Create iif file from all osC products?"

     

    I just tested it with my store and it is working properly, exporting all products (with or without attributes) and their descriptions.

     

    Open the iif file in Excel and see if the other products are missing from the iif, or just don't show up in Quickbooks. This will help in troubleshooting.

     

    Also, which version of QBI did you download (it will say 1.00 in the config screen for both versions 1.00 and 1.01 -- this has been corrected)? And what version of QB are you using?

     

    Has anyone else had this problem?

     

    Thanks,

    Adam

     

    Hi Again

     

    Thanks for your answer. I downloaded the version 1.01 , I opened the iff file with excel and I see that there are all products there.

    Maybe I am configuring something worng?

     

    I read this in the manual:

     

    preparing Quickbooks Using the Product Import Utility

    If you have never used Quickbooks with your on-line store, and you wish to import all your store items into Quickbooks, click the ?Create iif file from all osC products? button in the QBI Utilities to make an iif file that you can import into Quickbooks. This will work properly with osC products that have attributes, but will not work for osC products that you wish to match to QB item groups. Unless you have a large number of items that are not already in Quickbooks, and you will not wish to change the names or use item groups, this method is not recommended. It is preferable to add your items directly in Quickbooks, and then match them to the items in osC using the ?Match osC to Quickbooks? menu above. Note that the item import, if you choose to do it, only needs to be done one time.

     

    I am a little lost here. Thanks for the help


  7. Hi

     

    Thanks for this great contribution. I want to install quickbooks from scratch and import all my oSc products to it, but the only ones that I can manage to export from osc are the ones with atributtes. Is there a way to export all products? What can I be doing wrong?

     

    Thanks


  8. Brian

     

    Your contribution is great, thanks a lot for sharing this. I have one question I cannot find the answer , I have a shop in two languages and I need different images for each of them. I searched the solution you gave in other posts about $langid but I couldnt make it work. Could you please help me with this?

     

    Thanks

×