Latest News: (loading..)

mumme1

Members
  • Content count

    24
  • Joined

  • Last visited

1 Follower

About mumme1

Profile Information

  • Real Name
    magnus andersson
  1. Hi, I have slave products to almost all my products. The master products price is often zero. In the products listing i would like to have a function like this: If master_product_price = 0 then select all prices from the slave products. Then show the lowest price as the price in the product_listing. Lets say I have a master product called Pencils. The price is 0 to the master product. I have attached two slaves; Blue Pencil 3 € and Green Pencil 2 €. In the product listing i want: Pencil, price from 2€ (now it says Pencil 0€, and when i click on the master product I see the slaves)
  2. Aaaah....ofcourse I had forgotten to upgrade the jquery-ui js file... Thanks! =)
  3. Hi, After upgrading my theme to a Jquery 1.9.1 instead of 1.8.6 based, a line break or similar is added betweem the icon and the category name, (see image) Any ideas whats wrong, or how I can change that? My old costum 1.8.23 and 1.8.6 based themes works great, but when Im doing a new theme thats saves as 1.9.1 I get this linebreak.
  4. Hi, Is there anyway to hide the price for retail? Our store is busniess to business, so if a costumer is retail instead of the price i want to show "login for prices" So for retail: price hidde -> "login for prices" For Wholesalers and other costumer groups: -> $10
  5. The problem for me is that I need to add like 4000 products, with aprox 30-40 different infomation fields. To import all the data is easy to do it with easypopulate or create a sql-file from the existing product database and just import that to Oscommerce. I tought I could use Products Speficication to select which field to be shown in which category. So if I undestand it correctly, in standard products specification cant show information from existing fields on "products_info.php"? I checked the tep_fill_existing_fields() and tep_specification_table_cell(). In the functions there are references to eg Products Name and Products Model, but I cant get information from those files either on the product_info.php-page. So I guess I need to do a bigger workaround to get it work? So maybye, on the product_info.php its easier for me to do something like: if ($products_color < 0) { echo 'Product Color:' . $products_color; } Instead of trying to get the specification to work the way I want.
  6. To make sure i didnt missed anything I created a new specification group and linked it to all categories. I created two new specifications. 1 - Specification field with textbox to enter information in categories under the specification tab. 2 - Field that should pick information from products_id. On product_info and pdf-datasheet I can see information from the specification textbox, but not the filed tht shuld pick the products id.
  7. To the extra fields in the database eg. "products_extra_colors", "products_extra_length" and "products_extra_width" I enter the information with help of Easypopulate and / or categories.php. I have information in the fields , I have checked that in the database. All extra fields is in he Products-table. Im trying to show the data on product_info.php and your PDF-datasheet contribution. Both pages works if I creat a "specification-field", but not when it should collect data from an existing feld. Here is the settings in admin/products_specification.php Group name: Features Show Comparision Page: True Show on Product info page: True Show Filter: True Speficication Specification Name: Color Specification Description: Specification Prefix: Specification Suffix: Sort Order: 0 Justification: Left Column Name: products_e_color Filter Class: none Display the Filter as: Filter Show All: True Enter Specification Values as: text Filters on this Specification: 0 To makes sure it is linked to the categorie, I have linked it to all categories for testing purpous.
  8. Hi Jim. I have a small problem I really dont know how to solve. On the product_info page I want the Products Specification to load data from an Existing database field. For example products_color. But the information isnt visible on the product_info.php If a make a specification that dosent load information from an existing table the information shows, but none of the information thats collects from the existing database tables. I have read the manual several times, checked all settings twice, and checked the database in phpmyadmin to see that there is data in the fields.
  9. Hi Jim! Have you tried the PDF datasheet contribution with the Ultimate SEO by Jack_mcs (http://www.oscommerce.com/community/contributions,2823)? My PDF-datasheet worked pefectly beofre I installed the Ultimate SEO contribution, now I get an error when trying to generate a PDF. Notice: Undefined index: pName in website.com\includes\classes\seo.class.php on line 2095 I know this question may belong in the Ultimate SEO forum, but since Jim is the #1 oscommerce guru I take a chance and ask here aswell.
  10. Hi, Im using the PDF-Datasheet contribution made by Kymation (http://addons.oscommerce.com/info/8364) It worked perfect before I installed the Ulitmate SEO contr (which is a very good contr, thank you jack). To generate a PDF it sends a link, for example: http://www.website.com/pdf_datasheet.php?products_id=2&language=english Now I get an error related to Ultimate SEO: Can anyone explain the function on line 2095 so I can try to get the PDF datasheet to work?
  11. Sometimes the simpliest is the best solution, I added a background image the the wholepage, in that way I easily can change colors and layout on footer and header. To add a background image: (info from tcpdf.com) in pdf_datasheet.php find: $pdf = new TCPDF( PDF_PAGE_ORIENTATION, PDF_UNIT, PDF_PAGE_FORMAT, true, 'UTF-8', false ); change to: // Extend the TCPDF class to create custom Header and Footer class MYPDF extends TCPDF { //Page header public function Header() { // get the current page break margin $bMargin = $this->getBreakMargin(); // get current auto-page-break mode $auto_page_break = $this->AutoPageBreak; // disable auto-page-break $this->SetAutoPageBreak(false, 0); // set bacground image $img_file = K_PATH_IMAGES.'images/system/pdf_background.jpg'; $this->Image($img_file, 0, 0, 210, 297, '', '', '', false, 300, '', false, false, 0); // restore auto-page-break status $this->SetAutoPageBreak($auto_page_break, $bMargin); // set the starting point for the page content $this->setPageMark(); } } $pdf = new MYPDF(PDF_PAGE_ORIENTATION, PDF_UNIT, PDF_PAGE_FORMAT, true, 'UTF-8', false); //$pdf = new TCPDF( PDF_PAGE_ORIENTATION, PDF_UNIT, PDF_PAGE_FORMAT, true, 'UTF-8', false ); Remember to add the correct path to your image in this row -> $img_file = K_PATH_IMAGES.'images/system/pdf_background.jpg';
  12. I love this addon I have read the tutorials on tcpdf.org and made some changes I wanted. But I have one small problem I hav ent found a solution to yet; If i want to add a backgroundcolor to the heading, where can I do that? On a clean file I can use eg. SetFillColor to add a backgroundcolor to a cell, but not to the header. Any one have an idea?
  13. Buy acident I had Internet Explorer in compatibility mode, anyone have this problem in older internet explorers?
  14. Hi I need an WYSIWYG editor with a filemanager. I have installed CKeditor from http://addons.oscommerce.com/info/7650 and have tried to combine the CKeditor with a filemanager. I have tried to use CKfinder and KFM filemanager without any luck. I cant get it to work. There is an addon "CKeditor with KFM filemanager" http://addons.oscommerce.com/info/8302 but the download file is corrupt, so you cant open it. If you have succeed to combine a WYSIWYG editor with a filemanager, please let me know how you did that! =)
  15. Error in IE9? Hi all, I just installed the Simple Checkout for 2.3.1 v3.05 from the 25 of July. It works fine in Google Chrome and Mozilla Firefox. But in IE9 the box for the shoppingcart above the Shipping Adress-box is missing. When I compare how IE9 and Firefox is rendering the pages I can see that there is some code missing in the source code when viewing it in IE9. In IE9 this code is missing: <div id="cart" class="contentText"> <div class="ui-widget-header"> <div class="cartRow1" style="width:100px;"> </div> <div class="cartRow2">Product(s)</div> <div class="cartRow3">Price</div> <div class="cartRow4">Qty.</div> <div class="cartRow5">Total</div> <div class="cartRow6">Remove</div> <div class="clear"></div> </div> <div class="ui-widget-content"> <form name="cart_quantity" action="http://localhost/lds002/checkout.php?action=update_product" method="post"> <div id="cartContent" class="contentText"> <div class="contentText cartRow"> <div class="cartRow1" style="width:100px;"><a href="http://localhost/lds002/product_info.php?products_id=26"><img src="images/products/microsoft-mouse.jpg" alt="Microsoft IntelliMouse Explorer" title=" Microsoft IntelliMouse Explorer " width="100" height="80" /></a></div> <div class="cartRow2"><a href="http://localhost/lds002/product_info.php?products_id=26"><strong>Microsoft IntelliMouse Explorer</strong></a></div> <div class="cartRow3">$64.95</div> <div class="cartRow4 fields cartQty"><input type="text" name="cart_quantity[]" value="1" size="4" /><input type="hidden" name="products_id[]" value="26" /></div> <div class="cartRow5">$64.95</div> <div class="cartRow6 cartDelete" data-pid="26"><a href="http://localhost/lds002/checkout.php?products_id=26&action=remove_product"><span class="ui-icon ui-icon-trash"> </span></a></div> <div class="clear"></div> </div> </div> <div id="cartRefresh" class="contentText"> <div class="right"><span class="tdbLink"><button id="tdb9" type="submit">Update</button></span><script type="text/javascript">$("#tdb9").button().addClass("ui-priority-secondary").parent().removeClass("tdbLink");</script></div> <div class="clear"></div> </div> </form> <div id="stockWarning" class="contentText"> </div> <div id="totals" class="contentText"> <div id="totalsContent"> <table summary="" cellpadding="2" cellspacing="0" border="0"> <tr> <td align="right" class="main">Sub-Total:</td> <td align="right" class="main">$64.95</td> </tr> <tr> <td align="right" class="main">Flat Rate (Best Way):</td> <td align="right" class="main">$5.00</td> </tr> <tr> <td align="right" class="main">Total:</td> <td align="right" class="main"><strong>$69.95</strong></td> </tr></table> </div> <div id="discountContent"> </div> <div class="clear"></div> </div> </div> </div> Does any one else had this problem?