Latest News: (loading..)

Chrison

Members
  • Content count

    40
  • Joined

  • Last visited

1 Follower

About Chrison

Profile Information

  • Real Name
    Chris
  • Gender
    Male
  • Location
    Nanaimo, BC, Canada
  1. I can't answer your other question (about categories), but you might want to take a look at the Email For Quote add-on as it's a rather elegant solution to handling products with a $0 price. When the user clicks on the link, they're presented with a mailto dialog to e-mail the store owner for a quotation for the product. As far as I can tell, this add-on works with the Modular Front Page add-on, or at least it does for my site. Hope that helps.... Regards, Chris
  2. Hi, Jim: Yet ANOTHER great add-on! Love it! I'm having one minor problem, though... the accordion menu box is missing a title! I see in catalog/includes/modules/boxes/bm_categories_accordion.php there's this line: $this->title = MODULE_BOXES_CATEGORIES_ACCORDION_TITLE; And in catalog/includes/languages/english/modules/boxes/bm_categories_accordion.php that variable is defined thusly: define('MODULE_BOXES_CATEGORIES_ACCORDION_TITLE', 'Categories Accordion'); But that title isn't showing up on the screen (see attached screenshot). I'm probably missing something really obvious and dumb, but your help in fixing it would be greatly appreciated. Thanks! Regards, Chris
  3. There are several links above to several modules. I never got any of them working, though, because Canada Post won't give me an account number (see my remarks above). So, personally, I'm waiting for a new add-on to be built (I'm not capable of doing it or I would) using the new functionality at Canada Post. Hope that's helpful... Regards, Chris
  4. I'm looking for a similar solution, so I started to install the Restricted Delivery addon mentioned here. However, I quickly learned that this addon is for OSC 2.2 and I'm using OSC 2.3 instead! (SIGH!) Is anyone aware of an addon with this kind of functionality that works with OSC 2.3? Thanks for any and all help provided! Happy New Year! Regards,Chris
  5. Yes, it IS a small world! Nanaimo is a lovely city. I'm sure your friends who live here love it! Anyway, I'm sorry but I can't help you with your question. I only serve a small, local area, so I have created a CSV file with only the local postal codes. I can see how if you're going to do it for a whole country the CSV file would be huge and unmanageable. One thing you might want to check is whether your post office has functionality for looking-up postal codes and calculating shipping costs that could be incorporated into your site? I'm not sure if this is what you're looking for, but perhaps that might save you some time? Happy Holidays to you and your family! Regards, Chris
  6. That certainly looks interesting! Uhhh... I didn't see it in the "Community Addons" section of the OSC site, and there wasn't a download link on your blog. Is it available, or will it be soon? I'd sure like to take a closer look at it. Thanks!
  7. LOL! Like that is gonna work! ^_^ It looks like those who installed the add-on and got an account before they went to their new service are okay, at least for the moment. However, for those of us who haven't installed the add-on yet, it looks like we're out of luck! :blush: It looks like you get the reduced rates just by joining VentureOne (someone correct me if I'm wrong!). The real issue is getting a new add-on that incorporates the new Canada Post web services. If I were a PHP programmer, I'd get started on that right away. However, I can hardly install an add-on without mucking things up, so I guess I'll have to wait patiently for someone else to step up to the plate. Thanks, David, for the reply. If I come across a solution, I'll post a link here for you. In the meantime, good luck with your friend's website!
  8. Thanks, Alex and David, for the replies. However, I'm still somewhat confused. :wacko: First, let me state outright that I haven't (yet) installed the addon, as I wanted to get all of the "paperwork" of setting-up Canada Post accounts done first. So, pardon me if this is a totally dumb question, but... What's confusing me is that the instructions (which Ialways read first!) tells me that when I'm configuring the module I need to: "Enter Your CanadaPost Customer ID: You'll get this from emailing Sellonline@canadapost.ca to set up your account" When I e-mailed that address, they replied that they no longer create new Merchant IDs (copy of e-mail attached). If Canada Post won't issue a Merchant ID, then what number do I put in this field??? Is it the ID I was given when I joined VentureOne??? Thanks for any info clarifying this for me! Regards, Chris 20120905-Re_Electronic Shipping tools-964.txt
  9. It seems they're no longer issuing merchant ID's in favour of the new service. Therefore, I'm not sure if the existing Canada Post Online Shipping module (http://addons.oscommerce.com/info/7900/v,23) still works? Hopefully, someone will do a new module (or update the existing module?) soon. Regards, Chris
  10. I started installing this add-on last night. I obtained a VentureOne account and sent an e-mail to register for Electronic Shipping Tools as per the instructions. I haven't copied files to my server or modified files, yet, as I'll do that once I've gotten "the paperwork" out of the way. This morning, I received an e-mail from Canada Post informing me that they no longer issue Merchant ID's for EST as they have a new "Parcel Web" program. What now??? Will this add-on still work without the merchant ID Canada Post won't give me? I don't want to go through installing the new files and modifying existing files if this thing isn't going to work. Thanks for any help/suggestions offered! Regards, Chris
  11. I have installed this add-on to my OSC 2.3.1 site and it seems to be working as it should, at least in terms of processing discounts and gift vouchers. However, I've discovered a problem with another addon (PDF Datasheet) that's driving me nuts. when I try to load a datasheet, I'm getting this error message: [b]Notice[/b]: Undefined variable: gv_contents_string in [b]/home/chris400/public_html/crazychris.ca/store/includes/modules/boxes/bm_shopping_cart.php[/b] on line [b]112[/b] [b]Warning[/b]: Cannot modify header information - headers already sent by (output started at /home/chris400/public_html/crazychris.ca/store/includes/modules/boxes/bm_shopping_cart.php:112) in [b]/home/chris400/public_html/crazychris.ca/store/ext/tcpdf/tcpdf.php[/b] on line [b]8736[/b] [b]TCPDF ERROR: [/b]Some data has already been output to browser, can't send PDF file [b]Fatal error[/b]: Call to a member function store() on a non-object in [b]/home/chris400/public_html/crazychris.ca/store/includes/modules/ultimate_seo_urls5/main/usu5.php[/b] on line [b]78[/b] I have twice checked the modifications I made to bm_shopping_cart.php when installing CCGV but don't see anything that's obviously wrong, at least to my non-programmer eyes. I'm attaching a copy of bm_shopping_cart.php in the hopes that someone with more experience at php will take a look and spot the problem. As always, any help or suggestions on fixing this problem will be VERY much appreciated! Thanks! Regards, Chris
  12. Never mind. I never did figure out why this was happening, so I uninstalled this add-on and changed over to CCGV Credit Class Gift Voucher 6.0 instead. Happily, it installed without a hitch and works flawlessly. Thanks, anyway... Regards, Chris
  13. UPDATE: I have found the section of code that's breaking AJAX Attribute Manager, but for the life of me I can't figure out why?!?! :unsure: Here's the code in catalog/admin/includes/template_top that's causing a problem: <!-- AJAX Attribute Manager --> <?php if ((basename($_SERVER["SCRIPT_NAME"]) == FILENAME_CATEGORIES)) { require('attributeManager/includes/attributeManagerHeader.inc.php'); } ?> <!-- AJAX Attribute Manager end --> </head> <?php // Discount Code 3.1.1 - start if (basename($PHP_SELF) == FILENAME_DISCOUNT_CODES && isset($action) && $action == 'new') { echo '<body onload="onload();">'; } else { echo '<body onload="goOnload();">'; } // Discount Code 3.1.1 - end ?> If I take out the if/else statement for Discount Code and replace it with <body onload="goOnload();"> then AJAX Attribute Manager works fine. (I haven't checked to see if that breaks Discount Code, though.) But, if I leave that code in for Discount Code then AJAX Attribute Manager does not work even though the code is still outputting <body onload="goOnload();"> (I checked the page source)! To my non-programmer eyes the output that's going to the browser is exactly the same so shouldn't AJAX Attribute Manager work with the Discount Code if/else statement in there?!?!? Could someone please give me a hand with this as it's starting to drive me nuts! :( Thanks for any help/suggestions provided! Regards, Chris
  14. Hi, Burt! Sorry that I missed replying to your suggestion... Opps! :( I did install the validation addon I pointed to above, and it does work. IMHO, that's a better solution for my problem as it forces users to enter the postal code in the proper format (i.e. as approved by Canada Post) in the first place, instead of mucking with "fixing" improperly entered postal codes. Thanks for the suggestion, though. It might be helpful to someone else. Again, thanks for the wonderful add-on! It's now working great! :thumbsup: Regards, Chris
  15. Hi, everyone! With much agony, and by following the instructions in this thread, I have managed to get Shop by Price installed and more-or-less running on my store. (Quick side note: I agree with Sars that it would be nice if the developer would fix all these things and re-post the contribution!) Anyway... I found two problems, one that I was able to fix and the another one that's still driving me nuts. The problem I found and how to fix it: When the box loads, it displays "Shop by Price" in the input field instead of the values for the first price range (in my case "Under 10.00"). IMHO, this is confusing to the user (at least it was to me!) as it's not clear that this is where the user selects a price range they want to filter by. To change this... Find this in catalog/includes/languages/modules/boxes/shop_by_price.php: define('BOX_HEADING_SHOP_BY_PRICE', 'Shop by Price'); Change it to this: define('BOX_HEADING_SHOP_BY_PRICE', 'Under 10.00'); The problem I can't figure out how to fix: When the box is first loaded and displayed, the first price range (in my case "Under 10.00") is displayed (with the above fix) but is not active. In other words, the user sees "Under $10.00" but if he/she clicks on that nothing happens. If the user clicks on another price range and then clicks on "Under 10.00" then the program does work properly. Again, this is confusing to the user, IMHO, especially if the input field is displaying "Shop by Price" instead of the first price range (i.e. you haven't applied the above fix). So, could someone please figure-out how to get the first price range to be active (i.e. clickable) when the box is first loaded and post the solution here? I tried for several hours to figure it out but I'm just not that skilled at php programming. (I know enough to be able to break stuff, but not enough to fix it! LOL!) Thanks, in advance, for any help provided! Regards, Chris